Help With Firefox-Netflix No Video Playback

Forum Forums New users New Users and General Questions Help With Firefox-Netflix No Video Playback

This topic contains 11 replies, has 5 voices, and was last updated by rej Feb 13-2:52 pm.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #18445
    Member
    Avatar
    rej

    A yellow bar above Netflix page appears with this notification:

    “Firefox is installing components needed to play the audio or video on this page. Please try again later.”

    Have tried re-installing Firefox esr 60.5, installing regular Firefox Quantum 65, went back to the default kernel- 4.9.126 [currently using 4.18.7], disabling extentions, enabling OpenH264 Video Codec, and updating Widevine.

    DRM content is enabled. Tried toggling DRM off/on to see if that makes Firefox load these components.

    The system is updated and upgraded.

    Could not get Widevine to update through FF update plugins or find a .deb file to install with. Many of the searches online indicate that this is the problem. The installed version is not current.

    Is there a way to get an updated Widevine version?

    Any help would be appreciated.

    Thank you.

    #18446
    Member
    caprea
    caprea

    Don’t have a netflix-acount,I also see the yellow bar, but at least I can watch the trailers,if clicking on them.
    In about:plugins,if you click on “more” for the Widevine content decryption , you can see the version.
    Here it is 1.4.8.1008 and was updated on 17.Jan.2019
    Firefox Quantum 60.5.0 esr

    #18447
    Forum Admin
    rokytnji
    rokytnji

    Wondering if pulse audio needs to be installed also for a newer firefox to play sounds.

    https://www.tapatalk.com/groups/antix/missing-libxen-for-pulseaudio-install-t6758.html

    My netflix comes with my smart tv. I use couchtuner tv instead of netflix on my AntiX gear while traveling.
    Google it.

    Sometimes I drive a crooked road to get my mind straight.
    Not all who Wander are Lost.
    Linux Registered User # 475019
    How to Search for AntiX solutions to your problems

    #18448
    Member
    caprea
    caprea

    In the trailers I have sound. No pulseaudio is installed
    (Is there generally a difference in the playback when having an account or just play the trailers ? )

    #18450
    Member
    noClue
    noClue

    It‘s not a bug, it‘s a feature.

    Important to know here is, the intention of Netficks was to prevent the people of enjoying the video streaming, make them headache and indirectly force them to „behave“ and finally use what they are supposed to use — Windows or Mac. Beside DRM, they made their contents work properly (in 1080p) only in Internet Explorer, Microsoft Edge or Safari web browsers and Chrome and Firefox users would get only 720p, if anything.

    Now, there are two extensions made to help people to watch Netflix with less problems:

    Firefox: „Force 1080p playback for Netflix“ (Vlad Filippov)
    Chrome: „Netflix 1080p für Chrome“ (truedread)

    See if it helps.

    How strange is to be anything at all. (Alice in Wonderland)

    #18452
    Member
    Avatar
    seaken64

    I am interested to see if you can get this sorted out. I do not use Linux for any TV type services simply because I find it too hard to figure out. For all my TV type stuff I use Windows or Android. It seems that noClue is correct in that the content controllers do not care about supporting Linux at all. If we want to use Linux we’re on our own.

    I have been able to use antiX for YouTube. But any time I try anything with DRM content I can’t figure it out. It’s just too damn hard. But I do watch what others have done in hopes that I can one day use the likes of Netflix or Amazon, or YouTube TV, etc. on my linux boxes.

    I have heard others have luck using Chrome for Netflix. Have you tried that?

    Seaken64

    #18465
    Member
    Avatar
    rej

    caprea and rokytnji-

    Yes, you can play the trailers and Youtube, not the movies though.

    Pulseaudio has been active and works well.

    Thanks for the input!
    ———
    noClue-

    Thank you, I tried “Force 1080p playback for Netflix“ in FF and still got the yellow banner. Chrome does not have the problem.
    ———
    seaken64-

    As Chrome works with Netflix, that is what I currently use, but am hearing talk of Chrome soon disabling some extensions that I need and FF will not be doing that. I had stopped using Mozilla because of the crashing and other problems it had, but need to see if it is workable somehow. Thanks for the information.
    _____________________________
    Although it seems odd that the same banner appears with Firefox Quantum 65 installed, I think the following might be the problem, however, after installing the workaround, another site claims the old version re-installs itself:

    https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=921121#15

    Debian Bug report logs – #921121
    60.5.0esr-1~deb9u1 breaks Netflix playback

    “Problem is here that the wrong version of widevine is installed for firefox-esr 60.5.0. You can manually fix this by downloading (please check the in-sources list for non-x64 binary urls [1] on in firefox using the URL chrome://global/content/gmp-sources/widevinecdm.json

    It is currently unknown to me why the browser still downloads 1.4.8.1008. Even when removing my .mozilla directory. Is this inserted by some external service which still thinks that 60.x.0 is compatible to 1.4.8.1008 and not to 4.10.1196.0? I would therefore guess that the aus service of Mozilla is broken

    =========================
    https://www.linuxquestions.org/questions/slackware-14/firefox-60-5esr-upgrade-on-14-2-both-32bit-and-64bit-broke-netflix-4175647549/

    Quote:
    Originally Posted by SpiderTux View Post
    looks like Firefox 60.5.0esr is trying to download a wrong widevine version, but there is a workaround:
    https://bugs.debian.org/cgi-bin/bugr…?bug=921121#15
    ————
    “The workaround mentioned about is manually downloading and installing the plugin (which is what i did by running 65.0), but this will not keep the esr version from replacing the right version with the wrong version again after some time or by manually asking for an update. Just tested that and indeed, 60.5 esr keeps downloading 1.4.8.1008 instead of 4.10.1196.0.

    As mentioned in the above debian.org thread, the actual problem is a misconfiguration of a Mozilla service, not a bug in the software and it is not Slackware specific.”

    #18491
    Member
    Avatar
    rej

    Found a temporary workaround for current version of Widevine not installing and don’t know if it is smart to do this, security-wise.

    However, I uninstalled esr and installed FF Quantum 65 again, and although the application has the yellow banner, it plays Netflix if you go past it (which it does not do in esr).

    FF Quantum 65 will not update nor will it play Pulseaudio in Firejail (no sound) yet it installs the current Widevine version 4.10.1196.0.

    Had tried to re-install Pulseaudio and still no sound in Firejail.

    Uninstalled Quantum 65 and reinstalled esr and the banner appeared, but, again went past it, opened Widevine in the Plugins which still had Widevine version 4.10.1196.0. leftover from the install of FF 65. Selected “more…” and “Automatic updates” – off. Not doing this right away, causes it to revert back to the old version 1.4.8.1008.

    Between each uninstall and reinstall, except for the final install of esr, had rebooted.

    So far, it has worked after a few reboots and updating/dist-upgrading system. Updated version 4.10.1196.0. is still there. Netflix plays everything.

    Any reason this might cause other problems?

    #18536
    Member
    caprea
    caprea

    Thanks for clarification and posting the workaround. I can see the problem now.Looking again at the debian bugreport today, I saw they posted another workaround down there by changing the app.update.channel.

    #18558
    Member
    Avatar
    rej

    caprea-

    Thank you!! This is a much better workaround.

    I wonder if it needs to be changed back to “default” if Mozilla fixes it.

    #18563
    Member
    caprea
    caprea

    Seems we have to watchup for the firefox-esr update.
    Normally the upgrade of firefox-esr should overwrite the /usr/lib/firefox-esr/defaults/pref/channel-prefs.js
    Maybe resetting to default shortly before doing the upgrade and looking what happens, is the best.

    #18582
    Member
    Avatar
    rej

    Thanks again caprea – I will check it on the next release.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.