Hercules eCafé EC-800 screen resolution

Forum Forums General Hardware Hercules eCafé EC-800 screen resolution

  • This topic has 16 replies, 6 voices, and was last updated Oct 27-6:14 pm by anticapitalista.
Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #28485
    Member
    anewangelfades

      Hello,
      I have the netbook above, with 1GB RAM and an AMD Geode LX 800 processor.

      The screen resolution of this particular PC is known for its difficulties: the native resolutions are 800×480 and 1024×600.

      None of them work out of the box in antiX 19.
      I tried an old xorg.conf I used with ubuntu 12.04 but it did’t worked;
      I also tried to do
      X -configure
      as root, but it didn’t worked, either.
      I tried to install xserver-xorg-video-geode drivers from the repository, but after rebooting I couldn’t even start any GUI.

      The bug is described here:
      http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-geode/+bug/433142?comments=all

      but the solutions that used to work with ubuntu 10, 11 and 12 don’t work with antiX.

      Any ideas?

      Thanks in advance!

      • This topic was modified 4 years, 8 months ago by anewangelfades.
      #28487
      Forum Admin
      rokytnji

        Safe video mode using vesa usually with newer xorg AntiX ships with is usually a good starting point with old chips like geode, savage,sis,etc…….

        Just My opinion though. You old Ubuntu xorg conf worg as not probabaly compatible with newer xorg version Debian supplies in Buster. Newer Xorg and old chip drivers don’t play nice mostly. In my experience.

        Be nice if you you posted a

        inxi -Fxz -r

        also in this thread so folks can see your install < like kernel/xorg version > and gear. To make better responses.

        Sometimes I drive a crooked road to get my mind straight.
        I don't suffer from insanity. I enjoy every minute off it.
        Motorcycle racing is rocket science.

        Linux Registered User # 475019
        How to Search for AntiX solutions to your problems

        #28494
        Member
        PPC

          the native resolutions are 800×480 and 1024×600.

          Hi! I have a old intel netbook, with integrated intel graphics card, same RAM (shared), same resolution- never had a single problem since antiX 16 (now using 19 on that machine)- always ran live with safe mode (nomodeset , and selected the option to “ask for console resolution” (I belive that’s the term). It runs great at 1024*600-
          If you get it to work on your netbook too, I have a good tip- activate IceWM toolbar option to (I belive) “show colapse button”- colapsing the toolbar allows you to see the applications working at almost a default resolution when you need it, without the “hassle” of autohiding it- also if you can’t see the bottom part of a window- click the maximize button- and the window content’s usually auto organize to show everything (not sure why that’s not the default setting).

          P.

          #28495
          Member
          anewangelfades

            This is inxi -Fxz -r output:

            $ inxi -Fxz -r
            System:
              Host: EC-800 Kernel: 4.9.193-antix.1-486-smp i586 bits: 32 compiler: gcc v: 8.3.0 
              Desktop: IceWM 1.5.5+git20190610 
              Distro: antiX-19_386-full Marielle Franco 16 October 2019 
              base: Debian GNU/Linux 10 (buster) 
            Machine:
              Type: Desktop System: Hercules product: EC-800 v: 1.0 serial: <filter> 
              Mobo: TECO and Machinery model: TR2350 v: Rev 1.33 serial: <filter> BIOS: Insyde 
              v: 4.00.01 Rev. 1.00.003 date: Built: 08/18/2005 
            Battery:
              ID-1: BATT charge: 14.6 Wh condition: 21.7/29.8 Wh (73%) model: YOKU ENERGY BT-6005 
              status: Discharging 
            CPU:
              Topology: Single Core model: Geode Integrated by AMD PCS bits: 32 type: UP 
              arch: Geode rev: 2 L2 cache: 128 KiB 
              flags: N/A bogomips: 996 
              Speed: 498 MHz min/max: N/A Core speed (MHz): 1: 498 
            Graphics:
              Message: No Device data found. 
              Display: x11 server: X.Org 1.20.4 driver: vesa resolution: 640x480~N/A 
              OpenGL: renderer: llvmpipe (LLVM 7.0 128 bits) v: 3.3 Mesa 18.3.6 direct render: Yes 
            Audio:
              Device-1: AMD CS5536 [Geode companion] Audio driver: snd_cs5535audio v: kernel 
              bus ID: 00:0f.3 
              Sound Server: ALSA v: k4.9.193-antix.1-486-smp 
            Network:
              Device-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter driver: 8139too 
              v: 0.9.28 port: df00 bus ID: 00:0d.0 
              IF: eth0 state: down mac: <filter> 
              IF-ID-1: wlan0 state: up mac: <filter> 
            • This reply was modified 4 years, 8 months ago by anewangelfades.
            #28499
            Member
            anewangelfades

              the native resolutions are 800×480 and 1024×600.

              Hi! I have a old intel netbook, with integrated intel graphics card, same RAM (shared), same resolution- never had a single problem since antiX 16 (now using 19 on that machine)- always ran live with safe mode (nomodeset , and selected the option to “ask for console resolution” (I belive that’s the term). It runs great at 1024*600-
              If you get it to work on your netbook too, I have a good tip- activate IceWM toolbar option to (I belive) “show colapse button”- colapsing the toolbar allows you to see the applications working at almost a default resolution when you need it, without the “hassle” of autohiding it- also if you can’t see the bottom part of a window- click the maximize button- and the window content’s usually auto organize to show everything (not sure why that’s not the default setting).

              P.

              Thank you very much for your answer!

              I’m not using antiX live, I installed it to my hard drive.
              How can I select “safe mode”, nomodeset and select the option to “ask for console resolution” now?

              Thanks in advance!

              #28500
              Forum Admin
              rokytnji

                You are already running vesa

                Graphics:
                  Message: No Device data found. 
                  Display: x11 server: X.Org 1.20.4 driver: vesa 

                So nothing to do there.

                Sometimes I drive a crooked road to get my mind straight.
                I don't suffer from insanity. I enjoy every minute off it.
                Motorcycle racing is rocket science.

                Linux Registered User # 475019
                How to Search for AntiX solutions to your problems

                #28501
                Member
                Xecure

                  How can I select “safe mode”, nomodeset

                  You need to edit (with root privileges) /etc/default/grub file. You need to edit the line that says:
                  GRUB_CMDLINE_LINUX_DEFAULT="
                  and add the options there. For example:
                  GRUB_CMDLINE_LINUX_DEFAULT="quiet xorg=safe nomodeset"

                  Then save and update grub:
                  sudo grub-update

                  Restart your system and see how it goes.
                  Hopefully some experts can recommend other boot options.

                  antiX Live system enthusiast.
                  General Live Boot Parameters for antiX.

                  #28502
                  Forum Admin
                  rokytnji

                    in terminal.

                    xrandr -s 1024x600

                    might quick change resolution. You can put that line in startup in AntiX.

                    I have never tried the boot repair option myself in Control Center though. I am currently dist-upgradeing while I post this.

                    Sometimes I drive a crooked road to get my mind straight.
                    I don't suffer from insanity. I enjoy every minute off it.
                    Motorcycle racing is rocket science.

                    Linux Registered User # 475019
                    How to Search for AntiX solutions to your problems

                    #28508
                    Member
                    anewangelfades

                      xrandr -s 1024×600

                      Output:

                      $ xrandr -s 1024x600
                      Size 1024x600 not found in available modes
                      #28516
                      Member
                      anewangelfades

                        How can I select “safe mode”, nomodeset

                        You need to edit (with root privileges) /etc/default/grub file. You need to edit the line that says:
                        GRUB_CMDLINE_LINUX_DEFAULT="
                        and add the options there. For example:
                        GRUB_CMDLINE_LINUX_DEFAULT="quiet xorg=safe nomodeset"

                        Then save and update grub:
                        sudo grub-update

                        Restart your system and see how it goes.
                        Hopefully some experts can recommend other boot options.

                        Thanks.
                        I already tried several grub configurations, but none worked.
                        Moreover, the default installation had a vga=791 parameter that gave an error at boot, saying that was deprecated.

                        I am wondering if I have to install the xserver-xorg-video-geode package and try to find a working combination of boot options andò xorg.conf

                        #28525
                        Forum Admin
                        rokytnji

                          Hmmmm. That vga791 error was a atom 9 inch screen error on touchscreen single core atom netbooks.

                          I think I posted at the old forum about that.

                          Sometimes I drive a crooked road to get my mind straight.
                          I don't suffer from insanity. I enjoy every minute off it.
                          Motorcycle racing is rocket science.

                          Linux Registered User # 475019
                          How to Search for AntiX solutions to your problems

                          #28569
                          Member
                          anewangelfades

                            Hmmmm. That vga791 error was a atom 9 inch screen error on touchscreen single core atom netbooks.

                            I think I posted at the old forum about that.

                            Do you have a precise idea?
                            I cannot find a similar problem in the old forum, I cannot even find the post about the atom touchscreen netbook you are referring to.
                            It’s unlucky, since antiX is working, but 640×480 is really a resolution too low.

                            #28579
                            Moderator
                            caprea

                              $ xrandr -s 1024×600
                              Size 1024×600 not found in available modes

                              If a particular screen resolution is not found in available modes by xrandr,
                              there is a possibility to add a new modeline. It’s described in comment #51 in the bug-report you linked to or on this side
                              http://translate.google.com/translate?hl=en&sl=auto&tl=en&u=https%3A%2F%2Faxebase.net%2Fblog%2F2011%2F07%2F27%2Fhinzufuegen-einer-aufloesung-ueber-cvt-und-xrandr%2F

                              or on this side under resolution http://translate.google.com/translate?hl=en&sl=auto&tl=en&u=https%3A%2F%2Fwiki.ubuntuusers.de%2FRandR%2F%23Statische-Konfiguration-ohne-xorg-conf
                              You have to know the technical data for the screen.
                              I don’t have any experience with it, so I can’t promise that it will work and really help you, but maybe it’s worth a try.

                              You probably have already realized that an older antiX version might have less problems.

                              #28646
                              Member
                              anewangelfades

                                $ xrandr -s 1024×600
                                Size 1024×600 not found in available modes

                                If a particular screen resolution is not found in available modes by xrandr,
                                there is a possibility to add a new modeline. It’s described in comment #51 in the bug-report you linked to or on this side
                                http://translate.google.com/translate?hl=en&sl=auto&tl=en&u=https%3A%2F%2Faxebase.net%2Fblog%2F2011%2F07%2F27%2Fhinzufuegen-einer-aufloesung-ueber-cvt-und-xrandr%2F

                                or on this side under resolution http://translate.google.com/translate?hl=en&sl=auto&tl=en&u=https%3A%2F%2Fwiki.ubuntuusers.de%2FRandR%2F%23Statische-Konfiguration-ohne-xorg-conf
                                You have to know the technical data for the screen.
                                I don’t have any experience with it, so I can’t promise that it will work and really help you, but maybe it’s worth a try.

                                You probably have already realized that an older antiX version might have less problems.

                                Great idea, thanks!
                                I installed the Geode drivers, and used an old xorg.conf I saved from an working xubuntu installation, reported below:

                                Section "Module"
                                    Load  "ztv"
                                EndSection
                                Section "Device"
                                    Identifier	"card0"
                                    Driver	"geode"
                                    BusID	"PCI:0:1:1"
                                    Option	"PanelMode" "33450 800 840 968 1056 480 490 492 525"
                                EndSection
                                Section "Monitor"
                                    Identifier	"monitor0"
                                    Modeline  "1024x768" 64.56 1024 1056 1296 1328 768 783 791 807 -hsync +vsync
                                    Modeline  "1024x600" 48.96 1024 1064 1168 1312 600 601 604 622 -hsync +vsync
                                    Modeline   "800x480" 33.45  800  840  968 1056 480 490 492 525 -hsync +vsync
                                    Option	"dpms"
                                EndSection
                                Section "Screen"
                                    Identifier	"Default Screen"
                                    Monitor	"monitor0"
                                    Device	"card0"
                                    DefaultDepth 24
                                    Subsection "Display"
                                        Depth 24
                                        Modes "1024x600" "1024x768" "800x480"
                                    EndSubsection        
                                EndSection

                                Next time I booted up, I got a console. Logged in, typed startx, but I got an error.
                                The file /var/log/Xorg.0.log said the following:

                                [    55.164]    Module class: X.Org Video Driver
                                [    55.164]    ABI class: X.Org Video Driver, version 24.0
                                [    55.164] (II) z4l driver for Video4Linux
                                [    55.164] (II) GEODE: Driver for AMD Geode Chipsets: Geode LX, Geode GX
                                [    55.185] (WW) Falling back to old probe method for z4l
                                [    55.187] AmdPciProbe: Probing for supported devices!
                                [    55.188] (II) Loading sub module "vgahw"
                                [    55.188] (II) LoadModule: "vgahw"
                                [    55.194] (II) Loading /usr/lib/xorg/modules/libvgahw.so
                                [    55.221] (II) Module vgahw: vendor="X.Org Foundation"
                                [    55.221]    compiled for 1.20.4, module version = 0.1.0
                                [    55.221]    ABI class: X.Org Video Driver, version 24.0
                                [    55.222] (EE)
                                Fatal server error:
                                [    55.222] (EE) Unable to open /dev/cpu/0/msr: No such file or directory
                                [    55.222] (EE)
                                [    55.223] (EE)
                                Please consult the The X.Org Foundation support
                                         at http://wiki.x.org
                                 for help.
                                [    55.223] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional $
                                [    55.223] (EE)
                                [    55.339] (EE) Server terminated with error (1). Closing log file

                                So I typed sudo modprobe msr and then startx again, and it worked!

                                Now inxi -Fxz -r gives the following output:

                                System:
                                  Host: EC-800 Kernel: 5.2.15-antix.1-486-smp i586 bits: 32 compiler: gcc v: 8.3.0 
                                  Desktop: IceWM 1.5.5+git20190610 
                                  Distro: antiX-19_386-full Marielle Franco 16 October 2019 
                                  base: Debian GNU/Linux 10 (buster) 
                                Machine:
                                  Type: Desktop System: Hercules product: EC-800 v: 1.0 serial: <filter> 
                                  Mobo: TECO and Machinery model: TR2350 v: Rev 1.33 serial: <filter> BIOS: Insyde 
                                  v: 4.00.01 Rev. 1.00.003 date: Built: 08/18/2005 
                                Battery:
                                  ID-1: BATT charge: 20.0 Wh condition: 20.9/29.8 Wh (70%) model: YOKU ENERGY BT-6005 
                                  status: Unknown 
                                CPU:
                                  Topology: Single Core model: Geode Integrated by AMD PCS bits: 32 type: UP 
                                  arch: Geode rev: 2 L2 cache: 128 KiB 
                                  flags: N/A bogomips: 996 
                                  Speed: 498 MHz min/max: N/A Core speed (MHz): 1: 498 
                                Graphics:
                                  Message: No Device data found. 
                                  Display: server: X.Org 1.20.4 driver: geode resolution: 1024x600~60Hz 
                                  OpenGL: renderer: llvmpipe (LLVM 7.0 128 bits) v: 3.3 Mesa 18.3.6 direct render: Yes 
                                Audio:
                                  Device-1: AMD CS5536 [Geode companion] Audio driver: snd_cs5535audio v: kernel 
                                  bus ID: 00:0f.3 
                                  Sound Server: ALSA v: k5.2.15-antix.1-486-smp 
                                Network:
                                  Device-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter driver: 8139too 
                                  v: 0.9.28 port: df00 bus ID: 00:0d.0 
                                  IF: eth0 state: down mac: <filter> 
                                  IF-ID-1: wlan0 state: up mac: <filter> 
                                Drives:
                                  Local Storage: total: 18.66 GiB used: 4.41 GiB (23.6%) 
                                  ID-1: /dev/sda vendor: Samsung model: HS020GB size: 18.66 GiB 
                                Partition:
                                  ID-1: / size: 16.24 GiB used: 4.41 GiB (27.1%) fs: ext4 dev: /dev/sda1 
                                  ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
                                Sensors:
                                  Message: No sensors data was found. Is sensors configured? 
                                Repos:
                                  Active apt repos in: /etc/apt/sources.list.d/antix.list 
                                  1: deb http://it.mxrepo.com/antix/buster buster main nonfree
                                  Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
                                  1: deb http://ftp.it.debian.org/debian/ buster-updates main contrib non-free
                                  Active apt repos in: /etc/apt/sources.list.d/debian.list 
                                  1: deb http://ftp.it.debian.org/debian/ buster main contrib non-free
                                  2: deb http://security.debian.org/ buster/updates main contrib non-free
                                  No active apt repos in: /etc/apt/sources.list.d/onion.list 
                                  Active apt repos in: /etc/apt/sources.list.d/palemoon.list 
                                  1: deb http://download.opensuse.org/repositories/home:/stevenpusser/xUbuntu_16.04/ /
                                  No active apt repos in: /etc/apt/sources.list.d/various.list 
                                Info:
                                  Processes: 91 Uptime: 19m Memory: 973.8 MiB used: 186.5 MiB (19.1%) Init: SysVinit 
                                  runlevel: 5 Compilers: gcc: 8.3.0 Shell: bash v: 5.0.3 inxi: 3.0.36 

                                There are two problems anyway:

                                1) I always have to do sudo modprobe msr and then startx at startup: is there any way to fix it?
                                2) If I change desktop, e.g. fluxbox, or jwm, everything freezes. Why?!? Also if I use Ctrl+Alt+F2 (or F3, or F8, or any other F*). I cannot understand the reason for this.

                                Any ideas?

                                Thank you again!

                                #28652
                                Member
                                anewangelfades

                                  Ok, everything works now, I just added msr at beginning of /etc/modules

                                  So the steps for anyone with this problem are simply installing the xserver-xorg-video-geode package, use the xorg.conf above and add msr in the /etc/modules file to have it loaded at startup.

                                  It’s great to have a modern system running, I also installed the non-SSE2 version of the Pale Moon browser, and everything works fine now.

                                  Thanks!

                                Viewing 15 posts - 1 through 15 (of 17 total)
                                • You must be logged in to reply to this topic.