How do I make audio loopback PulseAudio module automatically via boot?

Forum Forums New users New Users and General Questions How do I make audio loopback PulseAudio module automatically via boot?

  • This topic has 17 replies, 6 voices, and was last updated Sep 6-2:08 pm by Chelsea.
Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #66282
    Member
    Chelsea

      Hi. So, I also make chiptunes sometimes and I occasionally use LSDJ on my GameBoy, but I would like to make sure that the USB split adapter captures my GameBoy audio properly via a 3mm jack. So, long story short, how do I make sure that antiX turns on the audio-loopback module automatically during boot. Also, how do I lower the latency on the audio loopback to make sure that it is recording correctly?

      Thanks in advance.

      Chase E.

      #66327
      Member
      sybok

        I am not sure about boot, but would not adding start of pulseaudio when you login suffice?
        If yes, then edit file ‘~/.desktop-session/startup’ and add a line:
        pulseaudio --start
        or better
        pulseaudio -D

        #66328
        Forum Admin
        anticapitalista

          That file should already have a commented pulseaudio line.

          Philosophers have interpreted the world in many ways; the point is to change it.

          antiX with runit - leaner and meaner.

          #66340
          Member
          sybok

            @anticapitalista: For some reason, mine (antiX-19.2_x64-full Hannie Schaft 27 March 2020) does not.

            #66363
            Member
            Chelsea

              I mean…I already did that, but I’m also wonder how to make sure it does this at boot too:

              load-module module-loopback

              …because I’m a bit lazy and don’t want to load it up in the terminal every time after booting up.

              #66365
              Member
              Xecure

                http://unix.stackexchange.com/a/139861
                Based on this answer, you add the module to be loaded in /etc/pulse/default.pa

                antiX Live system enthusiast.
                General Live Boot Parameters for antiX.

                #66366
                Member
                Chelsea

                  Okay, but what about loading the loopback module at startup?

                  #66370
                  Member
                  Xecure

                    Doesn’t adding the command to /etc/pulse/default.pa make it load as soon as pulseaudio loads (at startup)?

                    antiX Live system enthusiast.
                    General Live Boot Parameters for antiX.

                    #66372
                    Member
                    Chelsea

                      I’m using antiX 19.4. Not really Linux Mint and stuff

                      #66373
                      Member
                      Xecure

                        I’m using antiX 19.4. Not really Linux Mint and stuff

                        I wasn0t expecting this answer.

                        running man pulseaudio in the terminal:

                        [...]
                        FILES
                        [...]
                               ~/.config/pulse/default.pa, /etc/pulse/default.pa: the default configu‐
                               ration script to execute when the PulseAudio daemon is started. If  the
                               version in the user's home directory does not exist the global configu‐
                               ration script is loaded. See default.pa(5) for more information.

                        I edited /etc/pulse/default.pa as root and added at the end of the file:

                        ### Load audio-loopback module
                        load-module module-loopback

                        I restarted my antiX 19.4 system, and asked pulseaudio what modules were loaded:

                        $ pactl list short | grep loop
                        23	module-loopback		
                        0	0	-	module-loopback.c	s16le 2ch 44100Hz
                        0	1	-	module-loopback.c	s16le 2ch 44100Hz

                        The module loaded automatically (but as I don’t know how to use it, I can just show it started automatically).

                        Was this what you wanted to get working?

                        antiX Live system enthusiast.
                        General Live Boot Parameters for antiX.

                        #66394
                        Member
                        Chelsea

                          I’m not sure if this applies only to runit edition of antiX, but I’m using the default SysVinit edition. I also don’t have a default.pa file in the /.config/pulse/ folder, but I do have a default.pa in the /etc/pulse/ folder outside of my /home/chase/ folder. Do I have to edit it as root?

                          Sorry for asking so many questions by the way.

                          #66401
                          Member
                          Xecure

                            I do have a default.pa in the /etc/pulse/ folder outside of my /home/chase/ folder. Do I have to edit it as root?

                            Yes. Try it out. I edited the file as root, added the lines I mentioned above at the end of the file, and then rebooted.
                            When the session starts, and you have pulseaudio -D & set in startup, as soon as pulseaudio starts it will load the modules listed in /etc/pulse/default.pa (if you haven’t manually created /.config/pulse/default.pa).

                            Try it out. I tested it out above and it seemed to work (at least it is listed there, but I don’t knowo what to do with it). If it doesn’t work for you will try exploring what else needs o be done.

                            antiX Live system enthusiast.
                            General Live Boot Parameters for antiX.

                            #66418
                            Member
                            wildstar84

                              Is there anything for pulseaudio in /etc/rc5.d/ ? (I don’t have/use pulse installed, so don’t know). If so, check for a file like “/etc/default/pulse*”, edit it and make sure it’s “enabled” in a line in there, if commented out, uncomment it. Otherwise, if none of that is the case, /etc/rc.local is your friend – you can add the start command for pulse there.

                              Regards,

                              Jim

                              #66454
                              Member
                              seaken64

                                I’m using antiX 19.4. Not really Linux Mint and stuff

                                If you are using antiX 19.4 then you are in the right place. What does Linux Mint have to do with anything? Are you saying you are used to how Linux Mint does this setup and that antiX is not Linux Mint? Not sure what you are trying to convey.

                                Seaken64

                                #66456
                                Member
                                Xecure

                                  The link I shared was for Linux Mint, and the user didn’t know that pulseaudio works almost exacty the same in Ubuntu based (Linux Mint) as Debian based (antiX) systems. Once they try the proposed solution we will know if it worked for them.

                                  • This reply was modified 2 years, 10 months ago by Xecure.

                                  antiX Live system enthusiast.
                                  General Live Boot Parameters for antiX.

                                Viewing 15 posts - 1 through 15 (of 18 total)
                                • You must be logged in to reply to this topic.