How Do You Edit Individual Menu Items?

Forum Forums New users New Users and General Questions How Do You Edit Individual Menu Items?

This topic contains 6 replies, has 4 voices, and was last updated by fatmac Oct 21-11:32 am.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #12698
    Member
    codger
    codger

    The “Edit menus” item in the Control Center seems to just allow you to hide or show items in a list. How do you edit individual items (change, add, or delete)?

    #12699
    Moderator
    fatmac
    fatmac

    I usually alter the dot file menu.

    For Fluxbox, it’s .fluxbox/menu

    Linux (& BSD) since 1999

    #12706
    Forum Admin

    SamK

    How do you edit individual items (change, add, or delete)?

    For items within the Applications section of the main menu
    The way to do all 3 you mention is to edit or create the application launcher
    /usr/share/applications/filename.desktop
    alternatively
    /usr/share/applications/antix/filename.desktop
    In each case it must be done with root privileges.

    To just add or delete (not edit) an individual app item
    Applications→Preferences→Add Menu Item
    Applications→Preferences→Remove Menu Item
    Note: Menu items installed by an app are usually removed automatically when the app is uninstalled, so removing by this method normally applies only to items you create by this method.

    To leave the app installed but not shown in the main menu, use Menu Manager→Applications

    For items within the Personal section of the main menu
    To create a customised item for an installed app use Menu Manager→Personal

    To remove an item for an installed app use Menu Manager→Personal
    or
    Applications→Preferences→Remove Menu Item

    #12714
    Member
    codger
    codger

    Thanks to both of you for the replies. Considering both, I think I’ll go with editing the fluxbox files, since that’s the WM I’m using. I did some editing of several of the menu files, and it worked just fine.

    Well, actually I’m lying. Somehow I messed up the menu file, and it would only display the first submenu. I found the error at the top, but it still wouldn’t work. I ended up editing the default menu file that comes with the Fluxbox install. Anyway, I now have things the way I want them.

    #12716
    Member
    caprea
    caprea

    Fine, but anyway if you messed up your fluxbox-menu to badly you can always look in /etc/skel/.fluxbox how things have been from the start.

    #12719
    Member
    codger
    codger

    That’s a great tip. Thanks!

    #12733
    Moderator
    fatmac
    fatmac

    Somehow I messed up the menu file, and it would only display the first submenu.

    With the Fluxbox menu, you just need to make sure your entries us the correct pairings – [ ] ( ) { }

    Linux (& BSD) since 1999

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.