Does antiX run on newer AMD type computers.

Forum Forums New users New Users and General Questions Does antiX run on newer AMD type computers.

  • This topic has 6 replies, 4 voices, and was last updated Feb 8-11:18 am by Koo.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #53935
    Member
    KooKoo

    How good does antiX run on newer AMD type computers. Is there anything special we need to do like firmwares , kernels , magic tricks.
    MX has MX-19.3 x64 “ahs” for the newer computers. Do we need something like this to make them run. As I don’t want to use MX. I only have eyes for antiX.

    AMD Ryzen 5 & 7 3000 cpu’s
    RX5000xt video cards
    B450 & B550 boards

    • This topic was modified 2 months, 1 week ago by Koo.
    • This topic was modified 2 months, 1 week ago by Koo.

    T430 i7-3632QM 16gb , antiX-19.2.1-runit_x64-base Hannie Schaft 29 March 2020 , 5.8.16-antix.1-amd64-smp

    #53938
    Member
    Avatarskidoo

    You really need to do some of the legwork first.
    Search those phrases on MX Linux forum
    http://forum.mxlinux.org/search.php?keywords=AMD+Ryzen+3000
    See which users are running that hardware, on which kernels…
    and read their descriptions of problems/solutions encountered.
    Also note whether the “AHS” version of MX is, or is not required to support that hardware.
    And if so, why so.

    Then, return here to post a report, sharing with us the details gleaned from your search.
    At that point, we might discuss which necessary kernels, modules and various packages
    are available via MX but are not yet available via antiX.

    #53939
    Member
    linuxdaddylinuxdaddy

    And also you have to run the newest kernels on antiX. if your going to run buster or sid repos
    is deciding which.

    Normal == 🙂
    depends on the surrounding crowd ?!

    #53941
    Member
    KooKoo

    Thanks for your reply’s.

    I have in the past run MX ahs on the computer in question. Soon after ahs came out, this computer was on lone to one of my kids and I have it back now.

    The main thing back then was firmware updates, Ubuntu gang had updated a set of firmware for the newer 3000 cpu’s, and Stevo from MX was working on getting them running on MX.
    Plus new kernels were coming out with updated sets for the new hardware.

    But the motherboard has a dead ram slot which will be sent back for warranty as it still has 2 years left.

    I will spent time checking out the MX ahs version list of firmware and kernels used and forum topics on newer hardware.

    This is not a laptop it is my second mini-itx build. The first one is still going 5 years on.

    Nothing special
    AMD Ryzen 5 3000
    B450-I Rog Stix board
    Sapphire Pulse RX5600XT card
    HyperX Fury sticks 3200 32gb

    What I will start with is antiX 19 duel booting antiX 21a so I can compare the two. I will keep the forum up to date with my finding.

    T430 i7-3632QM 16gb , antiX-19.2.1-runit_x64-base Hannie Schaft 29 March 2020 , 5.8.16-antix.1-amd64-smp

    #54135
    Member
    KooKoo

    Will so far after installing the Asus modules https://github.com/electrified/asus-wmi-sensors this system is fully operational.
    Linux antix21a 5.8.16-antix.1-amd64-smp #1 SMP PREEMPT Tue Oct 20 01:48:36 EEST 2020 x86_64 GNU/Linux

    
    $ lspci -nnk | grep -i -EA3 "3d|display|vga"
    01:00.0 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset USB 3.1 XHCI Controller [1022:43d5] (rev 01)
    	Subsystem: ASMedia Technology Inc. 400 Series Chipset USB 3.1 XHCI Controller [1b21:1142]
    	Kernel driver in use: xhci_hcd
    	Kernel modules: xhci_pci
    --
    08:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] [1002:731f] (rev ca)
    	Subsystem: Sapphire Technology Limited Radeon RX 5600 XT [1da2:e411]
    	Kernel driver in use: amdgpu
    	Kernel modules: amdgpu
    koo@antix21a:~
    $ ls /sys/class/hwmon/; cat /sys/class/hwmon/*/name
    hwmon0  hwmon1  hwmon2  hwmon3
    k10temp
    asus
    amdgpu
    asuswmisensors
    
    ----------------------------------------
    koo@antix21a:~
    $ for m in /sys/class/hwmon/* ; do echo -n "$m = " ; cat $m/name ; done
    /sys/class/hwmon/hwmon0 = k10temp
    /sys/class/hwmon/hwmon1 = asus
    /sys/class/hwmon/hwmon2 = amdgpu
    /sys/class/hwmon/hwmon3 = asuswmisensors
    $ sensors
    amdgpu-pci-0800
    Adapter: PCI adapter
    vddgfx:      775.00 mV 
    fan1:           0 RPM  (min =    0 RPM, max = 3200 RPM)
    edge:         +44.0°C  (crit = +118.0°C, hyst = -273.1°C)
                           (emerg = +99.0°C)
    junction:     +44.0°C  (crit = +99.0°C, hyst = -273.1°C)
                           (emerg = +99.0°C)
    mem:          +44.0°C  (crit = +99.0°C, hyst = -273.1°C)
                           (emerg = +99.0°C)
    power1:        8.00 W  (cap = 135.00 W)
    
    k10temp-pci-00c3
    Adapter: PCI adapter
    Vcore:         1.43 V  
    Vsoc:          1.05 V  
    Tctl:         +41.6°C  
    Tdie:         +41.6°C  
    Tccd1:        +41.5°C  
    Icore:        13.00 A  
    Isoc:          3.50 A  
    
    asuswmisensors-isa-0000
    Adapter: ISA adapter
    CPU Core Voltage:        174.00 mV 
    VPP MEM Voltage:           2.50 V  
    +12V Voltage:             10.19 V  
    +5V Voltage:               5.01 V  
    3VSB Voltage:              3.33 V  
    VBAT Voltage:              3.23 V  
    AVCC3 Voltage:             3.33 V  
    SB 1.05V Voltage:          1.07 V  
    CPU Core Voltage:        199.00 mV 
    CPU SOC Voltage:           1.05 V  
    CPU Fan:                  753 RPM
    Chassis Fan 1:            967 RPM
    AIO Pump:                2051 RPM
    CPU OPT:                    0 RPM
    CPU Temperature:          +41.0°C  
    CPU Socket Temperature:   +37.0°C  
    Motherboard Temperature:  +39.0°C  
    Chipset Temperature:      +53.0°C  
    Tsensor 1 Temperature:   +216.0°C  
    CPU VRM Temperature:      +39.0°C  
    CPU VRM Output Current:    0.00 A 
    
    System:    Host: antix21a Kernel: 5.8.16-antix.1-amd64-smp x86_64 bits: 64 compiler: N/A 
               parameters: BOOT_IMAGE=/boot/vmlinuz-5.8.16-antix.1-amd64-smp 
               root=UUID=82593f8f-dfc1-43bd-8402-ff0a99626493 ro quiet 
               Desktop: i3 4.19 info: i3bar dm: SLiM 1.3.6 
               Distro: antiX-bullseye-a1_x64-full Grup Yorum 3 January 2021 
               base: Debian GNU/Linux bullseye/sid 
    Machine:   Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-I GAMING v: Rev 1.xx serial: <filter> 
               UEFI: American Megatrends v: 4204 date: 01/28/2021 
    Memory:    RAM: total: 15.62 GiB used: 809.8 MiB (5.1%) 
               RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
    PCI Slots: Permissions: Unable to run dmidecode. Root privileges required. 
    CPU:       Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 
               family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701021 L2 cache: 3072 KiB 
               bogomips: 86398 
               Speed: 2200 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 2200 
               2: 2199 3: 2205 4: 2193 5: 2199 6: 2198 7: 2199 8: 2200 9: 2199 10: 2200 11: 2199 
               12: 2200 
               Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 bmi2 bpext 
               cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy constant_tsc cpb cpuid cqm 
               cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists 
               extapic extd_apicid f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb 
               ibs irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr 
               mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter 
               pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse 
               pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sev sha_ni skinit smap smca 
               sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce 
               topoext tsc tsc_scale umip v_vmsave_vmload vgif vmcb_clean vme vmmcall wbnoinvd wdt 
               xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves 
               Vulnerabilities: Type: itlb_multihit status: Not affected 
               Type: l1tf status: Not affected 
               Type: mds status: Not affected 
               Type: meltdown status: Not affected 
               Type: spec_store_bypass 
               mitigation: Speculative Store Bypass disabled via prctl and seccomp 
               Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
               Type: spectre_v2 
               mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
               Type: srbds status: Not affected 
               Type: tsx_async_abort status: Not affected 
    Graphics:  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
               vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 08:00.0 chip ID: 1002:731f 
               Display: x11 server: X.Org 1.20.10 driver: amdgpu unloaded: fbdev compositor: compton 
               v: 1 resolution: 2560x1440~60Hz 
               OpenGL: 
               renderer: AMD Radeon RX 5600 XT (NAVI10 DRM 3.38.0 5.8.16-antix.1-amd64-smp LLVM 11.0.1) 
               v: 4.6 Mesa 20.3.4 direct render: Yes 
    Audio:     Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel bus ID: 08:00.1 
               chip ID: 1002:ab38 
               Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
               bus ID: 0a:00.4 chip ID: 1022:1487 
               Device-3: TEAC US-2x2 type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1:2 
               chip ID: 0644:8045 
               Sound Server: ALSA v: k5.8.16-antix.1-amd64-smp 
    Network:   Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: 5.6.0-k port: d000 
               bus ID: 03:00.0 chip ID: 8086:1539 
               IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
               IP v4: <filter> scope: global broadcast: <filter> 
               IP v6: <filter> scope: link 
               Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: ASUSTeK 
               driver: rtw_8822be v: N/A port: c000 bus ID: 04:00.0 chip ID: 10ec:b822 
               IF: wlan0 state: down mac: <filter> 
               WAN IP: <filter> 
    Drives:    Local Storage: total: 465.76 GiB used: 8.67 GiB (1.9%) 
               ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB block size: 
               physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 1B6Q scheme: GPT 
               Message: No Optical or Floppy data was found. 
    RAID:      Message: No RAID data was found. 
    Partition: ID-1: / raw size: 24.61 GiB size: 24.09 GiB (97.92%) used: 5.88 GiB (24.4%) fs: ext4 
               dev: /dev/sda6 label: rootantiX19 uuid: 82593f8f-dfc1-43bd-8402-ff0a99626493 
               ID-2: /boot/efi raw size: 100.0 MiB size: 96.0 MiB (96.00%) used: 31.0 MiB (32.3%) 
               fs: vfat dev: /dev/sda2 label: N/A uuid: E463-F5AD 
               ID-3: /home raw size: 96.01 GiB size: 94.00 GiB (97.91%) used: 2.76 GiB (2.9%) fs: ext4 
               dev: /dev/sda7 label: homeantiX uuid: 131a68bf-e32b-4404-8bf6-2bdaae384678 
               ID-4: swap-1 size: 16.17 GiB used: 0 KiB (0.0%) fs: swap swappiness: 10 (default 60) 
               cache pressure: 50 (default 100) dev: /dev/sda10 label: N/A 
               uuid: da707172-2f9e-4092-8c00-ae2100abc6d8 
    Unmounted: ID-1: /dev/sda1 size: 300.0 MiB fs: ntfs label: Recovery uuid: EA26632C2662F949 
               ID-2: /dev/sda3 size: 128.0 MiB fs: <root required> label: N/A uuid: N/A 
               ID-3: /dev/sda4 size: 132.27 GiB fs: ntfs label: N/A uuid: 306C18586C181AE4 
               ID-4: /dev/sda5 size: 517.0 MiB fs: ntfs label: N/A uuid: 84664A41664A3468 
               ID-5: /dev/sda8 size: 59.32 GiB fs: ext4 label: rootMX19 
               uuid: daa56471-769f-464c-9397-f3e47110ad52 
               ID-6: /dev/sda9 size: 136.37 GiB fs: ext4 label: homeMX 
               uuid: bf25c21e-978e-483a-8fff-098d7f2d8234 
    USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0 speed: 480 Mb/s 
               chip ID: 1d6b:0002 
               Device-1: 1-1:2 info: TEAC US-2x2 type: Audio,HID 
               driver: hid-generic,snd-usb-audio,usbhid interfaces: 5 rev: 2.0 speed: 480 Mb/s 
               chip ID: 0644:8045 
               Device-2: 1-6:3 info: ASUSTek AURA LED Controller type: HID driver: hid-generic,usbhid 
               interfaces: 1 rev: 2.0 speed: 12 Mb/s chip ID: 0b05:1872 serial: <filter> 
               Device-3: 1-8:4 info: ASUSTek Bluetooth Radio type: Bluetooth driver: btusb 
               interfaces: 2 rev: 1.1 speed: 12 Mb/s chip ID: 0b05:185c serial: <filter> 
               Hub: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
               chip ID: 1d6b:0003 
               Hub: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
               chip ID: 1d6b:0002 
               Device-4: 3-1:2 info: Razer USA DeathAdder Chroma type: Mouse,HID,Keyboard 
               driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s chip ID: 1532:0043 
               Device-5: 3-2:3 info: Logitech Pro Gaming Keyboard type: Keyboard,HID 
               driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 046d:c339 
               serial: <filter> 
               Device-6: 3-3:4 info: Brother Industries HL-L2350DW series type: Printer driver: usblp 
               interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 04f9:009e serial: <filter> 
               Hub: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
               chip ID: 1d6b:0003 
    Sensors:   System Temperatures: cpu: 46.1 C mobo: 40.0 C gpu: amdgpu temp: 44 C 
               Fan Speeds (RPM): cpu: 707 case-1: 1016 gpu: amdgpu fan: 0 
               Voltages: 12v: 10.14 5v: N/A 3.3v: N/A vbat: 3.25 
    Repos:     Active apt repos in: /etc/apt/sources.list.d/antix.list 
               1: deb https: //mirrors.evowise.com/mxlinux-packages/antix// testing main nosystemd nonfree
               Active apt repos in: /etc/apt/sources.list.d/debian.list 
               1: deb http: //deb.debian.org/debian/ bullseye main contrib non-free
               No active apt repos in: /etc/apt/sources.list.d/various.list 
    Processes: CPU top: 5 
               1: cpu: 7.3% command: firefox-esr pid: 4483 mem: 358.9 MiB (2.2%) 
               2: cpu: 2.7% command: xorg pid: 2099 mem: 121.6 MiB (0.7%) 
               3: cpu: 0.7% command: firefox-esr pid: 4623 mem: 204.2 MiB (1.2%) 
               4: cpu: 0.4% command: gtkdialog pid: 7664 mem: 26.9 MiB (0.1%) 
               5: cpu: 0.2% command: conky pid: 2447 mem: 15.7 MiB (0.0%) 
               Memory top: 5 
               1: mem: 358.9 MiB (2.2%) command: firefox-esr pid: 4483 cpu: 7.3% 
               2: mem: 204.2 MiB (1.2%) command: firefox-esr pid: 4623 cpu: 0.7% 
               3: mem: 121.6 MiB (0.7%) command: xorg pid: 2099 cpu: 2.7% 
               4: mem: 90.4 MiB (0.5%) command: firefox-esr pid: 7196 cpu: 0.0% 
               5: mem: 34.7 MiB (0.2%) command: i3 pid: 2388 cpu: 0.0% 
    Info:      Processes: 278 Uptime: 21m Init: SysVinit v: 2.96 runlevel: 5 default: 5 Compilers: 
               gcc: 10.2.1 alt: 10 Client: shell wrapper v: 5.1.4-release inxi: 3.0.36 
    • This reply was modified 2 months ago by Koo.

    T430 i7-3632QM 16gb , antiX-19.2.1-runit_x64-base Hannie Schaft 29 March 2020 , 5.8.16-antix.1-amd64-smp

    #54144
    Moderator
    capreacaprea

    Offtopic here, but looking at your inxi for antix21a saw this under Repos:Active apt repos in: /etc/apt/sources.list.d/antix.list
    1: deb https: //mirrors.evowise.com/mxlinux-packages/antix// testing main nosystemd nonfree

    The line with the double slash between antix an testing will certainly not work.The question is, how did you get there ?

    `

    #54146
    Member
    KooKoo

    The test server used to work, but the at the moment it stopped.
    There is more about this here. https://www.antixforum.com/forums/topic/antix-bullseye-a1-x64-bullseye-full-available/page/11/#post-54060

    T430 i7-3632QM 16gb , antiX-19.2.1-runit_x64-base Hannie Schaft 29 March 2020 , 5.8.16-antix.1-amd64-smp

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.