How to auto connect Bluetooth Keyboard & Mouse

Forum Forums New users New Users and General Questions How to auto connect Bluetooth Keyboard & Mouse

  • This topic has 7 replies, 3 voices, and was last updated Feb 13-11:25 pm by Crashed Disk.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #54182
    Member
    Crashed DiskCrashed Disk

    Hi guys,
    This may have been asked before but here goes. I have managed to get my Apple Magic Mouse and keyboard to work via bluetooth and it works quite well. The problem I have is every time I boot up I have to plug in a USB kB and mouse, login, enable Bluetooth so that I can then switch to the wireless devices.

    Just slightly annoying. Any thoughts, tips, links or guides on how to do this? limited Linux knowledge here so don’t want to do anything that will break the system I have installed the wireless mouse driver using this method:

    sudo apt-get install dkms
    git clone https://github.com/rohitpid/Linux-Magic-Trackpad-2-Driver.git
    cd Linux-Magic-Trackpad-2-Driver/scripts
    chmod u+x install.sh
    sudo ./install.sh

    I found the following web page, will this help or work?

    https://askubuntu.com/questions/17504/how-can-i-have-a-bluetooth-keyboard-auto-connect-at-startup

    Thanks in advance for any help you can give.

    • This topic was modified 3 weeks, 3 days ago by Crashed Disk.
    • This topic was modified 3 weeks, 3 days ago by Crashed Disk.
    #54188
    Moderator
    capreacaprea

    I just wonder if your problem is caused by the fact that bluetooth is turned off in the connman system tray, and therefore you have to enable it every start.
    You didn’t tell which antiX you are using. If antiX19-full go to
    control-centre > network > wifi connman
    look under tab “Status” under Technologies and enable bluetooth

    Otherwise I have had good experience with handling bluetooth devices with the graphical program blueman, which you can install.

    Edit: There’s also the configuration file /etc/bluetooth/main.conf
    Please look if it is set like this under [Policy] section
    AutoEnable=true

    • This reply was modified 3 weeks, 3 days ago by caprea.
    #54253
    Member
    Crashed DiskCrashed Disk

    Hi sorry yes it’s 19 Base but built things up by turning on extra bits that I thought would be needed. Blue man is there and works but each startup get the enable Bluetooth pop up dialog box at login. The config file may be worth a try

    • This reply was modified 3 weeks, 1 day ago by Crashed Disk.
    #54256
    Member
    XecureXecure

    If running live, you need to remove one of the “disable=” parameters. As I don’t know which, you can experiment or better remove all of the “disable=” expression.

    If running installed, check that the bluetooth service is starting at boot. If you are not sure, you can run this command to enable auto-start for bluetooth service:
    sudo update-rc.d bluetooth defaults

    You can follow the other great advice for autoconnecting the bluetooth device.

    • This reply was modified 2 weeks, 5 days ago by Brian Masinick. Reason: spelling, now vs "know"
    #54258
    Moderator
    capreacaprea

    You didn’t tell us if bluetooth is enabled in connman.
    control-centre > network > wifi connman
    look under tab “Status” under Technologies and enable bluetooth

    #54259
    Member
    XecureXecure

    You didn’t tell us if bluetooth is enabled in connman.

    Ups. I missed this.
    When following caprea’s instructions, in antiX Base, instead of a new window, a new icon will appear down in the system tray on the panel. Right-click and enable bluetooth switch there.

    #54353
    Member
    Crashed DiskCrashed Disk

    Thank you, that;s done the trick no more having to manually enable BT at login and no more more faffing with USB devices.

    #54354
    Member
    Crashed DiskCrashed Disk

    Thank you all for the suggestions now all sorted thanks to Xecure’s suggestion. I think i’m there the basics are all now working I have even dumped the Ubuntu partition and re-installed using my backup memory stick created from a snapshot iso and the live USB maker. Connectshares auto mounts at login and even changes=d the colours in conky.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.