How to fix broken packages in antiX?

Forum Forums New users New Users and General Questions How to fix broken packages in antiX?

  • This topic has 27 replies, 6 voices, and was last updated May 10-11:00 am by Wallon.
Viewing 15 posts - 1 through 15 (of 28 total)
  • Author
    Posts
  • #57964
    Member
    marcelocripemarcelocripe

    Title (in en): How to fix broken packages in antiX?

    Hey guys,

    Again I come to ask for help and more lessons for solving problems that occurred in antiX (“antiX-19-legacy-bet2_386-base.iso”):

    Error when updating antiX and broken package in Synaptic.

    cca5 @ antix5: ~
    $ sudo apt update
    Reached: 1 http://ftp.br.debian.org/debian buster-updates InRelease
    Reached: 2 http://ftp.br.debian.org/debian buster InRelease
    Hit: 3 http://security.debian.org buster / updates InRelease
    Hit: 4 http://repo.antixlinux.com/buster buster InRelease
    Reached: 5 http://deb.debian.org/debian buster-backports InRelease
    Reading package lists … Done
    Building dependency tree
    Reading status information … Ready
    39 packages can be upgraded. Run ‘apt list –upgradable’ to see them.

    cca5 @ antix5: ~
    $ sudo apt upgrade
    Reading package lists … Done
    Building dependency tree
    Reading status information … Ready
    Calculating update … Done
    The following packages have been installed automatically and are no longer needed:
    libvkd3d1 libwine wine32
    Use ‘sudo apt autoremove’ to remove them.
    The following packages will be maintained in their current versions:
    xserver-xorg xserver-xorg-core xserver-xorg-input-aiptek
    xserver-xorg-input-all xserver-xorg-input-elographics
    xserver-xorg-input-evdev xserver-xorg-input-joystick xserver-xorg-input-kbd
    xserver-xorg-input-mouse xserver-xorg-input-synaptics
    xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-ati
    xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-glide
    xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
    xserver-xorg-video-neomagic xserver-xorg-video-nouveau
    xserver-xorg-video-openchrome xserver-xorg-video-qxl xserver-xorg-video-r128
    xserver-xorg-video-radeon xserver-xorg-video-savage
    xserver-xorg-video-siliconmotion xserver-xorg-video-sisusb
    xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-vesa
    xserver-xorg-video-vmware
    The following packages will be updated:
    apt apt-transport-https apt-utils libapt-inst2.0 wpagui wpasupplicant
    youtube-dl
    7 updated packages, 0 new packages installed, 0 to be removed and 32 not updated.
    2 packages not fully installed or removed.
    You need to download 0 B / 5.072 kB of files.
    After this operation, an additional 169 kB of disk space will be used.
    Do you want to continue? [Y / n] sec
    Configuring libapt-pkg5.0: i386 (1.8.2.3) …
    (Reading database … 112650 files and directories currently installed.)
    Preparing to unpack … / youtube-dl_2021.04.07-1.0antix5_all.deb …
    Traceback (most recent call last):
    File “/ usr / bin / py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: warning: the sub-process of the old youtube-dl package, pre-removal script returned error of exit status 1
    dpkg: trying to script the new package instead …
    Traceback (most recent call last):
    File “/ usr / bin / py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: error processing the file /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix5_all.deb (–unpack):
    the subprocess of the youtube-dl package, new pre-removal script returned error of exit status 1
    Traceback (most recent call last):
    File “/ usr / bin / py3compile”, line 25, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: error when cleaning:
    the installed subprocess, from the youtube-dl package, the post-installation script returned an exit status error 1
    Preparing to unpack … / libapt-inst2.0_1.8.2.3_i386.deb …
    Unzipping libapt-inst2.0: i386 (1.8.2.3) on (1.8.2.2) …
    Preparing to unpack … / archives / apt_1.8.2.3_i386.deb …
    Unzipping apt (1.8.2.3) on (1.8.2.2) …
    Errors were encountered while processing:
    /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix5_all.deb
    E: Sub-process / usr / bin / dpkg returned an error code (1)

    cca5 @ antix5: ~
    $

    The broken package problems also occurred with the official versions (antiX-19.3_386-full.iso and antiX-19.3_x64-full.iso), not necessarily from the youtube-dl package, occurred with the LibreOffice, Firefox, Printer translation package (hplip-gui) when the installation process is done with the Synaptic package manager and when some type of error occurs. I do not know this problem occurs due to internet connection failure or if it is for another reason.
    Synaptic message after attempting to completely remove the youtube-dl package:

    E: youtube-dl: The package is in a very bad state of inconsistency; you must reinstall it before attempting removal.

    dpkg: error while processing the youtube-dl package (–remove):
    The package is in a very bad state of inconsistency; he must
    reinstall it before attempting removal.
    Errors were encountered while processing:
    youtube-dl
    E: Sub-process / usr / bin / dpkg returned an error code (1)
    A package failed to install. Trying to recover:
    dpkg: error while processing the youtube-dl package (–configure):
    The package is in a bad state of inconsistency; he must
    reinstall it before trying to configure it.
    Errors were encountered while processing:
    youtube-dl

    Synaptic message after attempting to remove the youtube-dl package:

    E: youtube-dl: The package is in a very bad state of inconsistency; you must reinstall it before attempting removal.

    dpkg: error while processing the youtube-dl package (–remove):
    The package is in a very bad state of inconsistency; he must
    reinstall it before attempting removal.
    Errors were encountered while processing:
    youtube-dl
    E: Sub-process / usr / bin / dpkg returned an error code (1)
    A package failed to install. Trying to recover:
    dpkg: error while processing the youtube-dl package (–configure):
    The package is in a bad state of inconsistency; he must
    reinstall it before trying to configure it.
    Errors were encountered while processing:
    youtube-dl

    I will send the texts that were displayed in the terminal and in Synaptic with the translation of the internet translator into the English language. I hope the texts are understandable.

    Grateful.

    marcelocripe
    (Original text in Brazilian Portuguese)

    ———-

    Título (em pt-BR): Como corrigir pacotes quebrados no antiX?

    Olá pessoal,

    Novamente eu venho pedir ajuda e mais ensinamentos para a resolução de problemas que ocorreram no antiX (“antiX-19-legacy-bet2_386-base.iso”):

    Erro na atualização do antiX o de pacote quebrado no Synaptic.

    (Os detalhes estão no texto traduzido para o idioma inglês)

    Os problemas de pacote quebrado também ocorreram com as versões oficiais (antiX-19.3_386-full.iso e antiX-19.3_x64-full.iso), não necessariamente do pacote youtube-dl, ocorreu com pacote de tradução do LibreOffice, Firefox, Impressora (hplip-gui) quando o processo de instalação é feito com o gerenciador de pacotes Synaptic e quando ocorre algum tipo de erro. Eu não sei este problema ocorre por falha de conexão com a internet ou se é por outro motivo.

    Mensagem do Synaptic após tentativa de remoção completa do pacote youtube-dl:

    (Os detalhes estão no texto traduzido para o idioma inglês)

    Mensagem do Synaptic após tentativa de remoção do pacote youtube-dl:

    (Os detalhes estão no texto traduzido para o idioma inglês)

    Eu vou enviar os textos que foram exibidos no terminal e no Synaptic com a tradução do tradutor da internet para o idioma inglês. Eu espero que os textos fiquem compreensíveis.

    Grato.

    marcelocripe
    (Texto original em idioma Português do Brasil)

    #57966
    Member
    XecureXecure

    Your problems will require a bit of investigating to solve. There is no “one solution that always works”, unfortunately.

    To manage packages in your system, it is good practice to always remove the “residual” packages, which usually are dependencies that were left after a package was removed (or are no longer needed after a an update of a certain package).
    Cleaning them is as simple as using antiX auto-remove or using the command
    sudo apt autoremove

    For missing or broken packages, you can usually use the the apt-get fix broken (-f) or fix missing options
    sudo apt-get install --fix-broken
    sudo apt-get install --fix-missing
    or the simplified
    sudo apt-get install -f
    This last one is the recommended (is is the same as fix-broken), and usually will solve most problems.

    When a program didn’t install properly, it may require a reinstallation (as one of the terminal output you shared states). Use the reinstall option with apt to try to fix the problem
    sudo apt install --reinstall youtube-dl
    or whatever package, not only for youtube-dl.

    Worst case scenario is purging the problematic package and installing again. For example, you could remove youtube-dl first, try to fix the broken packages, try to update the system without youtube-dl, and then later reinstall it again.

    sudo apt purge youtube-dl
    sudo apt-get install -f
    sudo apt upgrade
    sudo apt install youtube-dl

    Each case may be different, and may require a different procedure. Make a plan depending on the error output. If auto-remove and then fix-broken doesn’t help, then select logically the package or packages you thing may need to be reinstalled and maybe even purge them if reinstalling doesn’t work. Always pay attention to what other packages want to be removed when purging a package. Sometimes purging may lead to an even worse output than broken packages (like accidentally removing xorg packages and finding you cannot reboot to a graphical interface). Always try to understand what is going on, and you will be sure not to fall in a deadly trap.

    You are doing very well learning little by little. I hope this post helps with figuring out these kind of problems in the future.

    • This reply was modified 2 weeks, 5 days ago by Xecure. Reason: fixing typo
    #57968
    Member
    Avatarskidoo

    Reached: 1 http://ftp.br.debian.org/debian buster-updates InRelease
    Reached: 2 http://ftp.br.debian.org/debian buster InRelease
    Hit: 3 http://security.debian.org buster / updates InRelease
    Hit: 4 http://repo.antixlinux.com/buster buster InRelease
    Reached: 5 http://deb.debian.org/debian buster-backports InRelease
    […]
    Preparing to unpack … / youtube-dl_2021.04.07-1.0antix5_all.deb …
    Traceback (most recent call last):
    File “/ usr / bin / py3clean”, line 24, in <module>

    How is it possible to receive a packagename with “5” in the name
    when the repo has only a “1” -named package ? ? ?

    lookit: http://repo.antixlinux.com/buster/pool/main/y/youtube-dl/
    youtube-dl_2021.04.07-1.0antix1_all.deb

    #57969
    Member
    Avatarskidoo

    Reached: 5 http://deb.debian.org/debian buster-backports

    Incidental, or perhaps not-so-incidental to the problem at hand…
    leaving the backports repository permanently enabled can bring unwelcome surprises.
    (Backports packages are “best effort”, but are not widely/rigorously tested.)

    #57970
    Member
    Avatarskidoo

    EOFError: marshal data too short
    dpkg: warning: the sub-process of the old youtube-dl package,
    pre-removal script returned error of exit status 1
    […]
    the installed subprocess, from the youtube-dl package,
    the post-installation script returned an exit status error 1

    https://stackoverflow.com/questions/50391941/eoferror-marshal-data-too-short
    I was trying to install pyspark. The spark folder structure was something like this

    sparkybark/python/pyspark

    Under this folder contained a folder by name ‘__pycache__’ I went to the pyspark
    folder and deleted the ‘__pycache__’ folder using the command:

    rm -r __pycache__/

    This eliminated the error for me and I am now able to import pyspark.

    .pyc (python cached bytecode) files
    are automatically generated, and if deleted, will be automatically (selectively) re-generated
    upon next launch of any python script or python module which can benefit from presence of a particular .pyc file

    locate __pycache__ | grep youtube-dl

    /usr/lib/python3/dist-packages/youtube_dl/postprocessor/__pycache__/__init__.cpython-37.pyc
    /usr/lib/python3/dist-packages/youtube_dl/postprocessor/__pycache__/common.cpython-37.pyc
    /usr/lib/python3/dist-packages/youtube_dl/postprocessor/__pycache__/embedthumbnail.cpython-37.pyc
    /usr/lib/python3/dist-packages/youtube_dl/postprocessor/__pycache__/execafterdownload.cpython-37.pyc
    /usr/lib/python3/dist-packages/youtube_dl/postprocessor/__pycache__/ffmpeg.cpython-37.pyc
    /usr/lib/python3/dist-packages/youtube_dl/postprocessor/__pycache__/metadatafromtitle.cpython-37.pyc
    /usr/lib/python3/dist-packages/youtube_dl/postprocessor/__pycache__/xattrpp.cpython-37.pyc

    locate __pycache__ | grep setuptools
    ^—v
    this booger has no cached .pyc files

    /usr/lib/python3/dist-packages/setuptools/__pycache__
    /usr/lib/python3/dist-packages/setuptools/_vendor/__pycache__
    /usr/lib/python3/dist-packages/setuptools/_vendor/packaging/__pycache__
    /usr/lib/python3/dist-packages/setuptools/command/__pycache__
    /usr/lib/python3/dist-packages/setuptools/extern/__pycache__

    Traceback (most recent call last):
    File “/ usr / bin / py3clean”, line 24, in <module>

    geany /usr/bin/pyclean3:24

    mentions import of the “logging” module
    (whose logging module? Izzit called by setuptools? Idunno)

    locate __pycache__ | grep logging

    /usr/lib/python3.7/logging/__pycache__
    /usr/lib/python3.7/logging/__pycache__/__init__.cpython-37.pyc

    Although it may not be the most expedient approach to solving the problem, I would:
    cd /usr/lib/python3.7/logging/__pycache_
    sudo mv __init__.cpython-37.pyc __init__.cpython-37.pyc_OLD

    then retry the previously failed apt operation
    and then
    cd /usr/lib/python3.7/logging/__pycache_
    stat /usr/lib/python3.7/logging/__pycache__/__init__.cpython-37.pyc
    to confirm that .pyc was (regenerated and) used.
    If it was, regardlesss whether apt operation succeeded, to satisfy curiosity I would:
    md5sums __init__.cpython-37.pyc __init__.cpython-37.pyc_OLD
    to confirm the OLD file had become corrupted.
    ^— Then puzzle about “why so?” (unreliable storage drive?)

    #57979
    Member
    XecureXecure

    How is it possible to receive a packagename with “5” in the name
    when the repo has only a “1” -named package ? ? ?

    lookit: http://repo.antixlinux.com/buster/pool/main/y/youtube-dl/
    youtube-dl_2021.04.07-1.0antix1_all.deb

    I missed that entirely. Maybe marcelo needs to update the packagelist again.

    #57998
    Member
    marcelocripemarcelocripe

    Hi Xecure and Skidoo,

    I thank you for your answers and explanations. I will try to apply each command.

    Xecure, on the “antiX autoremove” program or the “$ sudo apt autoremove” command, I have a question about the correct time to use it, it should be used after updates (via “antiX Updater” / “antiX updater” or via commands $ sudo apt update, $ sudo apt upgrade)?

    cca5@antix5:
    $ sudo apt autoremove
    [sudo] senha para cca5:
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    The following additional packages will be installed:
    youtube-dl
    Pacotes sugeridos:
    libfribidi-bin | bidiv phantomjs
    Os pacotes a seguir serão REMOVIDOS:
    libvkd3d1 libwine wine32
    Os pacotes a seguir serão atualizados:
    youtube-dl
    1 pacotes atualizados, 0 pacotes novos instalados, 3 a serem removidos e 35 não atualizados.
    2 pacotes não totalmente instalados ou removidos.
    É preciso baixar 0 B/1.125 kB de arquivos.
    Depois desta operação, 214 MB de espaço em disco serão liberados.
    Você quer continuar? s
    Configurando dpkg (1.19.7) …
    (Lendo banco de dados … 112650 ficheiros e directórios actualmente instalados.)
    A preparar para desempacotar …/youtube-dl_2021.04.07-1.0antix1_all.deb …
    Traceback (most recent call last):
    File “/usr/bin/py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: aviso: o subprocesso do pacote antigo youtube-dl, script pre-removal retornou erro do status de saída 1
    dpkg: em vez disso a tentar script do novo pacote …
    Traceback (most recent call last):
    File “/usr/bin/py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: erro ao processar o arquivo /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix1_all.deb (–unpack):
    o subprocesso do pacote youtube-dl, novo script pre-removal retornou erro do status de saída 1
    Traceback (most recent call last):
    File “/usr/bin/py3compile”, line 25, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: erro ao limpar:
    o subprocesso instalado, do pacote youtube-dl, o script post-installation retornou erro do status de saída 1
    Erros foram encontrados durante o processamento de:
    /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    cca5@antix5:
    $ sudo apt-get install –fix-broken
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    The following additional packages will be installed:
    youtube-dl
    Pacotes sugeridos:
    libfribidi-bin | bidiv phantomjs
    Os pacotes a seguir serão atualizados:
    youtube-dl
    1 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 35 não atualizados.
    1 pacotes não totalmente instalados ou removidos.
    É preciso baixar 0 B/1.125 kB de arquivos.
    Depois desta operação, 167 kB adicionais de espaço em disco serão usados.
    Você quer continuar? s
    (Lendo banco de dados … 112650 ficheiros e directórios actualmente instalados.)
    A preparar para desempacotar …/youtube-dl_2021.04.07-1.0antix1_all.deb …
    Traceback (most recent call last):
    File “/usr/bin/py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: aviso: o subprocesso do pacote antigo youtube-dl, script pre-removal retornou erro do status de saída 1
    dpkg: em vez disso a tentar script do novo pacote …
    Traceback (most recent call last):
    File “/usr/bin/py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: erro ao processar o arquivo /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix1_all.deb (–unpack):
    o subprocesso do pacote youtube-dl, novo script pre-removal retornou erro do status de saída 1
    Traceback (most recent call last):
    File “/usr/bin/py3compile”, line 25, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: erro ao limpar:
    o subprocesso instalado, do pacote youtube-dl, o script post-installation retornou erro do status de saída 1
    Erros foram encontrados durante o processamento de:
    /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    cca5@antix5:
    $ sudo apt-get install –fix-missing
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    The following additional packages will be installed:
    youtube-dl
    Pacotes sugeridos:
    libfribidi-bin | bidiv phantomjs
    Os pacotes a seguir serão atualizados:
    youtube-dl
    1 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 35 não atualizados.
    1 pacotes não totalmente instalados ou removidos.
    É preciso baixar 0 B/1.125 kB de arquivos.
    Depois desta operação, 167 kB adicionais de espaço em disco serão usados.
    Você quer continuar? s
    (Lendo banco de dados … 112650 ficheiros e directórios actualmente instalados.)
    A preparar para desempacotar …/youtube-dl_2021.04.07-1.0antix1_all.deb …
    Traceback (most recent call last):
    File “/usr/bin/py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: aviso: o subprocesso do pacote antigo youtube-dl, script pre-removal retornou erro do status de saída 1
    dpkg: em vez disso a tentar script do novo pacote …
    Traceback (most recent call last):
    File “/usr/bin/py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: erro ao processar o arquivo /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix1_all.deb (–unpack):
    o subprocesso do pacote youtube-dl, novo script pre-removal retornou erro do status de saída 1
    Traceback (most recent call last):
    File “/usr/bin/py3compile”, line 25, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: erro ao limpar:
    o subprocesso instalado, do pacote youtube-dl, o script post-installation retornou erro do status de saída 1
    Erros foram encontrados durante o processamento de:
    /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    cca5@antix5:
    $ sudo apt-get install -f
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    The following additional packages will be installed:
    youtube-dl
    Pacotes sugeridos:
    libfribidi-bin | bidiv phantomjs
    Os pacotes a seguir serão atualizados:
    youtube-dl
    1 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 35 não atualizados.
    1 pacotes não totalmente instalados ou removidos.
    É preciso baixar 0 B/1.125 kB de arquivos.
    Depois desta operação, 167 kB adicionais de espaço em disco serão usados.
    Você quer continuar? s
    (Lendo banco de dados … 112650 ficheiros e directórios actualmente instalados.)
    A preparar para desempacotar …/youtube-dl_2021.04.07-1.0antix1_all.deb …
    Traceback (most recent call last):
    File “/usr/bin/py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: aviso: o subprocesso do pacote antigo youtube-dl, script pre-removal retornou erro do status de saída 1
    dpkg: em vez disso a tentar script do novo pacote …
    Traceback (most recent call last):
    File “/usr/bin/py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: erro ao processar o arquivo /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix1_all.deb (–unpack):
    o subprocesso do pacote youtube-dl, novo script pre-removal retornou erro do status de saída 1
    Traceback (most recent call last):
    File “/usr/bin/py3compile”, line 25, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: erro ao limpar:
    o subprocesso instalado, do pacote youtube-dl, o script post-installation retornou erro do status de saída 1
    Erros foram encontrados durante o processamento de:
    /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    cca5@antix5:
    $ sudo apt install –reinstall youtube-dl
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    Pacotes sugeridos:
    libfribidi-bin | bidiv phantomjs
    Os pacotes a seguir serão atualizados:
    youtube-dl
    1 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 35 não atualizados.
    1 pacotes não totalmente instalados ou removidos.
    É preciso baixar 0 B/1.125 kB de arquivos.
    Depois desta operação, 167 kB adicionais de espaço em disco serão usados.
    (Lendo banco de dados … 112650 ficheiros e directórios actualmente instalados.)
    A preparar para desempacotar …/youtube-dl_2021.04.07-1.0antix1_all.deb …
    Traceback (most recent call last):
    File “/usr/bin/py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: aviso: o subprocesso do pacote antigo youtube-dl, script pre-removal retornou erro do status de saída 1
    dpkg: em vez disso a tentar script do novo pacote …
    Traceback (most recent call last):
    File “/usr/bin/py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: erro ao processar o arquivo /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix1_all.deb (–unpack):
    o subprocesso do pacote youtube-dl, novo script pre-removal retornou erro do status de saída 1
    Traceback (most recent call last):
    File “/usr/bin/py3compile”, line 25, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: erro ao limpar:
    o subprocesso instalado, do pacote youtube-dl, o script post-installation retornou erro do status de saída 1
    Erros foram encontrados durante o processamento de:
    /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    cca5@antix5:
    $ sudo apt purge youtube-dl
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    Os pacotes a seguir serão REMOVIDOS:
    youtube-dl*
    0 pacotes atualizados, 0 pacotes novos instalados, 1 a serem removidos e 35 não atualizados.
    1 pacotes não totalmente instalados ou removidos.
    Depois desta operação, 5.966 kB de espaço em disco serão liberados.
    Você quer continuar? s
    dpkg: erro ao processar o pacote youtube-dl (–remove):
    O pacote está num estado de inconsistência muito mau; deve
    reinstalá-lo antes de tentar a remoção.
    Erros foram encontrados durante o processamento de:
    youtube-dl
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    cca5@antix5:
    $ sudo apt-get install -f
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    The following additional packages will be installed:
    youtube-dl
    Pacotes sugeridos:
    libfribidi-bin | bidiv phantomjs
    Os pacotes a seguir serão atualizados:
    youtube-dl
    1 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 35 não atualizados.
    1 pacotes não totalmente instalados ou removidos.
    É preciso baixar 0 B/1.125 kB de arquivos.
    Depois desta operação, 167 kB adicionais de espaço em disco serão usados.
    Você quer continuar? s
    (Lendo banco de dados … 112650 ficheiros e directórios actualmente instalados.)
    A preparar para desempacotar …/youtube-dl_2021.04.07-1.0antix1_all.deb …
    Traceback (most recent call last):
    File “/usr/bin/py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: aviso: o subprocesso do pacote antigo youtube-dl, script pre-removal retornou erro do status de saída 1
    dpkg: em vez disso a tentar script do novo pacote …
    Traceback (most recent call last):
    File “/usr/bin/py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: erro ao processar o arquivo /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix1_all.deb (–unpack):
    o subprocesso do pacote youtube-dl, novo script pre-removal retornou erro do status de saída 1
    Traceback (most recent call last):
    File “/usr/bin/py3compile”, line 25, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: erro ao limpar:
    o subprocesso instalado, do pacote youtube-dl, o script post-installation retornou erro do status de saída 1
    Erros foram encontrados durante o processamento de:
    /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    cca5@antix5:
    $ sudo apt update
    Obter:1 http://security.debian.org buster/updates InRelease [65,4 kB]
    Obter:2 http://deb.debian.org/debian buster-backports InRelease [46,7 kB]
    Obter:3 http://ftp.br.debian.org/debian buster-updates InRelease [51,9 kB]
    Atingido:4 http://ftp.br.debian.org/debian buster InRelease
    Obter:5 http://repo.antixlinux.com/buster buster InRelease [27,4 kB]
    Obter:6 http://security.debian.org buster/updates/main i386 Packages [271 kB]
    Obter:7 http://repo.antixlinux.com/buster buster/main i386 Packages [298 kB]
    Baixados 760 kB em 8s (90,8 kB/s)
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    36 packages can be upgraded. Run ‘apt list –upgradable’ to see them.

    cca5@antix5:
    $ sudo apt upgrade
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    Calculando atualização… Pronto
    Os pacotes a seguir serão mantidos em suas versões atuais:
    xserver-xorg xserver-xorg-core xserver-xorg-input-aiptek
    xserver-xorg-input-all xserver-xorg-input-elographics
    xserver-xorg-input-evdev xserver-xorg-input-joystick xserver-xorg-input-kbd
    xserver-xorg-input-mouse xserver-xorg-input-synaptics
    xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-ati
    xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-glide
    xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
    xserver-xorg-video-neomagic xserver-xorg-video-nouveau
    xserver-xorg-video-openchrome xserver-xorg-video-qxl xserver-xorg-video-r128
    xserver-xorg-video-radeon xserver-xorg-video-savage
    xserver-xorg-video-siliconmotion xserver-xorg-video-sisusb
    xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-vesa
    xserver-xorg-video-vmware
    Os pacotes a seguir serão atualizados:
    apt-transport-https wpagui wpasupplicant youtube-dl
    4 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 32 não atualizados.
    1 pacotes não totalmente instalados ou removidos.
    É preciso baixar 0 B/2.986 kB de arquivos.
    Depois desta operação, 169 kB adicionais de espaço em disco serão usados.
    Você quer continuar? s
    (Lendo banco de dados … 112650 ficheiros e directórios actualmente instalados.)
    A preparar para desempacotar …/youtube-dl_2021.04.07-1.0antix1_all.deb …
    Traceback (most recent call last):
    File “/usr/bin/py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: aviso: o subprocesso do pacote antigo youtube-dl, script pre-removal retornou erro do status de saída 1
    dpkg: em vez disso a tentar script do novo pacote …
    Traceback (most recent call last):
    File “/usr/bin/py3clean”, line 24, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: erro ao processar o arquivo /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix1_all.deb (–unpack):
    o subprocesso do pacote youtube-dl, novo script pre-removal retornou erro do status de saída 1
    Traceback (most recent call last):
    File “/usr/bin/py3compile”, line 25, in <module>
    import logging
    File “/usr/lib/python3.7/logging/__init__.py”, line 26, in <module>
    import sys, os, time, io, traceback, warnings, weakref, collections.abc
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 967, in _find_and_load_unlocked
    File “<frozen importlib._bootstrap>”, line 677, in _load_unlocked
    File “<frozen importlib._bootstrap_external>”, line 724, in exec_module
    File “<frozen importlib._bootstrap_external>”, line 857, in get_code
    File “<frozen importlib._bootstrap_external>”, line 525, in _compile_bytecode
    EOFError: marshal data too short
    dpkg: erro ao limpar:
    o subprocesso instalado, do pacote youtube-dl, o script post-installation retornou erro do status de saída 1
    A preparar para desempacotar …/apt-transport-https_1.8.2.3_all.deb …
    A descompactar apt-transport-https (1.8.2.3) sobre (1.8.2.2) …
    A preparar para desempacotar …/wpasupplicant_2%3a2.7+git20190128+0c1e29f-6+deb10u3_i386.deb …
    A descompactar wpasupplicant (2:2.7+git20190128+0c1e29f-6+deb10u3) sobre (2:2.7+git20190128+0c1e29f-6+deb10u2) …
    A preparar para desempacotar …/wpagui_2%3a2.7+git20190128+0c1e29f-6+deb10u3_i386.deb …
    A descompactar wpagui (2:2.7+git20190128+0c1e29f-6+deb10u3) sobre (2:2.7+git20190128+0c1e29f-6+deb10u2) …
    Erros foram encontrados durante o processamento de:
    /var/cache/apt/archives/youtube-dl_2021.04.07-1.0antix1_all.deb
    Writing Menu: jwm
    Writing Menu: fluxbox
    Writing Menu: icewm
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Thank you very much.

    marcelocripe
    (Original text in Brazilian Portuguese)

    ———-

    Olá Xecure e Skidoo,

    Eu agradeço por suas respostas e explicações. Eu irei tentar aplicar cada comando.

    Xecure, sobre o programa “antiX autoremove” ou comando “$ sudo apt autoremove”, eu possuo uma dúvida sobre o momento correto de utilizar, deve ser utilizado após as atualizações (via “antiX Updater”/”Atualizador do antiX” ou via comandos $ sudo apt update, $ sudo apt upgrade)?

    (Os resultados dos comandos estão no texto traduzido pelo tradutor da internet do idioma “pt-BR” para “en”)

    Muito obrigado.

    marcelocripe
    (Texto original em idioma Português do Brasil)

    #57999
    Member
    marcelocripemarcelocripe

    How is it possible to receive a packagename with “5” in the name
    when the repo has only a “1” -named package ? ? ?

    lookit: http://repo.antixlinux.com/buster/pool/main/y/youtube-dl/
    youtube-dl_2021.04.07-1.0antix1_all.deb

    Skidoo, I think I can explain the possible reasons to you, it must have been my mistake when I copied the text from the terminal and pasted it on the internet translator, or it could be some mess that the internet translator made, sometimes it happens when he it does not understand any construction or character, or even if I pressed number 5 by mistake.

    Therefore, I will not put the results of the commands in the translator, however it generates more work for you and Xecure, as they will have to translate the texts in “pt-BR” or “pt” that are displayed in the terminal for their respective languages.

    Incidental, or perhaps not-so-incidental to the problem at hand…
    leaving the backports repository permanently enabled can bring unwelcome surprises.
    (Backports packages are “best effort”, but are not widely/rigorously tested.)

    Skidoo, I didn’t change the repositories for “backports”, I’m using the repositories as it comes in the antiX ISOs (both in the Legacy version and in the official full versions of 23 and 64 bits). During the adaptations of the translations I did on the transifex, I found a text containing this information that you entered in brackets. I always prefer to use the stable repository, because the programs are more secure and properly tested.

    cca5@antix5:
    $ locate __pycache__ | grep youtube-dl

    cca5@antix5:
    $ locate __pycache__ | grep setuptools

    cca5@antix5:
    $ locate __pycache__ | grep logging
    /usr/lib/python3.7/logging/__pycache__
    /usr/lib/python3.7/logging/__pycache__/__init__.cpython-37.pyc
    /usr/lib/python3.7/logging/__pycache__/config.cpython-37.pyc
    /usr/lib/python3.7/logging/__pycache__/handlers.cpython-37.pyc

    cca5@antix5:
    $ cd /usr/lib/python3.7/logging/__pycache_
    bash: cd: /usr/lib/python3.7/logging/__pycache_: Arquivo ou diretório inexistente

    cca5@antix5:
    $ sudo mv __init__.cpython-37.pyc __init__.cpython-37.pyc_OLD
    [sudo] senha para cca5:
    mv: não foi possível obter estado de ‘__init__.cpython-37.pyc’: Arquivo ou diretório inexistente

    cca5@antix5:
    $ stat /usr/lib/python3.7/logging/__pycache__/__init__.cpython-37.pyc
    Arquivo: /usr/lib/python3.7/logging/__pycache__/__init__.cpython-37.pyc
    Tamanho: 62540 Blocos: 128 bloco de E/S: 4096 arquivo comum
    Dispositivo: 801h/2049d Inode: 665256 Links: 1
    Acesso: (0644/-rw-r–r–) Uid: ( 0/ root) Gid: ( 0/ root)
    Acesso: 2021-04-04 11:10:43.536061587 -0300
    Modificação: 2021-04-04 11:10:43.536061587 -0300
    Alteração: 2021-04-04 11:10:43.536061587 -0300
    Criação: –

    cca5@antix5:
    $ md5sums __init__.cpython-37.pyc __init__.cpython-37.pyc_OLD
    bash: md5sums: comando não encontrado

    Thank you very much.

    marcelocripe
    (Original text in Brazilian Portuguese)

    ———-

    How is it possible to receive a packagename with “5” in the name
    when the repo has only a “1” -named package ? ? ?

    lookit: http://repo.antixlinux.com/buster/pool/main/y/youtube-dl/
    youtube-dl_2021.04.07-1.0antix1_all.deb

    Skidoo, eu acho que consigo te explicar os motivos provavéis, deve ter sido algum erro meu quando copiei o texto do terminal e colei no tradutor da internet, ou pode ser alguma bagunça que o tradutor da internet tenha feito, às vezes isso ocorre quando ele não compreende alguma construção ou caractere, ou ainda que eu tenha pressionado por engano o número 5.

    Por isso, eu não colocarei os resultados dos comandos no tradutor, contudo gera mais trabalho para você e para o Xecure, pois terão que traduzir os textos em “pt-BR” ou em “pt” que são exibidos no terminal para os seus respectivos idiomas.

    Incidental, or perhaps not-so-incidental to the problem at hand…
    leaving the backports repository permanently enabled can bring unwelcome surprises.
    (Backports packages are “best effort”, but are not widely/rigorously tested.)

    Skidoo, eu não alterei os repositórios para “backports”, estou utilizando os repositórios como vem nas ISOs do antiX (tanto na versão Legacy quanto nas versões oficiais full de 23 e 64 bits). Durante as adaptações das traduções que eu fiz no transifex, eu encontrei um texto contendo estas informações que você inseriu entre parenteses. Eu prefiro sempre utilizar o repositório estável, devido os programas serem mais seguros e devidamente testados.

    (Os resultados dos comandos estão no texto traduzido pelo tradutor da internet do idioma “pt-BR” para o “en”)

    Muito obrigado.

    marcelocripe
    (Texto original em idioma Português do Brasil)

    #58000
    Member
    XecureXecure

    You can read skidoo’s analysis, and follow the instructions:

    Although it may not be the most expedient approach to solving the problem, I would:
    cd /usr/lib/python3.7/logging/__pycache__
    sudo mv __init__.cpython-37.pyc __init__.cpython-37.pyc_OLD

    then retry the previously failed apt operation
    and then
    cd /usr/lib/python3.7/logging/__pycache__
    stat /usr/lib/python3.7/logging/__pycache__/__init__.cpython-37.pyc
    to confirm that .pyc was (regenerated and) used.
    If it was, regardless whether apt operation succeeded, to satisfy curiosity I would:
    md5sums __init__.cpython-37.pyc __init__.cpython-37.pyc_OLD
    to confirm the OLD file had become corrupted.
    ^— Then puzzle about “why so?” (unreliable storage drive?)

    #58001
    Member
    XecureXecure

    $ cd /usr/lib/python3.7/logging/__pycache_
    bash: cd: /usr/lib/python3.7/logging/__pycache_: Arquivo ou diretório inexistente

    There was a missing _ symbol, but it is fixed in may previous answer.
    Always read the terminal output to be sure that what you are doing is OK.

    #58003
    Member
    Avatarskidoo

    not put the results of the commands in the translator

    Right, it would be best to post the verbatim output, untranslated.

    I didn’t change the repositories for “backports”

    Someone else can check to confirm/refute, but I don’t recall finding the
    antiX19 default configuration having “backports enabled, by default”.

    The probable cause of backports repo being unexpectedly enabled: packageinstaller
    If packageinstaller does not exit cleanly, it can leave the repositories lists in a “not the way they were, prior to using packageinstaller” state.
    On several occasions I, and a few others, have posted to mention this bug… but it has been “swept under the rug”.

    #58005
    Member
    XecureXecure

    Someone else can check to confirm/refute, but I don’t recall finding the
    antiX19 default configuration having “backports enabled, by default”.

    This is correct for the 19.0-19.1 releases, but this was later changed. You may have missed some of the related forum problems that popped up, but better yet, here are some of the official statements:

    buster-backports repo enabled

    https://antixlinux.com/antix-19-2-bug-fix-upgrade-isos-available/
    […]
    Changes:
    […]
    * Debian buster-backports repository enabled
    […]

    the buster-backports repo is enabled, but it has a lower priority to all other repos, so packages will only be installed from here when specifically asked (via terminal or with the “latest” packages in packageinstaller).

    #58010
    Member
    marcelocripemarcelocripe

    Xecure,

    After applying the commands taught by Skidoo, I repeated all the steps taught by you. But the error messages remained.

    In all program installations on antiX with internet connection via the “Package Installer” I do not remember any errors where Synaptic later warned of a broken package. These errors or failures occurred when installing packages via Synaptic.

    Right now (04-24-2021 at 3:13 pm local time) I don’t have antiX with broken packages, but tomorrow I will be able to access it again and run new tests, if possible.

    Thank you for helping me.

    marcelocripe
    (Original text in Brazilian Portuguese)

    ———-

    Xecure,

    Após aplicar os comandos ensinados pelo Skidoo, eu repeti todas as etapas ensinadas por você. Mas as mensagens de erro permaneceram.

    Em todas as instalações de programas no antiX com conexão com a internet através do “Package Installer” eu não me lembro de nenhum erro onde posteriormente o Synaptic avisava de pacote quebrado. Estes erros ou falhas ocorreram nas instalação de pacotes via Synaptic.

    Neste momento (dia 24-04-2021 às 15h13min horário local) eu não estou com o antiX que possui pacotes quebrados, mas amanhã eu poderei ter acesso novamente e realizar novos testes, se for possível.

    Agradeço por me ajudarem.

    marcelocripe
    (Texto original em idioma Português do Brasil)

    #58025
    Member
    Avatarskidoo

    FWIW, skimming the buster backports repository contents today, I didn’t find any packges which seem likely to be related to this pythonic error.

    possibly helpful:
    pyclean (provided by the “python-minimal” package, should be pre-installed and it has a manpage)

    sudo pyclean -p youtube-dl
    sudo pyclean -p python-minimal
    sudo updatedb

    and retry upgrade (or force reinstall) of youtube-dl afterward

    or, to achieve a more extensive, heavy-handed, cleaning

    cd /usr && sudo find . -name "*.pyc" -exec rm {} \;
    sudo updatedb

    and retry upgrade (or force reinstall) of youtube-dl afterward

    #58064
    Member
    AvatarWallon

    Dear Marcelocripe,

    If I want to show in English the result of one command in Terminal, I use “LANGUAGE=en” before the command.
    Here it is an example with “sudo apt update”

    In French;

    Wallon@ASUS:~
    $ sudo apt update
    [sudo] Mot de passe de Wallon :
    Réception de :1 http://deb.debian.org/debian buster-backports InRelease [46,7 kB]
    Réception de :2 http://ftp.be.debian.org/debian buster-updates InRelease [51,9 kB]
    Réception de :3 http://security.debian.org buster/updates InRelease [65,4 kB]
    Atteint :4 http://files.eid.belgium.be/debian buster InRelease
    Atteint :5 http://files2.eid.belgium.be/debian buster InRelease
    Atteint :6 http://dl.google.com/linux/chrome/deb stable InRelease
    Atteint :7 http://it.mxrepo.com/antix/buster buster InRelease
    Atteint :8 http://ftp.be.debian.org/debian buster InRelease
    164 ko réceptionnés en 4s (40,7 ko/s)
    Lecture des listes de paquets… Fait
    Construction de l’arbre des dépendances
    Lecture des informations d’état… Fait
    Tous les paquets sont à jour.

    In English;

    Wallon@ASUS:~
    $ LANGUAGE=en sudo apt update
    Hit:1 http://deb.debian.org/debian buster-backports InRelease
    Hit:2 http://it.mxrepo.com/antix/buster buster InRelease
    Hit:3 http://security.debian.org buster/updates InRelease
    Hit:4 http://files.eid.belgium.be/debian buster InRelease
    Hit:5 http://files2.eid.belgium.be/debian buster InRelease
    Hit:6 http://dl.google.com/linux/chrome/deb stable InRelease
    Hit:7 http://ftp.be.debian.org/debian buster-updates InRelease
    Hit:8 http://ftp.be.debian.org/debian buster InRelease
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    All packages are up to date.
    Wallon@ASUS:~

    I hope this little tip can help you.

    Kind regards,
    Wallon

Viewing 15 posts - 1 through 15 (of 28 total)
  • You must be logged in to reply to this topic.