How to get SpaceFM in French?

Forum Forums antiX-development Translations How to get SpaceFM in French?

  • This topic has 53 replies, 8 voices, and was last updated Apr 25-9:24 pm by Wallon.
Viewing 15 posts - 31 through 45 (of 54 total)
  • Author
    Posts
  • #54996
    Member
    Robin

      Hello @skidoo

      antiX, which is described as a “lightweight” distribution, does not preinstall the 225MB+ “locales-all” package.

      In this concern I absolutely with you. antiX is a “lightwight” distribution and there is no way to preinstall all the locales. But I don’t share your conclusion:

      sudo apt install locales-all util-linux-locales
      sudo dpkg-reconfigure locales
      then retry (may need to logout/login) launch spacefm and any other programs which were affected by missing translations.
      Does this resolve the issue?

      My answer: Yes and No. Why not? It doesn’t really solve it. OK, your solution does solve the problem theoretically, but what you’ve said about antiX being a “lightwight” distribution should be true for users of antiX in foreign languages also. So, do we really need to install all languages, just to get a translation to a single language working correctly? The translations of strings and the corresponding files make on the whole a couple of kiB, at most some MiB. So I think it is not really a good idea to advise people to install packages of some houndreds of MiB of languages they never will need, due to the fact they don’t speak english language everyday only and need a single foreign language.

      And we should clearly mark this off from the fact that at least some of the translations from transifex present on user systems in .mo files are not utilised by the running antiX system on a user PC or the included programs nevertheless.

      I’m still optimistic that this may provide a viable workaround

      Yes, this should work after all what I came to know until now, handling language files for some time now. But the question is: Why should this workaround be necessery? In “de” language all this works automatically: as long as there is a corresponding .mo file present in “de_DE” (or “de_AT”, “de_CH”…) it will be used by system. But if there is no corresponding file found in “de_DE” the file present in “de” is in use instead automatically. I’ve checked this more than once while writing the multilanguage test suite script. This is true for antiX 17.4.1 at least, but I don’t see a reason why it shouldn’t work on 19.x series still.

      Windows is like a submarine. Open a window and serious problems will start.

      #54999
      Moderator
      Brian Masinick

        It might be nice to install all translation files for a particular language, but I think that it would be much better for the applications installed to have a mechanism to recognize the locales installed and install them for their app.

        Alternatively we could install language files for the apps that are installed.

        • This reply was modified 3 years, 1 month ago by Brian Masinick.

        --
        Brian Masinick

        #55001
        Anonymous

          So, do we really need to install all languages, just to get a translation to a single language working correctly?

          I’m neither attempting to justify the status quo nor criticizing the status quo.

          The point of this post is to explain emphasize that we each can easily remove unused locales, followed by live-remaster and/or isosnapshot. With this in mind, it does not matter to skidoo whether 16, or 61, or all locales will be pre-installed.

          Across many of my posts spanning several years (none recently), I have suggested various ways a sysadmin (or end user) can “reduce bloat” when setting up a newly-released distribution. Specific to locales, we can (and, I do) as a first pass:

          echo “en_US.UTF-8 UTF-8” | sudo tee /etc/locale.gen
          LANG=C sudo dpkg-reconfigure –frontend=noninteractive locales
          LANG=C sudo update-locale LANG=en_US.UTF-8

          For me the above is performed via a scripted operation which also copies into place my customized: /usr/local/share/excludes/*.list files, /etc/iso-snapshot.conf and copies into place various /home/demo dotfiles and /etc/skel files

          second pass (pasted here from past notes):

          sudo install bleachbit
          sudo bleachbit ----}
          	clik OK to close the autopopup "preferences" dialog
          	find and tick "Localizations" in left pane, click OK to dismiss autopopup dialog
          	click the TrashCan bleachbit toolbar icon, click "Delete" button in the confirmation dialogbox
          noted:    bleachbit reported (in my test)   Disk space recovered 210Mb
                 exit bleachbit
          2Mb   sudo apt purge bleachbit
          browse to /usr/share/locale/
          noted (in my test) that bleachbit misses     8.7 Mb    files here
          for me, nix all here EXCEPT:
          /usr/share/locale/en/
          /usr/share/locale/en_US/
          /usr/share/locale/[[[symlink to]]]locale.alias
          ...and now /usr/share/locale/* occupies only 212Kb 
          #55002
          Moderator
          Brian Masinick

            I like your solution very much skidoo.

            I did similar things back when I was building OS software almost nightly from the nightly builds.

            I’m very out of date on the best techniques but your comments resonate with me. Thanks

            --
            Brian Masinick

            #55013
            Member
            Wallon

              Dear users,

              Please find my locale detail.
              Would you please tell me if there is a problem with my be_french installation?
              For your information, I use Timeshift for my backups.
              This software is well translated in French.
              The “timeshift.mo” file is only in this folder ~/usr/share/locale/fr/LC_MESSAGES and it works very well with Antix 19.3 Full.

              Best regards,
              Wallon
              (Belgium)

              
              Antix 19.3 Full
              wallon@ASUS:~
              $ locale
              LANG=fr_BE.UTF-8
              LANGUAGE=
              LC_CTYPE="fr_BE.UTF-8"
              LC_NUMERIC="fr_BE.UTF-8"
              LC_TIME="fr_BE.UTF-8"
              LC_COLLATE="fr_BE.UTF-8"
              LC_MONETARY="fr_BE.UTF-8"
              LC_MESSAGES="fr_BE.UTF-8"
              LC_PAPER="fr_BE.UTF-8"
              LC_NAME="fr_BE.UTF-8"
              LC_ADDRESS="fr_BE.UTF-8"
              LC_TELEPHONE="fr_BE.UTF-8"
              LC_MEASUREMENT="fr_BE.UTF-8"
              LC_IDENTIFICATION="fr_BE.UTF-8"
              LC_ALL=
              
              #55020
              Member
              Wallon

                Dear users,

                I don’t think it’s a problem for linux to work with a French installation with a Belgian azerty keyboard.
                Out of curiosity, I tested SpaceFM in Xubuntu 20.04.
                SpaceFM (from IgnorantGuru on Transifex) is well translated into French.
                The file “spacefm.mo” is in the folder ~/usr/share/locale/fr/LC_MESSAGES and it works very well.
                It’s a be_fr installation. You’ll notice that the “locale” variables are a mix of fr_fr and fr_be.

                Best regards,
                Wallon

                
                Xubuntu 20.4
                wallon@Asus-F3U:~$ locale
                LANG=fr_FR.UTF-8
                LANGUAGE=fr_FR:fr:en_GB:en
                LC_CTYPE="fr_FR.UTF-8"
                LC_NUMERIC=fr_BE.UTF-8
                LC_TIME=fr_BE.UTF-8
                LC_COLLATE="fr_FR.UTF-8"
                LC_MONETARY=fr_BE.UTF-8
                LC_MESSAGES="fr_FR.UTF-8"
                LC_PAPER=fr_BE.UTF-8
                LC_NAME=fr_BE.UTF-8
                LC_ADDRESS=fr_BE.UTF-8
                LC_TELEPHONE=fr_BE.UTF-8
                LC_MEASUREMENT=fr_BE.UTF-8
                LC_IDENTIFICATION=fr_BE.UTF-8
                LC_ALL=
                
                #55027
                Member
                Wallon

                  Dear developers,

                  I also think you should use software that has a multi-language package.
                  For example, I wasn’t using qpdfview pre-installed in Antix. qpdfview refused to print in black and white with my HP Officetjet Pro 8600 Plus printer and it wasn’t in French. That’ s why I didn’t use qpdfview.
                  I installed “evince” which works very well and it is directly in French.
                  You have to make choices if you want to make Antix known near other communities. I wish you good luck to find a video in French on Youtube that talks about Antix.
                  If you don’t want a multi-language package, then you need to make 2 ISO images like LibreOffice. A light ISO only in English and a multi-language ISO and maybe even with other software. It is not because the English drive on the left that the rest of the world has to drive on the left.

                  Best regards,
                  Walloon

                  #55064
                  Member
                  Robin

                    Keep calm, @Wallon. Not everything needs be solved by the developers. We are a strong community and can achieve some things on ourselves, covering the developers backs. For sure we’ll need their help in the end, but let us discuss possible solutions before demanding readymades. That’s the spirit of linux, even if some big players (like Canonical, Mozilla, Microsoft) dont’t care.

                    The file “spacefm.mo” is in the folder ~/usr/share/locale/fr/LC_MESSAGES and it works very well.

                    As I pointed out some posts above, exactly this mechanism works in antiX also. For a User Interface language e.g. “de_AT” or “de_CH” all the translation files present in the non country specific language folder “de” are in use. If this is not true for fr_BE there must be a bug in antiX (which I stated already in this matter.) There are obviously language files which are present on system, but NOT used by antiX. We identified this problem quite recently, and so you can’t expect to see a soulution already, since there are extremely many possible points of failure involved.

                    qpdfview refused to print in black and white with my HP Officetjet Pro 8600 Plus printer and it wasn’t in French.

                    Well, printing in linux is a very special thing… my CAPSL-IV Laser Printer wouldn’t even print in full resolution when on any linux, so small font sizes are unreadable, text on greyscale background also. These are the drawbacks when Manufacturers want to keep their trade secrets. I can’t tell anything about qpdf by now, since I am on antiX 17.4.1 sill, and evince is standard document viewer in this former antiX version. You may ask developers what was the reason for their decision to replace it.

                    Please find my locale detail.

                    I don’t see anything wrong in it. Looks just exactly as my de_DE locales. And here all the translation files (.mo) are in “de” folder only, de_DE is nearly empty. But when puting a translation file (marked by some replaced translation strings) for testing in de_DE folder for a specific program, it is used immediately, overruling the correspondent file in “de” folder. I’ve tested it with “de_AT” and “de_CH” also. Hence, exactly like this it should work for you in fr_BE also. If not, there must be a bug somewhere.
                    Please wait for the new aCMSTS version I’m just working on, it’s an antiX community project only, but it may help you in finding the reason for the behaviour of your language system. It will provide a way of checking and analysing the presence of language files and entries. While testing it we found a couple of malfunctioning .mo files already, which were present on system but not in use nontheless even if they should.

                    @skidoo: I’ll investigate on the method you you’ve posted above, it looks very interresting to me:

                    echo “en_US.UTF-8 UTF-8” | sudo tee /etc/locale.gen
                    LANG=C sudo dpkg-reconfigure –frontend=noninteractive locales
                    LANG=C sudo update-locale LANG=en_US.UTF-8

                    Thank you for this guidance. Even when you’ve posted it before already somewhere here in forum, I wasn’t aware of it.

                    With this in mind, it does not matter to skidoo whether 16, or 61, or all locales will be pre-installed.

                    A really good argument.

                    • This reply was modified 3 years, 1 month ago by Robin. Reason: missing word

                    Windows is like a submarine. Open a window and serious problems will start.

                    #55065
                    Forum Admin
                    anticapitalista

                      @Wallon – try deleting ~/.config/spacefm folder

                      Philosophers have interpreted the world in many ways; the point is to change it.

                      antiX with runit - leaner and meaner.

                      #55066
                      Forum Admin
                      anticapitalista

                        re – roxterm – you may wish to install lxterminal instead. It does give a menu in French

                        Philosophers have interpreted the world in many ways; the point is to change it.

                        antiX with runit - leaner and meaner.

                        #55068
                        Member
                        Wallon

                          Dear Sir,

                          Thank you very much, it’s magic. I have SpaceFM in French.

                          Here it’s the detail of all operations done ;

                          sudo apt install locales-all util-linux-locales

                          sudo dpkg-reconfigure locales ### (In the first window, I kept only all the variables fr, be and en, I unchecked the other languages. In the second window I confirmed fr_BE)

                          sudo apt install –reinstall spacefm

                          delete ~/.config/spacefm folder

                          For information, in terminal, “locale” is exactly de same before and after.

                          I wish you a pleasant weekend.
                          Thank you a thousand times for all the French speakers. (I think it’s a French expression that doesn’t exist in English)

                          Best regards,
                          Wallon

                          • This reply was modified 3 years, 1 month ago by Wallon.
                          #55148
                          Member
                          marcelocripe

                            Wallon,

                            It is very good that you have managed to solve the problem of translating SpaceFm.
                            Were you able to verify with this procedure that you performed, whether or not the translations contained in the transifex were entered?
                            I thank you for detailing the process you did for the translation to work.

                            anticapitalista,

                            Would a collective solution to this problem of translating SpaceFm be possible?
                            Could this problem be corrected by updating antiX 19.X?
                            Can this problem be prevented in antiX 21?

                            marcelocripe
                            (Original text in Brazilian Portuguese)

                            ———-

                            Wallon,

                            É muito bom que você tenha conseguido resolver o problema da tradução do SpaceFm.
                            Conseguiu verificar se com este procedimento que você realizou, se entraram ou não as traduções contidas no transifex?
                            Eu agradeço por detalhar o processo que você fez para a tradução funcionar.

                            anticapitalista,

                            Seria possível uma solução coletiva para este problema da tradução do SpaceFm?
                            Este problema poderia ser corrigido através de uma atualização do antiX 19.X?
                            Este problema pode ser prevenido no antiX 21?

                            marcelocripe
                            (Texto original em idioma português do Brasil)

                            #55150
                            Member
                            Xecure

                              You can see from where a package comes from using apt policy <name-of-package>
                              apt policy spacefm-common
                              As anticapitalista stated a few times already, the package comes from the DEBIAN repos (in Debian buster, the spacefm version is 1.0.6-4), so the DEBIAN maintainer is the one that needs to download the translation from the transifex of IGNORANTGURU (this transifex project IS NOT RELATED TO ANTIX LINUX), which you would need to check to which version of SPACEFM the translations correspond to, and add them there. antiX 21 will use Debian bullseye, and there they are using version 1.0.6-5. The changelog for this version:

                              spacefm (1.0.6-5) unstable; urgency=medium
                                [ Debian Janitor ]
                                * debian/copyright: use spaces rather than tabs to start continuation
                                  lines.
                                * Wrap long lines in changelog entries: 1.0.6-1.
                                * Use secure URI in Homepage field.
                                * Set debhelper-compat version in Build-Depends.
                                * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
                                  Repository-Browse.
                                * Drop unnecessary dependency on dh-autoreconf.
                                [ Mateusz Łukasik ]
                                * Fix FTBFS with gcc-10. (Closes: #957829)
                                  * debian/control:
                                  + Bump to Standards-Version to 4.5.0.
                               -- Mateusz Łukasik <mati75@linuxmint.pl>  Thu, 13 Aug 2020 11:45:23 +0200

                              There is no mention of updating the translations, so you would need to check yourself in the source code if the new translations were added.

                              Now, if the problem is related to using “hard-coded” English options in the spacefm configuration files (it would be good if people check if this statement is true or not), then the only thing that needs to be done is to remove the spacefm configuration folder (no need for reinstalling anything). Instead of speculating, it would be good if someone can confirm this (remove ~/.config/spacefm/session, logout/login, launch spacefm in your language and check if everything is in the (non-english) language you expect).
                              If so, then we just need to find the suspicious entries in the “session” config file and remove them. Test again until you are sure there are no longer any English specific entries.
                              Then, we can help the antiX development team asking to edit the desktop-defaults-spacefm-antix package in the specific gitlab project (http://gitlab.com/antiX-Linux/desktop-defaults-spacefm/-/blob/master/skel/.config/spacefm/session)

                              antiX Live system enthusiast.
                              General Live Boot Parameters for antiX.

                              #55158
                              Anonymous

                                After closing all visibly running instances of spaceFM and (if applicable)
                                switching to a NON space-xxxxx (e.g. space-icewm) desktop sessiontype, try this:

                                cp ~/.config/spacefm/session ~/.config/spacefm/session.BAK && rm ~/.config/spacefm/session

                                Afterward, upon next launch of spaceFM, are localized texts now correctly displayed to the buttons and other elements?
                                .

                                http://gitlab.com/antiX-Linux/desktop-defaults-spacefm/-/blob/master/skel/.config/spacefm/session

                                # SpaceFM Session File

                                # THIS FILE IS NOT DESIGNED TO BE EDITED – it will be read and OVERWRITTEN

                                # If you delete all session* files, SpaceFM will be reset to factory defaults.

                                [General]
                                single_click=1

                                [Window]
                                width=640
                                height=480
                                maximized=0

                                [Desktop]
                                show_wallpaper=1
                                wallpaper=/usr/share/wallpaper/lines.png
                                show_wm_menu=1

                                . . .

                                #55167
                                Member
                                Wallon

                                  Dear Xecure, Dear Skidoo

                                  Your explanations are highly technical. I find it difficult to follow you. I’m only a simple user. I’m not Linus Torvalds who uses AMD Threadripper 3970x-based processor.

                                  I’ve done something simpler.
                                  I took my live USB key (with the installer). I choose F2 Language (->French BE). If I check “locale” in Terminal, all variables are on fr_BE. On my first screen, I’m going to search for spaceFM in the applications (so, without changing my desktop). SpaceFM is badly translated in French. I use the other file manager (Rox) to delete ~/.config/spacefm directory.
                                  I go back in the applications to launch spaceFM and magic, it is well translated.
                                  So, I didn’t use command lines in a Terminal.
                                  I hope this can help you.

                                  I don’t like to do a lot of tests on my installed version anymore because I have difficulties to restore my Antix with Timeshift. This is new in Antix and MX Linux, I have GTK warnings, rsync syntax of Linux files not compatible … when I make a backup. I can’t find the Linux directory or file that is not compatible with the messages I receive. Apparently it’s not related to Timeshift.
                                  I don’t use snapshot anymore because I can’t retrieve my password, my fstab, AppImage… when I reinstall.

                                  Do I need to do another test to better understand the origin of the problem?

                                  Thank you very much for your support.

                                  Best regards,
                                  Wallon
                                  Antix 19.3 Full

                                  • This reply was modified 3 years, 1 month ago by Wallon.
                                Viewing 15 posts - 31 through 45 (of 54 total)
                                • You must be logged in to reply to this topic.