(Solved) How to Install NVIDIA Drivers on Antix

Forum Forums New users New Users and General Questions (Solved) How to Install NVIDIA Drivers on Antix

Tagged: ,

  • This topic has 26 replies, 5 voices, and was last updated Jan 17-3:09 pm by caprea.
Viewing 12 posts - 16 through 27 (of 27 total)
  • Author
    Posts
  • #129440
    Member
    keshav-uses-linux

      so, antix full takes up about 8gigs and base about 4.7 gigs, so that why i decided to go for it

      #129442
      Forum Admin
      rokytnji

        Err. My 16 gig chromebook ssd runs full iso

        harry@antix1:~
        $ inxi -Fxz
        System:
          Kernel: 5.10.153-antix.1-amd64-smp arch: x86_64 bits: 64 compiler: gcc
            v: 10.2.1 Desktop: IceWM v: 3.4.5 Distro: antiX-22_x64-full Grup Yorum 18
            October 2022 base: Debian GNU/Linux 11 (bullseye)
        Machine:
          Type: Laptop System: GOOGLE product: Candy v: 1.0
            serial: <superuser required>
          Mobo: GOOGLE model: Candy v: 1.0 serial: <superuser required>
            UEFI: coreboot v: MrChromebox-4.18.1 date: 10/27/2022
        Battery:
          ID-1: BAT0 charge: 3.6 Wh (9.1%) condition: 39.7/44.5 Wh (89.3%) volts: 12.1
            min: 11.4 model: Samsung DELL XK status: charging
        CPU:
          Info: dual core model: Intel Celeron N2840 bits: 64 type: MCP
            arch: Silvermont rev: 8 cache: L1: 112 KiB L2: 1024 KiB
          Speed (MHz): avg: 2075 high: 2471 min/max: 500/2582 cores: 1: 2471 2: 1679
            bogomips: 8666
          Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
        Graphics:
          Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
            driver: i915 v: kernel arch: Gen-7 bus-ID: 00:02.0
          Device-2: Suyin Integrated_Webcam_HD driver: uvcvideo type: USB
            bus-ID: 1-3:3
          Display: server: X.Org v: 1.20.11 driver: X: loaded: modesetting
            unloaded: fbdev,vesa dri: i965 gpu: i915 resolution: 1366x768~60Hz
          API: OpenGL v: 4.2 compat-v: 3.0 vendor: intel mesa v: 20.3.5 glx-v: 1.4
            direct-render: yes renderer: Mesa DRI Intel HD Graphics (BYT)
        Audio:
          Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
            driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
          API: ALSA v: k5.10.153-antix.1-amd64-smp status: kernel-api
          Server-1: PulseAudio v: 14.2 status: active
        Network:
          Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel bus-ID: 01:00.0
          IF: wlan0 state: up mac: <filter>
        Bluetooth:
          Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
            bus-ID: 1-4:5
          Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0
            lmp-v: 6
        Drives:
          Local Storage: total: 73.62 GiB used: 19.27 GiB (26.2%)
          ID-1: /dev/mmcblk0 model: USD00 size: 58.94 GiB
          ID-2: /dev/mmcblk1 vendor: Hynix model: HAG2e size: 14.68 GiB
        Partition:
          ID-1: / size: 13.36 GiB used: 7.17 GiB (53.7%) fs: ext4 dev: /dev/mmcblk1p2
          ID-2: /boot/efi size: 252 MiB used: 274 KiB (0.1%) fs: vfat
            dev: /dev/mmcblk1p1
        Swap:
          ID-1: swap-1 type: partition size: 768 MiB used: 0 KiB (0.0%)
            dev: /dev/mmcblk1p3
        Sensors:
          System Temperatures: cpu: 34.0 C mobo: N/A
          Fan Speeds (rpm): N/A
        Info:
          Processes: 150 Uptime: 7m Memory: total: 4 GiB available: 3.75 GiB
          used: 1.06 GiB (28.3%) Init: SysVinit runlevel: 5 Compilers: gcc: 10.2.1
          Packages: 1646 Shell: Bash v: 5.1.4 inxi: 3.3.31
        harry@antix1:~
        $ 
        

        I am pretty clueless but I know how to run home files on symlinked sd card.

        harry@antix1:~
        $ ls -l
        total 28
        drwxr-xr-x  4 harry harry 4096 Jul 23 14:35 bin
        drwxrwxr-x  2 harry harry 4096 Nov 17  2022 Desktop
        lrwxrwxrwx  1 harry harry   58 Aug  4 21:13 Documents -> ../../media/harry/mmcblk0p1-mmc-USD00_0x41dde1bd/Documents
        drwxr-xr-x  2 harry harry 4096 Dec 25 04:28 Downloads
        drwxr-xr-x  2 harry harry 4096 Nov 17  2022 Live-usb-storage
        lrwxrwxrwx  1 harry harry   54 Aug  4 21:13 Music -> ../../media/harry/mmcblk0p1-mmc-USD00_0x41dde1bd/Music
        lrwxrwxrwx  1 harry harry   57 Aug  4 21:13 Pictures -> ../../media/harry/mmcblk0p1-mmc-USD00_0x41dde1bd/Pictures
        drwxr-xr-x  2 harry harry 4096 Dec 13 18:36 Screenshots
        drwxr-xr-x  2 harry harry 4096 Dec 20 14:06 test
        drwxr-xr-x 24 harry harry 4096 Nov 17  2022 UCM
        lrwxrwxrwx  1 harry harry   58 Aug  4 21:12 Wallpaper -> ../../media/harry/mmcblk0p1-mmc-USD00_0x41dde1bd/Wallpaper
        harry@antix1:~
        

        to save space on my internal ssd drive that is not replaceable. But. You go ahead and do it the hard way.

        http://antixlinux.com/applications-on-antix-full-but-not-included-on-antix-base/

        You should be reading the above link to see what you are missing. When I put antiX 23 on here. It will be the full iso also.

        Sometimes I drive a crooked road to get my mind straight.
        I don't suffer from insanity. I enjoy every minute off it.
        Motorcycle racing is rocket science.

        Linux Registered User # 475019
        How to Search for AntiX solutions to your problems

        #129494
        Moderator
        caprea

          Err:4 http://mx-pkg.mirror.net.in/MX-Linux/antix/bookworm bookworm Release
          404 Not Found [IP: 2001:df5:fc00:fffb::3 80]

          @keshav-uses-linux, Your repos cant download the antiX-repos. Without the repo-manager you have to do the changes manually. Please open the file /etc/apt/sources.list.d/antix.list with
          sudo geany /etc/apt/sources.list.d/antix.list

          Change the first section of the file as follows

          # Use with Debian Bookworm repositories. 
          deb [signed-by=/etc/apt/keyrings/antix-archive-keyring.gpg] http://mirrors.piconets.webwerks.in/mx-mirror/packages/antix/bookworm bookworm main nonfree nosystemd  
          #deb-src http://mirrors.piconets.webwerks.in/mx-mirror/packages/antix/bookworm bookworm main nosystemd nonfree
          

          Then
          sudo apt update
          sudo apt-full-upgrade

          Afterwards you can install the repo-manager if you like(for the next time you have problems with the repos),update your kernel and try again the nvidia installer.Please post if you still have problems to update the system or installing the nvidia driver
          inxi -r

          #129503
          Member
          keshav-uses-linux

            Okay, so from all your suggestons, i have switch antix FUll

            running the nvidia driver installer from the control center, i got this error

            sudo  /usr/bin/ddm-mx -i nvidia
            Distribution:   antiX
            INSTALL IS nvidia
            creating lock ...
            ===================================
            ddm-mx: 23.03.01
            kernel release: 6.1.42-antix.1-amd64-smp
            kernel version: #1 SMP PREEMPT_DYNAMIC Mon Jul 31 18:30:05 EEST 2023
            command parameters: -i nvidia
            ===================================
            ===================================
            Install drivers for: nvidia
            Start at (m/d/y): 01/17/2024 09:19:39
            ===================================
            ========================================
            ========================================
            To restore open source drivers use:  
            sudo ddm-mx -p nvidia
            ========================================
            ========================================
            Refreshing Sources with apt-get update
            Continue?
              1) yes (default)
              2) no
            Press <Enter> for the default entry
            Use 'q' to quit
            Hit:1 http://security.debian.org bookworm-security InRelease
            Hit:2 http://deb.debian.org/debian bookworm-backports InRelease                                                 
            Hit:3 http://ftp.cn.debian.org/debian bookworm-updates InRelease                                                
            Hit:4 http://ftp.cn.debian.org/debian bookworm InRelease                             
            Ign:5 http://mx-pkg.mirror.net.in/MX-Linux/antix/bookworm bookworm InRelease
            Err:6 http://mx-pkg.mirror.net.in/MX-Linux/antix/bookworm bookworm Release
              404  Not Found [IP: 2001:df5:fc00:fffb::3 80]
            Reading package lists... Done
            E: The repository 'http://mx-pkg.mirror.net.in/MX-Linux/antix/bookworm bookworm Release' does not have a Release file.
            N: Updating from such a repository can't be done securely, and is therefore disabled by default.
            N: See apt-secure(8) manpage for repository creation and user configuration details.
            There was a problem with the apt-get update. See /var/log/ddm.log for details
            

            so, what should i do now?

            #129505
            Moderator
            caprea

              Go to control-centre < software > repo-manager
              and change the antiX Repos to another repos from your region,

              then update your system
              sudo apt update
              sudo apt full-upgrade

              and try again the nvidia driver

              #129510
              Member
              keshav-uses-linux

                So, I have successfully ran the nvidia drivers utility. And after reboot, I got dropped onto a CLI. And I don’t know what to do know

                Welcome to antiX. Powered by Debian.
                antix1 login:
                
                • This reply was modified 4 months, 1 week ago by keshav-uses-linux.
                #129515
                Moderator
                caprea

                  If you are dropped to a cli after reboot something went wrong during the nvidia installation.
                  Log in with username and password and uninstall the driver with

                  sudo ddm-mx -p nvidia
                  

                  Afterwards type
                  sudo reboot
                  at the cli and the system should boot with normal desktop and the nouveau driver again.

                  We now have to look why the nvidia couldn’t get build on your system. Is there a /var/log/ddm.log ?
                  Please post it here.
                  Did you already update the kernel?

                  #129522
                  Member
                  keshav-uses-linux

                    If you are dropped to a cli after reboot something went wrong during the nvidia installation.
                    Log in with username and password and uninstall the driver with

                    sudo ddm-mx -p nvidia
                    

                    Afterwards type
                    reboot
                    at the cli and the system should boot with normal desktop and the nouveau driver again.

                    I deeply appreciate your assistance and patience with a newcomer like myself.


                    Did you already update the kernel?

                    Regarding the kernel update, I’m not quite sure how to proceed. Could you kindly guide me through the process?


                    We now have to look why the nvidia couldn’t get build on your system. Is there a /var/log/ddm.log ?
                    Please post it here.

                    I’ve attached the ddm.log file as requested. We can now investigate why the Nvidia couldn’t be built on my system.

                    
                    creating lock ...
                    ===================================
                    ddm-mx: 23.03.01
                    kernel release: 5.10.188-antix.1-amd64-smp
                    kernel version: #1 SMP PREEMPT Mon Jul 31 18:52:00 EEST 2023
                    command parameters: -p nvidia
                    ===================================
                    ===================================
                    Purge drivers for: nvidia
                    Start at (m/d/y): 01/17/2024 16:30:39
                    ===================================
                    Refreshing Sources with apt-get update
                    Frontend: 
                    Open command = apt-get install --reinstall -y  xserver-xorg-video-nouveau xserver-xorg-video-vesa xserver-xorg-video-intel xserver-xorg-video-fbdev xserver-xorg-video-radeon xserver-xorg-video-ati xserver-xorg-video-nouveau
                    Reading package lists...
                    Building dependency tree...
                    Reading state information...
                    The following packages were automatically installed and are no longer required:
                      glx-alternative-mesa glx-diversions libatomic1:i386 libbsd0:i386
                      libdrm-amdgpu1:i386 libdrm-intel1:i386 libdrm-nouveau2:i386
                      libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libegl-mesa0:i386
                      libegl1:i386 libelf1:i386 libexpat1:i386 libffi8:i386 libgbm1:i386
                      libgl1:i386 libgl1-mesa-dri:i386 libglapi-mesa:i386 libgles1 libgles1:i386
                      libgles2:i386 libglvnd0:i386 libglx-mesa0:i386 libglx0:i386 libicu72:i386
                      libllvm15:i386 liblzma5:i386 libmd0:i386 libopengl0 libopengl0:i386
                      libpciaccess0:i386 libsensors5:i386 libstdc++6:i386 libtinfo6:i386
                      libvulkan1:i386 libwayland-client0:i386 libwayland-server0:i386
                      libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386
                      libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-randr0:i386
                      libxcb-shm0:i386 libxcb-sync1:i386 libxcb-xfixes0:i386 libxcb1:i386
                      libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxml2:i386 libxshmfence1:i386
                      libxxf86vm1:i386 libz3-4:i386 libzstd1:i386 nvidia-installer-cleanup
                      update-glx zlib1g:i386
                    Use 'sudo apt autoremove' to remove them.
                    0 upgraded, 0 newly installed, 6 reinstalled, 0 to remove and 0 not upgraded.
                    Need to get 0 B/2,898 kB of archives.
                    After this operation, 0 B of additional disk space will be used.
                    (Reading database ... 
                    (Reading database ... 5%
                    (Reading database ... 10%
                    (Reading database ... 15%
                    (Reading database ... 20%
                    (Reading database ... 25%
                    (Reading database ... 30%
                    (Reading database ... 35%
                    (Reading database ... 40%
                    (Reading database ... 45%
                    (Reading database ... 50%
                    (Reading database ... 55%
                    (Reading database ... 60%
                    (Reading database ... 65%
                    (Reading database ... 70%
                    (Reading database ... 75%
                    (Reading database ... 80%
                    (Reading database ... 85%
                    (Reading database ... 90%
                    (Reading database ... 95%
                    (Reading database ... 100%
                    (Reading database ... 113143 files and directories currently installed.)
                    Preparing to unpack .../0-xserver-xorg-video-ati_1%3a19.1.0-3_amd64.deb ...
                    Unpacking xserver-xorg-video-ati (1:19.1.0-3) over (1:19.1.0-3) ...
                    Preparing to unpack .../1-xserver-xorg-video-fbdev_1%3a0.5.0-2_amd64.deb ...
                    Unpacking xserver-xorg-video-fbdev (1:0.5.0-2) over (1:0.5.0-2) ...
                    Preparing to unpack .../2-xserver-xorg-video-intel_2%3a2.99.917+git20210115-1_amd64.deb ...
                    Unpacking xserver-xorg-video-intel (2:2.99.917+git20210115-1) over (2:2.99.917+git20210115-1) ...
                    Preparing to unpack .../3-xserver-xorg-video-nouveau_1%3a1.0.17-2_amd64.deb ...
                    Unpacking xserver-xorg-video-nouveau (1:1.0.17-2) over (1:1.0.17-2) ...
                    Preparing to unpack .../4-xserver-xorg-video-radeon_1%3a19.1.0-3_amd64.deb ...
                    Unpacking xserver-xorg-video-radeon (1:19.1.0-3) over (1:19.1.0-3) ...
                    Preparing to unpack .../5-xserver-xorg-video-vesa_1%3a2.5.0-1+b1_amd64.deb ...
                    Unpacking xserver-xorg-video-vesa (1:2.5.0-1+b1) over (1:2.5.0-1+b1) ...
                    Setting up xserver-xorg-video-nouveau (1:1.0.17-2) ...
                    Setting up xserver-xorg-video-radeon (1:19.1.0-3) ...
                    Setting up xserver-xorg-video-fbdev (1:0.5.0-2) ...
                    Setting up xserver-xorg-video-intel (2:2.99.917+git20210115-1) ...
                    Setting up xserver-xorg-video-vesa (1:2.5.0-1+b1) ...
                    Setting up xserver-xorg-video-ati (1:19.1.0-3) ...
                    Processing triggers for libc-bin (2.36-9+deb12u3) ...
                    Processing triggers for man-db (2.11.2-2) ...
                    Open drivers installed
                    rm 20-nvidia.conf
                    Reading package lists...
                    Building dependency tree...
                    Reading state information...
                    Package 'primus-libs-ia32' is not installed, so not removed
                    Package 'primus-vk-nvidia-i386' is not installed, so not removed
                    Package 'primus-vk:i386' is not installed, so not removed
                    Package 'nvidia-cuda-mps:i386' is not installed, so not removed
                    Package 'nvidia-settings-legacy-340xx:i386' is not installed, so not removed
                    Package 'libgl1-nvidia-legacy-340xx-glx-i386:i386' is not installed, so not removed
                    Package 'bumblebee-nvidia:i386' is not installed, so not removed
                    Package 'nvidia-driver:i386' is not installed, so not removed
                    Package 'nvidia-cuda-dev:i386' is not installed, so not removed
                    Package 'nvidia-tesla-440-vdpau-driver:i386' is not installed, so not removed
                    Package 'nvidia-tesla-418-vdpau-driver:i386' is not installed, so not removed
                    Package 'nvidia-legacy-390xx-vdpau-driver:i386' is not installed, so not removed
                    Package 'nvidia-cuda-toolkit:i386' is not installed, so not removed
                    Package 'libgl1-nvidia-glx:i386' is not installed, so not removed
                    Package 'nvidia-cg-doc:i386' is not installed, so not removed
                    Package 'libgl1-glvnd-nvidia-glx:i386' is not installed, so not removed
                    Package 'libgles1-glvnd-nvidia:i386' is not installed, so not removed
                    Package 'libgles2-glvnd-nvidia:i386' is not installed, so not removed
                    Package 'libglx0-glvnd-nvidia:i386' is not installed, so not removed
                    Package 'libopengl0-glvnd-nvidia:i386' is not installed, so not removed
                    Package 'libegl1-glvnd-nvidia:i386' is not installed, so not removed
                    Package 'libnvidia-egl-gbm1' is not installed, so not removed
                    Package 'nvidia-cuda-toolkit-doc' is not installed, so not removed
                    Package 'libnvidia-tesla-nvcuvid1' is not installed, so not removed
                    Package 'nvidia-cuda-toolkit-gcc' is not installed, so not removed
                    Package 'libnvidia-rtcore' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-driver-libs' is not installed, so not removed
                    Package 'nvidia-opencl-common' is not installed, so not removed
                    Package 'nvidia-primus-vk-common' is not installed, so not removed
                    Package 'nvidia-opencl-dev' is not installed, so not removed
                    Package 'nvidia-cg-toolkit' is not installed, so not removed
                    Package 'libnvidia-tesla-cuda1' is not installed, so not removed
                    Package 'libnvidia-tesla-ptxjitcompiler1' is not installed, so not removed
                    Package 'nvidia-tesla-470-kernel-support' is not installed, so not removed
                    Package 'libnvidia-tesla-nvoptix1' is not installed, so not removed
                    Package 'nvidia-open-kernel-support' is not installed, so not removed
                    Package 'nvidia-opencl-icd' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-driver-bin' is not installed, so not removed
                    Package 'nvidia-tesla-driver-bin' is not installed, so not removed
                    Package 'nvidia-tesla-470-kernel-source' is not installed, so not removed
                    Package 'libnvidia-opticalflow1' is not installed, so not removed
                    Package 'libnvidia-fbc1' is not installed, so not removed
                    Package 'libnvidia-tesla-opticalflow1' is not installed, so not removed
                    Package 'nvidia-tesla-legacy-check' is not installed, so not removed
                    Package 'nvidia-open-kernel-source' is not installed, so not removed
                    Package 'libnvidia-tesla-cfg1' is not installed, so not removed
                    Package 'libnvidia-tesla-470-eglcore' is not installed, so not removed
                    Package 'nvidia-alternative' is not installed, so not removed
                    Package 'glx-alternative-nvidia' is not installed, so not removed
                    Package 'libnvidia-tesla-ngx1' is not installed, so not removed
                    Package 'libgles-nvidia1' is not installed, so not removed
                    Package 'libgles-nvidia2' is not installed, so not removed
                    Package 'nvidia-open-kernel-dkms' is not installed, so not removed
                    Package 'nvidia-primus-vk-wrapper' is not installed, so not removed
                    Package 'nvidia-egl-icd' is not installed, so not removed
                    Package 'nvidia-vulkan-icd' is not installed, so not removed
                    Package 'firmware-nvidia-tesla-gsp' is not installed, so not removed
                    Package 'nvidia-vaapi-driver' is not installed, so not removed
                    Package 'libnvidia-tesla-470-ptxjitcompiler1' is not installed, so not removed
                    Package 'nvidia-tesla-470-driver' is not installed, so not removed
                    Package 'nvidia-tesla-vdpau-driver' is not installed, so not removed
                    Package 'nvidia-tesla-470-alternative' is not installed, so not removed
                    Package 'libnvidia-tesla-allocator1' is not installed, so not removed
                    Package 'libnvidia-tesla-470-nvvm4' is not installed, so not removed
                    Package 'libnvidia-compiler' is not installed, so not removed
                    Package 'libnvidia-eglcore' is not installed, so not removed
                    Package 'nvidia-settings-tesla' is not installed, so not removed
                    Package 'libnvidia-glcore' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-cuda1' is not installed, so not removed
                    Package 'nvidia-vulkan-common' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-glcore' is not installed, so not removed
                    Package 'nvidia-tesla-driver' is not installed, so not removed
                    Package 'nvidia-xconfig' is not installed, so not removed
                    Package 'libnvidia-api1' is not installed, so not removed
                    Package 'libnvidia-tesla-470-nvcuvid1' is not installed, so not removed
                    Package 'libnvidia-ptxjitcompiler1' is not installed, so not removed
                    Package 'libnvidia-tesla-470-encode1' is not installed, so not removed
                    Package 'libglx-nvidia0' is not installed, so not removed
                    Package 'nvidia-kernel-support' is not installed, so not removed
                    Package 'libnvidia-tesla-470-nvoptix1' is not installed, so not removed
                    Package 'nvidia-tesla-kernel-support' is not installed, so not removed
                    Package 'nvidia-powerd' is not installed, so not removed
                    Package 'libnvidia-tesla-glvkspirv' is not installed, so not removed
                    Package 'nvidia-driver-bin' is not installed, so not removed
                    Package 'nvidia-tesla-alternative' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-kernel-dkms' is not installed, so not removed
                    Package 'nvidia-profiler' is not installed, so not removed
                    Package 'libnvidia-nvvm4' is not installed, so not removed
                    Package 'libnvidia-egl-wayland1' is not installed, so not removed
                    Package 'libnvidia-tesla-470-cbl' is not installed, so not removed
                    Package 'libnvidia-ml1' is not installed, so not removed
                    Package 'libnvidia-glvkspirv' is not installed, so not removed
                    Package 'libnvidia-encode1' is not installed, so not removed
                    Package 'nvidia-driver-libs' is not installed, so not removed
                    Package 'nvidia-driver' is not installed, so not removed
                    Package 'nvidia-visual-profiler' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-kernel-support' is not installed, so not removed
                    Package 'libgl1-nvidia-tesla-glvnd-glx' is not installed, so not removed
                    Package 'libnvidia-tesla-470-cfg1' is not installed, so not removed
                    Package 'libnvidia-tesla-470-compiler' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-cfg1' is not installed, so not removed
                    Package 'nvidia-openjdk-8-jre' is not installed, so not removed
                    Package 'nvidia-tesla-470-egl-icd' is not installed, so not removed
                    Package 'nvidia-support' is not installed, so not removed
                    Package 'libnvidia-tesla-470-ngx1' is not installed, so not removed
                    Package 'libnvidia-tesla-eglcore' is not installed, so not removed
                    Package 'nvidia-tesla-470-vdpau-driver' is not installed, so not removed
                    Package 'libnvidia-tesla-470-ml1' is not installed, so not removed
                    Package 'libgles-nvidia-tesla1' is not installed, so not removed
                    Package 'libgles-nvidia-tesla2' is not installed, so not removed
                    Package 'libgles1-nvidia-legacy-340xx' is not installed, so not removed
                    Package 'nvidia-kernel-common' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-driver' is not installed, so not removed
                    Package 'libnvidia-tesla-470-glvkspirv' is not installed, so not removed
                    Package 'nvidia-cuda-dev' is not installed, so not removed
                    Package 'nvidia-tesla-470-driver-libs' is not installed, so not removed
                    Package 'nvidia-cuda-gdb' is not installed, so not removed
                    Package 'nvidia-cuda-toolkit' is not installed, so not removed
                    Package 'libnvidia-tesla-470-ifr1' is not installed, so not removed
                    Package 'primus-nvidia' is not installed, so not removed
                    Package 'libgl1-nvidia-tesla-470-glvnd-glx' is not installed, so not removed
                    Package 'libgl1-nvidia-glvnd-glx' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-ifr1' is not installed, so not removed
                    Package 'nvidia-cuda-mps' is not installed, so not removed
                    Package 'nvidia-kernel-dkms' is not installed, so not removed
                    Package 'mir-graphics-drivers-nvidia' is not installed, so not removed
                    Package 'libgles-nvidia-tesla-470-1' is not installed, so not removed
                    Package 'libgles-nvidia-tesla-470-2' is not installed, so not removed
                    Package 'libnvidia-tesla-cudadebugger1' is not installed, so not removed
                    Package 'libnvidia-allocator1' is not installed, so not removed
                    Package 'libnvidia-cfg1' is not installed, so not removed
                    Package 'libnvidia-tesla-470-cuda1' is not installed, so not removed
                    Package 'nvidia-tesla-470-opencl-icd' is not installed, so not removed
                    Package 'xserver-xorg-video-nvidia-tesla' is not installed, so not removed
                    Package 'libnvidia-ngx1' is not installed, so not removed
                    Package 'libnvidia-ml-dev' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-nvcuvid1' is not installed, so not removed
                    Package 'nvidia-fs-dkms' is not installed, so not removed
                    Package 'libnvidia-tesla-470-allocator1' is not installed, so not removed
                    Package 'nvidia-tesla-kernel-source' is not installed, so not removed
                    Package 'nvidia-tesla-470-smi' is not installed, so not removed
                    Package 'libgles2-nvidia-legacy-340xx' is not installed, so not removed
                    Package 'libnvidia-tesla-470-rtcore' is not installed, so not removed
                    Package 'libegl-nvidia-tesla-470-0' is not installed, so not removed
                    Package 'xserver-xorg-video-nvidia-legacy-340xx' is not installed, so not removed
                    Package 'libnvidia-tesla-fbc1' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-eglcore' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-ml1' is not installed, so not removed
                    Package 'nvidia-settings' is not installed, so not removed
                    Package 'libnvidia-tesla-encode1' is not installed, so not removed
                    Package 'libnvidia-tesla-ml1' is not installed, so not removed
                    Package 'nvidia-tesla-470-kernel-dkms' is not installed, so not removed
                    Package 'nvidia-egl-common' is not installed, so not removed
                    Package 'nvidia-cudnn' is not installed, so not removed
                    Package 'nvidia-tesla-egl-icd' is not installed, so not removed
                    Package 'nvidia-tesla-470-vulkan-icd' is not installed, so not removed
                    Package 'nvidia-tesla-driver-libs' is not installed, so not removed
                    Package 'libnvidia-tesla-nvvm4' is not installed, so not removed
                    Package 'nvidia-libopencl1' is not installed, so not removed
                    Package 'nvidia-legacy-check' is not installed, so not removed
                    Package 'nvidia-cuda-samples' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-vdpau-driver' is not installed, so not removed
                    Package 'xserver-xorg-video-nvidia-tesla-470' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-compiler' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-opencl-icd' is not installed, so not removed
                    Package 'libnvidia-egl-wayland-dev' is not installed, so not removed
                    Package 'nvidia-tesla-opencl-icd' is not installed, so not removed
                    Package 'libnvidia-tesla-api1' is not installed, so not removed
                    Package 'boinc-client-nvidia-cuda' is not installed, so not removed
                    Package 'nvidia-vdpau-driver' is not installed, so not removed
                    Package 'libegl1-nvidia-legacy-340xx' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-encode1' is not installed, so not removed
                    Package 'libglx-nvidia-tesla0' is not installed, so not removed
                    Package 'libglx-nvidia-tesla-470-0' is not installed, so not removed
                    Package 'primus-vk-nvidia' is not installed, so not removed
                    Package 'nvidia-tesla-kernel-dkms' is not installed, so not removed
                    Package 'hashcat-nvidia' is not installed, so not removed
                    Package 'libnvidia-tesla-470-glcore' is not installed, so not removed
                    Package 'mate-sensors-applet-nvidia' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-smi' is not installed, so not removed
                    Package 'nvidia-settings-tesla-470' is not installed, so not removed
                    Package 'nvidia-tesla-vulkan-icd' is not installed, so not removed
                    Package 'nvidia-tesla-470-driver-bin' is not installed, so not removed
                    Package 'libegl-nvidia0' is not installed, so not removed
                    Package 'bumblebee-nvidia' is not installed, so not removed
                    Package 'libnvidia-tesla-470-opticalflow1' is not installed, so not removed
                    Package 'firmware-nvidia-gsp' is not installed, so not removed
                    Package 'xserver-xorg-video-nvidia' is not installed, so not removed
                    Package 'nvidia-detect' is not installed, so not removed
                    Package 'nvidia-modprobe' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-kernel-source' is not installed, so not removed
                    Package 'libnvidia-tesla-glcore' is not installed, so not removed
                    Package 'libnvidia-tesla-rtcore' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-alternative' is not installed, so not removed
                    Package 'nvidia-cg-dev' is not installed, so not removed
                    Package 'libgl1-nvidia-legacy-340xx-glx' is not installed, so not removed
                    Package 'nvidia-cg-doc' is not installed, so not removed
                    Package 'nvidia-kernel-source' is not installed, so not removed
                    Package 'nvidia-persistenced' is not installed, so not removed
                    Package 'libnvidia-tesla-compiler' is not installed, so not removed
                    Package 'libegl-nvidia-tesla0' is not installed, so not removed
                    Package 'nvidia-smi' is not installed, so not removed
                    Package 'libnvidia-tesla-470-fbc1' is not installed, so not removed
                    Package 'nvidia-tesla-smi' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-fbc1' is not installed, so not removed
                    Package 'bumblebee' is not installed, so not removed
                    Package 'bumblebee-status' is not installed, so not removed
                    Package 'bumblebee-status-doc' is not installed, so not removed
                    Package 'primus-libs' is not installed, so not removed
                    Package 'primus' is not installed, so not removed
                    Package 'primus-vk' is not installed, so not removed
                    Package 'primus-libs:i386' is not installed, so not removed
                    Package 'primus:i386' is not installed, so not removed
                    Package 'primus-vk-nvidia:i386' is not installed, so not removed
                    Package 'libegl1-nvidia-legacy-340xx:i386' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-eglcore:i386' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-alternative:i386' is not installed, so not removed
                    Package 'libgl1-nvidia-legacy-340xx-glx:i386' is not installed, so not removed
                    Package 'nvidia-installer-cleanup:i386' is not installed, so not removed. Did you mean 'nvidia-installer-cleanup'?
                    Package 'libnvidia-legacy-340xx-glcore:i386' is not installed, so not removed
                    Package 'nvidia-support:i386' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-kernel-dkms:i386' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-kernel-source:i386' is not installed, so not removed
                    Package 'libgles1-nvidia-legacy-340xx:i386' is not installed, so not removed
                    Package 'libgles2-nvidia-legacy-340xx:i386' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-cfg1:i386' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-compiler:i386' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-cuda1:i386' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-smi:i386' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-cuda1-i386:i386' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-encode1:i386' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-nvcuvid1:i386' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-fbc1:i386' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-ifr1:i386' is not installed, so not removed
                    Package 'libnvidia-legacy-340xx-ml1:i386' is not installed, so not removed
                    Package 'glx-alternative-nvidia:i386' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-driver:i386' is not installed, so not removed
                    Package 'xserver-xorg-video-nvidia-legacy-340xx:i386' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-driver-bin:i386' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-driver-libs:i386' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-vdpau-driver:i386' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-driver-libs-i386:i386' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-kernel-support:i386' is not installed, so not removed
                    Package 'nvidia-kernel-common:i386' is not installed, so not removed
                    Package 'nvidia-modprobe:i386' is not installed, so not removed
                    Package 'nvidia-legacy-340xx-opencl-icd:i386' is not installed, so not removed
                    Package 'nvidia-opencl-common:i386' is not installed, so not removed
                    Package 'nvidia-libopencl1:i386' is not installed, so not removed
                    Package 'boinc-client-nvidia-cuda:i386' is not installed, so not removed
                    Package 'libnvidia-egl-wayland-dev:i386' is not installed, so not removed
                    Package 'libnvidia-egl-wayland1:i386' is not installed, so not removed
                    Package 'libnvidia-encode1:i386' is not installed, so not removed
                    Package 'nvidia-opencl-icd:i386' is not installed, so not removed
                    Package 'nvidia-vdpau-driver:i386' is not installed, so not removed
                    Package 'mate-sensors-applet-nvidia:i386' is not installed, so not removed
                    Package 'mir-graphics-drivers-nvidia:i386' is not installed, so not removed
                    Package 'nvidia-vaapi-driver:i386' is not installed, so not removed
                    Package 'nvidia-driver-libs:i386' is not installed, so not removed
                    Package 'nvidia-vulkan-icd:i386' is not installed, so not removed
                    Package 'nvidia-primus-vk-wrapper:i386' is not installed, so not removed
                    Package 'libnvidia-egl-gbm1:i386' is not installed, so not removed
                    Package 'nvidia-primus-vk-common:i386' is not installed, so not removed
                    Package 'nvidia-tesla-vulkan-icd:i386' is not installed, so not removed
                    Package 'nvidia-tesla-470-vulkan-icd:i386' is not installed, so not removed
                    Package 'libnvidia-ml1:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-ml1:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-470-ml1:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-cuda1:i386' is not installed, so not removed
                    Package 'nvidia-tesla-driver-libs:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-470-cuda1:i386' is not installed, so not removed
                    Package 'nvidia-tesla-470-driver-libs:i386' is not installed, so not removed
                    Package 'nvidia-cg-dev:i386' is not installed, so not removed
                    Package 'nvidia-cg-toolkit:i386' is not installed, so not removed
                    Package 'nvidia-alternative:i386' is not installed, so not removed
                    Package 'libnvidia-ptxjitcompiler1:i386' is not installed, so not removed
                    Package 'libegl-nvidia0:i386' is not installed, so not removed
                    Package 'libnvidia-eglcore:i386' is not installed, so not removed
                    Package 'libgl1-nvidia-glvnd-glx:i386' is not installed, so not removed
                    Package 'libglx-nvidia0:i386' is not installed, so not removed
                    Package 'libgles-nvidia1:i386' is not installed, so not removed
                    Package 'libgles-nvidia2:i386' is not installed, so not removed
                    Package 'libnvidia-glcore:i386' is not installed, so not removed
                    Package 'libnvidia-allocator1:i386' is not installed, so not removed
                    Package 'libnvidia-compiler:i386' is not installed, so not removed
                    Package 'libnvidia-fbc1:i386' is not installed, so not removed
                    Package 'libnvidia-glvkspirv:i386' is not installed, so not removed
                    Package 'libnvidia-nvvm4:i386' is not installed, so not removed
                    Package 'libnvidia-opticalflow1:i386' is not installed, so not removed
                    Package 'nvidia-egl-icd:i386' is not installed, so not removed
                    Package 'nvidia-egl-common:i386' is not installed, so not removed
                    Package 'libegl-nvidia-tesla0:i386' is not installed, so not removed
                    Package 'libegl-nvidia-tesla-470-0:i386' is not installed, so not removed
                    Package 'nvidia-tesla-opencl-icd:i386' is not installed, so not removed
                    Package 'nvidia-tesla-470-opencl-icd:i386' is not installed, so not removed
                    Package 'nvidia-vulkan-common:i386' is not installed, so not removed
                    Package 'nvidia-tesla-alternative:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-eglcore:i386' is not installed, so not removed
                    Package 'libgl1-nvidia-tesla-glvnd-glx:i386' is not installed, so not removed
                    Package 'libglx-nvidia-tesla0:i386' is not installed, so not removed
                    Package 'libgles-nvidia-tesla1:i386' is not installed, so not removed
                    Package 'libgles-nvidia-tesla2:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-glcore:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-allocator1:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-compiler:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-ptxjitcompiler1:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-encode1:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-nvcuvid1:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-fbc1:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-glvkspirv:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-nvvm4:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-opticalflow1:i386' is not installed, so not removed
                    Package 'nvidia-tesla-egl-icd:i386' is not installed, so not removed
                    Package 'nvidia-tesla-vdpau-driver:i386' is not installed, so not removed
                    Package 'nvidia-tesla-470-alternative:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-470-eglcore:i386' is not installed, so not removed
                    Package 'libgl1-nvidia-tesla-470-glvnd-glx:i386' is not installed, so not removed
                    Package 'libglx-nvidia-tesla-470-0:i386' is not installed, so not removed
                    Package 'libgles-nvidia-tesla-470-1:i386' is not installed, so not removed
                    Package 'libgles-nvidia-tesla-470-2:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-470-glcore:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-470-allocator1:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-470-compiler:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-470-ptxjitcompiler1:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-470-encode1:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-470-nvcuvid1:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-470-fbc1:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-470-glvkspirv:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-470-ifr1:i386' is not installed, so not removed
                    Package 'libnvidia-tesla-470-opticalflow1:i386' is not installed, so not removed
                    Package 'nvidia-tesla-470-egl-icd:i386' is not installed, so not removed
                    Package 'nvidia-tesla-470-vdpau-driver:i386' is not installed, so not removed
                    The following packages were automatically installed and are no longer required:
                      glx-alternative-mesa glx-diversions libatomic1:i386 libbsd0:i386
                      libdrm-amdgpu1:i386 libdrm-intel1:i386 libdrm-nouveau2:i386
                      libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libegl-mesa0:i386
                      libegl1:i386 libelf1:i386 libexpat1:i386 libffi8:i386 libgbm1:i386
                      libgl1:i386 libgl1-mesa-dri:i386 libglapi-mesa:i386 libgles1 libgles1:i386
                      libgles2:i386 libglvnd0:i386 libglx-mesa0:i386 libglx0:i386 libicu72:i386
                      libllvm15:i386 liblzma5:i386 libmd0:i386 libopengl0 libopengl0:i386
                      libpciaccess0:i386 libsensors5:i386 libstdc++6:i386 libtinfo6:i386
                      libvulkan1:i386 libwayland-client0:i386 libwayland-server0:i386
                      libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386
                      libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-randr0:i386
                      libxcb-shm0:i386 libxcb-sync1:i386 libxcb-xfixes0:i386 libxcb1:i386
                      libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxml2:i386 libxshmfence1:i386
                      libxxf86vm1:i386 libz3-4:i386 libzstd1:i386 nvidia-installer-cleanup
                      update-glx zlib1g:i386
                    Use 'sudo apt autoremove' to remove them.
                    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
                    rm symlinks
                    Proprietary drivers removed
                    Press <Enter> to exitcreating lock ...
                    ===================================
                    ddm-mx: 23.03.01
                    kernel release: 5.10.188-antix.1-amd64-smp
                    kernel version: #1 SMP PREEMPT Mon Jul 31 18:52:00 EEST 2023
                    command parameters: -i nvidia
                    ===================================
                    ===================================
                    Install drivers for: nvidia
                    Start at (m/d/y): 01/17/2024 16:31:18
                    ===================================
                    ========================================
                    ========================================
                    To restore open source drivers use:  
                    sudo ddm-mx -p nvidia
                    ========================================
                    ========================================
                    Refreshing Sources with apt-get update
                    Installing latest nvidia-detect package
                    Reading package lists...
                    Building dependency tree...
                    Reading state information...
                    The following packages were automatically installed and are no longer required:
                      glx-alternative-mesa glx-diversions libatomic1:i386 libbsd0:i386
                      libdrm-amdgpu1:i386 libdrm-intel1:i386 libdrm-nouveau2:i386
                      libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libegl-mesa0:i386
                      libegl1:i386 libelf1:i386 libexpat1:i386 libffi8:i386 libgbm1:i386
                      libgl1:i386 libgl1-mesa-dri:i386 libglapi-mesa:i386 libgles1 libgles1:i386
                      libgles2:i386 libglvnd0:i386 libglx-mesa0:i386 libglx0:i386 libicu72:i386
                      libllvm15:i386 liblzma5:i386 libmd0:i386 libopengl0 libopengl0:i386
                      libpciaccess0:i386 libsensors5:i386 libstdc++6:i386 libtinfo6:i386
                      libvulkan1:i386 libwayland-client0:i386 libwayland-server0:i386
                      libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386
                      libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-randr0:i386
                      libxcb-shm0:i386 libxcb-sync1:i386 libxcb-xfixes0:i386 libxcb1:i386
                      libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxml2:i386 libxshmfence1:i386
                      libxxf86vm1:i386 libz3-4:i386 libzstd1:i386 nvidia-installer-cleanup
                      update-glx zlib1g:i386
                    Use 'sudo apt autoremove' to remove them.
                    The following NEW packages will be installed:
                      nvidia-detect
                    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
                    Need to get 0 B/144 kB of archives.
                    After this operation, 230 kB of additional disk space will be used.
                    Selecting previously unselected package nvidia-detect.
                    (Reading database ... 
                    (Reading database ... 5%
                    (Reading database ... 10%
                    (Reading database ... 15%
                    (Reading database ... 20%
                    (Reading database ... 25%
                    (Reading database ... 30%
                    (Reading database ... 35%
                    (Reading database ... 40%
                    (Reading database ... 45%
                    (Reading database ... 50%
                    (Reading database ... 55%
                    (Reading database ... 60%
                    (Reading database ... 65%
                    (Reading database ... 70%
                    (Reading database ... 75%
                    (Reading database ... 80%
                    (Reading database ... 85%
                    (Reading database ... 90%
                    (Reading database ... 95%
                    (Reading database ... 100%
                    (Reading database ... 113143 files and directories currently installed.)
                    Preparing to unpack .../nvidia-detect_525.147.05-4~deb12u1_amd64.deb ...
                    Unpacking nvidia-detect (525.147.05-4~deb12u1) ...
                    Setting up nvidia-detect (525.147.05-4~deb12u1) ...
                    Distribution:   antiX
                    Latest  = 525.147.05
                    Detected NVIDIA GPUs:
                    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK208B [GeForce GT 710] [10de:128b] (rev a1)
                    Checking card:  NVIDIA Corporation GK208B [GeForce GT 710] (rev a1)
                    Your card is supported by the nvidia tesla 470 drivers series. nvidia-tesla-470-driver
                    It is recommended to install the following:
                    INSTALL:  nvidia-tesla-470-driver
                    To install alternate driver packages, use sudo ddm-mx -i nvidia -f [driver package name]
                    Candidate is: nvidia-tesla-470-driver 470.223.02-2~deb12u1
                    Installed is: nvidia-tesla-470-driver (none)
                    Would you like to check debian-backports for a later version?
                    Yes or No?
                    1: Yes
                    2: No
                    Enter Number of selection
                    Ok...
                    Refreshing Sources with apt-get update
                    Installing latest nvidia-detect package
                    Reading package lists...
                    Building dependency tree...
                    Reading state information...
                    nvidia-detect is already the newest version (525.147.05-4~deb12u1).
                    The following packages were automatically installed and are no longer required:
                      glx-alternative-mesa glx-diversions libatomic1:i386 libbsd0:i386
                      libdrm-amdgpu1:i386 libdrm-intel1:i386 libdrm-nouveau2:i386
                      libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libegl-mesa0:i386
                      libegl1:i386 libelf1:i386 libexpat1:i386 libffi8:i386 libgbm1:i386
                      libgl1:i386 libgl1-mesa-dri:i386 libglapi-mesa:i386 libgles1 libgles1:i386
                      libgles2:i386 libglvnd0:i386 libglx-mesa0:i386 libglx0:i386 libicu72:i386
                      libllvm15:i386 liblzma5:i386 libmd0:i386 libopengl0 libopengl0:i386
                      libpciaccess0:i386 libsensors5:i386 libstdc++6:i386 libtinfo6:i386
                      libvulkan1:i386 libwayland-client0:i386 libwayland-server0:i386
                      libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386
                      libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-randr0:i386
                      libxcb-shm0:i386 libxcb-sync1:i386 libxcb-xfixes0:i386 libxcb1:i386
                      libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxml2:i386 libxshmfence1:i386
                      libxxf86vm1:i386 libz3-4:i386 libzstd1:i386 nvidia-installer-cleanup
                      update-glx zlib1g:i386
                    Use 'sudo apt autoremove' to remove them.
                    0 upgraded, 0 newly installed, 0 to remove and 26 not upgraded.
                    Candidate is: nvidia-tesla-470-driver 470.223.02-2~deb12u1
                    Installed is: nvidia-tesla-470-driver (none)
                    Candidate is: nvidia-tesla-470-driver 470.223.02-2~deb12u1
                    Installed is: nvidia-tesla-470-driver (none)
                    Main repo candidate is: 470.223.02-2~deb12u1
                    Debian backports candidate is: 470.223.02-2~deb12u1
                    Installed is: (none)
                    Which driver do you wish to install
                    Main repos or debian-backports?
                    1: Main 470.223.02-2~deb12u1
                    2: debian-backports 470.223.02-2~deb12u1
                    3: Exit
                    Enter Number of selection
                    Ok...
                    Candidate is: nvidia-tesla-470-driver 470.223.02-2~deb12u1
                    Installed is: nvidia-tesla-470-driver (none)
                    Need driver: nvidia-tesla-470-driver 470.223.02-2~deb12u1 
                    NVIDIA packages to install are nvidia-tesla-470-driver nvidia-settings-tesla-470 nvidia-tesla-470-kernel-dkms
                    Frontend: 
                    Nvidia command = apt-get install --install-recommends --reinstall -y  -t bookworm-backports nvidia-tesla-470-driver nvidia-settings-tesla-470 nvidia-tesla-470-kernel-dkms
                    Reading package lists...
                    Building dependency tree...
                    Reading state information...
                    The following packages were automatically installed and are no longer required:
                      glx-alternative-mesa glx-diversions libatomic1:i386 libbsd0:i386
                      libdrm-amdgpu1:i386 libdrm-intel1:i386 libdrm-nouveau2:i386
                      libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libegl-mesa0:i386
                      libegl1:i386 libelf1:i386 libexpat1:i386 libffi8:i386 libgbm1:i386
                      libgl1:i386 libgl1-mesa-dri:i386 libglapi-mesa:i386 libgles1 libgles1:i386
                      libgles2:i386 libglvnd0:i386 libglx-mesa0:i386 libglx0:i386 libicu72:i386
                      libllvm15:i386 liblzma5:i386 libmd0:i386 libopengl0 libopengl0:i386
                      libpciaccess0:i386 libsensors5:i386 libstdc++6:i386 libtinfo6:i386
                      libvulkan1:i386 libwayland-client0:i386 libwayland-server0:i386
                      libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386
                      libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-randr0:i386
                      libxcb-shm0:i386 libxcb-sync1:i386 libxcb-xfixes0:i386 libxcb1:i386
                      libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxml2:i386 libxshmfence1:i386
                      libxxf86vm1:i386 libz3-4:i386 libzstd1:i386 nvidia-installer-cleanup
                      update-glx zlib1g:i386
                    Use 'sudo apt autoremove' to remove them.
                    0 upgraded, 0 newly installed, 2 reinstalled, 0 to remove and 0 not upgraded.
                    Need to get 0 B/8,152 kB of archives.
                    After this operation, 0 B of additional disk space will be used.
                    (Reading database ... 
                    (Reading database ... 5%
                    (Reading database ... 10%
                    (Reading database ... 15%
                    (Reading database ... 20%
                    (Reading database ... 25%
                    (Reading database ... 30%
                    (Reading database ... 35%
                    (Reading database ... 40%
                    (Reading database ... 45%
                    (Reading database ... 50%
                    (Reading database ... 55%
                    (Reading database ... 60%
                    (Reading database ... 65%
                    (Reading database ... 70%
                    (Reading database ... 75%
                    (Reading database ... 80%
                    (Reading database ... 85%
                    (Reading database ... 90%
                    (Reading database ... 95%
                    (Reading database ... 100%
                    (Reading database ... 113169 files and directories currently installed.)
                    Preparing to unpack .../linux-headers-5.10.188-antix.1-amd64-smp_5.10.188-antix.1-amd64-smp-1_amd64.deb ...
                    Unpacking linux-headers-5.10.188-antix.1-amd64-smp (5.10.188-antix.1-amd64-smp-1) over (5.10.188-antix.1-amd64-smp-1) ...
                    Preparing to unpack .../build-essential_12.9_amd64.deb ...
                    Unpacking build-essential (12.9) over (12.9) ...
                    Setting up linux-headers-5.10.188-antix.1-amd64-smp (5.10.188-antix.1-amd64-smp-1) ...
                    Setting up build-essential (12.9) ...
                    Reading package lists...
                    Building dependency tree...
                    Reading state information...
                    The following additional packages will be installed:
                      glx-alternative-nvidia libegl-nvidia-tesla-470-0
                      libegl-nvidia-tesla-470-0:i386 libgl1-nvidia-tesla-470-glvnd-glx
                      libgl1-nvidia-tesla-470-glvnd-glx:i386 libgles-nvidia-tesla-470-1
                      libgles-nvidia-tesla-470-1:i386 libgles-nvidia-tesla-470-2
                      libgles-nvidia-tesla-470-2:i386 libglx-nvidia-tesla-470-0
                      libglx-nvidia-tesla-470-0:i386 libnvidia-egl-wayland1
                      libnvidia-tesla-470-cbl libnvidia-tesla-470-cfg1 libnvidia-tesla-470-cuda1
                      libnvidia-tesla-470-cuda1:i386 libnvidia-tesla-470-eglcore
                      libnvidia-tesla-470-eglcore:i386 libnvidia-tesla-470-encode1
                      libnvidia-tesla-470-encode1:i386 libnvidia-tesla-470-glcore
                      libnvidia-tesla-470-glcore:i386 libnvidia-tesla-470-glvkspirv
                      libnvidia-tesla-470-glvkspirv:i386 libnvidia-tesla-470-ml1
                      libnvidia-tesla-470-nvcuvid1 libnvidia-tesla-470-nvcuvid1:i386
                      libnvidia-tesla-470-ptxjitcompiler1 libnvidia-tesla-470-ptxjitcompiler1:i386
                      libnvidia-tesla-470-rtcore nvidia-egl-common nvidia-kernel-common
                      nvidia-modprobe nvidia-support nvidia-tesla-470-alternative
                      nvidia-tesla-470-driver-bin nvidia-tesla-470-driver-libs
                      nvidia-tesla-470-driver-libs:i386 nvidia-tesla-470-egl-icd
                      nvidia-tesla-470-egl-icd:i386 nvidia-tesla-470-kernel-support
                      nvidia-tesla-470-smi nvidia-tesla-470-vdpau-driver
                      nvidia-tesla-470-vulkan-icd nvidia-tesla-470-vulkan-icd:i386
                      nvidia-vulkan-common xserver-xorg-video-nvidia-tesla-470
                    Suggested packages:
                      nvidia-cuda-mps vulkan-tools vulkan-tools:i386
                    Recommended packages:
                      nvidia-persistenced
                    The following NEW packages will be installed:
                      glx-alternative-nvidia libegl-nvidia-tesla-470-0
                      libegl-nvidia-tesla-470-0:i386 libgl1-nvidia-tesla-470-glvnd-glx
                      libgl1-nvidia-tesla-470-glvnd-glx:i386 libgles-nvidia-tesla-470-1
                      libgles-nvidia-tesla-470-1:i386 libgles-nvidia-tesla-470-2
                      libgles-nvidia-tesla-470-2:i386 libglx-nvidia-tesla-470-0
                      libglx-nvidia-tesla-470-0:i386 libnvidia-egl-wayland1
                      libnvidia-tesla-470-cbl libnvidia-tesla-470-cfg1 libnvidia-tesla-470-cuda1
                      libnvidia-tesla-470-cuda1:i386 libnvidia-tesla-470-eglcore
                      libnvidia-tesla-470-eglcore:i386 libnvidia-tesla-470-encode1
                      libnvidia-tesla-470-encode1:i386 libnvidia-tesla-470-glcore
                      libnvidia-tesla-470-glcore:i386 libnvidia-tesla-470-glvkspirv
                      libnvidia-tesla-470-glvkspirv:i386 libnvidia-tesla-470-ml1
                      libnvidia-tesla-470-nvcuvid1 libnvidia-tesla-470-nvcuvid1:i386
                      libnvidia-tesla-470-ptxjitcompiler1 libnvidia-tesla-470-ptxjitcompiler1:i386
                      libnvidia-tesla-470-rtcore nvidia-egl-common nvidia-kernel-common
                      nvidia-modprobe nvidia-settings-tesla-470 nvidia-support
                      nvidia-tesla-470-alternative nvidia-tesla-470-driver
                      nvidia-tesla-470-driver-bin nvidia-tesla-470-driver-libs
                      nvidia-tesla-470-driver-libs:i386 nvidia-tesla-470-egl-icd
                      nvidia-tesla-470-egl-icd:i386 nvidia-tesla-470-kernel-dkms
                      nvidia-tesla-470-kernel-support nvidia-tesla-470-smi
                      nvidia-tesla-470-vdpau-driver nvidia-tesla-470-vulkan-icd
                      nvidia-tesla-470-vulkan-icd:i386 nvidia-vulkan-common
                      xserver-xorg-video-nvidia-tesla-470
                    Preconfiguring packages ...
                    0 upgraded, 50 newly installed, 0 to remove and 26 not upgraded.
                    Need to get 0 B/126 MB of archives.
                    After this operation, 437 MB of additional disk space will be used.
                    Selecting previously unselected package glx-alternative-nvidia.
                    (Reading database ... 
                    (Reading database ... 5%
                    (Reading database ... 10%
                    (Reading database ... 15%
                    (Reading database ... 20%
                    (Reading database ... 25%
                    (Reading database ... 30%
                    (Reading database ... 35%
                    (Reading database ... 40%
                    (Reading database ... 45%
                    (Reading database ... 50%
                    (Reading database ... 55%
                    (Reading database ... 60%
                    (Reading database ... 65%
                    (Reading database ... 70%
                    (Reading database ... 75%
                    (Reading database ... 80%
                    (Reading database ... 85%
                    (Reading database ... 90%
                    (Reading database ... 95%
                    (Reading database ... 100%
                    (Reading database ... 113169 files and directories currently installed.)
                    Preparing to unpack .../00-glx-alternative-nvidia_1.2.2_amd64.deb ...
                    Unpacking glx-alternative-nvidia (1.2.2) ...
                    Selecting previously unselected package nvidia-tesla-470-alternative.
                    Preparing to unpack .../01-nvidia-tesla-470-alternative_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking nvidia-tesla-470-alternative (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package nvidia-settings-tesla-470.
                    Preparing to unpack .../02-nvidia-settings-tesla-470_470.161.03-1_amd64.deb ...
                    Unpacking nvidia-settings-tesla-470 (470.161.03-1) ...
                    Selecting previously unselected package libnvidia-tesla-470-eglcore:amd64.
                    Preparing to unpack .../03-libnvidia-tesla-470-eglcore_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libnvidia-tesla-470-eglcore:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-glcore:amd64.
                    Preparing to unpack .../04-libnvidia-tesla-470-glcore_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libnvidia-tesla-470-glcore:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libglx-nvidia-tesla-470-0:amd64.
                    Preparing to unpack .../05-libglx-nvidia-tesla-470-0_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libglx-nvidia-tesla-470-0:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libgl1-nvidia-tesla-470-glvnd-glx:amd64.
                    Preparing to unpack .../06-libgl1-nvidia-tesla-470-glvnd-glx_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libgl1-nvidia-tesla-470-glvnd-glx:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package nvidia-egl-common.
                    Preparing to unpack .../07-nvidia-egl-common_525.147.05-4~deb12u1_amd64.deb ...
                    Unpacking nvidia-egl-common (525.147.05-4~deb12u1) ...
                    Selecting previously unselected package libnvidia-egl-wayland1:amd64.
                    Preparing to unpack .../08-libnvidia-egl-wayland1_1%3a1.1.10-1_amd64.deb ...
                    Unpacking libnvidia-egl-wayland1:amd64 (1:1.1.10-1) ...
                    Selecting previously unselected package libegl-nvidia-tesla-470-0:amd64.
                    Preparing to unpack .../09-libegl-nvidia-tesla-470-0_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libegl-nvidia-tesla-470-0:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package nvidia-tesla-470-egl-icd:amd64.
                    Preparing to unpack .../10-nvidia-tesla-470-egl-icd_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking nvidia-tesla-470-egl-icd:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package nvidia-tesla-470-driver-libs:amd64.
                    Preparing to unpack .../11-nvidia-tesla-470-driver-libs_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking nvidia-tesla-470-driver-libs:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-ml1:amd64.
                    Preparing to unpack .../12-libnvidia-tesla-470-ml1_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libnvidia-tesla-470-ml1:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package nvidia-tesla-470-driver-bin.
                    Preparing to unpack .../13-nvidia-tesla-470-driver-bin_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking nvidia-tesla-470-driver-bin (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package nvidia-support.
                    Preparing to unpack .../14-nvidia-support_20220217+3~deb12u1_amd64.deb ...
                    Unpacking nvidia-support (20220217+3~deb12u1) ...
                    Selecting previously unselected package xserver-xorg-video-nvidia-tesla-470.
                    Preparing to unpack .../15-xserver-xorg-video-nvidia-tesla-470_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking xserver-xorg-video-nvidia-tesla-470 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package nvidia-tesla-470-vdpau-driver:amd64.
                    Preparing to unpack .../16-nvidia-tesla-470-vdpau-driver_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking nvidia-tesla-470-vdpau-driver:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package nvidia-kernel-common.
                    Preparing to unpack .../17-nvidia-kernel-common_20220217+3~deb12u1_amd64.deb ...
                    Unpacking nvidia-kernel-common (20220217+3~deb12u1) ...
                    Selecting previously unselected package nvidia-modprobe.
                    Preparing to unpack .../18-nvidia-modprobe_535.54.03-1~deb12u1_amd64.deb ...
                    Unpacking nvidia-modprobe (535.54.03-1~deb12u1) ...
                    Selecting previously unselected package nvidia-tesla-470-kernel-support.
                    Preparing to unpack .../19-nvidia-tesla-470-kernel-support_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking nvidia-tesla-470-kernel-support (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package nvidia-tesla-470-kernel-dkms.
                    Preparing to unpack .../20-nvidia-tesla-470-kernel-dkms_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking nvidia-tesla-470-kernel-dkms (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package nvidia-tesla-470-driver.
                    Preparing to unpack .../21-nvidia-tesla-470-driver_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking nvidia-tesla-470-driver (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-eglcore:i386.
                    Preparing to unpack .../22-libnvidia-tesla-470-eglcore_470.223.02-2~deb12u1_i386.deb ...
                    Unpacking libnvidia-tesla-470-eglcore:i386 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libegl-nvidia-tesla-470-0:i386.
                    Preparing to unpack .../23-libegl-nvidia-tesla-470-0_470.223.02-2~deb12u1_i386.deb ...
                    Unpacking libegl-nvidia-tesla-470-0:i386 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-glcore:i386.
                    Preparing to unpack .../24-libnvidia-tesla-470-glcore_470.223.02-2~deb12u1_i386.deb ...
                    Unpacking libnvidia-tesla-470-glcore:i386 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libglx-nvidia-tesla-470-0:i386.
                    Preparing to unpack .../25-libglx-nvidia-tesla-470-0_470.223.02-2~deb12u1_i386.deb ...
                    Unpacking libglx-nvidia-tesla-470-0:i386 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libgl1-nvidia-tesla-470-glvnd-glx:i386.
                    Preparing to unpack .../26-libgl1-nvidia-tesla-470-glvnd-glx_470.223.02-2~deb12u1_i386.deb ...
                    Unpacking libgl1-nvidia-tesla-470-glvnd-glx:i386 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libgles-nvidia-tesla-470-1:i386.
                    Preparing to unpack .../27-libgles-nvidia-tesla-470-1_470.223.02-2~deb12u1_i386.deb ...
                    Unpacking libgles-nvidia-tesla-470-1:i386 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libgles-nvidia-tesla-470-1:amd64.
                    Preparing to unpack .../28-libgles-nvidia-tesla-470-1_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libgles-nvidia-tesla-470-1:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libgles-nvidia-tesla-470-2:i386.
                    Preparing to unpack .../29-libgles-nvidia-tesla-470-2_470.223.02-2~deb12u1_i386.deb ...
                    Unpacking libgles-nvidia-tesla-470-2:i386 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libgles-nvidia-tesla-470-2:amd64.
                    Preparing to unpack .../30-libgles-nvidia-tesla-470-2_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libgles-nvidia-tesla-470-2:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-cbl:amd64.
                    Preparing to unpack .../31-libnvidia-tesla-470-cbl_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libnvidia-tesla-470-cbl:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-cfg1:amd64.
                    Preparing to unpack .../32-libnvidia-tesla-470-cfg1_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libnvidia-tesla-470-cfg1:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-ptxjitcompiler1:i386.
                    Preparing to unpack .../33-libnvidia-tesla-470-ptxjitcompiler1_470.223.02-2~deb12u1_i386.deb ...
                    Unpacking libnvidia-tesla-470-ptxjitcompiler1:i386 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-cuda1:i386.
                    Preparing to unpack .../34-libnvidia-tesla-470-cuda1_470.223.02-2~deb12u1_i386.deb ...
                    Unpacking libnvidia-tesla-470-cuda1:i386 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-ptxjitcompiler1:amd64.
                    Preparing to unpack .../35-libnvidia-tesla-470-ptxjitcompiler1_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libnvidia-tesla-470-ptxjitcompiler1:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-cuda1:amd64.
                    Preparing to unpack .../36-libnvidia-tesla-470-cuda1_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libnvidia-tesla-470-cuda1:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-nvcuvid1:amd64.
                    Preparing to unpack .../37-libnvidia-tesla-470-nvcuvid1_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libnvidia-tesla-470-nvcuvid1:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-encode1:amd64.
                    Preparing to unpack .../38-libnvidia-tesla-470-encode1_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libnvidia-tesla-470-encode1:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-nvcuvid1:i386.
                    Preparing to unpack .../39-libnvidia-tesla-470-nvcuvid1_470.223.02-2~deb12u1_i386.deb ...
                    Unpacking libnvidia-tesla-470-nvcuvid1:i386 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-encode1:i386.
                    Preparing to unpack .../40-libnvidia-tesla-470-encode1_470.223.02-2~deb12u1_i386.deb ...
                    Unpacking libnvidia-tesla-470-encode1:i386 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-glvkspirv:i386.
                    Preparing to unpack .../41-libnvidia-tesla-470-glvkspirv_470.223.02-2~deb12u1_i386.deb ...
                    Unpacking libnvidia-tesla-470-glvkspirv:i386 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-glvkspirv:amd64.
                    Preparing to unpack .../42-libnvidia-tesla-470-glvkspirv_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libnvidia-tesla-470-glvkspirv:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package libnvidia-tesla-470-rtcore:amd64.
                    Preparing to unpack .../43-libnvidia-tesla-470-rtcore_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking libnvidia-tesla-470-rtcore:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package nvidia-tesla-470-egl-icd:i386.
                    Preparing to unpack .../44-nvidia-tesla-470-egl-icd_470.223.02-2~deb12u1_i386.deb ...
                    Unpacking nvidia-tesla-470-egl-icd:i386 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package nvidia-tesla-470-driver-libs:i386.
                    Preparing to unpack .../45-nvidia-tesla-470-driver-libs_470.223.02-2~deb12u1_i386.deb ...
                    Unpacking nvidia-tesla-470-driver-libs:i386 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package nvidia-tesla-470-smi.
                    Preparing to unpack .../46-nvidia-tesla-470-smi_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking nvidia-tesla-470-smi (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package nvidia-vulkan-common.
                    Preparing to unpack .../47-nvidia-vulkan-common_525.147.05-4~deb12u1_amd64.deb ...
                    Unpacking nvidia-vulkan-common (525.147.05-4~deb12u1) ...
                    Selecting previously unselected package nvidia-tesla-470-vulkan-icd:amd64.
                    Preparing to unpack .../48-nvidia-tesla-470-vulkan-icd_470.223.02-2~deb12u1_amd64.deb ...
                    Unpacking nvidia-tesla-470-vulkan-icd:amd64 (470.223.02-2~deb12u1) ...
                    Selecting previously unselected package nvidia-tesla-470-vulkan-icd:i386.
                    Preparing to unpack .../49-nvidia-tesla-470-vulkan-icd_470.223.02-2~deb12u1_i386.deb ...
                    Unpacking nvidia-tesla-470-vulkan-icd:i386 (470.223.02-2~deb12u1) ...
                    Setting up nvidia-support (20220217+3~deb12u1) ...
                    Setting up nvidia-egl-common (525.147.05-4~deb12u1) ...
                    Setting up libnvidia-tesla-470-rtcore:amd64 (470.223.02-2~deb12u1) ...
                    Setting up nvidia-kernel-common (20220217+3~deb12u1) ...
                    Setting up libnvidia-tesla-470-eglcore:amd64 (470.223.02-2~deb12u1) ...
                    Setting up libnvidia-tesla-470-eglcore:i386 (470.223.02-2~deb12u1) ...
                    Setting up libnvidia-tesla-470-cbl:amd64 (470.223.02-2~deb12u1) ...
                    Setting up nvidia-modprobe (535.54.03-1~deb12u1) ...
                    Setting up libnvidia-egl-wayland1:amd64 (1:1.1.10-1) ...
                    Setting up libnvidia-tesla-470-glcore:amd64 (470.223.02-2~deb12u1) ...
                    Setting up libnvidia-tesla-470-glcore:i386 (470.223.02-2~deb12u1) ...
                    Setting up libnvidia-tesla-470-ptxjitcompiler1:amd64 (470.223.02-2~deb12u1) ...
                    Setting up libnvidia-tesla-470-ptxjitcompiler1:i386 (470.223.02-2~deb12u1) ...
                    Setting up nvidia-vulkan-common (525.147.05-4~deb12u1) ...
                    Setting up libnvidia-tesla-470-glvkspirv:amd64 (470.223.02-2~deb12u1) ...
                    Setting up libnvidia-tesla-470-glvkspirv:i386 (470.223.02-2~deb12u1) ...
                    Setting up glx-alternative-nvidia (1.2.2) ...
                    Processing triggers for man-db (2.11.2-2) ...
                    Processing triggers for mailcap (3.70+nmu1) ...
                    Processing triggers for desktop-file-utils (0.26-1) ...
                    Processing triggers for initramfs-tools (0.142) ...
                    update-initramfs: Generating /boot/initrd.img-5.10.188-antix.1-amd64-smp
                    Processing triggers for hicolor-icon-theme (0.17-2) ...
                    Processing triggers for libc-bin (2.36-9+deb12u3) ...
                    Processing triggers for glx-alternative-nvidia (1.2.2) ...
                    Setting up nvidia-tesla-470-alternative (470.223.02-2~deb12u1) ...
                    Processing triggers for nvidia-tesla-470-alternative (470.223.02-2~deb12u1) ...
                    update-alternatives: using /usr/lib/nvidia/tesla-470 to provide /usr/lib/nvidia/nvidia (nvidia) in auto mode
                    Setting up libgles-nvidia-tesla-470-1:i386 (470.223.02-2~deb12u1) ...
                    Setting up libgles-nvidia-tesla-470-2:amd64 (470.223.02-2~deb12u1) ...
                    Setting up libgles-nvidia-tesla-470-2:i386 (470.223.02-2~deb12u1) ...
                    Setting up nvidia-settings-tesla-470 (470.161.03-1) ...
                    Setting up xserver-xorg-video-nvidia-tesla-470 (470.223.02-2~deb12u1) ...
                    [?1049h[22;0;0t[1;24r[4l[?25l(B[m[37m[40m[1;24r[H[2J[1;1H[1m[37m[44m                                                                                [2;1H                                                                                [3;1H                                                                                [4;1H                                                                                [5;1H                                                                                [6;1H                                                                                [7;1H                                                                                [8;1H                                                                                [9;1H                                                                                [10;1H                                                                                [11;1H                                                                                [12;1H                                                                                [13;1H                                                                                [14;1H                                                                                [15;1H                                                                                [16;1H                                                                                [17;1H                                                                                [18;1H                                                                                [19;1H                                                                                [20;1H                                                                                [21;1H                                                                                [22;1H                                                                                [23;1H                                                                                [24;1H                                                                                [24;79H [4h [4l[1;1H(B[m[37m[44mPackage configuration[6;3H[30m[47m┌───────────┤ [31mConfiguring xserver-xorg-video-nvidia-tesla-470[30m ├───────────┐[7;3H│                                                                         │[1m[37m[40m [8;3H(B[m[30m[47m│ Conflicting nouveau kernel module loaded                                │[1m[37m[40m [9;3H(B[m[30m[47m│                                                                         │[1m[37m[40m [10;3H(B[m[30m[47m│ The free nouveau kernel module is currently loaded and conflicts with   │[1m[37m[40m [11;3H(B[m[30m[47m│ the non-free nvidia kernel module.                                      │[1m[37m[40m [12;3H(B[m[30m[47m│                                                                         │[1m[37m[40m [13;3H(B[m[30m[47m│ The easiest way to fix this is to reboot the machine once the           │[1m[37m[40m [14;3H(B[m[30m[47m│ installation has finished.                                              │[1m[37m[40m [15;3H(B[m[30m[47m│                                                                         │[1m[37m[40m [16;3H(B[m[30m[47m│                                 [37m[41m<Ok>[30m[47m                                    │[1m[37m[40m [17;3H(B[m[30m[47m│                                                                         │[1m[37m[40m [18;3H(B[m[30m[47m└─────────────────────────────────────────────────────────────────────────┘[1m[37m[40m [19;4H                                                                           [16;38H[?12l[?25h[24;1H(B[m[37m[40m(B[m[39;49m
                    [K
                    [?1049l[23;0;0tSetting up nvidia-tesla-470-vdpau-driver:amd64 (470.223.02-2~deb12u1) ...
                    Setting up libnvidia-tesla-470-ml1:amd64 (470.223.02-2~deb12u1) ...
                    Setting up libnvidia-tesla-470-cfg1:amd64 (470.223.02-2~deb12u1) ...
                    Setting up libglx-nvidia-tesla-470-0:amd64 (470.223.02-2~deb12u1) ...
                    Setting up libglx-nvidia-tesla-470-0:i386 (470.223.02-2~deb12u1) ...
                    Setting up libegl-nvidia-tesla-470-0:amd64 (470.223.02-2~deb12u1) ...
                    Setting up libegl-nvidia-tesla-470-0:i386 (470.223.02-2~deb12u1) ...
                    Setting up nvidia-tesla-470-kernel-support (470.223.02-2~deb12u1) ...
                    Setting up libgl1-nvidia-tesla-470-glvnd-glx:amd64 (470.223.02-2~deb12u1) ...
                    Setting up libgl1-nvidia-tesla-470-glvnd-glx:i386 (470.223.02-2~deb12u1) ...
                    Setting up nvidia-tesla-470-smi (470.223.02-2~deb12u1) ...
                    Setting up libnvidia-tesla-470-cuda1:amd64 (470.223.02-2~deb12u1) ...
                    Setting up libnvidia-tesla-470-cuda1:i386 (470.223.02-2~deb12u1) ...
                    Setting up libgles-nvidia-tesla-470-1:amd64 (470.223.02-2~deb12u1) ...
                    Setting up nvidia-tesla-470-egl-icd:amd64 (470.223.02-2~deb12u1) ...
                    Setting up nvidia-tesla-470-egl-icd:i386 (470.223.02-2~deb12u1) ...
                    Setting up nvidia-tesla-470-vulkan-icd:amd64 (470.223.02-2~deb12u1) ...
                    Setting up nvidia-tesla-470-vulkan-icd:i386 (470.223.02-2~deb12u1) ...
                    Setting up nvidia-tesla-470-driver-bin (470.223.02-2~deb12u1) ...
                    Setting up nvidia-tesla-470-driver-libs:amd64 (470.223.02-2~deb12u1) ...
                    Setting up nvidia-tesla-470-driver-libs:i386 (470.223.02-2~deb12u1) ...
                    Setting up libnvidia-tesla-470-nvcuvid1:amd64 (470.223.02-2~deb12u1) ...
                    Setting up libnvidia-tesla-470-nvcuvid1:i386 (470.223.02-2~deb12u1) ...
                    Setting up libnvidia-tesla-470-encode1:amd64 (470.223.02-2~deb12u1) ...
                    Setting up libnvidia-tesla-470-encode1:i386 (470.223.02-2~deb12u1) ...
                    Processing triggers for nvidia-tesla-470-alternative (470.223.02-2~deb12u1) ...
                    update-alternatives: updating alternative /usr/lib/nvidia/tesla-470 because link group nvidia has changed slave links
                    Setting up nvidia-tesla-470-kernel-dkms (470.223.02-2~deb12u1) ...
                    Loading new nvidia-tesla-470-470.223.02 DKMS files...
                    Building for 5.10.188-antix.1-amd64-smp
                    Building initial module for 5.10.188-antix.1-amd64-smp
                    Error! Bad return status for module build on kernel: 5.10.188-antix.1-amd64-smp (x86_64)
                    Consult /var/lib/dkms/nvidia-tesla-470/470.223.02/build/make.log for more information.
                    dpkg: error processing package nvidia-tesla-470-kernel-dkms (--configure):
                     installed nvidia-tesla-470-kernel-dkms package post-installation script subprocess returned error exit status 10
                    dpkg: dependency problems prevent configuration of nvidia-tesla-470-driver:
                     nvidia-tesla-470-driver depends on nvidia-tesla-470-kernel-dkms (= 470.223.02-2~deb12u1) | nvidia-tesla-470-kernel-470.223.02; however:
                      Package nvidia-tesla-470-kernel-dkms is not configured yet.
                      Package nvidia-tesla-470-kernel-470.223.02 is not installed.
                      Package nvidia-tesla-470-kernel-dkms which provides nvidia-tesla-470-kernel-470.223.02 is not configured yet.
                    dpkg: error processing package nvidia-tesla-470-driver (--configure):
                     dependency problems - leaving unconfigured
                    Processing triggers for update-glx (1.2.2) ...
                    Processing triggers for glx-alternative-nvidia (1.2.2) ...
                    update-alternatives: using /usr/lib/nvidia to provide /usr/lib/glx (glx) in auto mode
                    Processing triggers for glx-alternative-mesa (1.2.2) ...
                    Processing triggers for libc-bin (2.36-9+deb12u3) ...
                    Processing triggers for initramfs-tools (0.142) ...
                    update-initramfs: Generating /boot/initrd.img-5.10.188-antix.1-amd64-smp
                    Errors were encountered while processing:
                     nvidia-tesla-470-kernel-dkms
                     nvidia-tesla-470-driver
                    Writing Menu: jwm
                    Writing Menu: fluxbox
                    Writing Menu: icewm
                    E: Sub-process /usr/bin/dpkg returned an error code (1)
                    POSTINSTALL
                    symlinks
                    20_nvidia.conf
                    update-initramfs: Generating /boot/initrd.img-5.10.188-antix.1-amd64-smp
                    Finished
                    Press <Enter> to exit
                    • This reply was modified 4 months, 1 week ago by keshav-uses-linux.
                    #129526
                    Moderator
                    caprea

                      The above log file is of course, and I forgot that, the last log file, i.e. the one of the removal of the nvidia driver.So it says nothing about what went wrong during installation.

                      Before we start another installation attempt, I suggest updating the kernel first.
                      The newest kernel I see here on antiX23 64 bit is 5.10.197antix1
                      So
                      sudo apt update
                      sudo apt install linux-headers-5.10.197-antix.1-amd64-smp linux-image-5.10.197-antix.1-amd64-smp

                      Reboot

                      EDIT: Ah, i see you just edited your post and made another attemt and it is indeed the kernel that doesn’t build against the nvidia driver. Before you reboot remove the nvidia driver again with
                      sudo ddm-mx -p nvidia
                      or you have to do it again at the cli.

                      • This reply was modified 4 months, 1 week ago by caprea.
                      • This reply was modified 4 months, 1 week ago by caprea.
                      #129547
                      Member
                      keshav-uses-linux

                        That worked, Thanks a lot. couldn’t have ever figured that out without your help!

                        #129551
                        Member
                        keshav-uses-linux

                          for Anyone who wants a summary, here a recap

                          How to install NVIDIA Driver on Antix Base/Full (Without a .run file from their official website)

                          1. Use the antiX Menu > Control Centre > Drivers > Nvidia Driver Installer
                          2. if got an error, here are some general fixes that worked for me (and may work for you)
                            • if you are on Antix Full
                              • Use the “Repo Manager” app (control-centre > software > repo-manager) and change the antiX Repos to another repos from your region,
                              • Update you Kernel. you have to find out the specific kernel version yourself and install the latest one if not already installed
                                but this worked for me

                                sudo apt update
                                sudo apt install linux-headers-5.10.197-antix.1-amd64-smp linux-image-5.10.197-antix.1-amd64-smp
                              • then, run these command

                                sudo apt update
                                sudo apt full-upgrade

                                and try again the Nvidia Driver Installer (Menu > Control Centre > Drivers > Nvidia Driver Installer)

                              • Reboot
                            • if you are on Antix Base then, you have to install the “Repo Manager” app required for the fix. to install it, you need to do following things
                              • open up the /etc/apt/sources.list.d/antix.list in a text editor like Geany using this command
                                sudo geany /etc/apt/sources.list.d/antix.list

                              • Change the first section of the file as follows

                                # Use with Debian Bookworm repositories. 
                                deb [signed-by=/etc/apt/keyrings/antix-archive-keyring.gpg] http://mirrors.piconets.webwerks.in/mx-mirror/packages/antix/bookworm bookworm main nonfree nosystemd  
                                #deb-src http://mirrors.piconets.webwerks.in/mx-mirror/packages/antix/bookworm bookworm main nosyste
                              • then run this

                                sudo apt update
                                sudo apt full-upgrade
                                sudo apt install repo-manager
                              • Open the “Repo Manager” app (control-centre > software > repo-manager) and change the antiX Repos to another repos from your region,
                                then, run these command

                                sudo apt update
                                sudo apt full-upgrade

                                and try again the Nvidia Driver Installer (Menu > Control Centre > Drivers > Nvidia Driver Installe)

                              • Update you Kernel. you have to find out the specific kernel version yourself and install the latest one if not already installed
                                but this worked for me

                                sudo apt update
                                sudo apt install linux-headers-5.10.197-antix.1-amd64-smp linux-image-5.10.197-antix.1-amd64-smp
                              • Reboot
                            • If you are dropped to a cli after reboot something went wrong during the nvidia installation. then

                              • Log in with username and password
                              • uninstall the driver with
                                sudo ddm-mx -p nvidia
                              • Afterwards Reboot using
                                sudo reboot
                              • at the cli and the system should boot with normal desktop and the nouveau driver again.
                              • The errors are Logged to a log file in /var/log/ddm.log, Use that to refer to your Problem with the installation
                              • in my case, i didn’t updated my Kernel beforehand, so i just updated it and my error was fixed
                            • post if you still have problems to update the system or installing the nvidia driver
                          • This reply was modified 4 months, 1 week ago by keshav-uses-linux.
                          • This reply was modified 4 months, 1 week ago by keshav-uses-linux.
                          #129558
                          Moderator
                          caprea

                            Thank you for posting a summary, @keshav-uses-linux!
                            I’m very glad you got it fixed and could install the driver,nice.

                          Viewing 12 posts - 16 through 27 (of 27 total)
                          • You must be logged in to reply to this topic.