How to install SIS graphic driver

Forum Forums General Tips and Tricks How to install SIS graphic driver

Tagged: , , ,

  • This topic has 3 replies, 2 voices, and was last updated May 19-4:47 am by RJP.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #142780
    Member
    RJP

      Found from https://nyklinux.blogspot.com/2022/10/antix-linux-21-com-chipset-sis-661741760_23.html

      sudo apt install build-essential autoconf automake xorg-dev xutils-dev mesa-common-dev libdrm-dev libtool

      Download the driver:

      wget http://xorg.freedesktop.org/releases/individual/driver/xf86-video-sis-0.12.0.tar.bz2

      Extract driver:

      tar xjf xf86-video-sis-0.12.0.tar.bz2

      cd xf86-video-sis-0.12.0/

      Install driver:

      ./configure --prefix=/usr --disable-static

      make
      sudo make install

      Remove /etc/X11/xorg.conf file

      cd /etc/X11/
      sudo rm xorg.conf

      Reboot

      Works in antiX 22, but not working in antiX 23

      #142888
      Moderator
      BobC

        You didn’t say what happened?

        Was there an xorg.conf on antiX-22 where it worked? If so, did you try it in antiX-23.1 using the xorg.conf from when it worked on antiX-22?

        Maybe compare the logs from the two?

        Daily driver distro https://www.antixforum.com

        #142891
        Member
        RJP

          You didn’t say what happened?

          Was there an xorg.conf on antiX-22 where it worked? If so, did you try it in antiX-23.1 using the xorg.conf from when it worked on antiX-22?

          Maybe compare the logs from the two?

          antiX 22 bases on bulleye and antiX 23 bookworm. I have to test and see what is a difference.

          #142893
          Member
          RJP

            antiX 22 and antiX 23 has different Xorg versions.

            When making xorg.conf file in antiX 23 using commands

            sudo X :1 -configure
            sudo cp /root/xorg.conf.new /etc/X11/xorg.conf
            startx

            … display does not start and in the /var/log/Xorg.1.log has lines

            405.280] (II) LoadModule: "sis"
            [   405.280] (II) Loading /usr/lib/xorg/modules/drivers/sis_drv.so
            [   405.281] (II) Module sis: vendor="X.Org Foundation"
            [   405.281] 	compiled for 1.20.11, module version = 0.12.0
            [   405.281] 	Module class: X.Org Video Driver
            [   405.281] 	ABI class: X.Org Video Driver, version 24.1
            [   405.281] (EE) sis: module ABI major version (24) doesn't match the server's version (25)
            [   405.281] (EE) Failed to load module "sis" (module requirement mismatch, 0)

            In antiX 22 the same file with sis lines and SIS driver is working.

            [   293.257] 	ABI class: X.Org Video Driver, version 24.1
            [   293.257] (II) LoadModule: "sis"
            [   293.257] (II) Loading /usr/lib/xorg/modules/drivers/sis_drv.so
            [   293.258] (II) Module sis: vendor="X.Org Foundation"
            [   293.258] 	compiled for 1.20.11, module version = 0.12.0
            [   293.258] 	Module class: X.Org Video Driver
            [   293.258] 	ABI class: X.Org Video Driver, version 24.1

            PS: When running X -configure, it makes file which uses modesetting driver in both of antiXs, so it need to change to sis in antiX 22.

          Viewing 4 posts - 1 through 4 (of 4 total)
          • You must be logged in to reply to this topic.