How to make Fn+ netbook keys work? (Asus eeepc900)

Forum Forums Official Releases antiX-17 “Heather Heyer” How to make Fn+ netbook keys work? (Asus eeepc900)

This topic contains 3 replies, has 2 voices, and was last updated by sem Jul 12-3:53 am.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #11302


    in antiX-17.1 can`t switch between netbook display (Asus eeepc900) and external monitor with Fn+F5 keys. It’s the main reason.
    Other Fn+ keys like Volume and Brightness does not work too. Exept Fn+F2 – “WiFi On/Off” that works.
    In Ubuntu 12.04 all Fn+ keys worked normal.
    I think it’s a keyboard layout problem. Any recommendations are appreciated.

    Forum Admin

    the package that used to govern those extra functions is eeepc-acpi-scripts but there is not a stretch version. there is a sid version though.

    as for your volume keys try this: right click on the volume icon -> preferences -> and enable the volume hotkeys.



    Thanks for volume hotkeys – it works.
    I enabled deb sid main nosystemd
    for eeepc-acpi-scripts in antix.list
    executed apt-get update but I can’t find eeepc-acpi-scripts unfortunatly
    thought it should be somewhere:
    May be I missed something obvious?



    For interested now I use following commands to swith monitors without any additional installs.
    To get monitors names:
    xrandr -q

    Switch to external only:
    xrandr –output VGA1 –auto –output LVDS1 –off

    Switch to internal only:
    xrandr –output VGA1 –off –output LVDS1 –auto

    Extended left, internal primary:
    xrandr –output VGA1 –auto –left-of LVDS1 –output LVDS1 –auto –primary

    Extended left, external primary:
    xrandr –output VGA1 –auto –left-of LVDS1 –primary –output LVDS1 –auto

    After switching you may want to update background image size and Conki position in IceWM for example:
    /usr/local/lib/desktop-session-restart IceWM

    Of course these functions could be combined and assigned to hotkeys.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.