how to maximise windows by double clicking the title bar in icewm?

Forum Forums New users New Users and General Questions how to maximise windows by double clicking the title bar in icewm?

  • This topic has 12 replies, 5 voices, and was last updated Mar 9-5:48 am by chinguskhan.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #135749
    Member
    chinguskhan

      https://ice-wm.org/man/icewm-preferences.html, documentation refers to this line in ~/.icewm/preferences
      TitleBarMaximizeButton=1 # [0-5]
      but when i change it, it seems to do nothing. i’ve tried every number from 0 to 5 and none of them seem to work.

      #135751
      Member
      PPC

        That feature always worked perfectly, in the default value, under antiX. You have to double click the titlebar (i.e. click the titlebar of the window itself, not it’s entry on the taskbar).
        That feature only is guaranteed to work in gtk managed windows (that have the default window decorations, not for windows that have their own decoration, like Firefox, etc). But I just tested doubling clicking on a clear space in Firefox-esr, in antiX 23.1 live. It works, the window gets maximized.

        Edit: by default, that entry is commented out, in antix’s icewm configuration file

        P.

        • This reply was modified 2 months, 3 weeks ago by PPC.
        • This reply was modified 2 months, 3 weeks ago by PPC.
        #135793
        Member
        chinguskhan

          ah, so it only works for certain windows. say, were you able to maximise something like geany or roxterm?

          #135803
          Member
          fantasIA05

            On my antix 23 it works correctly, it was already enabled by default. It works in all the programs I use, including geany, roxterm.
            1. I’ll send you an image (attached) of my configuration file, you should have it exactly the same.
            2. Sometimes when you make a change you have to restart icewm so you can notice if it took effect. After making the changes, test if it works: Click on “Menu(antix)”——–»”Close the session”——-» “Restart icewm”.
            3. If it still doesn’t work you can explore the following, maybe something there is disabled. Click on “Menu(antix)”——–»”Settings”——-»”Preferences”——-»something that is disabled and activate it —– –» “save preferences” ——-» “restart icewm”

            Attachments:
            #135821
            Member
            chinguskhan

              yea it’s the same as yours. in the start menu preferences, there is no titlebarmaximisebutton option

              • This reply was modified 2 months, 3 weeks ago by chinguskhan.
              #135824
              Member
              Xunzi_23

                After making changes restarting ICEWM is as easy as entering

                icewm --restart in the terminal and pressing enter.

                You can explore and find many more useful settings in
                /home/yourusername/.icewm/preferences

                it is recommended to make changes in
                /home/yourusername/.icewm/.prefoverrides

                You may have to create that to activate an option copy it in to prefoverrides, remove the # at start of line
                then change option as you wish. The advantage of .prefoverrides is should you make any mistake there is no
                risk of a preference being ignored and renaming that file is an easy bailput option. And you will never forget
                which changes you made. I also use the .prefoverides to move options to other users. Very Easy.

                Prefoverrides is read after the preferences file, ICE shell carries out the last command for an option so
                if there are differences between .prefoverrides and original preferences the option in prefoverrides will be
                used during the WM start process.

                Example:

                #  TitleBar mouse-button double click to maximize the window.
                TitleBarMaximizeButton=1 # [0-5]

                ICEWM can do many very useful things, it has very clear and easy setup options, just takes a little energy to read
                the handbook and older posts here in the forum, many from or with the venerable BobC.

                • This reply was modified 2 months, 3 weeks ago by Xunzi_23.
                #135827
                Member
                chinguskhan

                  it still doesn’t work even when i put it in prefoverride

                  #135831
                  Member
                  PPC

                    Weird. I though that it was only in Windows, that something or another worked for every single user except a particular one. It may be that just that feature is not working on your device, on your hardware… but the usual explanation is what I call the “Apple defense”: you’re using it wrong.

                    P.

                    #135882
                    Member
                    Xunzi_23

                      Pls post full path to your.prefoverides it is a hidden file so you must prefix with a dot, it is not recognized if called prefoverride
                      And the content of that file

                      #135893
                      Member
                      anti-apXos

                        yea it’s the same as yours. in the start menu preferences, there is no titlebarmaximisebutton option

                        If your preferences entry looks exactly like the one @FantasIA05 posted, then note that the entry is commented out with a # like @PPC mentioned. By default (including when it’s commented out), double clicking with the left mouse button (1) should maximize the window. If you uncomment the line, then the other possible values 2-5 mean double clicking with other mouse buttons will maximize. 0 means that titlebarmaximize is disabled.

                        Since this is not a simple on/off setting, the entry in the root menu preferences is under the “Scalar” submenu, not the main alphabetical listing.

                        Are you able to maximize the windows you want to maximize if you click the titlebar maximization icon or right-click the titlebar and choose “Maximize”?

                        #135915
                        Member
                        chinguskhan

                          Pls post full path to your.prefoverides it is a hidden file so you must prefix with a dot, it is not recognized if called prefoverride
                          And the content of that file

                          /home/f/.icewm/prefoverride

                          TaskBarShowShowDesktopButton=1
                          TaskBarShowWorkspaces=0
                          TaskBarShowCPUStatus=0
                          TaskBarShowNetStatus=0
                          ShowRun=0
                          TitleBarMaximizeButton=1

                          i don’t think the file needs to be prefixed with a dot though. all of the other modifications above the last line work correctly. in fact, when it is prefixed with a dot, all of the modifications get ignored

                          the entry in the root menu preferences is under the “Scalar” submenu

                          nope, i only see clickmotiondelay and clickmotiondistance

                          Are you able to maximize the windows you want to maximize if you click the titlebar maximization icon or right-click the titlebar and choose “Maximize”?

                          yes, other methods of maximizing work fine

                          • This reply was modified 2 months, 3 weeks ago by chinguskhan.
                          #136016
                          Member
                          anti-apXos

                            You haven’t mentioned what version of icewm you have installed. That’s all I can think of, that you may have an old version. In v3.4.1 and v3.4.5 that I have here for testing, there should be a couple dozen configurable options under Settings>Preferences>Scalar. I don’t see any way of reducing how many options are shown in the preferences menu.

                            • This reply was modified 2 months, 3 weeks ago by anti-apXos.
                            #136051
                            Member
                            chinguskhan

                              You haven’t mentioned what version of icewm you have installed.

                              it is version 3.4.5

                              there should be a couple dozen configurable options under Settings>Preferences>Scalar

                              oh sorry, i was an idiot in that last post. the TitleBarMaximizeButton option is present in the scalar menu and it’s set to 1

                            Viewing 13 posts - 1 through 13 (of 13 total)
                            • You must be logged in to reply to this topic.