How to mount exfat USB drive

Tagged: 

  • This topic has 30 replies, 7 voices, and was last updated Sep 3-10:06 am by symbol.
Viewing 15 posts - 1 through 15 (of 31 total)
  • Author
    Posts
  • #37320
    Member
    namida12

      64gig fat32 USB drive mounts but 128gig exfat does not auto mount

      If I look in gparted I can see both drives. If I use yad (Unplug Removable Drive Icon in the panel) only the 64 gig drive is listed.

      Looking @ /media/green611 (Thumbs) I have one blue folder USB30FD that is the 64gig fat32…

      Seems the 128 gig flash drive is being seen by gparted, but not in media…

      What do I need to do for the exfat drive to automount, or force mount the flash drive?

      `$ inxi -F
      System: Host: green611 Kernel: 4.19.100-antix.1-amd64-smp x86_64 bits: 64 Desktop: IceWM 1.6.6
      Distro: antiX-19.2-4.19_kernel_x64-full Hannie Schaft 6 April 2020
      Machine: Type: Desktop Mobo: ASRock model: B450M Pro4 serial: <root required> UEFI [Legacy]: American Megatrends
      v: P3.90 date: 12/09/2019
      CPU: Topology: Quad Core model: AMD Ryzen 5 3400G with Radeon Vega Graphics bits: 64 type: MT MCP L2 cache: 2048 KiB
      Speed: 1860 MHz min/max: 1400/3700 MHz Core speeds (MHz): 1: 1252 2: 1252 3: 1252 4: 2293 5: 1258 6: 1252
      7: 1253 8: 2294
      Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Picasso driver: N/A
      Display: x11 server: X.Org 1.20.4 driver: vesa resolution: 1920×1080~N/A
      OpenGL: renderer: llvmpipe (LLVM 7.0 128 bits) v: 3.3 Mesa 18.3.6
      Audio: Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
      Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel
      Sound Server: ALSA v: k4.19.100-antix.1-amd64-smp
      Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
      IF: eth0 state: up speed: 1000 Mbps duplex: full mac: a8:a1:59:0d:db:5a
      Drives: Local Storage: total: 640.75 GiB used: 254.24 GiB (39.7%)
      ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS500G3XHC-00SJG0 size: 465.76 GiB
      ID-2: /dev/sda type: USB vendor: PNY model: USB 3.0 FD size: 57.80 GiB
      ID-3: /dev/sdb type: USB model: SMI USB size: 117.19 GiB
      Partition: ID-1: / size: 14.70 GiB used: 4.62 GiB (31.4%) fs: ext4 dev: /dev/nvme0n1p2
      ID-2: /home size: 434.06 GiB used: 192.24 GiB (44.3%) fs: ext4 dev: /dev/nvme0n1p4
      ID-3: swap-1 size: 8.00 GiB used: 256 KiB (0.0%) fs: swap dev: /dev/nvme0n1p3
      Sensors: System Temperatures: cpu: 36.6 C mobo: N/A
      Fan Speeds (RPM): N/A
      Info: Processes: 229 Uptime: 4d 17h 35m Memory: 13.62 GiB used: 2.26 GiB (16.6%) Shell: bash inxi: 3.0.36
      green611@green611:~

      #37328
      Member
      Xecure

        When I have problems mounting devices, I add them to fstab. It has worked for me time and time again.

        It should be relatively easy to add its information manually to fstab, but if you don’t have much experience here, do:

        First, open /etc/fstab and check that you specific exFAT drive is not already there. If it is, change the no-auto to auto, save the file, and DONt follow what is below.
        If it is not there, make a copy of this fstab file (very important). Follow these steps to add automatically your drive to fstab.

        2. Updating fstab
        2.1. Make a copy of your fstab (located in /etc/fstab just in case)
        2.2. Connect the devices and manually mount the partitions you wish will automount
        2.3. Open a terminal and execute
        sudo make-fstab
        2.4. Open your /etc/fstab file (with root privilegies) and check if the partitions are added. Change “noauto” to “auto” for all interested partitions. Save file once finished editing.

        antiX Live system enthusiast.
        General Live Boot Parameters for antiX.

        #37374
        Member
        namida12

          Xecure,

          Below is what shows in fstab:

          # Pluggable devices are handled by uDev, they are not in fstab   <---  Should I be using uDev instead of fstab?  
          UUID=42915636-f499-4f2f-a4b3-7d8b653a2416 / ext4 defaults,noatime 1 1
          UUID=5355c772-b18e-43cf-9ec3-33eedfb95a3a /home ext4 defaults,noatime 1 2
          UUID=cdc4e84b-8f50-43ad-aeae-1cf260df0c8e swap swap defaults 0 0 
          #-> /dev/nvme0n1p1
          UUID=58DB-7115                             /media/58DB-7115                            vfat       noauto,uid=1000,gid=users,dmask=002,fmask=113,users  0 0
          /dev/cdrom                                 /media/cdrom                                iso9660    noauto,exec,users,ro            0 0
          /dev/cdrw                                  /media/cdrw                                 iso9660    noauto,exec,users,rw            0 0
          /dev/dvd                                   /media/dvd                                  udf        noauto,exec,users,ro            0 0
          /dev/dvdrw                                 /media/dvdrw                                udf        noauto,exec,users,rw            0 0
          /dev/sr0                                   /media/sr0                                  auto       noauto,exec,users,ro            0 0
          

          Appears that the USB device is not showing.

          In your instructions this is all I want to do!
          2.2. Connect the device and manually mount the drive <— This is what I want to do, I do not have ability to find, locate and mount the exfat flash drive.

          JR

          • This reply was modified 3 years, 10 months ago by namida12.
          #37377
          Member
          Xecure

            Sorry about that. I misunderstood that you were able to manually mount it but not get it to automount. My mistake.

            Manually mounting should be fairly easy. I will give you two ways: a GUI way and a terminal way.

            1. Using GUI. There is a GUI tool for mounting devices in antiX. You can find it in the Control Centre, in the Disks tab.
            Control Centre > Disks > Mount connected devices
            First you will need to know the path to the drive. You can get it from the List button (on the right of the program, when clicked, search for the TYPE=”exfat” line and see the path at the beginning of that line) or from Gparted, that you have already used. For this example, let us imagine the path is /dev/sdb1
            Now, we need to decide the name of the mounting point. For this example, I will name it “USB128SMI”. You can use a better name if you like.
            Once you know the device path and the mount name, change those values in antiX-Mountbox program. FOr this example:

            Device: /dev/sdb1
            Mount point: /media/USB128SMI

            Hit the Mount button and it should mount your exfat drive.

            2. Terminal method
            Using the same info as above, we must first create the mount point and then ask for the device to mount in said mountpoint:

            sudo mkdir /media/USB128SMI
            sudo mount -t exfat /dev/sdb1 /media/USB128SMI

            3. Optional automount method for SpaceFM.
            I was searching the forums for exfat problems, and it seems there is a way to add exfat in a udev rule for Spacefm, based on:
            https://www.antixforum.com/forums/topic/antix-19-bug-automount-drives-does-not-work/page/2/#post-29090
            But as the user didn’t come back to report if they got it working, I cannot be sure. I leave it here in case you want to add it.

            4. For the future, using fstab to automount.
            Once you have manually mounted your exfat device, if you don’t want to manually mount it in the future, you can do as I suggested in my original post, and add it to your /etc/fstab file. The “easy” way is doing it as above, saving a fstab copy for backup and updating fstab with sudo make-fstab
            You can then edit your fstab file change the noauto option to auto for your exfat device. After saving, you will see in the future that the exfat drive will always automount to your selected mount point.

            • This reply was modified 3 years, 10 months ago by Xecure. Reason: spelling
            • This reply was modified 3 years, 10 months ago by Xecure. Reason: stupid mistake

            antiX Live system enthusiast.
            General Live Boot Parameters for antiX.

            #37381
            Member
            namida12

              Xecure,

              Mount connected devices was easy to find. Control Centre > Disks > Mount connected devices

              See attached list
              See attached input <–Maybe I did this wrong, as it still did not mount.

              JR

              #37386
              Member
              namida12

                I just found this info on-line: http://linuxize.com/post/how-to-mount-an-exfat-drive-on-debian/ From this it appears Debian does not include exfat???

                Trying terminal

                $ sudo mkdir /dev/sda1
                [sudo] password for green611: 
                mkdir: cannot create directory ‘/dev/sda1’: File exists
                green611@green611:~
                $ sudo mkdir /media/7A7F-06FF
                green611@green611:~
                $ sudo mount -t exfat /dev/sda1 /media/7A7F-06FF
                FUSE exfat 1.3.0
                WARN: volume was not unmounted cleanly.
                green611@green611:~
                

                An instant solution: boot from MX-19.1 ahs live media and open the 128 exfat flash drive, store the files I want on to use on another flash drive and then reboot back into antix to use the files. Solves problem for the moment, but the mounting of the exfat drive still is not really solved unless I follow the advice of the above website.

                auto mounting was solved in MX so I am presuming this can now be fixed in antix? I hope not to have destroyed/damaged the exfat USB, with the message not unmounted cleanly trying to mount in antix.

                #37387
                Member
                Xecure

                  exfat-fuse and exfat-utils are already installed in antiX.
                  Even if the error comes up, it doesn’t mean that the mounting didn’t work. Check it out.

                  sudo umount /media/7A7F-06FF
                  sudo mount -t exfat /dev/sda1 /media/7A7F-06FF

                  You will see that the error no longer apears and that the device mounted properly.

                  antiX Live system enthusiast.
                  General Live Boot Parameters for antiX.

                  #37388
                  Member
                  namida12

                    In the link you sent to me:

                    There was a comment posted: “anticapitalista’s post mentioned “won’t automount [..] because pmount in Debian doesn’t recognize the exfat file format.””

                    Date of that posting was November 2019, wonder if that has been fixed and can be updated and included as an option in the next release of antix to handle exfat medium like MX was able to accomplish?

                    JR

                    #37400
                    Member
                    Xecure

                      I just created a 1.4 GB exfat partition on a USB device. I tried to follow my step 2 procedure on an antiX 19.2.1 base x64 live system (not updated). And I got to mount the exfat device, first the same error as before, but now it works.

                      demo@antix1:~
                      $ sudo mkdir /media/USB-DATA
                      demo@antix1:~
                      $ sudo mount -t exfat /dev/sdc1 /media/USB-DATA/
                      FUSE exfat 1.3.0
                      WARN: volume was not unmounted cleanly.
                      demo@antix1:~
                      $ sudo umount /media/USB-DATA
                      demo@antix1:~
                      $ sudo mount -t exfat /dev/sdc1 /media/USB-DATA/
                      FUSE exfat 1.3.0

                      See screenshot for proof.
                      I will test this on my antiX tablet and then test is the fstab trick will help me automount my exfat partition whenever I connect it.

                      Attachments:

                      antiX Live system enthusiast.
                      General Live Boot Parameters for antiX.

                      #37436
                      Member
                      namida12

                        OK, I used MX live media, it auto mounted the exfat drive I then copied the files to another flash drive, and booted back into antiX and created the documents i wanted. emailed them job finished.

                        While I had MX mounted I tried a few flash drives I was going to toss, a 128, and several 32 gig drives. They all auto mounted in MX live media to my surprise.
                        I attached my backup drive, in a USB toaster and copied the files that were on these flash drives. The 128 is a exfat format, but is never seen in antiX, the 32 gig drives also mounted without any problems.

                        I booted out of MX live media, booted up antiX and can not see the 128 gig drive. Yad tells me there is no mounted drive. but control center>disk>mount Has both flash drive listed

                        sudo umount /media/7A7F-06FF
                        sudo mount -t exfat /dev/sda1 /media/7A7F-06FF

                        Doing the unmount has allowed the drive to show in media…

                        $ sudo mkdir /media/7A7F-06FF
                        green611@green611:~
                        $ sudo mount -t exfat /dev/sda1 /media/7A7F-06FF
                        FUSE exfat 1.3.0
                        WARN: volume was not unmounted cleanly.
                        green611@green611:~
                        sudo umount /media/7A7F-06FF
                        sudo mount -t exfat /dev/sda1 /media/7A7F-06FF
                        

                        Now yad can remove the drive. The directory /media/7A7F-06FF is still showing in the folder but the device unmounted.

                        JR

                        #37441
                        Member
                        Xecure

                          Now yad can remove the drive. The directory /media/7A7F-06FF is still showing in the folder but the device unmounted.

                          That is the only problem when manually mounting. You create a folder (mkdir creates the folder), but it will not automatically delete itself. It will stay there for easier mounting in the future, so you only need to mount -t exfat …, reducing the steps a bit. If you get it in fstab, it would reduce the steps to 0.

                          MX uses a whole desktop environment and other packages for mount/unmount. It is a more complex and heavy system, but it is easier for most users.

                          Whatever workaround you prefer is good. I just made some suggestions based on my own experience, as setting drives on fstab has helped me with some of my external drives. You could always try to mirror MX behavior, by looking and investigating the packages and systems it uses. The magic of linux is how much you can change and customize your system.

                          Regards.

                          antiX Live system enthusiast.
                          General Live Boot Parameters for antiX.

                          #42655
                          Anonymous

                            @Xecure
                            I have made a ventoy disk and did every thing you said to do named a mount for /dev/sdd1 changed the the fstab to auto all seemed good, sdd1 which is 14gb and stores the iso’s. I can open sdd2 no worry’s which is the boot portion.
                            Just get this error if try and open sdd1 FUSE exfat 1.3.0 ERROR: invalid VBR checksum 0x55e0cb9 (expected 0x565cdb9). This error makes no sense at all as ventoy works just fine to install systems from iso files, not only that I can read , write , mount and umount to sdd1 & sdd2 with an arch based system.

                            #42766
                            Member
                            Xecure

                              No idea why. I am no expert. Hopefully this is no longer a problem in newer kernels now that microsoft has added exfat support to the linux kernel. Probably kernel 5.X should work perfectly with exfat. Not tested, so I cannot really say.

                              antiX Live system enthusiast.
                              General Live Boot Parameters for antiX.

                              #64190
                              Member
                              namida12

                                Running Live media:
                                $ inxi -F
                                System: Host: antix1 Kernel: 5.10.27-antix.1-amd64-smp x86_64 bits: 64 Desktop: IceWM 2.4.0
                                Distro: antiX-bullseye-b1_x64-full Grup Yorum 11 June 2021
                                Machine: Type: Desktop Mobo: ASRock model: B450M Pro4 serial: <root required> UEFI [Legacy]: American Megatrends v: P3.90
                                date: 12/09/2019
                                CPU: Topology: Quad Core model: AMD Ryzen 5 3400G with Radeon Vega Graphics bits: 64 type: MT MCP L2 cache: 2048 KiB
                                Speed: 2745 MHz min/max: 1400/3700 MHz Core speeds (MHz): 1: 1255 2: 3061 3: 3066 4: 2908 5: 1609 6: 3062 7: 3060
                                8: 3059
                                Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Picasso driver: amdgpu v: kernel
                                Display: x11 server: X.Org 1.20.11 driver: amdgpu,ati unloaded: fbdev,modesetting,vesa resolution: 2560×1440~60Hz
                                OpenGL: renderer: AMD Radeon Vega 11 Graphics (RAVEN DRM 3.40.0 5.10.27-antix.1-amd64-smp LLVM 11.0.1)
                                v: 4.6 Mesa 20.3.4
                                Audio: Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
                                Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel
                                Sound Server: ALSA v: k5.10.27-antix.1-amd64-smp
                                Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
                                IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 68:1c:a2:13:05:64
                                Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
                                IF: eth1 state: down mac: a8:a1:59:0d:db:5a
                                Drives: Local Storage: total: 599.73 GiB used: 4.50 GiB (0.8%)
                                ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS500G3XHC-00SJG0 size: 465.76 GiB
                                ID-2: /dev/sda type: USB vendor: PNY model: USB 2.0 FD size: 14.46 GiB
                                ID-3: /dev/sdb type: USB vendor: Samsung model: Flash Drive size: 119.51 GiB
                                Partition: ID-1: / size: 10.79 GiB used: 3.08 GiB (28.6%) fs: overlay source: ERR-102
                                ID-2: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p3
                                Sensors: System Temperatures: cpu: 46.1 C mobo: N/A gpu: amdgpu temp: 46 C
                                Fan Speeds (RPM): N/A
                                Info: Processes: 213 Uptime: 9h 44m Memory: 13.59 GiB used: 1.15 GiB (8.5%) Shell: bash inxi: 3.0.36
                                demo@antix1:~

                                Still can not find or see a 128 gig flash drive, except in Gparted.

                                • This reply was modified 2 years, 8 months ago by namida12.
                                Attachments:
                                #64197
                                Forum Admin
                                Dave

                                  I do not have a flash drive that size to test (mostly I format to ext* or ntfs if sharing with a windows pc).
                                  As noted make sure exfat-utils and exfat-fuse are installed (should be by default).
                                  apt update && apt install exfat-utils exfat-fuse.

                                  What does the command blkid show?
                                  blkid

                                  It seems from inxi/gparted that the device is shown as /dev/sdb1. Does /dev/sdb1 exist?
                                  ls -l /dev/sdb1

                                  The previous suggestions attempt to mount the /dev/sda1 partition which is reported as the 64gb drive. Perhaps try mounting the /dev/sdb1 partition as this is what inxi/gparted reports as the 128gb drive (or 119.5gb reported). This should be run as the root user.
                                  mkdir -p /mnt/usb-drive && mount -t exfat /dev/sdb1 /mnt/usb-drive;

                                  If that mounts an fstab entry could be made using the UUID from the output of blkid. Then you can simply run
                                  mount /mnt/usb-drive
                                  or have spacefm mount it without special parameters. (I am not certain about rox).

                                  Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

                                Viewing 15 posts - 1 through 15 (of 31 total)
                                • You must be logged in to reply to this topic.