how to re-install X from terminal

Forum Forums New users New Users and General Questions how to re-install X from terminal

  • This topic has 16 replies, 7 voices, and was last updated Apr 2-9:30 am by Robin.
Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #56514
    Member
    Avatarstephenbbb

    after a grub failure I manually copied i386-pc folder from /user/lib and I can boot, but get to a prompt as X server is broken.
    what is the best way to re-install X?

    thanks
    S.

    #56516
    Member
    Avatarseaken64

    Check the xorg log file for clues. Read the screen at the prompt. It tells you where the log file is.

    It’s probably a driver issue. Try using the Vesa driver to troubleshoot.

    At the prompt login with your username and password. Then run

    inxi -Fxzr

    and tell us what equipment you have.

    use mc to look around the file system for the logs.

    seaken64

    #56518
    Member
    Avatarstephenbbb

    I think you are going in the wrong direction, I had a good antix install and it was working fine until I did apt update and apt upgrade.
    this is not a hardware compatibility issue. X is now missing/broken and I need to install it. I have a working ubuntu mate install on the same laptop and this post is coming from the ubuntu install. on ubuntu the command would be

    
    apt install lxde
    

    after getting the wifi to work. is there an equivalent command in antix? also, how do I get wifi working from the terminal?

    • This reply was modified 2 weeks, 3 days ago by stephenbbb.
    • This reply was modified 2 weeks, 3 days ago by stephenbbb.
    #56523
    Member
    Avatarseaken64

    Hi stephenbbb,

    It’s hard to tell what is going on. When you had antiX working did you share your “inxi -Fxzr” output on the forum?

    I’m sure someone will be along to help you with the exact commands for reinstalling X if that’s what you need. But it’s usually something simpler.

    We don’t yet know what version of antiX you’re using, what repos and mirrors are being used, what command(s) you have already initiated. And we can’t see your hardware.

    We just need more info from you if we’re going to have a chance to help you get your X desktop back.

    seaken64

    #56540
    Member
    AvatarRobin

    Maybe this guidance about reinstalling Xorg from console helps:

    [8] Install Xorg 1.19 and some packages needed:

    sudo apt install xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-libinput xserver-xorg-input-mouse xserver-xorg-input-evdev xserver-xorg-input-kbd

    For me this (mostly) worked for the recent Xorg also. So you might give it a try.
    In case you have a touchpad you’ll probably have to install
    sudo apt-get install xserver-xorg-input-synaptics
    additionally.

    #56583
    Member
    Avatarstephenbbb

    after logging in to the terminal I try startx and get

    
    /etc/X11/xinit/xserverrc: 3 exec /usr/bin/X: not found
    xinit: giving up
    xinit: unable to connect to X server: Connection refused
    

    also the output you asked about:

    
    System:    Host: acer-c50 Kernel: 4.9.235-antix.1-amd64-smp x86_64 bits: 64 compiler: gcc v: 8.3.0 Console: tty 1
               Distro: antiX-19.3_x64-full Manolis Glezos 15 October 2020 base: Debian GNU/Linux 10 (buster)
    Machine:   Type: Laptop Mobo: Acer model: Aspire 5250 v: V1.01 serial: <filter> BIOS: Acer v: 1.01 date: 04/21/2011
    CPU:       Topology: Dual Core model: AMD C-50 bits: 64 type: MCP arch: Bobcat L2 cache: 512 KiB
               flags: lm nx pae sse sse2 sse3 sse4a ssse3 svm bogomips: 3989
               Speed: 800 MHz min/max: 800/1000 MHz Core speeds (MHz): 1: 800 2: 800
    Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 6250] vendor: Acer Incorporated ALI driver: N/A
               bus ID: 00:01.0
               Display: server: N/A driver: ati,radeon unloaded: fbdev,modesetting,vesa tty: 128x48
               Message: Advanced graphics data unavailable in console. Try -G --display
    Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: Acer Incorporated ALI driver: N/A bus ID: 00:14.2
    Network:   Device-1: Qualcomm Atheros AR8152 v2.0 Fast Ethernet vendor: Acer Incorporated ALI driver: atl1c v: 1.0.1.1-NAPI
               port: 2000 bus ID: 06:00.0
               IF: eth0 state: down mac: <filter>
               Device-2: Qualcomm Atheros AR9285 Wireless Network Adapter vendor: Lite-On driver: N/A port: 2000 bus ID: 07:00.0
    Drives:    Local Storage: total: 225.41 GiB used: 21.36 GiB (9.5%)
               ID-1: /dev/sda vendor: Dogfish model: SSD 240GB size: 223.57 GiB
               ID-2: /dev/sdb model: Multi-Card size: 1.84 GiB
    Partition: ID-1: / size: 57.49 GiB used: 6.03 GiB (10.5%) fs: ext4 dev: /dev/sda4
               ID-2: /home size: 107.17 GiB used: 15.33 GiB (14.3%) fs: ext4 dev: /dev/sda3
               ID-3: swap-1 size: 3.91 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2
    Sensors:   Message: No sensors data was found. Is sensors configured?
    Repos:     Active apt repos in: /etc/apt/sources.list.d/antix.list
               1: deb http://mirrors.rit.edu/mxlinux/mx-packages/antix/buster/ buster main nonfree nosystemd
               Active apt repos in: /etc/apt/sources.list.d/buster-backports.list
               1: deb http://deb.debian.org/debian buster-backports main contrib non-free
               Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
               1: deb http://ftp.ca.debian.org/debian/ buster-updates main contrib non-free
               Active apt repos in: /etc/apt/sources.list.d/debian.list
               1: deb http://ftp.ca.debian.org/debian/ buster main contrib non-free
               2: deb http://security.debian.org/ buster/updates main contrib non-free
               No active apt repos in: /etc/apt/sources.list.d/onion.list
               No active apt repos in: /etc/apt/sources.list.d/opera-stable.list
               No active apt repos in: /etc/apt/sources.list.d/various.list
    Info:      Processes: 130 Uptime: 4m Memory: 3.60 GiB used: 71.5 MiB (1.9%) Init: SysVinit runlevel: 5 Compilers: gcc: 8.3.0
               Shell: bash v: 5.0.3 inxi: 3.0.36 
    

    how do I setup my wifi from the terminal? or can I just copy some folders from the antix live usb?
    cheers

    • This reply was modified 2 weeks, 2 days ago by stephenbbb.
    #56585
    Moderator
    AvatarBobC

    It sounds to me like something unusual has affected your install, outside of normal updates and such. Otherwise many of us would also be having problems with updates and X-Windows, like you.

    It’s not that you can’t install other things. They might work, or might work until something else affects them, or they might have or cause other completely unusual problems. Until problems are encountered, nobody knows anything about them or how to resolve them.

    Its best to try to run software that was tested and commonly run with the distro by the developers, testers, and other users so you don’t end up being a trail blazer, alpha testing for your one of a kind respin.

    I’ve been there myself. There are times its cool because its exactly what you wanted, but when there are problems, its not easy to solve them.

    #56586
    Member
    Avatarstephenbbb

    @ BobC

    can you tell me how to get the wifi working from the terminal? or what to copy from the live usb? I can see that the X script is missing, but is that script just copied from the live usb or it is configured during the install?
    I see also that the Xorg library in /usr/lib/xorg is missing and so is the /usr/lib/xorg/modules dir.
    all I did was apt update and then apt upgrade. there is another post with 3 pages of how sth went wrong with grub and people keep saying to run grub repair, but it does not work. I had the same experience. manually copying files from the live usb did what grub repair could not do, so I can login to a prompt now.

    • This reply was modified 2 weeks, 2 days ago by stephenbbb.
    #56587
    Moderator
    AvatarBobC

    I haven’t tried wireless from a console in recent years. Ceni is a console based program though, so you could give it a try.

    If reinstalling X-Windows doesn’t work, if it was me I would create another partition and reload antiX fresh from the USB to that partition, and create a separate new home directory. I would then run update and dist-upgrade, and make a list, and install any add on programs. Then I would bring over the configurations and data for my add on programs and make sure they all work right. It’s your system, and I don’t really know all about it, but that would be the method I would use to recover.

    #56588
    Moderator
    AvatarBobC

    Sorry, the X-Windows part I can’t really help with.

    I’ve been where you are before and spent days or weeks trying to fix this or that, and then find something else wrong. That was why I suggested the fresh start above. It may seem harder, but actually is easier because it really gets back to a reliable and supportable system. Yo need to be running a system that you are capable of supporting mostly yourself. People here are willing to help, but if you get way far away from a normal antiX install, the problems get too difficult.

    I’m sorry, I’m not capable of figuring out the rest.

    #56591
    Member
    Avatarseaken64

    Your inxi shows you don’t have a driver loaded for your graphics. Oops, caprea pointed out that the driver is there it’s that the Xorg server is not. .

    I have also had situations where I accidentally messed up the system beyond repair and it was just easier to re-install. If you have enough hard drive space you could try setting up another partition and re-install. Or just re-install over the top of your existing antiX and choose to preserve the /home.

    seaken64

    • This reply was modified 2 weeks, 2 days ago by seaken64.
    #56592
    Member
    Avatarseaken64

    If you haven’t tried Ceni yet I would try that. It’s available from the command line and is text based. Also check out antiX-cli-cc. It is a control center for the command line interface. Setting up wifi from command line involves ifconfig. iwconfig, and other such config files and utilities. It’s been a long time since I’ve done it. I used to do it a lot in Slackware before I found antiX.

    see here for some ideas:

    https://www.linux.com/training-tutorials/how-configure-wireless-any-linux-desktop/

    seaken64

    #56594
    Moderator
    capreacaprea

    I also tend to a new install, there must be a reason why xorg was uninstalled on your system.
    However, the graphic driver is loaded , driver: ati,radeon,
    The Xorg server is missing.
    To use connman from the console you can follow the instructions in the archWiki.

    https://wiki.archlinux.org/index.php/ConnMan

    It is not recommended to switch between connman and ceni or vice versa on antiX19 just like that, the antix-wifi-switcher was introduced for that purpose, thanks to Xecure. Files must be deleted and rewritten during this measure.
    Try it with connman first.

    • This reply was modified 2 weeks, 2 days ago by caprea.
    #56602
    Member
    KooKoo

    Have a look at this Debian site. Not much good if you can’t access the internet.
    http://forums.debian.net/viewtopic.php?f=30&t=81353

    On minimum installs sudo apt install xorg xserver-xorg xutils mesa-utils xserver-xorg-video-radeon

    These are only suggestions. This an agp video card..

    ceni is not hard to use but thats up to your network chips.

    • This reply was modified 2 weeks, 2 days ago by Koo.

    T430 i7-3632QM 16gb , antiX-19.2.1-runit_x64-base Hannie Schaft 29 March 2020 , 5.8.16-antix.1-amd64-smp

    #56605
    Member
    syboksybok

    Hi, expanding/commenting on suggestions by other members:
    1) @Koo: You may try
    A) Run (not 100% sure about the command – currently in Windows)
    apt install --reinstall xorg xorgserver-xorg
    in your antiX (installed system/live-USB) console and see what packages are needed.
    B) Download these Debian/antiX packages in the other system, mount antiX home and copy it there, unmount antiX home.
    C) Manually install each of them in your installed system
    2) @seaken64: The re-install as suggested by preserving /home/ is another option. You may want to backup some configuration files from the current install, e.g. from /home/ and /etc/.

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.