[SOLVED] How to set “apulse firefox” as default browser?

Forum Forums General Software [SOLVED] How to set “apulse firefox” as default browser?

Tagged: , ,

  • This topic has 2 replies, 2 voices, and was last updated Jun 10-4:45 pm by Grisonix.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #61287
    Member
    Grisonix

      I have non-ESR firefox and would like to launch it from the taskbar icon as “apulse firefox”. And if I open a link in another program I always want it to call “apulse firefox”.

      What I tried that didn’t work was, making /usr/share/applications/firefox-apulse.desktop with the following contents.

      #!/bin/bash
      apulse /usr/share/applications/firefox.desktop

      In control center, I then set the default application to be /usr/share/applications/firefox-apulse.desktop. This did not work. I guess there is something wrong with the script?

      Anyway, how do I set it so “apulse firefox” is the default browser option?

      • This topic was modified 3 years, 1 month ago by Grisonix.
      • This topic was modified 3 years, 1 month ago by Grisonix.
      #61289
      Forum Admin
      Dave

        .desktop files are different from scripts.
        Best bet would be to copy the firefox.desktop file to firefox-apulse.desktop and change the Exec= line to apulse firefox.
        There is also add/remove desktop and menu manager to do this graphically.

        cat /usr/share/applications/firefox.desktop |sed "s/Exec=.*/Exec=apulse firefox %u/ig" > ~/.local/share/applications/firefox.desktop && sudo desktop-menu --write-out-global

        Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

        #61290
        Member
        Grisonix

          Thanks a lot!

          That fixed it.

        Viewing 3 posts - 1 through 3 (of 3 total)
        • You must be logged in to reply to this topic.