How to set Pulseaudio default

Forum Forums New users New Users and General Questions How to set Pulseaudio default

Tagged: 

  • This topic has 5 replies, 4 voices, and was last updated Feb 25-8:48 pm by caprea.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #54881
    Member
    angel7

      How to set pulseaudio default instead of alsa? the audio from OBS & Firefox(not esr) only works with pulseaduio.
      Every time that I reboot my system I need to invoke the command “pulseaduio –start” I’ve try everything searching in the google and duckduck go.
      Any help is apreciate. Thanks in advance!

      #54882
      Forum Admin
      Dave

        Are we assuming that adding pulseaudio –start to one of the startup files (Ex: ~/.desktop-session/startup) does not work.?.
        If so try enabling xdg autostart in ~/.desktop-session/desktop-session.conf

        Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

        #54889
        Moderator
        caprea

          For doing so, you can go to

          control-centre > session > configuration of the user

          It will open geany with the startup file, where you can add the line

          pulseaudio -D &

          After that, if you have also pavucontrol installed , which is recommended for pulseaudio,you can also right-click on the volume-icon in the tray,
          go to preferences,
          under “Status icon”, “External mixer” you can write
          pavucontrol
          instead of alsamixer

          Afterwards the volumeicon will open pavucontrol with a middle mouse click or under “Open mixer”

          Besides all that, firefox will play sound without problems and without pulsaudio if you open it with the command

          apulse firefox
          
          • This reply was modified 3 years, 4 months ago by caprea. Reason: corrected a misconception
          #54890
          Member
          ModdIt

            angel7 wrote the audio from OBS & Firefox(not esr) only works with pulseaduio.

            That is incorrect, the solution has been posted several times, in particular in Browser thread.
            Latest Firefox release 86, (Installed deb from sid), tor, other programmes I have tested to date
            will give high quality sound output without using sound degrading Pulse Audio.
            Edit: Firefox downloaded as bundle from Mozilla also has sound.

            Works on antiX 19 and the Bullseye RC which I am using daily. Earlier versions not tested today,
            worked when I ran them.

            I am not starting Firefox with prefix, just command as below.
            prog “Firefox” /usr/share/icons/papirus-antix/48×48/categories/firefox.png /usr/lib/firefox/firefox

            For any new users ~/. is shorthand for a hidden file in your home directory. It should be created with
            your rights not created/invoked with sudo..

            NEED
            ~/.asound.conf Mine is as below. Substitute devices as neccesary.

            #Substitute N with a small integer, 0 for your first sound card (which is the default),
            #1 for your second, and so on.

            pcm.!default {
            type hw
            card 0
            }

            ctl.!default {
            type hw
            card 0
            }

            my ~/.asound.rc is as below

            defaults.pcm.!card PCH
            defaults.ctl.!card PCH

            You may find your sound is muted in alsamixer.

            • This reply was modified 3 years, 4 months ago by ModdIt. Reason: Clarity
            • This reply was modified 3 years, 4 months ago by ModdIt. Reason: Clarity
            #54924
            Member
            angel7

              I need to restaure to default settings in “External Mixer”. Do you know what was write there? Because in the emulators did not work the sound. the error message:
              Assertion 'pthread_mutex_unlock(&m->mutex) == 0' failed at pulsecore/mutex-posix.c:108, function pa_mutex_unlock(). Aborting.

              • This reply was modified 3 years, 4 months ago by angel7.
              #54930
              Moderator
              caprea

                The default settings in “External Mixer” are
                desktop-defaults-run -t alsamixer

                Maybe it was not clear enough, you need to install pavucontrol and afterwards you can change the above and write just “pavucontrol” there.

              Viewing 6 posts - 1 through 6 (of 6 total)
              • You must be logged in to reply to this topic.