How to set the ‘set gfxmode = 1024x768x16, 1024×768’ ?

Forum Forums New users New Users and General Questions How to set the ‘set gfxmode = 1024x768x16, 1024×768’ ?

How to set the 'set gfxmode = 1024x768x16, 1024x768'? / Como configurar o 'set gfxmode=1024x768x16, 1024x768'?

How to set the 'set gfxmode = 1024x768x16, 1024x768'? Como configurar o 'set gfxmode=1024x768x16, 1024x768'?

You must be logged in to participate.
  • #1
  • #2
  • This topic has 88 replies, 7 voices, and was last updated Jul 19-5:22 pm by marcelocripe.
Viewing 15 posts - 1 through 15 (of 87 total)
  • Author
    Posts
  • #37217
    Member
    Avatarmarcelocripe

    Title: How to set the ‘set gfxmode = 1024x768x16, 1024×768’?

    Hello dear colleagues.

    I’m starting with antiX 19.2 version 32 bits and 64 bits, I was able to install both images (antiX-19.2_386-full.iso and antiX-19.2_x64-full.iso) on a computer / notebook.

    I was impressed with this operating system, very light, consumes about 157 MB of RAM, beautiful and has translation into several languages, including the Portuguese language of Brazil.

    The “full” ISOs have basic programs, necessary programs and drivers for any user. This operating system is certainly the direction to be taken to save many computers and notebooks that are being rendered useless due to the system / hardware requirements required by MS Windows and other Linux distributions, causing the programmed obsolescence of technologies that work.

    After installing antiX, the first message was displayed:
    “loading Linux 4.9.212-antix.1-amd64
    vga = 791 is obsolete. Instead, use ‘set gfxmode = 1024x768x16, 1024×768’
    before the ‘linux’ command ”

    How do I make the mentioned change?

    In which file should I insert the ‘set gfxmode = 1024x768x16, 1024×768’?

    Another video situation:

    After installing antiX-19.2_386-full.iso and restarting correctly, I needed to remove the offboard video card and use the onboard video card, after removing the offboard video card, antiX no longer loads in graphics mode. How do I get the operating system to load graphics mode again?

    On the other computer that installed antiX with the onboard card, the same situation occurred, after the computer received the offboard video card. How do I get the operating system to load graphics mode again using the offboard video card?

    I thank anyone who can help me.

    marcelocripe

    Original text in Brazilian Portuguese, translated into English by Google translator.

    —————–

    Título: Como configurar o ‘set gfxmode=1024x768x16, 1024×768’?

    Olá caro colegas.

    Estou iniciando com o antiX 19.2 versão 32 bits e 64 bits, eu consegui fazer a instalação de ambas as imagens (antiX-19.2_386-full.iso e antiX-19.2_x64-full.iso) em um computador/notebook.

    Fiquei impressionado com este sistema operacional, muito leve, consome cerca de 157 MB de memória RAM, bonito e possui tradução para vários idiomas, inclusive o para o idioma português do Brasil.

    As ISOs “full” possuem programas básicos, programas necessários e drivers para qualquer usuário. Este sistema operacional é certamente a direção a ser seguida para salvar muitos computadores e notebook que estão sendo inutilizados devido aos requisitos de sistemas/hardware exigidos pelo MS Windows e em outras distribuições Linux, causando a obsolência programada de tecnologias que funcionam.

    Após a instalação do antiX, na primeira inicialização foi exibido a mensagem:
    “carregando o Linux 4.9.212-antix.1-amd64
    vga=791 está obsoleto. Ao invés, use ‘set gfxmode=1024x768x16, 1024×768’
    antes do comando ‘linux'”

    Como faço a alteração mencionada?

    Em qual arquivo devo inserir o ‘set gfxmode=1024x768x16, 1024×768’?

    Outra situação sobre vídeo:

    Após a instalação do antiX-19.2_386-full.iso e reinicialização correta, eu precisei retirar a placa de vídeo offboard e usar a placa de vídeo onboard, após a retirada da placa de vídeo offboard o antiX não carrega mais no modo gráfico. Como faço para o sistema operacional voltar a carregar o modo gráfico?

    No outro computador que realizei a instalação do antiX com a placa onboard, ocorreu a mesma situação, após o computador receber a placa de vídeo offboard. Como faço para o sistema operacional voltar a carregar o modo gráfico usando a placa de vídeo offboard?

    Desde já agradeço a quem puder me ajudar.

    marcelocripe

    Texto original em idioma português do Brasil, traduzido para o inglês por Google tradutor.

    • This topic was modified 3 months, 2 weeks ago by marcelocripe.
    #37225
    Member
    XecureXecure

    “loading Linux 4.9.212-antix.1-amd64
    vga = 791 is obsolete. Instead, use ‘set gfxmode = 1024x768x16, 1024×768’

    Just a few posts ago, in less than 24 hours, this was being discussed in the forum. Also, a quick internet search gave this result:

    From: https://wiki.debian.org/GrubTransition

    Grub 2 and the VGA parameter

    In Grub2 the vga= parameter is deprecated 1.
    To set a screen resolution for your console you can do the following log in as root
    edit /etc/default/grub uncomment the GRUB_GFXMODE=640×480 and change the resolution to something you can use e.g. 1024×768
    Add the line
    GRUB_GFXPAYLOAD_LINUX=keep
    to the file to have the same resolution at the Linux console. You do not edit the 00_header file as some suggest you need to do.
    run update-grub

    run reboot to confirm that your changes worked!

    So, if you need a step by step guide:

    1. Edit /etc/default/grub with root privileges.
    sudo geany /etc/default/grub
    if you cannot load a graphica interface, call nano instead:
    sudo nano /etc/default/grub

    2. Look at the line starting with GRUB_CMDLINE_LINUX_DEFAULT. At the end of that line, you need to remove the vga=791. For example, mine says:
    vga=791 quiet
    I would only need to remove the vga=791, resulting in:
    quiet

    3. Now, search for the line
    #GRUB_GFXMODE=
    Uncomment that line and change the value. In your case, it should be:
    GRUB_GFXMODE=1024x768x16

    4. Below the previous line, add the line:
    GRUB_GFXPAYLOAD_LINUX=keep
    Save the file.

    5.Now, update grub, in terminal:
    sudo update-grub

    • This reply was modified 3 months, 2 weeks ago by Xecure. Reason: giving terminal option
    #37227
    Member
    XecureXecure

    After installing antiX-19.2_386-full.iso and restarting correctly, I needed to remove the offboard video card and use the onboard video card, after removing the offboard video card, antiX no longer loads in graphics mode. How do I get the operating system to load graphics mode again?

    First you will need to see what the graphic device is, and if the driver is loaded or no.
    In terminal, do:
    inxi -G
    This should give us info about the grafic card and info.

    An example of a system with a graphic card but no grafic driver:

    inxi -G
    Graphics:     Device-1: NVIDIA GT-218 [GeForce 8400 GD Rev. 3] driver: N/A
                  Display: Server: X.org 1.20.4 driver: nouveau, vesa  unloaded: fbdev, modesetting
                  tty: 102x38
                  Message: advanced graphics data not available in console. Try -G --display

    The important part, driver: N/A, meaning, no driver is managing the graphic card, so it cannot load the “gui interface”.

    If you share the same problem, and you graphic card is also nvidia, you could enable the opensource graphic driver for nvidia (nouveau) to start at boot.
    As above recomendation, edit /etc/default/grub, serach for the line containing GRUB_CMDLINE_LINUX_DEFAULT, and add an extra boot option
    nouveau.modeset=1 to force this driver to load during boot.

    If this isn’t your case (you are not using a nvidia card), please share with us your inxi -G information and we will try to help you further.

    #37236
    Member
    Avatarmarcelocripe

    Hello Xecure, how are you?

    Thank you for answering my questions.

    I apologize for my lack of knowledge in Linux distributions, my job opportunities always took me to MS Windows, currently I am able to start my studies and dedicate myself to antiX Linux.

    I managed to find some information on the internet, but without a step-by-step or tutorial, well described as yours, I can’t implement the necessary changes to work.

    Furthermore, translations from Google Chrome or https://translate.google.com/ are not always fully understandable enough for me to be able to implement the necessary changes without damaging the operating system I am starting to learn about. I hope the translations are becoming understandable in your language. If there are no problems in this forum, I will continue to post with the original text written in Brazilian Portuguese and including the translation done by https://translate.google.com/, this can be useful for more people who speak Portuguese.

    Thank you very much for the step by step or tutorial on how to set the ‘set gfxmode = 1024x768x16, 1024 × 768’.

    After restarting the computer and antiX starts to load, the message changed to:
    “vga = is obsolete. Instead, use ‘set gfxpaymode = text’, before the ‘linux’ command”

    In the case of the other computer that I needed to uninstall the offboard video card to use the onboard video card, when the antiX loading started, the monitor lost the video signal and I can no longer see the command prompt.

    The onboard video card controller is Via VT8237R Plus.

    Reinstalling the offboard video card loading the antiX in graphical mode normally occurs, so I can make the necessary modifications to work with the Via VT8237R Plus onboard video card, but I don’t know how to do it. Could you please teach me?

    The video card in question (nVidia GeForce MX 4000 Version 4.18.20.36.00 64 MB) will need to be used on another computer, as the onboard video card uses a shared RAM memory of a maximum of 64 MB and is failing.

    Thank you so much for helping me.

    marcelocripe

    Original text in Brazilian Portuguese, translated into English by Google translator.

    ——————

    Olá Xecure, tudo bem?

    Agradeço por responder as minhas perguntas.

    Eu peço desculpas devido ao meu pouco conhecimentos em distribuições Linux, as minhas oportunidades de trabalho sempre me levavam para o MS Windows, atualmente eu estou podendo iniciar os estudos e me dedicar ao antiX Linux.

    Eu consegui encontrar algumas informações na internet, mas sem um passo a passo ou um tutorial, bem descrito como o seu, eu não consigo implementar as alterações necessárias para funcionar.

    Além do mais, nem sempre as traduções do Google Chrome ou do https://translate.google.com/ ficam totalmente compreensíveis o suficiente para eu conseguir implementar as alterações necessárias sem danificar o sistema operacional do qual estou começando a conhecer. Eu espero que as traduções estejam ficando compreensíveis em seu idioma. Se não houver problemas neste fórum, irei continuar postando com o texto original escrito em português do Brasil e incluindo a tradução feita pelo https://translate.google.com/, isso pode ser útil para mais pessoas que falam idioma português.

    Muito obrigado pelo passo a passo ou tutorial de como definir o ‘set gfxmode=1024x768x16, 1024×768’.

    Após reiniciar o computador e o antiX começar a carregar, a mensagem mudou para:
    “vga = está obsoleto. Ao invés, use ‘set gfxpaymode=text’, antes do comando ‘linux’”

    No caso do outro computador que eu precisei desinstalar a placa de vídeo offboard para usar a placa de vídeo onboard, quando iniciou o carregamento do antiX o monitor perdeu o sinal de vídeo e eu não consigo mais visualizar sequer o prompt de comando.

    O controlador da placa de vídeo onboard é Via VT8237R Plus.

    Reinstalando a placa de vídeo offboard o carregamento do antiX em modo gráfico ocorre normalmente, então posso fazer as modificações que forem necessárias para funcionar com a placa de vídeo onboard Via VT8237R Plus, mas eu não sei como fazer. Por favor, poderia me ensinar?

    A placa de vídeo em questão (nVidia GeForce MX 4000 Versão 4.18.20.36.00 64 MB) precisará ser utilizada em outro computador, pois a placa de vídeo onboard usa memória compartilhada da RAM de no máximo 64 MB e está falhando.

    Muito obrigado por estar me ajudando.

    marcelocripe

    Texto original em idioma português do Brasil, traduzido para o inglês por Google tradutor.

    #37237
    Forum Admin
    anticapitalistaanticapitalista

    vga = is obsolete

    is only a message. It will not do the computer any harm to keep if (if you wish),

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #37240
    Member
    Avatarmarcelocripe

    Forum Admin,

    Do I have to replace it in the gub file located in the / etc / default /) directory, on the line GRUB_CMDLINE_LINUX_DEFAULT = “vga = 791 quiet” for GRUB_CMDLINE_LINUX_DEFAULT = “vga = is obsolete”?

    Do I understand you correctly? Will the message stop showing?

    Thank you for helping me.

    marcelocripe

    Original text in Brazilian Portuguese, translated into English by Google translator.

    ————–

    Forum Admin,

    Eu tenho que substituir no arquivo gub localizado no diretório /etc/default/), na linha GRUB_CMDLINE_LINUX_DEFAULT=”vga=791 quiet” para GRUB_CMDLINE_LINUX_DEFAULT=”vga=is obsolete”?

    Eu entendi corretamente? A mensagem irá deixar de ser exibida?

    Muito obrigado por me ajudar.

    marcelocripe

    Texto original em idioma português do Brasil, traduzido para o inglês por Google tradutor.

    #37244
    Forum Admin
    anticapitalistaanticapitalista

    Leave it as vga=791 quiet

    It will do no harm.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #37248
    Member
    XecureXecure

    The onboard video card controller is Via VT8237R Plus.

    Reinstalling the offboard video card loading the antiX in graphical mode normally occurs, so I can make the necessary modifications to work with the Via VT8237R Plus onboard video card, but I don’t know how to do it. Could you please teach me?

    Sure. First, when you get everything back online with you nvidia card, open a terminal emulator and execute:
    inxi -G
    I have tried searching for the graphical driver for this particular graphic device, and have found very little. if this inxi command finds only the nvidia graphic device, you will be limited to using an offboard one, and having to find another nvidia card for this particular machine.

    But let us not go into this yet without testing inxi -G first.

    #37266
    Member
    Avatarmarcelocripe

    Xecure,

    With the offboard video card installed, I applied the command to the terminal:

    usuario@antix:~
    $ inxi -G
    Graphics:
    Device-1: NVIDIA NV18 [GeForce4 MX 4000] driver: nouveau v: kernel
    Display: x11 server: X.Org 1.20.4 driver: nouveau
    unloaded: fbdev,modesetting,vesa resolution: 1024×768~60Hz
    OpenGL: renderer: Mesa DRI nv18 v: 1.2 Mesa 18.3.6

    marcelocripe

    Original text in Brazilian Portuguese, translated into English by Google translator.

    —————

    Xecure,

    Com a placa de vídeo offboard instalada, apliquei o comando no terminal:

    usuario@antix:~
    $ inxi -G
    Graphics:
    Device-1: NVIDIA NV18 [GeForce4 MX 4000] driver: nouveau v: kernel
    Display: x11 server: X.Org 1.20.4 driver: nouveau
    unloaded: fbdev,modesetting,vesa resolution: 1024×768~60Hz
    OpenGL: renderer: Mesa DRI nv18 v: 1.2 Mesa 18.3.6

    marcelocripe

    Texto original em idioma português do Brasil, traduzido para o inglês por Google tradutor.

    #37277
    Member
    XecureXecure

    $ inxi -G
    Graphics:
    Device-1: NVIDIA NV18 [GeForce4 MX 4000] driver: nouveau v: kernel
    Display: x11 server: X.Org 1.20.4 driver: nouveau
    unloaded: fbdev,modesetting,vesa resolution: 1024×768~60Hz
    OpenGL: renderer: Mesa DRI nv18 v: 1.2 Mesa 18.3.6

    Unfortunately, it seems the system can only detect 1 device (Device-1: NVIDIA NV18 [GeForce4 MX 4000]). It would be extremely difficult to get the onboard graphics working, first because it would need a lot of terminal work and I think very few (if any) here would know how and what to search for (you maybe even need to compile drivers or even compile a whole kernel). The easiest solutions is getting another nvidia card for the system, if this one you are using is needed for a different computer.

    Not much I can help here, I am afraid.

    #37444
    Member
    Avatarmarcelocripe

    Xecure,

    I thank you for all your help.

    If I managed to understand well, in case of problems with the offboard video card and the user needs to use the onboard video card or replace it with another superior offboard video card, as it is possible to do in MS Windows, in antiX 19.2 it will be necessary to make a new installation of the operating system, requiring much more work. If there was a way to load a generic driver or video server, for example, xvesa or Xorg-7.7 on the first boot with the new video card, there would already be a way in graphics mode to solve the problem.

    Thank you for helping me.

    marcelocripe

    Original text in Brazilian Portuguese, translated into English by the Google translator.

    ——————-

    Xecure,

    Eu agradeço por toda a sua ajuda.

    Se eu consegui compreender bem, nos casos de problemas na placa de vídeo offboard e o usuário precisar utilizar a placa de vídeo onboard ou substituir por outra placa de vídeo offboard superior, como é possível fazer no MS Windows, no antiX 19.2 será necessário fazer uma nova instalação do sistema operacional, acarretando muito mais trabalho. Se houvesse uma forma de carregar um driver genérico ou servidor de vídeo, por exemplo, xvesa ou Xorg-7.7 na primeira inicialização com a nova placa de vídeo já teria um meio em modo gráfico para resolver o problema.

    Muito obrigado por me ajudar.

    marcelocripe

    Texto original no idioma português do Brasil, traduzido para inglês pelo tradutor do Google.

    #37450
    Member
    XecureXecure

    As I am not sure if my wording is the correct one, I will first define the words I will be using:
    Onboard graphics: Graphic chip present on your motherboard.
    Dedicated Graphic card: A card you plug into your computer to use as a connection to your motherboard.

    With antiX, most of the necessary drivers are included, so plug and play should be fairly easy.
    If your dedicated graphic card ever breaks and you replace it with a new one (be it the same or different model), on the next boot antiX will detect it and start using it. It will load a driver for it and should load your graphical environment properly.

    For most cases, you won’t have to do anything, as antiX (and linux in general) will load the corresponding open source driver (for nvidia, the Open Source driver is nouveau).
    For very old graphic cards (and the super new ones too), there may be some problems, and you may have to tweak it a bit. Those should be relatively few cases, so only worry about this if/when it comes.

    The last issue is if you install a proprietary driver (like nvidia’s proprietary driver). The installation usually blacklists the opensource driver to avoid problems and conflicts between them, so changing to a different card in the future will need you to uninstall that driver and whitelist the open source driver, but it isn’t something difficult, so you shouldn’t worry about this now if you encounter this problem in the future.

    So, trying to summarize: Changing dedicated graphic cards should be as easy as plug and play on windows. If you have more than one graphic card available to you, you can test this out yourself. So you shouldn’t be worried about this, at least for now.

    #37459
    Member
    AvatarBobC

    Maybe the onboard video is disabled in the BIOS. Run inxi for the system and tell us the manufacturer and model so we can look at the specifications.
    inxi -Fxz

    I hit a problem like this with my 1998 Pentium III. The old PCI and AGP nVidia cards (one of them an MX like yours) I have are no longer supported upstream in Debian or Xorg, so I had to replace the card to solve it. I installed a correct old, used ATI Radeon based card, which I bought very cheap on ebay, and IS still supported, and that fixed it.

    #37661
    Member
    Avatarmarcelocripe

    BobC,

    Thank you for responding.

    I would like to be able to report the result of the command you taught me:

    inxi -Fxz

    But, when I remove the offborad video card and connect the monitor to the onboard video card (from the motherboard), the antiX starts, displays the options menu, I select the first one, the text mode displays the boot loadings, then the monitor turns off, leaving the screen black. The computer remains on, I have visual responses using the keyboard LEDs, but I have no image.

    Is there any way to load the antix in safe mode? (I searched the website and the forum and couldn’t find “safe mode” in antix Linux).

    What I have is the chip model of the Via VT8237R Plus onboard video card.

    thankful

    marcelocripe

    ————–

    BobC,

    Agradeço por responder.

    Eu gostaria de poder informar o resultado do comando que você me ensinou:

    inxi -Fxz

    Mas, quando retiro a placa de vídeo offborad e conecto o monitor na placa de vídeo onboard (da placa mãe), o antiX inicia, exibe o menu de opções, eu seleciono a primeira, o modo texto exibe o carregamentos dos serviços de inicialização, em seguida o monitor apaga, ficando a tela preta. O computador permanece ligado, tenho respostas visuais por meio dos leds do teclado, mas não tenho nenhuma imagem.

    Existe alguma forma de carregar o antix em modo de segurança? (Eu pesquisei no site e no fórum e não consegui encontrar “safe mode” no antix Linux).

    O que eu tenho é o modelo do chip da placa de vídeo onboard Via VT8237R Plus.

    Grato

    marcelocripe

    • This reply was modified 3 months ago by marcelocripe.
    #37667
    Member
    AvatarBobC

    I don’t have recent computers with Via video cards.

    Try xorg=safe on the boot command line. It can go in with: vga=791 xorg=safe quiet

    • This reply was modified 3 months, 1 week ago by BobC.
Viewing 15 posts - 1 through 15 (of 87 total)
  • You must be logged in to reply to this topic.