I can’t get any bluetooth device to pair with my PC

Forum Forums General Hardware I can’t get any bluetooth device to pair with my PC

  • This topic has 2 replies, 2 voices, and was last updated Jan 10-11:23 am by Xecure.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #49548
    Member
    PPC

    Hi! I have a problem connecting to devices using bluetooth:
    Because my onboard soundboard is busted (no sound at all, after some days with very bad sound), I borrowed a bluetooth stick and tried to pair my antiX 19.X PC with a portable JBL column, to have sound on my PC (while I’m waiting for my new soundboard to arrive from China, it’s seems to be on it’s way by mule…).
    I don’t think inxi of my system is relevant to this question, but I’m using a BlueWalker BW-UD02.

    What I did- on antiX 19.X 64bits full:
    – I reenabled bluethoot on sysV on Control Centre and rebooted
    – I installed pulse audio, with all dependencies, pavcontol.
    – I searched on-line, and in the forum, and installed “blueman” with all dependencies. I installed “bluetoothctl”.
    – I start “blueman-manager”, I hit the “bluetooth” button on my column, click “search” on blueman. My column name appears on blueman (as JBL go 2). I right click my column’s icon and select “pair”. A window asking for the column’s pin pops up, I enter it (“0000”). To the right of the columns id in blueman, some statisctics appear, and it says “connected”, but the column is not paired (it’s light does not stop blinking, and it does not make any sound)- the statistics disappear after about 1 minute.

    What happens:
    – No pairing ever happens,
    – On cli I get this output:

    `Generate (/usr/lib/python3/dist-packages/blueman/gui/manager/ManagerDeviceMenu.py:173)
    JBL GO 2
    Traceback (most recent call last):
    File “/usr/lib/python3/dist-packages/dbus/connection.py”, line 607, in msg_reply_handler
    *message.get_args_list()))
    File “/usr/lib/python3/dist-packages/blueman/bluez/Device.py”, line 33, in err
    raise exception
    dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.`

    Note: the same set up, Bluetooth adapter and column were testes on a windows 10 machine and worked fine.

    After many tries, I tried to connect my android phone to my PC- same outcome- it’s correctly identified, asks for PIN, but pairing is not achieved…
    So, blueman does not pair with any bluetooth device, dispite identifying them…

    I also tested connection via cli, launching bluetoothctl and then:
    [bluetooth]# power on
    [bluetooth]# agent on
    [bluetooth]# default-agent
    [bluetooth]# scan on

    But no device is ever even found this way… the outcome is

    Discovery started
    [CHG] Controller 00:0B:0D:0A:68:41 Discovering: yes

    Do I have to remove “policy kit” like in the thread about testing Bluetooth on antiX 21 alpha? I don’t like to mess with my system packages unless I have to…

    P.

    • This topic was modified 5 months, 1 week ago by PPC.
    #49550
    Member
    Xecure
    Helpful
    Up
    0
    :D

    Not enough information.
    First we need to know the bluetooth device

    lsusb
    inxi -Nxxx

    Second, we need to be sure that bluetooth is working properly. You need to check the dmesg output to see if there is any error related to the bluetooth.
    sudo dmesg | grep -i “bl\|bluetooth”
    if we knew the device and driver loaded, we could check for other patterns to find any output related to the device and drivers.
    We also need to make sure that the bluetooth service is running
    service bluetooth status

    Third, we need to make sure that connman enabled bluetooth. Check /var/lib/connman/settings to see if

    [Bluetooth]
    Enable=true

    If this is on, then connman is not blocking the bluetooth signal.

    You also need to make sure that pulseaudio (launching pavucontrol will tell you if the pulseaudio daemon is running)

    I installed pulse audio, with all dependencies, pavcontol.

    Did you also install pulseaudio-module-bluetooth (or else pairing won’t work).

    – I start “blueman-manager”, I hit the “bluetooth” button on my column, click “search” on blueman. My column name appears on blueman (as JBL go 2). I right click my column’s icon and select “pair”.

    Did you also select “trust” before pairing and connecting?

    A window asking for the column’s pin pops up, I enter it (“0000”).

    After many tries, I tried to connect my android phone to my PC- same outcome- it’s correctly identified, asks for PIN

    My bluetooth headset has no security pin feature, so this may be the real reason for the problem. I will see if I can figure out how to enable it on my phone and see if this is the reason.

    #49552
    Member
    Xecure
    Helpful
    Up
    0
    :D

    Just tested on a live USB with antiX 19.2.1 base x64 (not updated) on my laptop.
    0. Enabled bluetooth with the connman gui.

    1. I installed
    bluez blueman pulseaudio pulseaudio-module-bluetooth pavucontrol

    2. I checked that bluetooth was enabled

    service bluetooth status
    ...is running ...

    3. I ran the blueman applet so I have a systemtray icon to keep experimenting
    blueman-applet &

    4. Right-clicked the tary icon, and selected Devices. Hit search and it found my phone. Right-click on the phone, selected “trust”. Then right-click egain and selected “pair”. A pop up message appeared, telling me to verify if the small code is correct and asking to allow connecting in my phone. I unlocked my phone’s screenlock and saw the same message with the same code. I “allowed” the connection both on the phone and on the laptop and it paired correctly. I tried sending an image from my phone to my laptop and I recieved it correctly (now I think I know how to do it).

    5. I enabled pulseaudio daemon
    pulseaudio -D &

    6. I pressed the pairing button on my bluetooth headset. Then I clicked search on the opened blueman devices window. It found my bluetooth headset. I right click, select “trust”. Then right-click again, and selected “pair”. It paired correctly and gave me 3 options to connect to the headset (I selected the one that is set as “Headset”, as that is how I wanted it to work like, and not as microphone. I then heard a sound from my headset and knew it paired correctly. I open pavucontrol to make sure the headset was the main output device. I then opened firefox-esr, went to youtube, selected a video and it played the sound on my headset.

    I cannot say for your specific device, but maybe a kernel update is necessary for better bluetooth driver support for your device.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.