IBM ThinkPad A31p – wifi trouble

Forum Forums New users New Users and General Questions IBM ThinkPad A31p – wifi trouble

  • This topic has 92 replies, 7 voices, and was last updated Jan 5-6:27 pm by Xecure.
Viewing 15 posts - 1 through 15 (of 92 total)
  • Author
    Posts
  • #48690
    Member
    XecureXecure

    For some reason, the new posts from user BruceW are not being posted, and are “pending for approval”. He has contacted me so I will publish what he has sent me so far and we can try to figure out what is going on.

    System:

    Bruce@antix1:~
    
    $ inxi -Fxz
    System:
    Host: antix1 Kernel: 4.9.235-antix.1-486-smp i686 bits: 32 compiler: gcc
    v: 8.3.0 Desktop: IceWM 1.8.3
    Distro: antiX-19.3_386-full Manolis Glezos 15 October 2020
    base: Debian GNU/Linux 10 (buster)
    Machine:
    Type: Laptop System: IBM product: 2653R9U v: N/A serial: <filter>
    Mobo: IBM model: 2653R9U serial: <filter> BIOS: IBM v: 1NET16WW (1.10 )
    date: 10/19/2006
    Battery:
    ID-1: BAT0 charge: 25.5 Wh condition: 25.5/43.2 Wh (59%)
    model: SANYO IBM-02K6898 status: Full
    CPU:
    Topology: Single Core model: Mobile Intel Pentium 4 – M bits: 32 type: MCP
    arch: Netburst Northwood rev: 7 L2 cache: 512 KiB
    flags: pae sse sse2 bogomips: 2398
    Speed: 1200 MHz min/max: 1200/2000 MHz Core speed (MHz): 1: 1200
    Graphics:
    Device-1: AMD RV200/M7 GL [Mobility FireGL 7800] vendor: IBM
    driver: radeon v: kernel bus ID: 01:00.0
    Display: x11 server: X.Org 1.20.4 driver: ati,radeon
    unloaded: fbdev,modesetting,vesa resolution: 1600×1200~60Hz
    OpenGL: renderer: Mesa DRI R100 (RV200 4C58) x86/MMX/SSE2 DRI2
    v: 1.3 Mesa 18.3.6 direct render: Yes
    Audio:
    Device-1: Intel 82801CA/CAM AC97 Audio vendor: IBM ThinkPad T30
    driver: snd_intel8x0 v: kernel bus ID: 00:1f.5
    Sound Server: ALSA v: k4.9.235-antix.1-486-smp
    Network:
    Device-1: Intersil ISL3874 [Prism 2.5]/ISL3872 [Prism 3] vendor: Actiontec
    driver: hostap_pci v: kernel port: 3000 bus ID: 02:02.0
    IF: wifi0 state: down mac: <filter>
    Device-2: Intel 82801CAM PRO/100 VE Ethernet
    vendor: IBM ThinkPad A/T/X Series driver: e100 v: 3.5.24-k2-NAPI
    port: 8000 bus ID: 02:08.0
    IF: eth0 state: down mac: <filter>
    IF-ID-1: irda0 state: down mac: <filter>
    IF-ID-2: wlan0 state: down mac: <filter>
    Drives:
    Local Storage: total: 55.89 GiB used: 4.83 GiB (8.6%)
    ID-1: /dev/sda vendor: Hitachi model: HTS726060M9AT00 size: 55.89 GiB
    Partition:
    ID-1: / size: 7.32 GiB used: 4.73 GiB (64.6%) fs: ext4 dev: /dev/sda2
    ID-2: /home size: 46.89 GiB used: 105.0 MiB (0.2%) fs: ext4 dev: /dev/sda1
    ID-3: swap-1 size: 511.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3
    Sensors:
    System Temperatures: cpu: 37.0 C mobo: 21.0 C
    Fan Speeds (RPM): cpu: 0
    Info:
    Processes: 160 Uptime: 4m Memory: 493.4 MiB used: 160.8 MiB (32.6%)
    Init: SysVinit runlevel: 5 Compilers: gcc: 8.3.0 Shell: bash v: 5.0.3
    inxi: 3.0.36

    Problem summary: “invalid-key” error after writing the password (14 characters, only letters and numbers) while trying to connect to a Wireless Access Point with connman.

    So, the user follows all the steps correctly (enable wifi, select the Wireless Access Point in the corresponding Wireless point in the Wireless tab in cmst, click connect, fill out the Passphrase box with the password (correct capitalization when needed), click OK but cannot connect because of this “invalid-key” error.

    The Wireless device is one I haven’t seen yet:

    Device-1: Intersil ISL3874 [Prism 2.5]/ISL3872 [Prism 3] vendor: Actiontec
    driver: hostap_pci v: kernel port: 3000 bus ID: 02:02.0
    IF: wifi0 state: down mac: <filter>

    It comes up as wifi0 instead of wlan0, so this could be the cause of the problem?

    I would recommend trying to use ceni, just in case this device has trouble working with connman. Run in terminal:
    antix-wifi-switch --gui ceni
    will disable connman and immediately start ceni. It has a terminal interface, but you can click with the mouse to select options.
    See if you can connect with ceni with the password for your wifi.

    Does anyone else have any advice?

    #48698
    Moderator
    AvatarModdIt

    Rare device, ibm-thinkpad-a31p Manual and further info here http://www.thinkwiki.org/wiki/Category:A31p.

    All I could think of is trying to check then if it is switched on and powered then activate wifi all using connmanctrl.
    i mailed a set of commands to BruceW
    should above fail
    The card also some information on enabling here https://wiki.debian.org/hostap

    #48742
    Member
    AvatarBruceW

    Hi all,
    First, I tried running antix-wifi-switch –gui connman, per Moddit. I was presented a dialog box saying:

    No WLAN entries were found in /etc/network/interfaces.
    We recommend only modifying this file if you keep experiencing
    Wifi connection problems with connman.
    Edit the file?

    I clicked on OK to proceed with the edit. No change in the results, though. I can see my wifi router. I click on it to select it, click on Connect, enter my password in the Passphrase box, and click OK. Connman almost immediately returns “invalid-key”.

    Next, I ran antix-wifi-switch –gui ceni. I recall that the first time I ran ceni, I was presented with several configuration boxes that I had to accept, one of which allowed me to enter my password. Not this time. I am now presented only the box that selects the wifi device. Of three possible wifi choices ceni highlights “Eth0 ethernet 00:02:8A:31:08:B9 e100 Intel 82801CAM”. I hit Enter to accept this choice and ceni steps through configuration in Terminal mode, including several steps of “DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval xx”. After that ceni wants to exit. I tried deleting the configuration and running it again and got the same result. After ceni, I no longer see the wifi box in the tool bar at the bottom of the screen. Next steps?

    Thanks again for your help.

    #48744
    Moderator
    christophechristophe

    I am hesitant to jump in with advice, since “too many cooks spoil the soup.”

    But following the actions you performed in ceni:
    You wrote that you configured the Eth0 device.

    Of three possible wifi choices ceni highlights “Eth0 ethernet 00:02:8A:31:08:B9 e100 Intel 82801CAM”. I hit Enter to accept this choice and ceni steps through configuration

    What are the other 2 (you mentioned 3) choices (devices) seen by ceni? Is one Wlan0 or Wifi0?
    If so, use the arrow keys or tab (I can’t remember which, or if both are valid) to highlight that one & press enter.

    But if Xecure or Moddit have better help, look into that line of inquiry…

    • This reply was modified 1 month, 3 weeks ago by christophe.
    #48751
    Member
    AvatarBruceW

    One is wifi0. The other is wlan0. The description for both is the same. I’ll give the wifi0 one a try.

    #48752
    Member
    AvatarBruceW

    Running wifi0, I can see two instances of my wifi router:

    00 80:3f:5d:d6:c2:f5 SIG–66
    01 58:cb:52:bc:52:36 SIG=-56

    My router runs 2.4 and 5 Ghz. I’ll try 00.

    #48753
    Member
    marcelocripemarcelocripe

    Hi BruceW,

    Welcome to antiX and the forum.

    I hope it is something simple and that I can help you.

    If you have an Ethernet network cable, try connecting to your router’s LAN port, do the following test:

    1-We will try to decrease security and try to increase compatibility.

    2-Access your router, look for the Wireless Security Configuration option, change your Wi-Fi password, enter only numbers, maximum 8 characters, if “AES” is selected and change to “TKIP & AES”.

    Save your changes, disconnect the Ethernet cable and try to connect again via Wi-Fi.

    If these actions don’t work, we can still try other options, like changing:

    3-The Channel Band from 20 to 20/40, change the Channel Extension or Channel Frequency;

    4-If you do MAC Access Control, you will have to add the MAC address of the W-Fi network card, otherwise you will never be able to access your wireless network.

    I hope this helps you, sometimes we forget to test the basics.

    If it works, let us know.

    marcelocripe
    (Original text in Brazilian Portuguese)

    ———-

    Olá BruceW,

    Seja bem-vindo ao antiX e ao fórum.

    Eu espero que seja algo simples e que eu possa te ajudar.

    Se você possui um cabo de rede Ethernet, tente fazer a conexão com a porta LAN do seu roteador, faça o seguinte teste:

    1-Vamos tentar diminuir a segurança e tentar aumentar a compatibilidade.

    2-Acesse o seu roteador, procure a opção Configuração de Segurança Wireless, altere a senha do seu Wi-fi, insira apenas números, no máximo 8 caracteres, se estiver selecionado “AES” e altere para “TKIP&AES”.

    Salve as alterações, desconecte o cabo Ethernet e tente conectar novamente via Wi-Fi.

    Se não der certo com estas ações, ainda podemos tentar outras opções, como alterar:

    3-A Banda do Canal de 20 para 20/40, alterar a Extensão de Canal ou Frequência do Canal;

    4-Se você faz Controle de Acesso por MAC, você terá que adicionar o endereço MAC da placa de rede W-Fi, caso contrário nunca poderá acessar a sua rede sem fio.

    Eu espero que isso te ajude, às vezes nos esquecemos de testar o básico.

    Se der certo, nos avise.

    marcelocripe
    (Texto original em Português do Brasil)

    #48761
    Member
    XecureXecure

    One is wifi0. The other is wlan0. The description for both is the same. I’ll give the wifi0 one a try.

    Yes, please try one first and then the other.

    Some ceni images: https://download.tuxfamily.org/antix/docs-antiX-19/FAQ/net.html
    Ceni instructions by christophe: https://antixlinuxfan.miraheze.org/wiki/Ceni

    To connect to wifi with ceni, first select the wireless interface (wlan0 or wifi0), bu clicking or moving with the arrows and pressing Enter.
    Then, select the Access Point from the ones available.
    Then, add the Passphrase of the wireless connection, click OK (or use arrows/Tab to “highlight” The OK option), ignore the other parameters and continue, thenit will try to connect and inform you if all went well.
    Ceni has no systemtray icon, so you can only guess if it worked by opening a browser and connecting to a website.

    Let us know if ceni worked for you (and if it does, if it autoconnects after rebooting the computer).

    #48765
    Member
    AvatarBruceW

    When I run ceni and select wifi0, I can see my wifi and I can put in my password. Ceni starts the configuration and the returns the following:

    Unsupported device type 801 for “wifi0”

    If you think you have received this message due to a bug rather
    than a configuration issue pleas read the section on submitting
    bugs on either our web page at http://www.isc.org or in the README file
    before submitting a bug. These pages explain the proper
    Process and the information we find helpful for debugging.

    Exiting.
    Ifup: failed to bring up wifi0
    W: up wifi0 failed due to error at /usr/sbin/ceni line 1516.

    Press Enter to continue …

    If i, instead select wlan0, ceni steps through DHCPDISCOVER and then returns:

    No DHCPOFFERS received.
    No working leases in persistent database – sleeping
    /bin/run-parts – -exit-on-error – -verbose /etc/network/if-up.d

    #48769
    Member
    Avatarseaken64

    It could be a bad router or access point. How old is the router? I recently had two routers go bonkers and replacing them fixed my problems.

    Also, I agree with Marcelo and you should try to connect without the security feature on, just to make sure you can connect. Also, try all the other security protocols supported by your router. If all else fails you can try a USB dongle, a known good one known to work with Linux, to connect to the wifi to confirm the router is not the problem.

    seaken64

    #48773
    Member
    XecureXecure

    This may lead to some more complicated troubleshooting.
    If you have time, could you post the output of:
    sudo dmesg | grep -i "wifi0\|wlan0\|hostap_pci"
    and
    iwconfig

    I understand you need to handwrite it, so if you don’t feel it is worth it, don’t worry. A possible solution for now may be using a USB wifi dongle (to replace the wifi functionality) or use ethernet connection (or even use your mobile phone to share the wifi connection).

    Based on the link of the debian wiki (provided by ModdIt): https://wiki.debian.org/hostap#Firmware
    It is mentioned the use of programs in the package hostap-utils (which is no longer available in Debian Buster).
    You may find you are luckier and can perform the tests described in antiX 17.

    For now, we will try to discover what firmware is being loaded and if we need to find ones more suitable for your wireless device by analyzing the dmesg output (if you wish to continue the investigation).

    Let us know if you want to continue exploring possible solutions. It will mainly require your free time (for testing and checking different possibilities and for waiting for answers), it can be a bit hard, and it could easily lead to a dead end, so don’t feel bad if you want to give up halfway. We will help when you need it (if we know how), and will try to demand little of you.
    So, if you are interested to continue exploring and see if we can learn anything from this device, let us know.

    #48782
    Member
    AvatarBruceW

    The router is almost new. I bought it in November of 2019.

    https://smile.amazon.com/gp/product/B01MAW2294/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

    I’ll have to check and see if I can get my router to accept the computer’s MAC address.
    I’m not going to change my password as I have several devices connected to my wifi router

    Here are the result of running sudo dmesg | grep -i “wifi0\|wlan0\|hostap_pci”:

    [ 22.879623] hostap_pci: Registered netdevice wifi0
    [ 22.879633] wifi0: Original COR value: 0x0
    [ 23.092066] wifi0: NIC: id=0x8013 v1.0.0
    [ 23.093062] wifi0: PRI: id=0x15 v1.0.0
    [ 23.093214] wifi0: STA: id=0x1f v1.4.2
    [ 23.096381] wifi0: defaulting to host-based encryption as a workaround for fi
    rmware bug in Host AP mode WEP
    [ 23.096385;: wifi0: defaulting to bogus WDS frame as a workaround for firmware
    bug in Host AP mode WDS
    [ 23.096387] wifi0: Warning: secondary station firmware version 1.4.2 does not
    seem to work in Host AP mode
    [ 23.098897] wifi0: Intersil Prism2.5 PCI: mem-0xf8000000, irq=11
    [ 23.099442] wifi0: registered netdevice wlan0
    [ 26.392546] prism2: wifi0: operating mode changed 3 -> 2
    [ 26.416459] wifi0: Linkstatus=2 (Disconnected)
    [ 26.416708] wifi0: Linkstatus: BSSID=00:20:e0:8f:a7:76
    [ 26.437715] wlan0: Preferred AP (SIOCSIWAP) is used only in Managed mode when
    host_roaming is enabled
    [ 26.438503] wifi0: Linkstatus=2 (Disconnected)
    [ 26.438749] wifi0: Linkstatus: BSSID=44:44:44:44:44:44
    [ 26.459721] wifi0: Preferred AP (SIOCSIWAP) is used only in Managed mode when
    host_roaming is enabled
    [ 26.460730] wifi0: Linkstatus=2 (Disconnected)
    [ 26.460930] wifi0” Linkstatus: BSSID=44:44:44:44:44:44
    [ 31.801543] networking: ifup wifi0
    [ 31.802005] networking:ifup wlan0
    [ 31.888447] wifi0: Preffered AP (SIOCSIWAP) is used only in Managed mode when
    host_roaming is enabled
    [ 31.889114] wifi0: Linstatus=2 (Disconnected)
    [ 31.909931} wifi0: Linkstatus: BSSID=44:44:44:44:44:44
    [ 31.925515] IPv6: ADDRCONF(NETDEV_UP): wifi0: link is not ready
    [ 31.935536] wifi0: Preferred AP (SIOCSIWAP) is only used in Managed mode when
    host_roamingis enabled
    [ 31.936274] wifi0: Linstatus=2 (Disconnected)
    [ 31.936497] wifi0: Linkstatus: BSSID=44:44:44:44:44:44
    Bruce@antix1:~
    $

    Here are the results of running iwconfig:

    wifi0 IEEE 802.11b ESSID:”g\xC6isQ\xFFJ\xEC\xCD\xBA\xAB\xF2\xFB\xE3F|\xC2T\xF8\x1B\xE8\xE
    7\x8DvZ.c3\x9F\xC9\x9A”
    Mode:Managed Frequency:2.412 Ghz Access Point: None
    Bit Rate:2 Mb/s Sensitivity=1/3
    Retry short limit:8 RTS thr:off Fragment thr:off
    Power Management:off

    wlan0 IEEE 802.11b ESSID:”g\xC6isQ\xFFJ\xEC\xCD\xBA\xAB\xF2\xFB\xE3F|\xC2T\xF8\x1B\xE8\xE
    7\x8DvZ.c3\x9F\xC9\x9A”
    Mode:Managed Frequency:2.412 Ghz Access Point: None
    Bit Rate:2 Mb/s Sensitivity=1/3
    Retry short limit:8 RTS thr:off Fragment thr:off
    Power Management:off
    Link Quality=0/70 Signal level=-73 dBm Noise level=-73dBm
    Rx invalid nwid:0 Rx invalid crypt:5543 Rx invalid frag:0
    Tx excessive retries:1 Invalid misc:5633 Missed beacon:0

    irda0 no wireless extensions

    eth0 no wireless extensions

    lo no wireless extensions

    Bruce@antix1:~
    $

    I think we can continue to try for at least a short time further. I really appreciate the help. Perhaps I need a dongle wifi card?

    • This reply was modified 1 month, 3 weeks ago by BruceW.
    • This reply was modified 1 month, 3 weeks ago by BruceW.
    • This reply was modified 1 month, 3 weeks ago by BruceW.
    #48783
    Member
    AvatarBruceW

    Sorry. I intended to insert a link to my wifi router, not a picture of it.

    Will the B-QUOTE fix that? Take the extra spaces out of the reference, below.

    http://www.ama zon.com/gp/pro duct/B01MAW 2294/ref=ppx_yo_dt_b_se arch_asin_title?ie=UTF8&psc=1

    #48784
    Member
    AvatarBruceW

    That should be an https link. Spaces are in amazon, product, B01MAW2294, and search.

    #48788
    Member
    AvatarBruceW

    I may have screwed up. I posted the results of sudo dmesg | grep -i “wifi0\|wlan0\|hostap_pci” and iwconfig, but now I don’t see them. When I try to add them back, the system says it’s a duplicate of what’s already there. Let me know if I need to add them back, again. I can do that fairly easily.

    • This reply was modified 1 month, 3 weeks ago by BruceW.
    • This reply was modified 1 month, 3 weeks ago by BruceW.
Viewing 15 posts - 1 through 15 (of 92 total)
  • You must be logged in to reply to this topic.