IBM ThinkPad A31p – wifi trouble

Forum Forums New users New Users and General Questions IBM ThinkPad A31p – wifi trouble

  • This topic has 92 replies, 7 voices, and was last updated Jan 5-6:27 pm by Xecure.
Viewing 15 posts - 16 through 30 (of 92 total)
  • Author
    Posts
  • #48792
    Member
    AvatarBruceW

    Now I can see my post with the outputs Xecure requested.

    #48794
    Member
    AvatarBruceW

    Thank you for the welcome to the forum, Marcelocripe. Xecure and Moddit have also made me feel welcome.

    By way of introduction, I am now 70 years old and retired from work. Unlike others my age though, I have used computers most of my adult life. I was once quite adept at using the DOS command line. I went through too many versions of MS Windows to recall. I also did some programming in MS Basic and converted a few complex programs from other versions of Basic. I bought the components for my two kids’ first computers and helped my kids build them. Now, I mostly use a 2015 13″ MacBook Pro, but have two Windows 10 computers, as well.

    My daughter is now an avid user of Unix. She likes Linux Mint, but I rapidly learned it exceeded the capability of my Thinkpad A31p. I tried Lubuntu, but didn’t like its limitations. That’s when I found AntiX. I had a few early issues with GRUB, but got those worked out.

    I really appreciate the help you are all providing to this newbee to Unix. Thank you very much!!
    Bruce

    #48796
    Member
    XecureXecure

    Thanks for providing the terminal output.

    I think we are closer to finding a permanent solution. At least I think we have identified the problem.
    In the dmesg output we can see:

    [ 23.092066] wifi0: NIC: id=0x8013 v1.0.0
    [ 23.093062] wifi0: PRI: id=0x15 v1.0.0
    [ 23.093214] wifi0: STA: id=0x1f v1.4.2

    Which tells us the firmware versions of the device.

    If the Debian wiki article is correct, the PRISM wireless chips do not use firmware files stored inside your hard drive, as other wireless devices do, but instead have their firmware files inside a flash storage beside the wifi chip.
    Based on the above mentioned article, Prism2 devices with STA (station) firmware v1.4.2 (your case) DON’T have capability to connect to Access Points with WPA security, and need at least firmware version 1.7.4 for that.

    If possible, please test creating (with your mobile phone, for example), a wireless access point with NO password (no protection), just to see if you can connect to it with your ThinkPad computer. My guess is that you will be able to connect and use the internet, proving your wireless device works but has trouble with WPA protected wireless connections.

    Updating/flashing the firmware requires a special program not available in the current Debian version used by antiX 19. Even if we found a way, the servers that hosted the other firmware files seem to be down (and I haven’t found one that works), so we are stuck in the step of not being able to even download the updated firmware files.

    We may be able to find something if we know the exact device ID for your wireless PRISM card. If you can also provide the output of:
    lspci -nn | grep -i "prism"
    or, if the above doesn’t show anything, the full output of
    lspci -nn

    If we are not able to find the firmware or able to update it, you may be better off with a wifi USB dongle. I think there are no longer any need for WEP protected wifi connections, as WPA2 is now the standard. No need for changing the router password for it works for all other devices, and only this ThinkPad is the odd one.

    #48799
    Moderator
    AvatarModdIt

    You could ask on the thinkpad wiki if anyone has the firmware to update your card.

    Maybe the better/easier way long term though, especially as you have a nice and rare device.:

    Look for a fitting mini PCI wifi card.
    I think you only need to pull the battery back a little, loosen one captive screw and remove the cover
    for access.
    Please steer away from Broadcom cards, I just bin them these days after too many issues.

    Maintenance manual is available in the net over the link I gave you.

    #48840
    Member
    marcelocripemarcelocripe

    I’m not going to change my password as I have several devices connected to my wifi router

    Bruce, Xecure knows a lot! If you don’t give up and keep returning with the information he needs, he will surely find a solution.

    My suggestion to decrease security and change the password was just to do some tests, then you would return to the current password.

    Xecure has already recommended another process where you will not need to change your router’s password. You need to make sure that your wireless network card can connect to a network, even if it is without any type of security. When connecting, try to check what frequency the smartphone uses, this information can be useful to use on the router.

    I went through a similar situation with Wi-Fi, where old devices struggled to stay connected to a new router’s wireless network. I needed to decrease security to test, after I managed to keep the connection to the wireless network a little more stable, I was testing each of the available frequencies, when the connection was stable I was able to enter a much more complex and secure password. Another issue that complicates the connection of some old devices is that if there are other Wi-Fi networks from the neighbors of nearby houses or apartments, where they all use the same frequency (channel) it becomes a “pollution” and a “dirty” network or overlaps the other.

    I hope you have checked whether your router has MAC Access Control enabled or not, once a colleague forgot to implement this security and spent a lot of time trying to connect to the wireless network. When I asked him about MAC Access Control, he almost cried with laughter, because that was the problem.

    You are in good hands, continue with Xecure. I just tried to collaborate with the little knowledge I have.

    I will continue to follow this topic in order to learn from this excellent teacher, called Xecure.

    Thanks.

    marcelocripe
    (Original text in Brazilian Portuguese)

    ———-

    I’m not going to change my password as I have several devices connected to my wifi router

    Bruce, o Xecure conhece muito! Se você não desistir e continuar retornando com as informações que ele precisa, certamente ele encontrará uma solução.

    A minha sugestão de diminuir a segurança e alterar a senha era apenas para fazer alguns testes, em seguida você voltaria para a senha atual.

    O Xecure já recomendou outro processo que você não precisará alterar a senha do seu roteador. É preciso ter certeza que a sua placa de rede sem fio consegue conectar a uma rede, mesmo que seja sem qualquer tipo de segurança. Quando conectar, tenta verificar qual é a frequência que o smartphone utiliza, esta informação poderá ser útil para utilizar no roteador.

    Eu passei por situação semelhante com rede Wi-Fi, onde dispositivos antigos tinham dificuldades para se manter conectados na rede de sem fio de um roteador novo. Eu precisei diminuir a segurança para testar, depois que consegui manter a conexão com a rede sem fio um pouco mais estável, eu fui testando cada uma das frequências disponíveis, quando a conexão ficou estável eu pude inserir um senha muito mais complexa e segura. Outra questão que complica a conexão de alguns dispositivos antigos é que se existirem outras redes Wi-Fi dos vizinhos de casas ou apartamentos próximos, onde todos utilizam a mesma frequência (canal) vira uma “poluição” e uma rede “suja” ou se sobrepõe a outra.

    Eu espero que você tenha verificado se no seu roteador está habilitado ou não o “Controle de Acesso” por MAC, uma vez um colega se esqueceu que implementava esta segurança e ficou muito tempo tentando se conectar na rede sem fio. Quando eu perguntei a ele sobre o “Controle de Acesso” por MAC, ele quase chorou de tanto rir, pois o problema era esse.

    Você está em boas mãos, continue com o Xecure. Eu só tentei colaborar com o pouco conhecimento que possuo.

    Eu vou continuar acompanhando este tópico para poder aprender com este excelente professor, chamado Xecure.

    Obrigado.

    marcelocripe
    (Texto original em idioma Português do Brasil)

    #48850
    Member
    AvatarBruceW

    Yes, I could temporarily change my password and then change is back. I’m going to try setting up my cell phone as a wireless access point. I’ve done that in the past with a different phone. Not sure if the software got transferred to this phone. I’ll check.

    #48857
    Moderator
    AvatarModdIt

    Please look for an updater package from debian sid.
    Sorry my information was unfortunately outdated.

    • This reply was modified 1 month, 3 weeks ago by ModdIt.
    • This reply was modified 1 month, 3 weeks ago by ModdIt.
    #48859
    Moderator
    Brian MasinickBrian Masinick

    Back up your system, then if you have an experimental nature, try it out.
    Before you do so, make sure to not only back it up; also make sure that the restored copy, (or whatever method you use to “recover” to a working state) actually “works” too.

    As long as you have a way to get back to a working system (or a couple of other options), sometimes “wrecking” something provides an “opportunity” to learn through practicing diagnosis, repair, or replacement. Only you know what you have time, effort, energy, experience and the patience to handle.

    Brian Masinick

    #48864
    Member
    AvatarBruceW

    I set up my cell phone as a hot spot with no security and tried again. When trying to connect via wifi0, I got the same error message message as before. Web browser confirmed no internet access. When trying to connect via wlan0, it wouldn’t even run until I removed the configuration for wifi0. Then it ran. This time, though, as it stepped through DHCPDISCOVER, it told me the port it was using with each test and it gave me the result after each test. Ultimately, it also bombed as before:

    No DHCPOFFERS received.
    No working leases in persistent database – sleeping
    /bin/run-parts – -exit-on-error – -verbose /etc/network/if-up.d

    Does this mean I need a wifi dongle or is there still a chance for a firmware upgrade?

    #48867
    Member
    AvatarBruceW

    Connman DID connect via my cell phone hot spot with no security! Whoopee!!!

    • This reply was modified 1 month, 3 weeks ago by BruceW.
    #48876
    Member
    AvatarBruceW

    Output of lspci -nn | grep -i “prism” is:

    02.02.0 Network controller [0280]: Intersil Corporation ISL3874 [Prism 2.5]/ISL3872 [Prism 3] [1260:3873] (rev 01)

    #48882
    Member
    AvatarBruceW

    Intersil is now Renesas.

    #48887
    Member
    AvatarBruceW

    Unfortunately, the links to firmware from https://wiki.debian.org/ appear to be broken. There are downloads available at https://packages.debian.org/sid/synaptic if we can figure out which one.

    • This reply was modified 1 month, 3 weeks ago by BruceW.
    • This reply was modified 1 month, 3 weeks ago by BruceW.
    #48890
    Member
    AvatarBruceW

    OK. I understand, Moddit.

    • This reply was modified 1 month, 3 weeks ago by BruceW.
    #48903
    Member
    XecureXecure

    Connman DID connect via my cell phone hot spot with no security! Whoopee!!!

    Well done. With this test we have confirmed that the wireless device works for unprotected wireless connection. The only problem is with protected connection. I think there is still hope.

    Thanks for the lspci output. It helped me find information on how different drivers worked on PRISM2/PRISM3.
    Now I am sure that this device needs firmware flashing.

    Based on this link: https://linux-hardware.org/index.php?id=pci:1260-3873-1260-3873
    This device accepts two drivers (orinoco and hostap_pci, which we already know works), but based on some research, the orinoco driver will never work with WPA2 protected networks, so it is not an option for us.

    I found a new link for one of the broken links in the Debian wiki: http://junsun.net/linux/intersil-prism/
    Unfortunately, the links to firmware files are all broken except for the private firmware collection of the website’s author.
    Based on their research, the best firmware for your case is version 1.8.2, as the 1.8.4 seems to have some bugs that lead to lost packets.

    I think that we could get to fix and flash the firmware with antiX 17.4.1 iso (live) and then return to your antiX 19 installation (and connecting to your router should work ater the flashing).

    I will post the instructions here, and will also try to create an ISO snapshot of antiX 17 with everything ready so you don’t need an internet connection to flash the firmware.

    Requirements:
    1. hostap-utils package installed (installable on antiX 17).
    2. Having a copy of the needed firmwares (can be downloaded from http://junsun.net/linux/intersil-prism/firmware/1.8.2/ )

    Installation steps:
    1. Open a terminal

    2. Navigate to the folder containing the firmware files using the cd command. If it is in the Downloads folder, for example, the command would look like this:
    cd "$HOME/Downloads/"

    3. Log in as root (password: root)
    su

    4. Run the next command to confirm that the old firmware is recognized:
    hostap_diag wlan0
    The output should look (similar to):

    Host AP driver diagnostics information for 'wlan0'
    
    NICID: id=0x8013 v1.0.0 (PRISM II (2.5) PCMCIA (SST parallel flash))
    PRIID: id=0x15 v1.0.0
    STAID: id=0x1f v1.4.2 (station firmware)

    5. Test to see if the downloaded firmware is compatible. For the 1.8.2 version, the command should look like:
    prism2_srec -v wlan0 PK010101.HEX SF010802.HEX
    and the output should tell you that the firmware is compatible (if it doesn’t, we have a problem. If you see any strange output, please let us know. We will try to help based on that).

    6. If the above output stated that the firmware was compatible, we will proceed with flashing the device to install the new firmware:
    prism2_srec -v -f wlan0 PK010101.HEX SF010802.HEX

    7. Wait until the flashing is finished. After it is done, we can check if the correct version was properly flashed:
    hostap_diag wlan0
    It should say, for the station firmware:
    STAID: id=0x1f v1.8.2 (station firmware)

    8. before we shutdown the live session and return to your installed system, let’s check that the wifi can now connect to your router from the live session.
    Control Centre > Network > WICD (I think this is the programs that shiped with antiX 17). A new icon should appear on the system tray. Click it and try to connect to your router.
    If it doesn’t work, not panic, as it may be a problem of the live session. We can power off the live session, remove the CD/USB and boot the installed session to see if wifi works with connman.

    If I am not able to build a snapshot for 17.4, or I am taking too long, you can follow the above steps from antiX 17.4 live (you need to have the firmware and packages downloaded to a separate USB to install them on the offline system or you need to connect to the unprotected mobile wireless connection you created and install the package with sudo apt update && sudo apt install hostap-utils)

Viewing 15 posts - 16 through 30 (of 92 total)
  • You must be logged in to reply to this topic.