iceWM keyboard shortcuts cannot be changed

Forum Forums New users New Users and General Questions iceWM keyboard shortcuts cannot be changed

  • This topic has 27 replies, 5 voices, and was last updated Aug 15-2:26 pm by serenity.
Viewing 15 posts - 1 through 15 (of 28 total)
  • Author
    Posts
  • #25561
    Member
    Avatarserenity

    I want to redefine some iceWM keyboard shortcuts and I tried redefining them in /home/User/.iceWM/preferences file via Control Centre>Edit IceWM Settings to NO avail. The changes do not take effect !!! Something overrides the keyboard shortcuts and current shortcuts defined in ….//.iceWM/preferences. They cannot be disabled by turning them into comments.

    As an aside right clicking on title bar in a window displays a slew of shortcuts that seem to be set in stone. Where are these shortcuts set? Can’t rox set keyboard shortcuts as well?

    There has to be a definition of global shortcuts somewhere.

    It’s wierd in that the shortcuts defined in preferences when changed do not take effect. It also seems that there are some shortcuts in preferences as well that do not even fucntion as defined.

    AntiX 17.4.1 Base space-iceWM

    Thanks in advance

    • This topic was modified 4 months ago by serenity. Reason: more info
    • This topic was modified 4 months ago by serenity.
    #25565
    Member
    AvatarBobC

    Did you restart IceWM (from the little arrow off the Logout button on the main menu) after saving your changes?

    Are the keys you used entered in the correct format?

    Are the keys you used being remapped by something else (like keys file or other program??

    #25605
    Member
    orka89orka89

    /home/User/.iceWM/preferences

    /home/User/.iceWM/keys ?

    #25606
    Member
    Avatarkernelpanic

    as orka89 already pointed out:
    there is another file called “keys” in your .iceWM folder.

    the file “preferences” only takes care of general key behavior, e.g.

    
    Win95Keys=1
        Support win95 keyboard keys (Penguin/Meta/Win_L,R shows menu).
    ModSuperIsCtrlAlt=1
        Treat Super/Win modifier as Ctrl+Alt.
    

    if you want to assign applications to special keys, use the “keys”-file.
    just follow the appropriate code of entries already there.

    #25609
    Member
    Avatarserenity

    I think i must have mistyped last post. Ok I used Control Center > Edit IceWM Settings and as a test I purposely commented out KeySyCollapseTaskBar=”Alt+Ctrl+h”
    into a comment. I then logout>Restart Session. After Restart Session I tested Alt+Ctrl+h and it no longer worked. So this poves that update process works. I think I got this sane result previously by using reboot but did not realize it since i was using a different shortcut as test.

    Anyway what I didn’t realize that I realize now is the following. It depends what key shortcut sequence you are changing to get an update. Some changes simply do not take hold.

    For example try keys: Alt+F10 and Alt+Shift+F10 you get same result which is maximize window. Alt+Shift+F10 is by default defined by IceWM as KeyWinMaximizeVert. You can verify this by query: sudo icewm –postpreferences in terminal. There is some sort of bug here. In fact half the shortcuts with Shift as a middle term do not work. Such is life.

    IF you can get Alt+Shift+F10 to do anything else but maximize window let me know. Something is intercepting the shortcut Alt+Shift+F10. It cannot be chnaged unless the source program or table that has a higher priority changes it.

    As an aside if you check the preferences file commands there’s a slew of commands that do not work. Some pgm and/or table has higher priority.

    Ok I leave up to you guys. Learned a lot about icewm. Not sure I wanted to learn this much.

    #25610
    Member
    Avatarserenity

    I only tested general keyboard behavior so only preferences applies.

    #25641
    Member
    Avatarskidoo

    you

    Due to differing hardware, differing keymappings, etc. other folks may not be able to reproduce your result

    icewm –postpreferences
    ^—— there should be no need to invoke sudo here.
    If you found it necessary to do so (due to permission denied without it), that indicates an errant file permissions scenario

    Possibly it’s a hardware problem ~~ your SHIFT key//keys are intermittently, or consistently, failing.
    Possibly it’s a keymapping problem.
    Try running the xev command. Press/release the leftShift key and note the result; repeat same for rightShift. Are the key events detected? If so, what scancodes are being emitted, and to those codes properly map to Shift keycodes?

    example output from the xev command:

    KeyRelease event, serial 36, synthetic NO, window 0x2e00001,
    root 0x4a8, subw 0x0, time 3633835325, (-1559,241), root:(144,689),
    state 0x1, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

    #25652
    Member
    Avatarserenity

    Boi this is work. Been reading up on scan codes and keycodes. My scancode seems incorrect it’s 41 on left shift supposed to be 2A. The key code of 50 is correct. The right shift is also incorrect with scancode of 41 supposed to be 36. The key code of 62 is correct.

    I’m intrigued why is your keycode 50? Isn’t 36 scan code for right Shift? Asking with my limited keyboard knowledge at best.

    Images of xev included.

    The computer that I am using is my test computer. It’s triple boot with AntiX. Linux Mint and MX 18.3. I am only having this kind of problem with Antix.

    I even changed keyboards to see what would happen; same result. From PS2 to usb keyboard.

    I am impressed with the combination of spaceFM and rox. Finally dumping windoze. I do not have email on linux yet so I had to copy screen shot onto usb and transfer that way to windoze. I used rox to do it. I will never move to win 10. I am now on win 7.

    I’ve been in and out of linux for years. Forget and remember. Remember and forget …… 🙂

    Just for the heck of it I tried the test with MX 18.3. The result is scan code 37 keycode 50 for left shift and scan code 37 keycode 62 right shift.

    I will try linux Mint 19.2 next.
    Linux Mint has same results as MX 18.3.

    The scan code does not make sense to me at this point. Both Linux mint and MX 18.3 use 37 as scan code which is not SHIFT. The interesting thing is that the key code is always correct.

    Well I ist exhausted.

    Attachments:
    #25655
    Member
    Avatarskidoo

    why is your keycode 50

    I don’t know why. I haven’t selected an alternate keyboard mapping
    (hmm, this machine has a 105-key kb, is the “standard” still 101 keys?)
    nor have I changed the system-wide locale.

    $ setxkbmap -query
    rules:      evdev
    model:      pc105
    layout:     us
    options:    grp:alt_shift_toggle,terminate:ctrl_alt_bksp,grp_led:scroll
    $ locale
    LANG=en_US.UTF-8
    LANGUAGE=
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=
    #25660
    Member
    AvatarBobC

    I had the same problem with Alt+Shift+F10 and I changed the key assignment for a number of keys that I couldn’t get to work on any of my keyboards to other keys.

    KeyWinMaximizeVert=”Alt+Ctrl+Up”

    Seemed to work nicely. I just unassigned the horizontal one.

    • This reply was modified 4 months ago by BobC.
    #25675
    Member
    Avatarserenity

    BOBC had already decided on your solution when I got xev suggestion. So I spent some time with xev and screenkey viewer programs. I am giving up on trying to find out cause. I must have spent 24+ hours on this. Becomes an obsession. Have to stop.

    All my needs are met per your suggestion so why bang my head against the wall?

    Here some obscure mouse shortcuts from reading various icewm sources on the intertubes :-):
    1) maximize horizontal window via SHIFT + double click middle button mouse on title bar of window
    2) maximize vertical window as SHIFT + double click left button on mouse on titel bar of window
    VOILA

    I have also defined keyboard keys per your suggestion.

    Any way learned a lot but mostly relearned find + xargs combinatio which are extremely useful comvbination and take a while to understad.

    For some reason on MX18.3 and Linux Mint everythihg seams to work shortcut wise

    I like the low PC requiremetns and speed of AntiX.

    Will reinstall AntiX. Who knows what I have done in trying to figure out cause of this problem. Simple changes to add back: keyboard shortcut and reduction of delay for boot counter in grub.

    Out for a jog.

    Thanks all.

    #25676
    Member
    AvatarBobC

    You might consider trying my other IceWM keys and preferences tweaks too. The recent ones are for the new version of IceWM that is included in the antiX 19 beta, but anticapjtalista provided instructions for upgrading the icewm alone on 17.4 if you want to implement those as well.

    I don’t use the mouse to it’s full ability, but if you post your list of tweaks, if they are useful and work for everyone, maybe they will get adopted in.

    BobC

    #25681
    Member
    Avatarserenity

    I really don’t have a list of tweaks. All I was interested in was Max vertical and Max horizontal as keyboard shortcuts. The mouse shortcuts that I mentioned was basically obscura like finding an antique somewhere. I found it interesting. It comes automatically with icewm.

    Anyway thanks all.

    #25713
    Member
    AvatarBobC

    What key did you choose for Max Horizontal?

    It wasn’t defined by IceWM or antiX, and since the other Alt+Ctrl arrow keys were already defined, and I didn’t see a big need for it, I left it undefined.

    #25722
    Member
    Avatarserenity

    I undefined ALT+CTR+h since I don’t need KeySysCollapseTaskBar as a shortcut. Doesn’t seem I would do this comamnd that often.
    And then I defined:
    KeySysCollapseTaskBar=0 #correct wierd problem in unique situation NOT necessary unless u literally duplicate my shortcuts but idea ist here

    KeyWinMaximizeHoriz=”Alt+Ctrl+h” #windows key+h Horizontal max window
    KeyWinMaximizeVert=”Alt+Ctrl+v” #windows key+v vertical max window

    One wierd thing that happened once with Alt+Ctrl+h. What I did initially was comment out KeySysCollapseTaskBar and define KeyWinMaxiniazeHoriz. it DID NOT WORK. So what I did was assign 0 (zero) to KeySysCollapseTaskBar and it then worked !!! But this only happened once.

    I was looking at the genesis version beta2 AntiXl ive without further updates:antiX-19.b2_x64-full.iso and was looking at your shortcuts. I checked one:
    KeyWinArrangeN=”ALT+Ctrl+KP_Up” which you have redefined and made live. It did not work for me. It used up arrow in key pad. Does it work? Of course I am looking at genesis version, u might have updated parameters.

    One more question. In spaceFM non-root mode you really can’t update a file by changing toroot within spaceFM itself unless you open a new instance of spaceFM as ROOT while in ROX you can actually switch to root to update file within non-root mode rox correct?

Viewing 15 posts - 1 through 15 (of 28 total)
  • You must be logged in to reply to this topic.