IceWM Start Menu Icons [Solved]

Forum Forums General Software IceWM Start Menu Icons [Solved]

This topic contains 23 replies, has 5 voices, and was last updated by noClue Jan 31-2:21 am.

Viewing 9 posts - 16 through 24 (of 24 total)
  • Author
    Posts
  • #18063
    Moderator
    masinick
    masinick

    Trump Tower? />

    LOL, probably true!

    Thanks, anti , not only for years of gracious work, but a great sense of humor as well!

    • This reply was modified 6 months, 3 weeks ago by anticapitalista.

    Brian Masinick

    #18075
    Member
    Avatar
    skidoo

    For these, the pseudocode governing the menu painting is like this:
    if item.selected == True
    paintBulletGlyph(); paintItemLabeltext()
    else
    paintItemLabelText()
    endif

    Aside from which resourcefile shall serve as the generic bullet(diamond) glyph,
    we have no opportunity to specify a custom icon here.
    .

    ref: src/ymenu.cc#L980
    .

    See? The generic “isActive” (aka menuselPixmap) pixmap resource is assigned in advance (not per-item),
    along with the fontface, the activeBgcolor, in inactiveBgcolor…
    .

    #18076
    Member
    Avatar
    skidoo

    Toward troubleshooting these, check:
    On devuan system, are the icons “missing” regardless which locale is selected?

    .

    .

    (to ruleout possibility ‘corrupt’ xpm file(s) or theme file)
    Try copying the theme+icon files from the known-good working system into the misbehaving system, then retest.

    #18173
    Member
    noClue
    noClue

    @ skidoo

    Thanks for still trying.

    One thing first: I know and understand a lot about design, UI/UX and about general Linux usage but, I am not Linux expert programmer being able to debug the broken programs.

    I’ve no idea on how to check if “the icons (are) “missing” regardless which locale is selected” on Devuan system. Any easy suggestion?
    (It wouldn’t help in actual usage if the icons would appear only in English or Chineese localization but, probably important only for your debugging.)

    Now what I know or can say about:

    1. Icons used should be fine. I did reverse test. I took a ‘virgin’ antiX 17.3.1 and did the (see the 1st screenshot: prepare_test_antiX.17.3.1.png) test.
    That left me with an antiX 17.3.1 in the following state:
    1. Without any icons or themes folders or sub folders in my home directory.
    2. Without the main icons folder (which got basically reduced to ‘highcolor’ and a couple of antiX Control Center and Shutdown icons).
    3. Without the icons or themes in /usr/share/icewm folder (with the exception of ‘Clearview’).
    4. Without /usr/share/pixmaps folder.
    What’s left is: the icons in Rox folder, Volume icons in their corresponding folder and one or the other icon ‘hidden’ in there own folders.
    With other words, no any usable icons are left. There are a couple in /usr/local/share which can be ignored for that matter.
    As you can see it on the 1st screenshot, that part worked well and there are no more icons shown in the start menu.

    2. I copied the icon set that I’m using in Devuan to the ‘broken virgin’ antiX 17.3.1 (as seen on the 2nd screenshot: execute_test_antiX.17.3.1.png).
    I copied the new icon set to /usr/share/icewm/icons and fixed the permissions (from some reason 644 doesn’t work, only 755).
    It worked like a charm and ‘my nightmare icons’ showed up as and how was expected.
    The icons used are fine.

    3. I copied the ‘known good’ icons back in to Devuans /usr/share/icewm/icons and fixed the permissions again. Everything works fine except those 8 ‘cursed’ icons.
    As you can see on the 3rd and 4th screenshot.
    On that 3rd screenshot (check-devuan-icewm-icons-1.png), one can also see the 2nd ‘proof’ that icons themselves are fine: ‘strange’ Debian menu (Utilities) is fully populated.

    Now the facts:

    4. I do not believe that the OS version, kernel or the OS localization has anything to with misbehaving icons but, just in case:

    devuan@devuan:~$ cat /etc/debian_version
    9
    devuan@devuan:~$ cat /etc/devuan_version
    ascii
    devuan@devuan:~$ uname -r
    4.9.0-8-amd64
    devuan@devuan:~$ locale
    LANG=de_CH.UTF-8
    LANGUAGE=
    LC_CTYPE=”de_CH.UTF-8″
    LC_NUMERIC=”de_CH.UTF-8″
    LC_TIME=”de_CH.UTF-8″
    LC_COLLATE=”de_CH.UTF-8″
    LC_MONETARY=”de_CH.UTF-8″
    LC_MESSAGES=”de_CH.UTF-8″
    LC_PAPER=”de_CH.UTF-8″
    LC_NAME=”de_CH.UTF-8″
    LC_ADDRESS=”de_CH.UTF-8″
    LC_TELEPHONE=”de_CH.UTF-8″
    LC_MEASUREMENT=”de_CH.UTF-8″
    LC_IDENTIFICATION=”de_CH.UTF-8″
    LC_ALL=
    devuan@devuan:~$

    5. IceWM / Rox versions used:

    icewm / icewm-common 1.3.8+mod+20161220-1
    rox-filer 1:2.11-1

    After reading things like:

    “Some brilliant fellow that think they know better broke optional argument options processing in getopt() in glibc.. …again. I happens about every 2 years.”

    https://github.com/bbidulock/icewm/issues/263 (I understand only ‘railway station’ about ‘glibc’, somthin’ to do with compilers …)

    If I search for ‘glibc’ in Synaptic, I don’t get anything shown as installed.

    Only glibc-doc, glibc-source, libdb1-compat and gftp-text are shown. The last two being DB compatibility files and ftp client. glibc documentation and sources are not relevant.

    6. The interesting question would now be: why the IceWM in antiX shows the icons andthe IceWM in Devuan not?

    Now, if I look around for different IceWM screenshots, then I find very, very often something like this:

    * https://www.bettertechtips.com/wp-content/uploads/2017/12/antiX.jpg
    https://www.ghacks.net/wp-content/uploads/2009/05/icewm_desktop.png
    https://celettu.files.wordpress.com/2008/05/icewm7.jpg
    http://marko.isfoundhere.com/images/my_desktop.jpg
    http://projects.fabiannowak.de/icewm/keramik1.png

    Sometimes but rarely, something like this:

    * https://vignette.wikia.nocookie.net/en.linux/images/b/bb/Antix.png/revision/latest?cb=20180519201930

    😉 🙂

    And never something as this:

    https://user-images.githubusercontent.com/10660264/44000496-ef2b80b6-9e20-11e8-98f9-b318c0fb0fa0.png

    So obviously, there mus be some way to get the icons show up and also, there must be some way to rearrange those menu different ways, alas, it’s out of ‘my scope’. 🙁 🙁 🙁

    Maybe the whole thing is just somewhere some ‘catch’ in the preferences file but, there’s a lot of text (options which one needs to understand) in there.

    If it can help, and since ‘I’m just toyin’ around’ for learning and better understanding, I could provide you my vBox VM, so you’d have ‘my problem’ 1:1 in your hands.

    Thanks!

    P.S.
    Did you notice that some links are were marked with ‘*’?

    How strange is to be anything at all. (Alice in Wonderland)

    #18223
    Member
    noClue
    noClue

    @ skidoo & anticapitalista

    Could you please provide me a direct download link(~s) to those .DEBs?

    Just to see what gives. They should work for Devuan. If they give some icons ?..

    P.S. If you have some other, NEWER versions, please give me those links too.

    Thanks!

    Attachments:

    How strange is to be anything at all. (Alice in Wonderland)

    #18226
    Member
    caprea
    caprea
    #18227
    Forum Admin
    anticapitalista
    anticapitalista

    icewm

    menu-icewm-antix

    Philosophers have interpreted the world in many ways; the point is to change it.

    #18231
    Member
    noClue
    noClue

    @ caprea & anticapitalista

    The problem was icewm / icewm-common 1.3.8+mod+20161220-1.

    Screenshots 1 and 2 shows you how the Start Menu icons (and different menu structure) look like with Ice WM 1.3.8.

    Screenshot 3 shows you how the Start Menu icons look like with Ice WM 1.4.2 (from the antiX repository).

    One ‘Linux mystery’ got solved, but we got another one …

    P.S.
    Please have a look at pnmixer volume icon.
    That’s for another thread. 😉

    How strange is to be anything at all. (Alice in Wonderland)

    #18247
    Member
    noClue
    noClue

    P.S. It doesn’t let me edit the title any more so, maybe one of the moderators could mark it as solved.

    How strange is to be anything at all. (Alice in Wonderland)

Viewing 9 posts - 16 through 24 (of 24 total)

You must be logged in to reply to this topic.