[Solved] .icewm startup file "not working"

Forum Forums Official Releases antiX-16 “Berta Cáceres” [Solved] .icewm startup file "not working"

This topic contains 4 replies, has 3 voices, and was last updated by PPC Jul 5-5:03 am.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #11238
    Member

    PPC

    Hi!
    I have Antix 16.2 instaled in my hd (I also use a live Antix 17.1 usb with root persistance) and my 16.2 OS started acting up…
    First some background about the situation: when I first instaled Antix 16.2 it refused to make my keyboard and screen resolution persistante between boots. I looked around the web and the foruns and ended up creating a startup file with this content:

    #!/bin/bash
    xrandr –output LVDS1 –mode 800×600 –output VGA1 –mode 1024×768
    numlockx
    setxkbmap -model pc105 -layout pt -option

    To be honest, the first line I don’t even remember why I put it there…
    the second line sets the resolution of my netbook inbuilt screen and the resolution for the external monitor I always use (I use this netbook as a “desktop” connected to external screen, keyboard and mouse).
    the third line sets numlock always on
    The fourth line sets the keyboard to my own language.

    Last week I noticed that when I booted to my 16.2 Antix I had to manually set the screen resolution and keyboard language… Today I tried to solve the problem. My “.icewm” folder did not have a “startup” file but a “startup.disabled” file with the same contents as above. I renamed it “startup.BAK”, created a new “startup” file with the same content and rebooted, but the problem still persists: I have to manually set screen resolution and keyboard language after each boot, either from the terminal or the Control Center.
    Any ideas about what happened and how to solve the problem?
    Thanks in advance for any input…
    PPC

    EDIT: Many thanks for que quick replies! Changing the “startup” file permitions to “Executable” solved the problem!

    • This topic was modified 4 months, 2 weeks ago by PPC.
    • This topic was modified 4 months, 2 weeks ago by PPC.
    #11239
    Member

    736b69646f6f

    no idea “what happened”. Possible fix: ensure the executable bit is set for the startup file, otherwise icewm will ignore it
    chmod +x

    #11241
    Forum Admin
    dolphin_oracle
    dolphin_oracle

    if you are booting one of the “min” options (like icewm-min) I think the startup files get disabled.

    #11245
    Member

    736b69646f6f

    aha! Found in /usr/local/bin/desktop-session script

    min_check() {
         if [ "$im" != "min" ]; then
             if [ -f "~/.$wm/startup.disabled" ]; then
                 mv ~/.$wm/startup.disabled ~/.$wm/startup
             fi
             launch_desktop & launch_desktop_pid=$! ;
         else
             mv ~/.$wm/startup ~/.$wm/startup.disabled
         fi
    }
    #11282
    Member

    PPC

    Hi! thanks for digging into my situation, even after is was solved (by you :-)). I don’t understand much about scripts, but I gather that this situation was caused by me testing out the “other desktops” from the menu… I normally use the Rox-ICEW desktop, but I tried them all a while ago, just to check their memory comsumption…
    If this comes up again, at least I know how to solve it. Once again, thanks…

    P.S.:
    I’m not even getting into why this netbook needs the startup file to indicate the correct keyboard language, when the same OS, in my home desktop computer did that out of the box without need to tamper with the startup… I always figured it was a little antiX bug, but I also thought it may scare away new users trying it out. Folks comming to Windows Xp, Vista or even 7 (I’m not really sure if they are a good part of antiX users or not) that want to keep their old PC’s with a supported OS are not used to their computer “forgetting” it’s choosen keyboard language and screen resolution.

    PPC

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.