I’m clueless on how get WiFi working on 32bit antiX19-full …

Forum Forums General Software I’m clueless on how get WiFi working on 32bit antiX19-full …

  • This topic has 91 replies, 12 voices, and was last updated Jan 21-9:14 am by gf.
Viewing 15 posts - 1 through 15 (of 92 total)
  • Author
    Posts
  • #30538
    Member
    Avatarmikey777

    Installing wifi on antiX 17.4.1 32bit was really cool with ceni.
    However, I’ve replaced this version with antiX19 32bit, but seem
    unable to get wifi up and running.

    Any help on how to setup wifi up on antiX19 is much appreciated.
    I did look through the forum, but couldn’t find anything on this.

    Many thanks for any help

    • This topic was modified 7 months, 3 weeks ago by mikey777.
    #30543
    Member
    capreacaprea

    What did you try until now ?

    control-centre > network > WiFi connman

    That will open connman system tray
    Go to “Status”, under Technologies look if WiFi is powered on, otherwise click to power on.
    Then go to “Wireless” ,look for your router and click on it. Then click on Connect. That’s it.

    Oh I forgot, the first time you have to type your password in the window that will appear, under passphrase.

    • This reply was modified 7 months, 3 weeks ago by caprea.
    #30576
    Member
    Avatarmikey777

    @caprea
    Many thanks for your reply.
    I tried Connman, GPRS/UMTS and WPA Supplicant Configuration, but without success.
    In my version of Connman, Technologies is under Status.
    Technologies shows only shows the Wired connection (Ethernet) and this works.
    When I click on the Wireless tab, the window that comes up is empty: clicking
    on Rescan doesn’t produce the usual list of wifi networks (including our own).

    The blue wifi indicator light at the front of the netbook is off – this is unusual as
    the default for this is on when other distros (including setup with antiX19-core) are running. Furthermore the Fn+F9 keyboard
    command, for switching the wifi indicator light on, doesn’t seem to work with antiX19.

    Thanks again for any further help with this – much appreciated

    • This reply was modified 7 months, 3 weeks ago by mikey777.
    • This reply was modified 7 months, 3 weeks ago by mikey777.
    • This reply was modified 7 months, 3 weeks ago by mikey777.
    #30601
    Forum Admin
    BitJamBitJam

    Since the wired connection works, you could try installing ceni and disabling the connman service. We use ceni on MX-19-core.

    You could also try connmanctl to see if that works. The version/wrapper in /usr/local/bin gives instructions on the commands you need to use inside of connmanctl (because I can’t remember them).

    You could also try:
    sudo rfkill list
    If wireless is available then this will tell you if it is software blocked or hardware blocked. The rfkill program can remove software blocks but not hardware blocks.

    Another approach would be to give us some more info about your system. If you wifi device is built in technically on the pci bus) then the output of this command should tell us more about it:
    lspci -k -d::280
    If not then try:
    lspci -k
    and see if there is an entry for a Wireless Network Adapter. If all of the above fails then the output of:
    inxi -F
    may be helpful. It may be helpful anyway. If you have older hardware then it is more likely that some support got dropped in newer kernels.

    Most likely the problem is one of the following:

    1) connman is broken for your wireless chip/device (use ceni)
    2) the kernel in antiX-19 is not working with your wireless chip/device
    3) your wireless chip/device is either software blocked or hardware blocked

    If (1) is the problem ten installing and using ceni should fix it. If (3) is the problem then rfkill should tell us and may be able to fix it. If it is hardware blocked then you may need to make a change in your BIOS. If (2) is the problem then most likely you will need to install a different kernel.

    Context is worth 80 IQ points -- Alan Kay

    #30605
    Member
    Avatarmikey777

    @BitJam
    Many thanks for your very detailed & helpful reply.
    You’ve given me a few things to think about – I’ll work on this again
    over the weekend and post the result back.

    #30727
    Member
    Avatargf

    Hello,
    Thanks to Mikey for posting this. I thought it was just me.

    I also have this problem on 32bit AntiX 19. I tried connman with no luck.
    My noticed my hardware switch (Function-F2) was off and I switched it on but that didn’t help.
    I tried ceni and wicd (without disabling the connman service, however) again with no luck.

    I thought the hardware was failing and reinstalled AntiX 17 to check. I am on 17 now, and wireless works fine with ceni.

    I will boot with a live DVD of AntiX19 and post the results of your commands above.

    I want to say thanks for the great distro, allowing me to love this little laptop a while longer. 🙂

    Take care and will post soon
    G

    #30739
    Member
    Avatarga77a

    hi all
    im also having a similar issue trying to connect to the internet via my smart phone (antix-64bit)

    #30742
    Member
    Avatargf

    Hello again,
    Attached is an .ODT document with the step by step on trying Connman to work in AntiX 19 32 bit, screen shots of the errors I got, along with some output from various terminal commands.
    Please let me know if there are any other commands you’d like me run, or steps you’d like me to take
    Happy to help get this fixed.
    Take care
    G

    #30744
    Forum Admin
    anticapitalistaanticapitalista

    Turn wired off, then try to connect wifi.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #30776
    Member
    Avatargf

    Thanks for the reply, anticapitalista.
    I tried it with same result.
    See attached Odt doc with screen prints and step by step for this try.
    Thanks again
    G

    #30779
    Member
    capreacaprea

    Just to be on the safe side,
    there was a user who had to type his password 4 times in a row before connman finally connected.
    http://www.antixforum.com/forums/topic/wifi-configuration/

    #30795
    Member
    Avatarmikey777

    Since the wired connection works, you could try installing ceni and disabling the connman service. We use ceni on MX-19-core….

    You could also try … rfkill program can remove software blocks but not hardware blocks.

    Many thanks for the tip with ‘rfkill’ which shows if it’s software and/or hardware that’s blocking wifi connection, just type the following in terminal and read the output for a diagnosis:

    $ rfkill

    In my case it was a software problem, and to unblock I typed the following in terminal:

    $ rfkill unblock all

    The ‘unblocking’ worked, as shown by running ‘rfkill’ again. I then installed ‘Ceni’, and was able to connect to wifi with this. However, with each reboot, I have to reconfigure the wifi settings, as they don’t appear to be saved between boots.

    • This reply was modified 7 months, 3 weeks ago by mikey777.
    • This reply was modified 7 months, 3 weeks ago by mikey777.
    #30821
    Member
    Avatargf

    Thanks for the ideas, Caprea and Mikey.

    rfkill did show a software block and I ran rfkill unblock all but I still get the same errors.

    Caprea, I can’t figure out how to put in the passphrase four times. I can’t get past the error messages after the first time I put my passphrase in.

    I have attached the results

    Thanks again everyone

    G

    #30874
    Member
    Avatarmikey777

    @gf
    You might be interested in this – it might work for you – I found a solution to the wifi problem, though it was on a slightly different setup.

    As well as the wifi problem, I had stability problems on my single-core Intel Atom netbook, with both JMW and IceWM window managers, that come prepackaged with both the antiX19-base and full editions. So in the end I set up antiX19-core with an LXDE desktop.

    With this new setup, I used wicd to connect to wifi – it worked really well!
    Make sure though that you tick the box next to the passphrase (=your network password) in the wicd setup window so that it automatically connects to your wifi network on booting, that’s if you want it set up like that.

    • This reply was modified 7 months, 3 weeks ago by mikey777.
    • This reply was modified 7 months, 3 weeks ago by mikey777.
    • This reply was modified 7 months, 3 weeks ago by mikey777.
    #30907
    Member
    Avatargf

    Thanks for the idea, Mikey. Yes, I like wicd as well and it has worked just fine in the past. I just tried out the latest (antiX-19.1-sid_386-core.iso) and it doesn’t seem to work on my notebook (I get kernel panic).
    Can you tell me which version of core you used?
    Thanks
    G

Viewing 15 posts - 1 through 15 (of 92 total)
  • You must be logged in to reply to this topic.