I’m clueless on how get WiFi working on 32bit antiX19-full …

Forum Forums General Software I’m clueless on how get WiFi working on 32bit antiX19-full …

  • This topic has 91 replies, 12 voices, and was last updated Jan 21-9:14 am by gf.
Viewing 15 posts - 76 through 90 (of 92 total)
  • Author
    Posts
  • #31620
    Forum Admin
    anticapitalistaanticapitalista

    ipw2200 should be supported out of the box since the firmware is installed on the iso.

    https://wiki.debian.org/ipw2200

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #31626
    Member
    AvatarModdIt

    @gf, would you please setup wifi and do sudo update-grub.

    A lot of things happen in the background with that command, saves a lot of settings
    re configures others. not all sure if it can help in your case but worth trying.

    please also give us contents of /etc/udev/rules.d persistent-net.rules
    if in Antix 17 wifi is working for you contents of same file on 17 would be nice

    #31628
    Member
    AvatarModdIt

    @ anti, use rgf states wifi is working but lost on reboot. The card or driver is not the problem.

    #31630
    Forum Admin
    anticapitalistaanticapitalista

    @moddit – are you sure since it seems to me that connman doesn’t connect at all.
    I suggest gf starts a new thread. Same with Cojos.
    This thread is too confusing.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #31631
    Member
    AvatarModdIt

    @ anti gf posted on January 11, 2020 at 3:56 pm
    #31596 in answer to Moddit post
    Just in case you are addressing me, wifi worked fine for me in AntiX 17.
    Then

    I can get wifi to work in AntiX 19 if I attach network wire, install ceni, disconnect network wire, remove connman,

    add the symlink for resolv.conf.

    Then, the wireless works. The problem then is that the symlink breaks when I reboot.

    If I could retain the symlink over reboots, I would be fine.
    As it is, after reboot I’d have to do the symlink again, then reconfigure my wifi in ceni again. That is a hassle. In version 17 it worked just fine.

    This might be an issue killing wifi in other cases too. No link to resolv config, he is able to set it manually losing on reboot.
    Agree this thread is long but feel a new thread might need to be started by each individual with wifi problems
    to stop confusion.

    #31632
    Member
    AvatarCojos

    Ho yes, it is your self I am addressing, (Irish slang) many thanks for your response, yes it is a nuesense getting this to work, even worse when it drops off on you without explanation which happend to my when I was on Linux Mint, no hrlp from anyone then.
    Cojos

    #31633
    Forum Admin
    anticapitalistaanticapitalista

    @moddit – yes true, but connman should also work without issues (after configuration).

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #31634
    Member
    AvatarCojos

    Am I sure, no I am not. Too many wild goose trails for me.
    Cojos

    #31635
    Member
    AvatarCojos

    Hi G, Like you I came to linux when XP died and strait into Mint, which was great for a while, I knew there was a problem when Getting on line became too hit and miss.
    I stayed with Mint for a while, but realised there was other problem when nobody on the Furum wanted to mention what it was that caused the problem.
    I then started with MX linux which was also great, but the fall off started again. I then installed AntiX and it set up the wi fi without a problem.
    I cannot give you dates, because I spent whatever time I had trying to get it to work. And here we are!
    Cojos

    #31636
    Member
    AvatarModdIt

    @ anti trouble with should work is that user has been trying to get consistently working wifi for nearly one month.

    he was not able to get wifi working with connman.

    He can get wifi to work using ceni but loses it (wifi) upon reboot.

    So accepting the information he gives us, the issue is not due defective hardware.

    To get wifi working he sets a symlink which disappears on reboot along with wifi.

    Is the missing symlink the problem. Maybe. Why does it disappear Link set in a temporary file system ?.

    To see if that is the issue, is it possible to point ceni straight to resolv.conf

    I would like to compare content of /etc/udev/rules.d persistent-net.rules with 19 against 17
    where wifi works.

    same output of iwconfig which might give clues.

    Neither of us have the same hardware as the users so troubleshooting is not so easy.

    #31638
    Member
    Avatargf

    OK everyone, I will start a new thread – Thanks.
    See you on the new thread. I have reinstalled antiX 17.3.1 and will post the results there.

    Take care
    G

    #31642
    Member
    Avatarsemicynic

    I’ve put it all together for you and any else having trouble with 32bit connman.

    32bit antix-19-full connman

    Here is what I did to get wifi working booting from live usb on my eeepc901 netbook with atom CPU. It took several days of trying different approaches to succeed. I’ve given parts of this in response to gf but here it is for any other 32bit users.

    I 1st tried going to controlcenter-→network>connman.
    Didn’t work.
    I tried lspci in a terminal and was surprised and very confused to see that my ralink PCIe network controller wasn’t listed even tho it was with 32bit antix-17.4. Went back to connman gui and fumbled around until I found how to make the ralink visible. Progress. I then tried to go thru gui connman procedure but it hung after I entered passphrase. I could not figure out how to make that work.

    So I went back to terminal to see if that might work. I gave command
    connmanctl technologies
    This showed that I had ethernet, wifi, and bluetooth. Correct!
    Not only that but it gave a list of subcommands used to connect, but unfortunately not in the correct order. I list proper order inline.
    Next gave command
    connmanctl
    and it returned connmanctl>
    and waited for subcommand
    Below is order for subcommands and the replies. I’ve included error attempts.

    connmanctl>enable wifi
    Enabled wifi
    connmanctl> scan wifi
    wifi scanned
    connmanctl> services
    <mywifi> wifi_0022435c6bd5_6465637265706974_managed_psk
    … do not use <mywifi> later, only the string you need that starts with wifi and ends with managed_…
    connmanctl> agent on
    Agent registered
    connmanctl> connect wifi
    Error /net/connman/service/wifi: Method “Connect” with signature “” on interface “net.connman.Service” doesn’t exist
    connmanctl> wifi_0022435c6bd5_6465637265706974_managed_psk
    Error ‘wifi_0022435c6bd5_6465637265706974_managed_psk’: Unknown command
    connmanctl> connect wifi_0022435c6bd5_6465637265706974_managed_psk
    Agent RequestInput wifi_0022435c6bd5_6465637265706974_managed_psk
    Passphrase = [ Type=psk, Requirement=mandatory, Alternates=[ WPS ] ]
    WPS = [ Type=wpspin, Requirement=alternate ]
    Passphrase? ******************
    Connected wifi_0022435c6bd5_6465637265706974_managed_psk
    connmanctl> quit
    demo@antix1:~

    Now you can see activity in conky or bottom panel, and use browser.
    You don’t have to ControlCentre–>Network–>connman at all if timezone,date,time are correct, just do CLI as above
    I don’t know if 64bit has connman problem too.

    I hope this helps.

    #31646
    Member
    Avatargf

    New thread for gf’s wireless problem is:

    “Connman wireless not working in antiX 19.1 Full 32-bit”

    under Software forum.

    Thanks
    gf

    #31647
    Member
    Avatargf

    Moddit – regarding MX, my notebook is non-pae and I believe that MX 32-bit needs pae. Thanks for the idea. : ) G

    #31651
    Member
    ileile

    Hello gf
    32bit iso. Live-Kernel-Updater choose a non-pae kernel. Follow steps to remaster and switch kernel, for a non-pae live usb using antiX tools.

Viewing 15 posts - 76 through 90 (of 92 total)
  • You must be logged in to reply to this topic.