Image too big for the screen (overscan?)

  • This topic has 10 replies, 4 voices, and was last updated May 2-8:26 am by mauriciomunuera.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #35355
    Member
    mauriciomunuera

    Hey there!
    I’ve been using antix for a few days and loving it. Tried a dozen distros on my netbok and this one was the best by far. (also, being brazilian, I really appreciated the homage to Marielle Franco).
    The only problem I have is with the screen. The image is too tall for the screen, so the bottom part of the image is cut off.
    I think it’s called overscan when it happens on a TV, but I’m not sure it’s the term applies here.
    Already tried every suggestion I found on google and here, but none of them made a difference (perhaps I’m skipping a step somewhere, I’m not sure).
    The resolution 1024×768 is just not the right aspect ratio for this monitor. On windows I used 1200×800 or something like that, but on linux 1024×768 is the only option for now.

    It’s a netbook from around 2008 with a 1.2GHz VIA C7 processor and 512Mb of RAM. The graphics are:
    Device-: VIA VX800/VX820 Chrome 9 HC3 Integrated Graphics
    vendor: QUANTA
    driver: N/A
    bus ID: 00:01.0
    Display Server: X.org
    driver: openchrome
    unloaded: modesetting, vesa
    tty: 80×25
    Message: advanced graphics unavailable in console. Try -G –display

    resolution: 1024×768~60Hz
    OpenGL rendererL llvmpipe (LLM 7.0 128bits) v: 3.3 Mesa 18.3.6

    I already modified SO MANY things that I don’t even know what I did anymore and will probably have to format and reinstall the system once I figure out how to do it properly.

    I’m sorry, I know this topic has been discussed a lot, but I really need a little bit of guidance.

    #35356
    Forum Admin
    anticapitalista
    Helpful
    Up
    0

    Welcome!

    Does this help?

    how-to-make-openchrome-driver-work-with-antix-19/

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #35404
    Member
    mauriciomunuera
    Helpful
    Up
    0

    Thank you!
    I tried that one, but it didn’t work 🙁
    Then I thought “it’s an older computer, I should try an older version of the OS”, so I installed the Antix17 and everything just worked perfectly!
    No idea what’s the difference between them, but everything works now.
    The system feels a bit slower with 17, so I’m thinking about upgrading to 19. Maybe it will keep the drivers and the configuration that made it work… does it make sense?

    #35405
    Forum Admin
    anticapitalista
    Helpful
    Up
    0

    It is probably the new xorg in 19 that your old box doesn’t like so upgrading from 17-19 probably won’t solve the problem.
    Plus it is a very big upgrade.

    Still, if you have time and patience (and remember it might not work in the end) give it a go.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #35407
    Member
    mauriciomunuera
    Helpful
    Up
    0

    I might try it later today, but it’s workig well with 17 so I might keep it if it requires too much effort to make 19 work.

    Oh! One more question, I don’t know if I should create a different post for it… is there a way to boot straight into the terminal, and only lauch the desktop when I want to? Kind of like using MS-DOS and Windows 3.1, you know? Because the antiX-cli-cc is perfect for most of the things I want to do on this micro.

    #35408
    Forum Admin
    anticapitalista
    Helpful
    Up
    0

    You can boot into level 3 (no Xorg) by adding a 3 to the grub menu list.

    If you then want to get to desktop, after logging in as user, don’t use startx but

    startx /usr/local/bin/desktop-session rox-icewm

    (if you use rox-icewm)

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #35409
    Member
    mauriciomunuera
    Helpful
    Up
    0

    Perfect! Thank you so much.
    I love how much you can tailor linux

    #35410
    Member
    Xecure
    Helpful
    Up
    0

    If you have no other graphic problems in antiX 19 except for the resolution problem (you have no screen tearing, no ghosting images, etc) after following anticapitalista’s instructions, you could try to simply add the resolution option using xrandr.

    I have a troublesome external monitor which has a higher resolution than what antiX (and other linux systems can detect), so I have a little script I execute when I connect this monitor. You could set this little script to execute at startup, but before that you should test if this solution works for you.

    0. Open a terminal emulator

    1. First you need to know the device’s output port. I imagine it is LVDS or LVDS-1, but you better check it yourself
    xrandr -q

    2. Now that you know the device output port, you can generate a modeline (the instructions for the resolution you want to use). Your post suggests you should be able to use 1200×800 at 60Hz (please make sure of this). Using cvt, you can generate this modeline:
    cvt 1200 800 60
    It should give you something similar to:

    # 1200x800 59.86 Hz (CVT) hsync: 49.74 kHz; pclk: 78.00 MHz
    Modeline "1200x800_60.00"   78.00  1200 1264 1384 1568  800 803 813 831 -hsync +vsync

    The important info is in the modeline.

    3. Next step is to create this new mode with xrandr. Using the modeline information, it should be similar to:
    xrandr --newmode "1200x800_60.00" 78.00 1200 1264 1384 1568 800 803 813 831 -hsync +vsync

    4. Now you can add this mode for your monitor using xrandr and the output port information we got in step 1:
    xrandr --addmode LVDS-1 1200x800_60.00
    For this example I have used LVDS-1 as device output port. You should use the one xrandr has identified on step 1.

    5. Set this mode using xrandr instruction.
    xrandr --output LVDS-1 --mode 1200x800_60.00
    You could also use arandr to select the resolution, as it will now appear as an option.

    If this works for you and you have no graphical problems, you could add all instructions to a script and execute it on startup.

    Whatever you choose, let us know how it goes. antiX 17 will work perfectly and will have support for two more years, so you are good for a while.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #35411
    Member
    mauriciomunuera
    Helpful
    Up
    0

    Awesome, I’m going to try that!
    I tried something similar with the xrandr, but the only option it gave me was 1024×768 and it wouldn’t allow me to create the new mode.

    #35414
    Forum Admin
    rokytnji
    Helpful
    Up
    0

    I used to just cheat on my acer 701sd screen and use alt + left click to move windows till I could see buttons.

    Beat the heck out messing with drivers or xorg settings.

    Sometimes I drive a crooked road to get my mind straight.
    Not all who Wander are Lost.
    I'm not outa place. I'm from outer space.

    Linux Registered User # 475019
    How to Search for AntiX solutions to your problems

    #35524
    Member
    mauriciomunuera
    Helpful
    Up
    0

    The biggest problem with the Alt+click was the menus, they would extend past the bottom of the screen and I couldn’t access the options that were there.
    But now it’s all working well with the Antix 17 🙂
    Thanks for the help, guys!

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.