[Solved] Incorrect Time in Hyper-V VM

Forum Forums New users New Users and General Questions [Solved] Incorrect Time in Hyper-V VM

  • This topic has 0 replies, 1 voice, and was last updated Nov 16-4:29 pm by Joo Yin.
Viewing 1 post (of 1 total)
  • Author
  • #123721
    Joo Yin

      Hi! I did try to search the web and forum for answers before posting. It looks like installing NTP might be an option, but I want to ask for official solutions here first before I begin experimenting (aka breaking stuff).

      I’m running Windows 10 Pro.
      My installation is antiX 23 x64 Base in a Hyper-V virtual machine. I’ve got it set up as a recursive Unbound Pi-Hole for the rest of my home network and that’s all it does.

      I don’t remember if I set antiX to UTC or local time when I installed it, but the output of “sudo hwclock –verbose” is attached.

      There’s no hardware BIOS/CMOS or RTC since antiX is running in a VM.

      What can I do to get antiX to automatically sync the time after each reboot? Using “Control Centre -> System -> Set Date and Time -> Use Internet Time server to set automaticaly time/date” works, but only until the next reboot.

      The timezone is already set correctly: US – Central

      It’s not just the hours that are wrong after a reboot; the minutes are too. The amount that the minutes are offset after a reboot seems to be completely random. Of course, the hours are offset too, but I assume that is due to some sort of UTC vs local time issue.

      Thank you for all the assistance you provide. It is much appreciated.

      Edit 1: I found this thread here:
      It gave me the idea to set “” as my timeserver in Connman and edit “/var/lib/connman/settings”:
      Let’s see how this works out. I’ll report back after awhile with my results.

      Edit 2: This thread also has similar information:

      Edit 3: Setting a timeserver in Connman and editing “/var/lib/connman/settings” seems to have fixed the problem. I’m marking this thread as “solved”.

      • This topic was modified 2 weeks, 1 day ago by Joo Yin.
      • This topic was modified 2 weeks ago by Joo Yin.
      • This topic was modified 2 weeks ago by Joo Yin.
    Viewing 1 post (of 1 total)
    • You must be logged in to reply to this topic.