Inputting Username/Password with Ceni

Forum Forums New users New Users and General Questions Inputting Username/Password with Ceni

This topic contains 3 replies, has 4 voices, and was last updated by afghan Sep 13-1:53 am.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #27062
    Member
    Avatar
    LactoseTolerant

    Hi all,

    I would like to use Ceni rather than Wicd, and better than both would be to just have the WiFi running when the computer turns on. I am trying to log on to Ceni at work, but there is no option to select WPA2. Only WPA which only allows me to put in a password, not a username. How do I fix that?

    Wicd’s OK but won’t connect half the time and it’s annoying to keep the window open in order for it to run.

    #27072
    Member
    Avatar
    seaken64

    I’m not sure. But I have noticed in my own experience that Wicd sometimes needs to be run twice. Sometimes it doesn’t take until after second running.

    Seaken64

    #27074
    Member
    caprea
    caprea

    Sorry can’t help you with ceni , but
    your problems with wicd may be caused by the wicd-daemon not autostarting properly.
    It’s easily fixed.

    https://www.antixforum.com/forums/topic/errors-when-updating/#post-18143

    #27088
    Member
    afghan
    afghan

    If you don’t mind roaming manually (which is what I usually prefer) rather than having it connect promiscuosly to whatever AP your wlan interface finds, especially those unsecured ones which may be unsafe. On my notebook which I normally use at home connected to my home wifi, I put in my /etc/network/interfaces the following:

    ## This connects automatically to home wifi if available
    allow-hotplug wlan0
    iface wlan0 inet dhcp
        wpa-ssid "home wifi"
        wpa-psk "home passphrase"
    
    ## Work wifi. Connects manually
    iface office-wifi inet dhcp
        wpa-ssid "office wifi"
        wpa-psk "work passphrase"

    My notebook will connect automatically upon startup if wlan0 finds my “home wifi”. Otherwise it will not connect to anything.
    If you wish to connect to your office wifi then issue the commands:

    sudo ifdown wlan0; sudo ifup wlan0=office-wifi

    You can test you network settings without restarting by:

    sudo /etc/init.d/networking restart

    You can add as many logical interfaces like “office-wifi” and give them memorable names. I’ve not had good experience getting ceni, wicd, wpa_cli/gui or connman to work consistently. This way is the simplest and most reliable for me.

    Note that my wireless interface is wlan0, which may be different from yours.

    I know I'm not myself sometimes..., but I don't know when I'm myself always.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.