[SOLVED] Install Epson Lx 300+ printer

Forum Forums General Hardware [SOLVED] Install Epson Lx 300+ printer

  • This topic has 9 replies, 5 voices, and was last updated Apr 7-1:24 pm by Neo78.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #56578
    Member
    Neo78

    The system does not automatically recognize the Lx-300 + printer, I use Antix 19.3 on an old dual core with 2 gigs of Ram, it works fine for me but it does not recognize the printer automatically.

    !Please Help!

    #56580
    Moderator
    caprea
    Helpful
    Up
    0
    :D

    Is this live or installed ? On a live-system the cups service is disabled by default.
    sudo service cups start

    Did you look in control-centre > hardware > printersettings ?
    What did you try until now?

    #56593
    Member
    seaken64
    Helpful
    Up
    0
    :D

    Have you used the Epson printer on Linux before? It probably requires a driver. Have you checked the Epson website for a driver?

    seaken64

    #56601
    Member
    afghan
    Helpful
    Up
    0
    :D

    I have an EPSON LQ-300+ which is a 24pin version of the LX-300+. There is a PPD file for this printer nowadays so I use that. Try looking for a PPD file the LX-300 series.

    Before somebody made the PPD file for the printer, I used the Epson generic 24pin driver. It works fine, so I strongly suspect that the generic Epson 9pin driver will also work fine for your printer. Just don’t expect fancy features – it’s a simple dot matrix printer after all. I use mine mostly for printing out code listing for debugging (yes I’m old school) and backup (yes a hardcopy is the most reliable backup).

    Good luck.

    Beware of people who knows nothing; they are the ones that won't know that they know nothing.

    #56654
    Moderator
    ModdIt
    Helpful
    Up
    0
    :D

    Getting a driver for older printers is on occasion tricky. Hit me with a Tally 9330 laser.

    In most cases the PPD is included in the printer specific windows driver installer exe. Unpack the executable and you can add the
    ppd for your printer to cups from the web interface on localhost:631.
    Rename the exe to .zip in most cases it will unpack far enough to access the ppd.

    #56684
    Member
    Neo78
    Helpful
    Up
    0
    :D

    Thank you very much for all the comments, I am using the live mode, so I did not know that the possibility of printing was disabled, I will try with sudo service cups start, to see what happens, it is not possible for me to download the linux diver from the epson page also my internet connection is very slow and it takes me a long time to do a sudo apt update especially from live mode.

    I live in Cuba.

    Thanks for the answers. Very good job. Antix works very well for me on my old machine.

    I use it daily very fast.

    Greetings.

    #56685
    Member
    Neo78
    Helpful
    Up
    0
    :D

    Thanks for your answer, could you give me more details about that procedure?
    Greetings.

    #56690
    Moderator
    ModdIt
    Helpful
    Up
    0
    :D

    Neo78, guess Epson main site is blocked for you because of USA Embargo. I am not a fan of those kind of politics.

    Just did some more testing, the epson install exe file will not unpack, that is a first time problem for me.

    You will need to experiment as I do not have same printer to use to find all steps perfectly.
    Open Printing.org states that the IBM Pro PPD will work with your printer.
    You will probably need to download the PPD from http://openprinting.org/printer/Epson/Epson-LX-300plus

    Connect your printer and switch it on
    Boot your computer and login.
    start cups: sudo service cups start

    Enter localhost:631 in Browser, press enter to reach cups interface.
    Go in to adding printers and classes, check if your printer is detected by cups, it should be,
    look for IBM Pro entry, (if not already present) you will need to import the PPD yourself.

    If you are still stuck please give us more details of what you need. We will do our best to get
    your system working smoothly.

    #56694
    Moderator
    caprea
    Helpful
    Up
    0
    :D

    antiX-live always starts with some services disabled by default,
    the boot-params are disable=lxF

    On a bios-boot you should see them on boot screen
    on a uefi-boot you have to press the e-key

    if you delete the l, the cups service should start on boot

    But
    sudo service cups start
    should work, too.

    got a pm from the OP,accidentally I guess

    Thank you for your reply, Yes I use Antix in live mode, I thought it will automatically detect the printer, but it did not happen so I tried to add it through the control panel but it does not work.
    Thanks greetings.
    #57212
    Member
    Neo78
    Helpful
    Up
    0
    :D

    Problem solved, thanks for the answers to all.
    Greetings.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.