[solved] Install trouble

Forum Forums Official Releases antiX-21/22 “Grup Yorum” [solved] Install trouble

  • This topic has 48 replies, 13 voices, and was last updated Jan 22-8:52 pm by roland.
Viewing 4 posts - 46 through 49 (of 49 total)
  • Author
    Posts
  • #75774
    Member
    roland

      I managed to try cli-installer, it warns on the intro that it does not support UEFI booting nor separate boot partition, but I ran it anyway, it finished ok, but the reboot failed to find any copy of antiX. Not really surprising as grub was written to the MBR not the EFI partition.

      I also ran christophe Grenier’s HD analysis and partition recovery routine, it located some cylinders that seem to be corrupt. I’ll try Linux-daddy’s suggested badblocks search next.

      It’s looking as if the HD is damaged. It has not done very much work and is not very old. I shall have to read up on how to set up persistence and run it from a large fast USB stick.

      #75781
      Forum Admin
      anticapitalista

        Latest version of cli-installer does install on a UEFI partition.
        As I said before, make sure you update the gui and cli installers BEFORE trying to install.

        Philosophers have interpreted the world in many ways; the point is to change it.

        antiX with runit - leaner and meaner.

        #75819
        Member
        madibi

          I cannot install any current release of antiX on this Acer Aspire small laptop, having recently tried with 17, 19 and 21. The install procedure usually fails processing the device, either attempting some partition format or simply hanging endlessly. I can run from a memory stick which is what I am doing right now using the very latest release 21 recently downloaded.

          simply because you cannot! In fact the kernel wont load.

          I discovered this problem some years ago. First I owned an Acer EEEpc, and with that machine I could install a distro and boot it from an sd inserted into the slot.
          With aqnother ACER, expire 5732z, I couldnt.With my asus neither.

          The solution is to use plopkexec.

          I did it and for a certain period I could load a linux distro from my ssd slot.

          I learned that in 2 steps:
          the 1st (the worst) to create a boot cd that let me start from the mmcblk0p(x) slot.
          the 2nd one (not easy for my low level of understanding), that I did in some days of try and then was successful, is to personalize some parameters both of your installed distro on the ssd and your grub: http://www.plop.at/en/plopkexec/full.html

          Some job is waiting from you 🙂

          I discovered this gui because I had an old pc that was not booting from the usb ports, and with another little program from him (the plop tool) that fits in a 1 Mb floppy, I could do the job

          #75838
          Member
          roland

            This marathon is solved !! I now have a new working install of Manolis Glezos 19.3 on this laptop, which at present I prefer to Grup Yorum 21, as I am still finding odd things 19.3 offers that 21 as yet does not.

            I have to thank all of you contributors, but most of all anticapitalista, whose advice and suggestion to run the install using cli-installer AFTER making sure the installer was updated. I ran a general update with apt update then apt dist-upgrade, and requesting grub to be installed on the efi partition, all went just as he said it should and I now have this troublesome little laptop back in working order with all the advantages that the step up from 17 to 19.3 offers. And I have my root swap and home partitions where I wanted them, and grub in the efi partition.

            The question remains, what does the cli-installer know that the graphical installer doesn’t ?

            It just shows what a fine community of users experts and enthusiasts we have in this forum, so thanks once more to all of you, and especially to anticapitalista !

            Best wishes, and sorry from me for my being so slow and stupid at times !!

            • This reply was modified 2 years, 4 months ago by roland.
            • This reply was modified 2 years, 4 months ago by roland.
          Viewing 4 posts - 46 through 49 (of 49 total)
          • You must be logged in to reply to this topic.