Installer Doesn’t Exist or Doesn’t Work – antiX 19.3

Forum Forums New users New Users and General Questions Installer Doesn’t Exist or Doesn’t Work – antiX 19.3

Tagged: 

  • This topic has 3 replies, 3 voices, and was last updated Jan 9-4:23 pm by scmm.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #49393
    Member
    scmm

      I am trying to install antiX 19.3 from a live USB stick into a dual-boot system on a new SSD. The USB stick boots with no issue, but

      (a) there is no icon for the installer on the desktop,
      (b) when I select the installer from the right click menu, the installer shows up on the taskbar but doesn’t open on the desktop; it also hangs, and
      (c) when I try to run it from the cmd line (su-to-root -X -c minstaller, IIRC), it hangs at Exit 29, after showing the disks under the headings “Name Size Model FS | isDisk isGPT…”

      I … can’t figure it out. I’ve used Rufus to create the live USB, I’ve tried the antiX full, antix base, and even antix 386 (instead of 64). I’ve tried the live USB on two different computers (both Lenovos), and no joy. When I use the same method on mx-linux 19, the installer does show up on the desktop, and clicking it opens it up to begin the install process. Same for Mint.

      I’m not adept with Linux, but I’ve been using antix 15 since whenever it came out (and I loved it), and really would like to upgrade to 19.3 (which I really like on the USB). I feel like I must be doing something very stupid, but I’ve looked around a fair bit and can’t figure it out. Any help is much appreciated.

      #49395
      Member
      Xecure

        A) When booting from Rufus, do an MD5sum (checkmd5 boot parameter) and filesystem check (checkfs boot parameter) to make sure that the antiX live system is OK.
        B) If this goes OK, try booting with toram boot parameter so that we can discard bad USB connection.[You need at least 2GB RAM).
        C) Provide from the live system the terminal output of:
        inxi -Fxz
        Also, is the SSD a Sata SSD, M2 (nmve or sata) drive? You give no info related to this.
        D) Try it again with a different USB. It may be the first one has problems.

        E) Hopefully this is not Rufus related. Could you perhaps create the Live USB with a the MX Live USB maker? Let’s leave this for later, though.

        antiX Live system enthusiast.
        General Live Boot Parameters for antiX.

        #49404
        Anonymous

          yeah longwinded, I can’t resist…

          when I try to run it from the cmd line (su-to-root -X -c minstaller, IIRC)

          su-to-root -X -c minstaller

          First, there’s a typo (er, “mis-remembered” name of the installer executable)

          Second, if you inspect the /usr/bin/su-to-root script, you’ll notice that
          su-to-root -X
          always passes through to gksu. So… why not just call “gksu minstall” directly?

          consider: What is gksu? What is the purpose and function of gksu?
          Some folks presume it, or the “sudo” command, solely represents “a way to gain elevated privileges”.
          -=-
          Other folks point out “gksu is needed when launching graphical programs, to preserve your $HOME directory and to avoid the pitfall of having any files saved by or created by the elevated program winding up as ‘owned by’ root”

          man sudoers
          and
          sudo visudo
          and
          inspect the content of the (plaintext) file /etc/sudoers.d/antixers
          …and understand that antiX sudo is, by default, preconfigured to preserve your $HOME environment variable.
          So, the sole benefits from calling any prog via gksu (sez me, rebuttals welcome) are:
          — lookup and apply the gtk desktop theming chosen (lxappearance) for “your” user
          — present a dialogbox, which serves to both alert you to the fact that something has requested an elevpriv launch (in case gksu was called from controlCenter button or some other script, vs via commandline) and to grab/hold kb+mouse focus while you type your password.

          The “minstall” program has a Qt gui, so isn’t really themeable,
          and when calling it from the commandline, the gksu popup dialog creates a workflow nuisance. So…

          .
          sudo minstall

          #49456
          Member
          scmm

            Thanks to both Xecure and skidoo. I went through the various suggestions, and while neither directly solved the problem, they did point the way to the solution. Specifically, running “sudo minstall” on both the antix 19 live usb and on the mx 19 live usb showed me that both were getting to the same place. As the mx 19 installer seemed to be running properly, it seemed likely that the antix one was too, and that the only problem was that I couldn’t see the graphical interface. I right-clicked the antix installer on the taskbar and selected “Move,” and the graphical interface suddenly appeared.

            Anyway, thanks again. I now have antix 19 installed, about which I’m psyched.

          Viewing 4 posts - 1 through 4 (of 4 total)
          • You must be logged in to reply to this topic.