Is antiX going to get s6 init manager?

Forum Forums antiX-development Development Is antiX going to get s6 init manager?

  • This topic has 291 replies, 23 voices, and was last updated Feb 26-1:17 am by ProwlerGr.
Viewing 7 posts - 286 through 292 (of 292 total)
  • Author
    Posts
  • #132193
    Member
    eric

      I just spent two hours on it and i don’t get it. Perhaps someone has an idea to submit?

      This was my bad (I had left the refracta shortcuts on the desktop), but I ended up using the antix snapshot tools to create.

      Try installing using:
      gexec su-to-root -X -c minstall

      Sorry for my late response. I’m currently auditing a big company on my country to study the feasibility of servers migration from CentOS to Rhel and this taking me a lot of time to do it.
      Anyway, i tried to launch you command line and i get

      $ gexec su-to-root -X -c minstall
      Unknown option -X
      
      #132196
      Member
      ProwlerGr

        No worries @eric, no need to spend any of your precious time on that old issue anymore, we have overcome it & s6-66 mostly boots on both i386 & amd64.

        We have since then produced an experimental iso containing all 4 inits (sysvinit-runit-s6-rc & s6-66) which we are looking to refine.
        The 3 out of 4 inits are rock stable (sysvinit – runit & s6-rc), only s6-66 seems to be affected by a random boot-up bug (on both 32bit & 64bit).

        Most times s6-66 will fully boot properly – but on some boots something crashes midway meaning the user is either left without a network connection (connman not loaded), or without a graphical interface (slimski also not loaded).
        Sometimes the bug takes 5 boots to reveal itself, sometimes less which really annoying because it is not consistent.

        I can suggest to grab the either of the iso from #post-131550 – or alternatively – use script from #post-131555 to recreate the 4-in-1 “init-diversity” installation. Try booting into s6-66 a few times & there is a certain chance you will run into the bug.

        If you could find some time to assist us working out what causes that bug (only affecting 66) it would be greatly appreciated by the whole antiX (& broader Debian) user community.

        #132197
        Moderator
        Brian Masinick

          Gentleman, something is wrong with the experimental repository.

          The s6-rc package trio won’t properly install.

          I’ve attempted to document it on the “What are you “here” with thread. I’ll cross post here (unless it’s here too).

          --
          Brian Masinick

          #132198
          Moderator
          Brian Masinick
            #132199
            Moderator
            Brian Masinick
              #132215
              Member
              eric

                No worries @eric, no need to spend any of your precious time on that old issue anymore, we have overcome it & s6-66 mostly boots on both i386 & amd64.

                We have since then produced an experimental iso containing all 4 inits (sysvinit-runit-s6-rc & s6-66) which we are looking to refine.
                The 3 out of 4 inits are rock stable (sysvinit – runit & s6-rc), only s6-66 seems to be affected by a random boot-up bug (on both 32bit & 64bit).

                Most times s6-66 will fully boot properly – but on some boots something crashes midway meaning the user is either left without a network connection (connman not loaded), or without a graphical interface (slimski also not loaded).
                Sometimes the bug takes 5 boots to reveal itself, sometimes less which really annoying because it is not consistent.

                I can suggest to grab the either of the iso from #post-131550 – or alternatively – use script from #post-131555 to recreate the 4-in-1 “init-diversity” installation. Try booting into s6-66 a few times & there is a certain chance you will run into the bug.

                If you could find some time to assist us working out what causes that bug (only affecting 66) it would be greatly appreciated by the whole antiX (& broader Debian) user community.

                i switched to https://www.antixforum.com/forums/topic/antix-23-1_init-diversity-edition-sysvinit-runit-s6-rc-s6-66/page/4/#post-132214

                #134301
                Member
                ProwlerGr

                  @eric

                  A bit off topic, but I wonder if you have tested 66 with systemd…

                  https://forum.mxlinux.org/viewtopic.php?t=79448

                Viewing 7 posts - 286 through 292 (of 292 total)
                • You must be logged in to reply to this topic.