Is antiX going to get s6 init manager?

Forum Forums antiX-development Development Is antiX going to get s6 init manager?

  • This topic has 291 replies, 23 voices, and was last updated Feb 26-1:17 am by ProwlerGr.
Viewing 15 posts - 31 through 45 (of 292 total)
  • Author
    Posts
  • #55141
    Forum Admin
    anticapitalista

      *bump my spam-filtered post*

      Philosophers have interpreted the world in many ways; the point is to change it.

      antiX with runit - leaner and meaner.

      #55161
      Member
      mobinmob

        I tried to install and start antix and voidlinux with 66 (back to back :P). Antix indeed fails as @anticapitalisma mentions, but voidlinux works fine. So, the issue is definately not in the arch 🙁

        #55166
        Member
        fungalnet

          I am pretty sure mobinmob-isma means 32bit trials in both … to avoid confusion.

          #55196
          Member
          mobinmob

            I am pretty sure mobinmob-isma means 32bit trials in both … to avoid confusion.

            That is correct. I have not used 66 in i686 previously, strange as it may seem. But I did not anticipate any problems either.
            I have to say I am a little confused by the directory choices in the conf as I am used to a unified layout under /usr. I will try with slightly different options.

            • This reply was modified 3 years, 2 months ago by mobinmob.
            #55199
            Member
            eric

              hum, the only way to debug it, it’s to start the 66-boot with strace -s256 -vf. Maybe the trouble comes from the code itself, but i have doubt as long as Void works.

              #55204
              Anonymous

                tried the updated script on a p-4 3ghz with 512mb ram and builds and reboots with
                no errors then stops as anticapitalista says, attached a shot of where it stops on the machine.
                not sue if it matters … I ran the script as sudo from / directory using antiX-19.3-runit-full
                32-bit iso install. It also says

                random: crng init done

                after a minute and I can log in as root to root@none

                #55209
                Anonymous

                  eric wrote: start the 66-boot with strace -s256 -vf

                  it stops at the shot attached.

                  #55212
                  Member
                  eric

                    please save the output of strace somewhere with the -o, so strace -s256 -vf -o <file> 66-boot -m and provide the full output.Also do not forget to use VERBOSITY=4(this is can be done by appending it at your the bootloader kernel command line).

                    #55215
                    Anonymous

                      ok took me a minute to get strace to a usb stick on it.

                      #55217
                      Member
                      oops

                        Nice work there Eric. The install script worked on my antiX Libre respin. eth0 is down for the moment, the OS threw up an “Unable to find a connection to the system bus” error for connman.

                        FI: Here, for the moment, I can use Ceni instead connman (and to use the web browser)
                        And I have created the file /etc/resolv.conf
                        # nameserver DNS-IP-of-your-box
                        nameserver 192.168.xxx.xxx

                        #55218
                        Anonymous

                          when I type
                          cat /sbin/init
                          the output is

                          #!/bin/execlineb -P
                          66-boot -m
                          #55221
                          Member
                          eric

                            First thanks linuxdaddy for the output, useful for me :).
                            So according to the strace output
                            = -1 EFAULT (Bad address)
                            something is “wrong” on the code. I need to debug it by installing 66 on a antix 32bit inside a VM and try to understand what happens. This will take time…

                            #55222
                            Anonymous

                              btw I took quiet and vga lines off my kernel boot line and have it with rw in case have
                              to edit anything.

                              shouldn’t that say DEFAULT

                              #55223
                              Member
                              eric

                                @linuxdaddy
                                can please you try the following?

                                Boot the machine, wait for the crash, log on with root at sulogin and try to launch the following command(replace <file> by a good one) and share the output.
                                strace -s256 -vf -o <file> /usr/bin/66-scandir -v5 -l /run/66 -b -s /etc/66/ -L root create

                                #55224
                                Anonymous

                                  I did and says
                                  strace:Can't stat '/usr/66-scandir': No such file or directory

                                Viewing 15 posts - 31 through 45 (of 292 total)
                                • You must be logged in to reply to this topic.