Is it possible to install runit in antix-19.1

  • This topic has 2 replies, 2 voices, and was last updated May 8-3:05 am by Atlanelan.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #35716
    Member
    Atlanelan

    Hi there!Happy to see antix with runit.Im already running antiX-19.1-sid_x64-core Marielle Franco.In the news about 19.2 @anticapitalista says:

    “antiX-19.2 (Hannie Schaft) bug-fix/upgrade isos available
    March 28, 2020 by anticapitalista
    All new isos are bug-fix/upgrades/improvements of antiX-19 sysvinit series.
    BONUS: We now offer versions running the runit init system as well.
    No need to download if using antiX-19(.x).”

    Can I replace sysvinit with runit or do I need to install runit version of antix-19.2.Thankyou.

    #35720
    Member
    Xecure
    Helpful
    Up
    0
    :D

    I don’t know if it also works with the sid version, but anticapitalista wrote:

    I meant – how can I try runit while using my current antix19? Like safe switch from sysVinit.

    May not be ‘safe’, but this should work

    sudo apt install runit-init runit

    If you are asked ‘Yes do as I say!’, check to see what will be removed before doing so.

    #35724
    Member
    Atlanelan
    Helpful
    Up
    0
    :D

    I don’t know if it also works with the sid version

    Thanks @Xecure.You guessed right.

    demo@antix1:~
    $ sudo apt install runit-init runit
    [sudo] password for demo: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     runit-init : Conflicts: systemd-sysv
                  Conflicts: systemd-sysv:i386
    E: Unable to correct problems, you have held broken packages.
    demo@antix1:~
Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.