Is your hardware incompatible with the Debian/AntiX kernel 5.10 series?

Forum Forums General Software Is your hardware incompatible with the Debian/AntiX kernel 5.10 series?

  • This topic has 2 replies, 3 voices, and was last updated Sep 18-6:45 am by Xunzi_23.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #116949
    Member
    mikey777

      My Asus X71Q laptop continues to be incompatible with the 5.10 series of kernels from either Debian or the AntiX versions of these.
      It’s the only laptop in our house that does this.

      Because of this issue I use the 5.10 gnu kernels listed at http://linux-libre.fsfla.org/pub/linux-libre/freesh/pool/main/l/linux-5.10.194-gnu1/

      If your machine also has this issue, could you share its details (make/model) on this thread – thanks.

      $ inxi -MS
      System:
        Host: X71Q Kernel: 5.10.193-gnu1 arch: x86_64 bits: 64 Desktop: LXDE
          v: 0.10.1 Distro: antiX-21_x64-base Grup Yorum 31 October 2021
      Machine:
        Type: Laptop System: ASUSTeK product: X71Q v: 1.0
          serial: <superuser required>
        Mobo: ASUSTeK model: X71Q v: 1.0 serial: <superuser required>
          BIOS: American Megatrends v: 201 date: 09/17/2008

      ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
      - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
      ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
      - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
      - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

      #116969
      Moderator
      Brian Masinick

        @mikey777 Interesting that you bring this up. My Dell Dimension 5558 laptop has, over the years, experienced multiple issues with the 5.10 kernel series; what’s interesting is that *sometimes* they’ll work without issues, other times they’ll get hung up as the /dev filesystem is being loaded. The 5.10.142 antiX kernel was particularly problematical, the others less so, but still, in my entire career of using Linux software and Linux systems, ESPECIALLY Debian, MEPIS, MX Linux, and antiX, this is the ONLY kernel series that has ever given me ANY problems.

        The newest of the antiX updated 5.10 kernels though have usually worked; oh, and it’s only on this Dell that I have problems. My Lenovo, Acer, and HP systems have worked fine; Prior to this issue, various Dell models over the years, the Dell Dimension 4100 desktop, which I had way back when antiX first came out, the Dell D600 series laptops, (I’ve used D600, D610, D620 AND D630) and the Inspiron 5558 laptop, have ALWAYS worked well with Linux. I was beginning to wonder if I was the only one … so certain ASUS models are not exempt either?

        From what I can tell from the overall 5.10 series, this particular series had specific features to FIX certain issues and get particular problems solved; apparently whatever was done had consequences; sure looks like it fixed some and broke others.

        See if you can get the newer 6.1.42 working on this system; it does use somewhat more memory, but I’ve had very good success using it on some pretty old systems, including two Lenovo models, the X201 and the T510.

        --
        Brian Masinick

        #117078
        Member
        Xunzi_23

          5.10 Kernel, worst series I ever met up with, no boot on many devices.
          Until antiX 23 came along I setup devices using
          later debian kernels. Often 5.18 until it became unsupported.

          One 5.10 will not boot on. The device sold a lot although mostly not with the expensive unlocked K suffix CPU.

          Desktop System: Gigabyte product: N/A v: N/A serial: <superuser required> Chassis: type: 3
          serial: <superuser required>
          Mobo: Gigabyte model: B75M-D3H v: x.x serial: <superuser required> BIOS: American Megatrends
          v: F15 date: 10/23/2013

          CPU:
          Info: model: Intel Core i5-2500K bits: 64 type: MCP arch: Sandy Bridge gen: core 2 level: v2

        Viewing 3 posts - 1 through 3 (of 3 total)
        • You must be logged in to reply to this topic.