JBL Go 2 speaker can’t pair by bluetooth

Forum Forums General Software JBL Go 2 speaker can’t pair by bluetooth

  • This topic has 29 replies, 7 voices, and was last updated Feb 14-4:56 pm by Brian Masinick.
Viewing 15 posts - 16 through 30 (of 30 total)
  • Author
    Posts
  • #131897
    Member
    Wabi

      I have uninstalled pulseaudio and youtube and internet radio works.

      • This reply was modified 3 weeks, 4 days ago by Wabi.
      #132772
      Member
      Wabi

        I did it sudo apt install pipewire pipewire-audio-client-libraries libspa-0.2-bluetooth but JBL still can’t connect.

        #132777
        Member
        abc-nix

          These are the steps for pipewire

          sudo apt update
          sudo apt install pipewire pipewire-alsa pipewire-jack pipewire-pulse wireplumber pavucontrol gstreamer1.0-pipewire antix-pipewire-extras liblua5.3-0

          Then open the control-centre > Session > User Desktop-Session
          This will open geany with the startup file
          Go to line 23 and remove the # from the line
          pipewire-start &

          Most people need to give the volumeicon some time to start in interaction with pipewire.So go to line 26 and change the volumeicon line into
          sleep 5 && volumeicon &

          Save and close the file.Now reboot.Hopefully everything works as smoothly as it did here.
          Go to the menu > applications > Entertainment media > pavucontrol(Pulse-audio volume control) and see if it is working.
          If everythings fine you can now right click on the volumeicon in the taskbar,go to Settings.
          Under “Externel mixer” delete the desktop-default-alsamixer and write instead there pavucontrol.
          You can now achieve quickly pavucontrol with a right click on the volumeicon — Open Mixer
          ———————————

          Now to the bluetooth part

          sudo apt install bluez blueman bluetooth bluez-alsa-utils gnome-bluetooth libspa-0.2-bluetooth

          Go to control-centre > system > choose startup services
          Look if bluetooh is now mentioned there as a service, you have the option to enable it to autostart on every boot.
          During installation here I got the impression it’s better to reboot here,too.
          Then try your headphones, open blueman
          In blueman under Adapter > Adapter Settings you have to make it visible.
          Search for the head phones or if they are already shown right click on them and trust them,then right click and click on Pairing.
          Afterwards try to connect.
          Everything went well here, if you have any problems please let us know.I may also have overlooked something in the howto.

          #132779
          Member
          Wabi

            @antix1:~
            $ sudo apt install pipewire pipewire-alsa pipewire-jack pipewire-pulse wireplumber pavucontrol gstreamer1.0-pipewire antix-pipewire-extras liblua5.3-0
            Czytanie list pakietów… Gotowe
            Budowanie drzewa zależności… Gotowe
            Odczyt informacji o stanie… Gotowe
            E: Nie udało się odnaleźć pakietu antix-pipewire-extras

            #132781
            Member
            abc-nix

              E: Nie udało się odnaleźć pakietu antix-pipewire-extras

              The mirror that your system is using for the antiX repo seems to be broken. What does
              cat /etc/apt/sources.list.d/antix.list
              Say? Can you use repo manager to change the mirror?

              #132783
              Member
              Wabi

                cat /etc/apt/sources.list.d/antix.list
                # Use with Debian Bullseye repositories.
                deb http://ftp.icm.edu.pl/pub/Linux/dist/antix-workspace/antix/bullseye bullseye main nosystemd nonfree
                #deb-src http://ftp.icm.edu.pl/pub/Linux/dist/antix-workspace/antix/bullseye bullseye main nosystemd nonfree

                # Use with Debian Testing/’rolling’ repositories.
                #deb http://ftp.icm.edu.pl/pub/Linux/dist/antix-workspace/antix/testing testing main nosystemd nonfree
                #deb-src http://ftp.icm.edu.pl/pub/Linux/dist/antix-workspace/antix/testing testing main nosystemd nonfree

                # Use with Debian Sid repositories.
                #deb http://ftp.icm.edu.pl/pub/Linux/dist/antix-workspace/antix/sid sid main nosystemd nonfree
                #deb-src http://ftp.icm.edu.pl/pub/Linux/dist/antix-workspace/antix/sid sid main nosystemd nonfree

                #132790
                Member
                abc-nix

                  Based on the mirror tracker, the mirror you are using is out of date. Try with the http://ftp.task.gda.pl based one. You should be able to switch to it with the repo manager. If you cannot find the repo manager, change the /etc/apt/sources.list.d/antix.list file so it looks like this:

                  # Use with Debian Bullseye repositories.
                  deb https://ftp.task.gda.pl/site/mx-packages/antix/bullseye bullseye main nosystemd nonfree

                  Still, I must say I didn’t read the previous replies and didn’t realize you are running antiX 22. For antiX 22, I think antix-pipewire-extras cannot install (is not available).

                  After updating the system, install
                  pipewire pipewire-alsa pipewire-jack pipewire-pulse wireplumber pavucontrol gstreamer1.0-pipewire liblua5.3-0
                  Then reboot and run these commands one at a time (you may need more than one terminal)

                  pipewire &
                  wireplumber &
                  pipewire-pulse &

                  Then start the Bluetooth manager and try to connect to your bluetooth speaker. If it works, then you will need to edit the startup file so that this works automatically in the future. If it doesn’t we can explore to see what is going on.

                  • This reply was modified 2 weeks, 4 days ago by abc-nix.
                  #133133
                  Member
                  Wabi

                    sudo apt install pipewire pipewire-alsa pipewire-jack pipewire-pulse wireplumber pavucontrol gstreamer1.0-pipewire liblua5.3-0
                    Czytanie list pakietów… Gotowe
                    Budowanie drzewa zależności… Gotowe
                    Odczyt informacji o stanie… Gotowe
                    pipewire is already the newest version (0.3.19-4).
                    Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
                    że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
                    w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
                    z katalogu Incoming (“Przychodzące”).
                    Następujące informacje mogą pomóc rozwiązać sytuację:

                    Następujące pakiety mają niespełnione zależności:
                    pipewire-alsa : Wymaga: pipewire (= 0.3.65-2~bpo11+1) ale 0.3.19-4 ma zostać zainstalowany
                    Wymaga: libpipewire-0.3-0 (= 0.3.65-2~bpo11+1) ale 0.3.19-4 ma zostać zainstalowany
                    pipewire-jack : Wymaga: pipewire (= 0.3.65-2~bpo11+1) ale 0.3.19-4 ma zostać zainstalowany
                    Wymaga: libpipewire-0.3-0 (= 0.3.65-2~bpo11+1) ale 0.3.19-4 ma zostać zainstalowany
                    pipewire-pulse : Wymaga: pipewire (= 0.3.65-2~bpo11+1) ale 0.3.19-4 ma zostać zainstalowany
                    Narusza zależności: pipewire-bin (< 0.3.27-2)
                    Narusza zależności: pipewire-bin:i386 (< 0.3.27-2)
                    wireplumber : Wymaga: libpipewire-0.3-0 (>= 0.3.52) ale 0.3.19-4 ma zostać zainstalowany
                    Wymaga: libwireplumber-0.4-0 (= 0.4.13-1~bpo11+1) ale nie zostanie zainstalowany
                    Wymaga: pipewire (>= 0.3.52) ale 0.3.19-4 ma zostać zainstalowany
                    E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

                    #133141
                    Member
                    olsztyn

                      @Wabi:
                      Just a question, so please do not take it the wrong way, as all here just try to help you:
                      Is there a particular reason you stick with antiX 22 and do not want to install antiX 23 or antiX 23.1, where these things are mostly working out of the box?

                      Live antiX Boot Options (Previously posted by Xecure):
                      http://antixlinuxfan.miraheze.org/wiki/Table_of_antiX_Boot_Parameters

                      #133142
                      Member
                      Wabi

                        I will install antiX 23.

                        #133148
                        Moderator
                        caprea

                          Please after installing antiX23 dont forget to update and upgrade the system, because pipewire will only function correctly if it is upgraded to the latest version.

                          #133149
                          Forum Admin
                          rokytnji

                            Runit version is easier to turn on bluetooth on startup. Full iso comes with everything and saves headaches. md5sum check is must in my book.

                            Sometimes I drive a crooked road to get my mind straight.
                            Not all who Wander are Lost.
                            Motorcycle racing is rocket science.

                            Linux Registered User # 475019
                            How to Search for AntiX solutions to your problems

                            #133152
                            Member
                            PPC

                              I already had a bad experience recommending that users that are not Advanced level users should always, and I mean ALWAYS install the Full version of antiX, until they have extremely valid reasons for not doing so. As I see it, installing a non “Full” version of the OS and then waste your time and the time of the people that try to help out here in the forum trying to do something and the “Full” version already provides is not exactly “learning”. It’s just being stubborn and expecting other people to do the work for us (since we installed something meant for Advanced users, not being an advanced user).
                              I’m not ashamed to say that I’m a somewhat Advanced user and the only time that I booted into a “Base” version of antiX was because I downloaded, and burned the wrong iso… A lot of work went into making sure that antiX Full is… well, the fullest OS antiX can be, including all the required packages, all the GUIs that help use and configure the system, etc…

                              That said – anyone is, of course, free to install anything on their computers… But, please, be aware any other version of antiX that’s not Base is not for non advanced users!
                              Usually, the latest version of antiX is the one that includes the latest version of the packages and includes all the latest fixes… So I recommend antiX 23 Full

                              P.

                              • This reply was modified 2 weeks, 1 day ago by PPC.
                              #133158
                              Member
                              olsztyn

                                Please after installing antiX23 dont forget to update and upgrade the system, because pipewire will only function correctly if it is upgraded to the latest version.

                                I would recommend to install antiX 23.1 published on January 26. It is called ‘final’ pending some updates from @PPC and @Robin but seemed to me it worked fine…

                                Live antiX Boot Options (Previously posted by Xecure):
                                http://antixlinuxfan.miraheze.org/wiki/Table_of_antiX_Boot_Parameters

                                #133162
                                Moderator
                                Brian Masinick

                                  Please after installing antiX23 dont forget to update and upgrade the system, because pipewire will only function correctly if it is upgraded to the latest version.

                                  I would recommend to install antiX 23.1 published on January 26. It is called ‘final’ pending some updates from @PPC and @Robin but seemed to me it worked fine…

                                  I agree. The boot loader issue in the previous antiX 23 Full image has been resolved and the antiX 23.1 Full run it image is solid.

                                  As long as you don’t need sysvinit for specific services this is the solid solution.

                                  --
                                  Brian Masinick

                                Viewing 15 posts - 16 through 30 (of 30 total)
                                • You must be logged in to reply to this topic.