Keep sound card settings Lost after live remastering

Forum Forums Official Releases antiX-21/22 “Grup Yorum” Keep sound card settings Lost after live remastering

  • This topic has 5 replies, 2 voices, and was last updated Nov 20-7:57 pm by ModdIt.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #71080
    Member
    ModdIt

      On a system starting with Runit 64 bit sound card 2 keeps being lost/reset to the internal card 0.

      Means after a remaster the sound card must be reset and tested using controll center tool.
      This keeps happening which is somewhat annoying. The built in board Intel HD Audio delivers
      very poor sound quality when A/B compared with the Audigy card.

      user home asound.rc
      defaults.pcm.!card Audigy2
      defaults.ctl.!card Audigy2

      To me it looks like the .asound.conf gets broken replaced as a manual change from card 0 to card 2
      is apparently not sticking.

      #Substitute N with a small integer, 0 for your first sound card (which is the default),
      #1 for your second, and so on.

      pcm.!default {
      type hw
      card 0
      }

      ctl.!default {
      type hw
      card 0

      • This topic was modified 2 years, 6 months ago by ModdIt.
      #71084
      Anonymous

        This can be a pain every time you reboot or boot the default sound card changers. Debian was bad for this with me (not antiX)
        Started to happening with Arch too, but the fix pretty easily solved.

        I have a usb dac and is set to defaults.pcm.card 1 defaults.ctl.card 1 in my asound.conf

        So my alsa-base.conf is set like this
        options snd_hda_intel index=0
        options snd_usb_audio index=1 <<<< my usb dac is set to default 1

        This is from the Arch wiki

        Configuring the index order via kernel module options
        If your sound card order changes on boot, you can specify their order in any file ending with .conf in /etc/modprobe.d (/etc/modprobe.d/alsa-base.conf is suggested). For example, if you want your mia sound card to be #0:

        /etc/modprobe.d/alsa-base.conf
        options snd_mia index=0
        options snd_hda_intel index=1

        #71093
        Member
        ModdIt

          Thanks Koo,
          Will make/test the changes tomorrow.

          I rebuilt my box during the last few last days and put in the card.
          What a change, the boost in audio quality was a revelation.

          Be nice if the sound card chooser could make the required settings, this is the kind of
          problem to drive a new user away.

          #71105
          Anonymous

            If you want to find the name of your device like Audigy2 hardware id name, I use inxi -A as below.

            inxi -A
            Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI Audio driver: snd_hda_intel
                       Device-2: TEAC US-2x2 type: USB driver: hid-generic,snd-usb-audio,usbhid     (snd-usb-audio) <<<
                       Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes

            Yes adding your own sound device is the way to go if it is possible.

            I don’t use pulseaudio , jack or pipewire just Alsa

            From inxi -Fxz on ArchLabs
            Audio: Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI Audio driver: snd_hda_intel v: kernel
            bus-ID: 09:00.1
            Device-2: TEAC US-2×2 type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1:2
            Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes
            Sound Server-2: sndio v: N/A running: no
            Sound Server-3: JACK v: 1.9.19 running: no
            Sound Server-4: PulseAudio v: 15.0 running: no
            Sound Server-5: PipeWire v: 0.3.40 running: no

            Have fun with your new sound..

            #71123
            Member
            ModdIt

              $ inxi -A
              Audio:
              Device-1: Intel 7 Series/C216 Family High Definition Audio
              driver: snd_hda_intel
              Device-2: NVIDIA GF116 High Definition Audio driver: snd_hda_intel
              Device-3: Creative Labs EMU10k2/CA0100/CA0102/CA10200 [Sound Blaster
              Audigy Series]
              driver: snd_emu10k1
              Sound Server-1: ALSA v: k5.10.57-antix.1-amd64-smp running: yes

              The Intel sound devices get nowhere near the audigy quality wise.
              Computer Sound is from a Teufel setup with big sub bass box and
              Two way front Sattelites.

              Tempted to change that for second Hand Yamaha Piano Craft, that gives
              the best quality sound relationshio I have come across to date. Good
              build too.

              I also want nothing on top of alsa. Every further processing introduces
              new sound artefacts. That includes Pulse, pipewire=pipedream experience,
              lousy crashing sound mangle.

              #71307
              Member
              ModdIt

                Most. I hope all of my issues seem fixed after installing package alsa-firmware-loaders
                was unaware I might need any extra package for my card as it had worked without, albeit
                with obscure problems.

                Furter I had been used to starting programmes using –apulse programm name.
                Now only apulse then programm name is the rule.
                for example with full starter string
                prog “Tor Browser” /usr/share/icons/papirus-antix/48×48/categories/torbrowser.png apulse torbrowser-launcher

              Viewing 6 posts - 1 through 6 (of 6 total)
              • You must be logged in to reply to this topic.