Keyboard not working

Forum Forums New users New Users and General Questions Keyboard not working

  • This topic has 44 replies, 13 voices, and was last updated Apr 2-6:14 pm by Skrnet.
Viewing 15 posts - 1 through 15 (of 45 total)
  • Author
    Posts
  • #136269
    Member
    leoven

      Hi
      First off let me say what a great linux package this seems to be. I am runnng it on my chromebook with a USB and it consumes such little resources – not sure how you manage to put so much on this version, impressive.

      Anyway, I have tried about 5 light distros, all of them allow the keyboard to work – Anti X is the only one where my keyboard doesn’t work – the reason I say this is it must be a common setting I am missing?

      I am new to linux but have used terminal commands, I just cannot find anything on your menus to add a driver or select a keyboard (if that is the issue).

      I searched the forums but looks like I am the only one since 2017 having this issue.
      In that other post it said to try to not boot UEFI, so I tried that, same result.

      Just wondering if I should keep trying with settings or if someone might know how to remedy this.
      Thanks

      #136277
      Member
      leoven

        Note : I should mention I am able to use the keyboard in the startup menu – it is when the program loads that the keyboard doesn’t work. Thanks

        #136280
        Member
        wildstar84

          Use your mouse to open a terminal, then try the following commands:

          sudo grep -i "keyboard" /var/log/Xorg.0.log

          sudo grep "EE" /var/log/Xorg.0.log

          and post the output. You could also try booting up in runlevel 3 (editing the boot line text to add a ” 3″ to the end of it, which should take you to a text login prompt (no X graphics) and see if you can type your user-name (to determine if kb doesn’t work at all or just doesn’t work in X).

          Regards,

          Jim

          • This reply was modified 1 month ago by caprea.
          #136323
          Member
          Robin

            If you can’t use the default keyboard, use your mouse to click open one of the virtual keyboards available from the antiX main menu → Barrier-free submenu. (There should be at least “onboard” available.) This might allow you to key in the commands wildstar gave you above, and also the sudo password.

            And then, try opening the antiX control centre, head for the entry Keyboard layout in the section system, click it open. Therein check what keyboard layouts are enabled, and try to add another one. Maybe you need to select the proper hardware layout (Chromebook, in the first place, but if this fails try generic 105 keys, dell latitude notebook, toshiba satellite, ibm thinkpad, hp pavillon or whatever else also) from the listing in the pulldowns rather than accepting the defaults. To be able to access the keyboard layout program it will ask you for sudo password, which can’t be entered by the virtual keyboard for some strange reason. So make sure to have entered the sudo password shortly before in a console window (e.g. roxterm) for an arbitrary command, which will allow you to access the programs in control centre without again having to give your credentials for a short time, so you can access them, avoiding the issue with the virtual keyboard not working in the graphical sudo password entry field.

            Windows is like a submarine. Open a window and serious problems will start.

            #136325
            Moderator
            caprea

              To rule it out here, was the download md5sum or sha256 checked ?

              #136429
              Member
              leoven

                Hi
                Thanks for the replies.

                So I did the following (not working yet).

                I was able to find the onboard keypad and use that to enter some commands. (you are right you cannot enter the sudo password as the onboard keypad is in the background and can’t be enabled to be in front of the “password” box for some reason.)

                Because I am using a different laptop than the chromebook for which I installed the Anti X program, I cannot transfer all the details for the sudo grep -i “keyboard” /var/log/Xorg.0.log command. It is long. Some of the entries are:

                board id 6)
                video bus is tagged by udev as: keyboard
                video bus: device is a keyboard

                I then entered the sudo grep “EE” /var/log/Xorg.0.log command
                it mainly said :failed to load module synaptics (module does not exist, 0) and something about an Elan touchpad.
                I don’t see anything related to keyboard.

                I was able to go to the Keyboard menu and find the options for Keyboards, I started to go though the options but will have to test them all.
                So far Chromebook, Generic 102, 104 etc. don’t work.

                Unfortunately checking requires clicking each one individually so it takes a bit of time but I will do them all.
                Since I changed to OS system to Gallium OS a few years ago the chromebook is not running the chromebook OS, so it might be one of the others.

                Sorry I don’t really understand the process yet of : “editing the boot line text to add a ” 3″ to the end of it”. I’ll have to read the docs to see how to do this.

                Again, it must be something simple as any distro (probably 10 in the last month) have all enabled the keyboard.

                As for the checksum, I did not do that because I used the “Startup Disk Maker” program in ubunutu and it worked (except the keyboard). Then I read the documentation and found that since I am using a Linux distribution (ubuntu) I should really use the appimage process and use this command:

                To use, please download the tarball, extract to a folder, and run via a terminal from inside the folder with
                sudo ./live-usb-maker-qt-19.11.02.x86_64.AppImage

                So I ran that installer and it started, but then it stopped and produced an error message saying it could not complete the usb image.

                Thanks

                #136430
                Member
                Robin

                  Then I’d suggest the following path:

                  Since you can run antiX now basically, and have a way to key in something by using the virtual keyboard, create a new boot device from within antiX itself, just to make sure to have a clean base to start from (might solve the issue already). Click open the antiX control centre, section drives → Live USB maker; let it create a Full featured USB device (writable) (not a dd-image device).

                  In case you have only a single USB stick at hand, you may use the boot option toram (either key it in manually into the boot line on antiX boot screen, or select it by using the F4 key. (Btw, check out the F1 key in this boot screen, there is pretty much documented what can be useful to understand how things work on antiX); some more boot cheat codes here: https://antixlinuxfan.miraheze.org/wiki/Table_of_antiX_Boot_Parameters) Using the toram boot option allows to umount the boot device so you can overwrite the former content. But even when this is possible, please be carefully, if this fails you’ll have to start over by creating the boot device from within another system again, so it is rather recommended to use a second USB stick instead of applying this toram trick.

                  Before using the ISO file, make sure its checksum matches:
                  Either download the respective checksum file from sourceforge, put it next to your downloaded ISO file, and run from within a terminal window (roxterm, click terminal in antiX main menu and cd to the directory where the two files are stored)

                  $ shasum -c ›checksumfile‹
                  OK

                  If the output reads OK the downloaded ISO is fine and you can proceed. If not, redownload, then it was corrupted on transport.
                  Alternatively you may validate the ISO by its gpg signature, open the download page here in forum, scroll to its bottom and follow the procedure as described there.
                  Or do it manually: just let shasum create a checksum of the downloaded ISO file and compare the output with the checksum string belonging to your ISO, found also at the bottom of the already linked download page here in the forum. In this case make sure to use the same parameter, e.g. sha256 or sha512 or whatever the given checksum line is marked, by using the -a option of shasum command: shasum -a 256 -b ›downloaded_ISO_file‹ for sha256 checksums.

                  Whatever method from the above you chose, use the downloaded ISO only if you have made sure it was not damaged.

                  Sorry I don’t really understand the process yet of : “editing the boot line text to add a ” 3″ to the end of it”

                  If you start antiX, you’ll see the antiX boot screen. It has a line you can edit. (This is the very place you could enter the toram option if not selecting it from the F4 boot option menu.) Just append the cipher 3 to it, what should boot your system to runlevel 3, which will you present a console login merely. Wildstar wanted you to check whether your keyboard works on this runlevel still, that means whether you can key in something there still (e.g. your login credentials). To shut down the system properly from this text console only level, use afterwards:
                  sudo shutdown -h now

                  Windows is like a submarine. Open a window and serious problems will start.

                  #136469
                  Forum Admin
                  rokytnji

                    I keep a silicone keyboard like so when I am troubleshooting symptoms like these.

                    [/url]

                    Cost was under 5 bucks at ebay. Long time ago though.

                    Edit. It gets used more than you think.

                    • This reply was modified 1 month ago by rokytnji.

                    Sometimes I drive a crooked road to get my mind straight.
                    I don't suffer from insanity. I enjoy every minute off it.
                    Motorcycle racing is rocket science.

                    Linux Registered User # 475019
                    How to Search for AntiX solutions to your problems

                    #136534
                    Member
                    leoven

                      Thanks.I will have to go buy a new USB to perform the install commend you mentioned. I don’t feel comfortable using a single USB since there is some risk I could wipe my hard drive without the right command.

                      As for the adding the “3”, I really cannot find where to add anything. I went through Advanced options, boot menu, etc. – must be my novice skills.

                      I just copied this screen off the net as a sample boot up since the chromebook doesn’t have a screen capture that can be used without the keyboard.
                      Can you tell me where I am to enter the 3?

                      (I have never seen a silicone keyboard – but thank). It does somewhat defeat the purpose of using anti x though. With all the replies I assume this is a one off problem but I cannot find why it would be just my chromebook with anti x. ) Thanks.

                      #136539
                      Member
                      abc-nix

                        As for the adding the “3”, I really cannot find where to add anything. I went through Advanced options, boot menu, etc. – must be my novice skills.

                        On the first entry “antiX-22 x64-full (18 October 2022)”, hit the e key on your keyboard and write the boot parameters at the end of the line starting with linux. You will have to be careful when writing, as it will be using the US layout for the keyboard.

                        From antiX wiki
                        1. Use the arrow key to select the antiX Linux system you want to boot.
                        2. Press the e key on your keyboard and a “window” will pop up.
                        3. Add or remove the boot options in the first line that starts with linux /boot/vmlinuz…, after theses entries, where the boot parameters normally go (usually the boot parameters come after the quiet boot option, if there is one).
                        4. Press F10 key to start the antiX system with your proposed changes.

                        • This reply was modified 4 weeks, 1 day ago by abc-nix.
                        #136550
                        Member
                        Robin

                          For me the boot screen looks differently (see screenshot below). As abc-nix already has stated, in your screen you have to press the e key. I wonder why you don’t have the default boot screen. I have never seen that reduced one your shot shows. I guess after creating the USB stick by the MX/antiX usb maker you’ll have the default boot screen also.

                          Additional hint: If you want to have all internal drives automatically mounted on boot in live or frugal mode, add
                          mount=all to this line and let it save by selecting “save” from F8 (This is only needed once to make it permanent).

                          Recommendation: Introduction into antiX and MX boot menus by Dolphin Oracle.
                          Or, if you happen to understand Portuguese, you can watch the really great collection created by Marcelo.

                          (Shot taken from Dolphin Oracles fine video mentioned above) Double click the images to see the footer line with all the Function buttons.

                          Windows is like a submarine. Open a window and serious problems will start.

                          #136553
                          Member
                          PPC

                            For me the boot screen looks different

                            The boot screen differs between BIOS and UEFI computers. The option to manually edit boot options is present on both.

                            P.

                            #136621
                            Member
                            leoven

                              Ok thanks. Attached is the menu that appears after I pressed “e” on the Antix version.

                              I do not have the /boot/vmlinuz. line.

                              So I added a “3” after the .gz word (the very last line just at the edge of the globe).

                              Then I tried $3 as well.

                              I pressed CTRL X to boot it with those parameters – and it give me an error message saying unable to boot.

                              So I went to the first line parameters, where the last word is “initrd” and entered ‘3’, and that didn’t work either. I also tried ‘$3’, that didn’t work.

                              If there is anything else you might think of please let me know.

                              Thanks

                              Attachments:
                              #136624
                              Member
                              leoven

                                ps. that boot screen was just one I found on the internet to show the sample of what the issue was (it was a Japanese user I believe that screen shot it)
                                I have the normal boot up screen for the latest version – thanks.

                                I’ll try the other suggestions shortly.

                                #136626
                                Member
                                abc-nix

                                  Sorry. I meant that starts with linux. In your screen you can see all the other boot parameters “quiet splasht disable=lxF”

                                  You add or remove the boot parameter at the end of this line.

                                  Anyway, adding 3 will only boot you to a console with no desktop environment.

                                Viewing 15 posts - 1 through 15 (of 45 total)
                                • You must be logged in to reply to this topic.