[Solved] Keyboard only working under GRUB with boot media plugged in

Forum Forums General Software [Solved] Keyboard only working under GRUB with boot media plugged in

Tagged: , ,

  • This topic has 2 replies, 2 voices, and was last updated May 11-12:01 pm by catalinux.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #35814
    Member
    catalinux

      Hi there,

      As the title says, I am unable to make any selection inside GRUB unless I plug in the install media (Antix is fully installed and up-to-date).

      Below are my specs:

      $ inxi -Fz
      System:
        Host: ***** Kernel: 4.9.212-antix.1-amd64-smp x86_64 bits: 64 
        Desktop: JWM 2.3.7 
        Distro: antiX-19.2.1_x64-base Hannie Schaft 29 March 2020 
      Machine:
        Type: Desktop Mobo: Gigabyte model: 8I945GZME-RH serial: <filter> 
        BIOS: Award v: F10 date: 05/28/2007 
      CPU:
        Topology: Single Core model: Intel Pentium 4 bits: 64 type: MT 
        L2 cache: 1024 KiB 
        Speed: 3059 MHz min/max: N/A Core speeds (MHz): 1: 3059 2: 3059 
      Graphics:
        Device-1: Intel 82945G/GZ Integrated Graphics driver: i915 v: kernel 
        Display: x11 server: X.Org 1.20.4 driver: intel resolution: 1440x900~60Hz 
        OpenGL: renderer: Mesa DRI Intel 945G v: 1.4 Mesa 18.3.6 
      Audio:
        Device-1: Intel NM10/ICH7 Family High Definition Audio 
        driver: snd_hda_intel 
        Sound Server: ALSA v: k4.9.212-antix.1-amd64-smp 
      Network:
        Device-1: Marvell 88E8001 Gigabit Ethernet driver: skge 
        IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter> 
      Drives:
        Local Storage: total: 149.05 GiB used: 3.90 GiB (2.6%) 
        ID-1: /dev/sda vendor: Samsung model: SP1654N size: 149.05 GiB 
      Partition:
        ID-1: / size: 40.30 GiB used: 3.90 GiB (9.7%) fs: ext4 dev: /dev/sda3 
        ID-2: swap-1 size: 1023.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
      Sensors:
        Message: No sensors data was found. Is sensors configured? 
      Info:
        Processes: 163 Uptime: 25m Memory: 1.95 GiB used: 805.5 MiB (40.4%) 
        Shell: bash inxi: 3.0.36 

      GRUB is installed on the MBR and I have chosen sda as the install location (I had the option to select sda and fd0, but when trying to install there, it was showing me that fd0 is too small).

      I tried to use boot repair to repair grub from both the installation media and the installed system, but still nothing

      I tried to add the lines GRUB_TERMINAL_INPUT="usb_keyboard" and GRUB_PRELOAD_MODULES="usb usb_keyboard ohci uhci ehci" to /etc/default/grub (as in this thread on the Gentoo forums) and then run grub-update but the whole system was messed and I had to reinstall.

      The keyboard works just fine both under Linux and Windows after boot, it is just in GRUB where I need to have the installation media inside so that the keys work

      • This topic was modified 4 years, 2 months ago by catalinux.
      #35815
      Forum Admin
      anticapitalista

        Have you tried fixing it via bios?

        Philosophers have interpreted the world in many ways; the point is to change it.

        antiX with runit - leaner and meaner.

        #35816
        Member
        catalinux

          Have you tried fixing it via bios?

          You’re a genius, sir, haha! Yeah, it seems that keyboard control was disabled in BIOS. Enabling that and saving straight away solved the situation. Thank you very much!

          Now I have to set a machine back pretty much from scratch, haha.

          Have a nice day!

        Viewing 3 posts - 1 through 3 (of 3 total)
        • You must be logged in to reply to this topic.