Keylock Indicator? [solved]

Forum Forums New users New Users and General Questions Keylock Indicator? [solved]

  • This topic has 10 replies, 5 voices, and was last updated Nov 4-5:57 am by rej.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #92119
    Member
    rej

      Hi-

      My T450s ThinkPads have no indicator light when caps are on. Does antiX 21 have a keylock indicator that can be downloaded or installed?

      MX 21 has Indicator-keylock, and this app has always worked in antiX, but I have not been able to install it in antiX 21 – missing dependencies. I think.

      Adding the repository for it “sudo add-apt-repository ppa:tsbarnes/indicator-keylock” – “command not found”.

      Any suggestions?

      Thank you.

      #92133
      Member
      ile

        Hi rej
        Newer conky versions have a conky variable for key state.

        antiX with conky-legacy can show key state with something like this
        in conky.

        key state 
        ${exec xset -q|gawk '/Caps/ {print"caps "$4 "\nnum "$8}'}
        

        You willing to use conky?

        #92139
        Member
        rej

          Thanks ile-

          It is an interesting idea, so I tried it and found that it would not be something that would work for me, but enjoyed experimenting with it.

          I need an indicator icon that is always visable yet out of the way, preferably on the panel, that gets my attention when caps are on.

          There might not be anything like this anymore for antiX 21.

          Thanks again – I appreciate the suggestion.

          #92142
          Member
          ModdIt

            Had you searched you would have found-

            http://mxrepo.com/mx/repo/pool/main/i/indicator-keylock/
            has suitable safe debs for buster bullseye stretch.
            Please download and install.

            BAD IDEA below.
            @rej wrote regarding Indicator-keylock

            Adding the repository for it “sudo add-apt-repository ppa:tsbarnes/indicator-keylock” – “command not found”.
            Any suggestions?

            Please save yourself pain, never use PPA in antiX.

            That has been repeated in dozens of posts. PPA are for buntu, buntu is in many ways a different
            system based on debian sid. If your addition pulls in sid dependancys you will probably have a non recoverable mess
            and a reinstall to do.

            #92145
            Member
            ile

              hello rej
              awaiting indicator-keylock news and trial. Thanks Moddit.
              meantime fallback conky play.
              Glad to hear that you will try a conky. Thanks.
              attention size sample fun . bigger(?)

              #for conky-legacy this: entering with set as ${color}${font} 
              num ${if_match "${exec xset -q|gawk '/Caps/ {print $8}'}"=="on"}${color lime}${font :bold:size=14} LOCK is ON${color}$font${else}${font}${color}off${endif}
              caps ${if_match "${exec xset -q|gawk '/Caps/ {print $4}'}"=="on"}${color orange}${font :bold:size=14} LOCK is ON${color}$font${else}${font}${color}off${endif}
              ${color khaki}hello ${color}
              $conky_version
              conky
              #for  newer conky version this: carry ${color}${font} 
              #num ${if_match "${key_num_lock}"=="On"}${color lime}${font :bold:size=14} LOCK is ON${color}$font${else}${font}${color}off${endif}
              #caps ${if_match "${key_caps_lock}"=="On"}${color orange}${font :bold:size=14} LOCK is ON${color}$font${else}${font}${color}off${endif}
              #92146
              Member
              PPC

                Adding the repository for it “sudo add-apt-repository ppa:tsbarnes/indicator-keylock” – “command not found”.

                Any suggestions?

                Yes, I have one suggestion- never, ever try to install a PPA in antiX, please read the sticky posts on the forum, with essential info on using antiX.
                More detailed explanation – a .deb included in a PPA may work perfecly fine in antiX (I’ve used them often), but you risk breaking your system- it may force the instalation of dependencies that are not the same versions that the rest of the system expect, and you end up with a brick, forcing you to reinstall your system – it’s ok if you are running live or just want to checkout if a particular .deb from a PPA is safe to use- in those cases, if you are sure that you don’t mind breaking a system, use said .deb files, otherwise, see the Sticky post about how to install apps in antiX…

                Try Moddit’s suggestion. If it fails to work, use web search engines and try to find a similar app…

                Edit: I just tried in my antiX 21 netbook – in fact I get a dependency that can’t be solved: libappindicator3-1 (>=0.2.92)
                If I find any suitable replacement, for a caps-lock indicator app in the system tray, I’ll post it here…

                P.

                • This reply was modified 1 year, 5 months ago by PPC.
                #92156
                Member
                ile

                  Thanks Moddit for the direction.
                  indicator-keylock with notifier+ systray icons+ preferences in antiX21 here.
                  then i unchecked a box and lost the tray icons.
                  Can you tell how to bring up the preferences dialog for indicator-keylock?

                  rej, there is hope, it is running but it hides the systray icons.

                  #92195
                  Member
                  ModdIt

                    Hi ile, sorry I do not know how to restore the capslock indicator,
                    is it in desktop session, or perhaps config.

                    #92221
                    Member
                    blur13

                      Install the mx package libindicator3-7

                      wget http://ftp.mx.debian.org/debian/pool/main/libi/libindicator/libindicator3-7_0.5.0-3+b1_amd64.deb
                      sudo apt install ./libindicator3-7_*

                      and libappindicator3-1
                      wget http://ftp.mx.debian.org/debian/pool/main/liba/libappindicator/libappindicator3-1_0.4.92-7_amd64.deb

                      the forum would not let me post the link to where I found this solution so instead replicating it here. Usually if a package works in mx but not antix the missing dependencies are also found in the mx repos (my experience from trying to install telegram from mx test repos).

                      • This reply was modified 1 year, 5 months ago by blur13.
                      #92243
                      Member
                      ile

                        hello blur13, latest, libappindicator3-1 0.4.92-8 mx21+1, libindicator3-7 0.5.0-4 mx21+1
                        rej, i went to another installation of antiX bullseye and took a picture where there is tray icons and all. .
                        hello everyone , antiX 21 indicator-keylock installed

                        Attachments:
                        #92277
                        Member
                        rej

                          Thank you all!

                          ——————–
                          PPC-

                          No PPA additions in the future – was experimenting with it only on very updated (day old) current live snapshot media, to see if would be work, but that was probably a bad idea also.

                          Thanks for the information.
                          —————-
                          Ile –

                          I have edited conky in the past, but had never added lines that did not exist in it to make a custom version. Thanks for your help, pictures, and especially your persistence! Please see attached “Onboard” and conky with battery addition – handy.

                          As a temporary fix until “indicator-keylock” could be installed, was using virtual keyboard (Onboard) and shrinking it down. It stays on top of what is opened and the caps-lock lights red when in use.

                          But now I have the real thing.
                          —————
                          ModdIt –

                          Success – I had tried installing the MX version so many times before and came up with the dependencies issue – so thanks for posting!
                          —————
                          blurr13 –

                          Great instructions! – Thanks so much!!

                          ———————–

                          Cannot mark as “solved” or I would.

                        Viewing 11 posts - 1 through 11 (of 11 total)
                        • You must be logged in to reply to this topic.