Laptop Lid-dissabling suspend/sleep/hib

Forum Forums General Hardware Laptop Lid-dissabling suspend/sleep/hib

  • This topic has 8 replies, 3 voices, and was last updated May 29-7:45 pm by dukester.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #83780
    Member
    dukester

    I want to connect a monitor to my laptop.
    I use a wireless keyboard, therefore:
    I want the laptop lid closed and out of the way.
    Without putting the laptop to sleep/suspend/hibernate.
    I can turn the laptop monitor off with a function key.

    Where do I change the settings for the laptop sleep/suspend/hibernate events?
    TIA …

    --
    dukester

    #83782
    Moderator
    caprea
    Helpful
    Up
    1
    ::

    This is configured in /etc/default/acpi-support

    Afaik the LID_Sleep and LID_SHUTDOWN are already outcommented in antiX by default.

    #83783
    Member
    dukester
    Helpful
    Up
    0
    ::

    On my system, both applicable settings are /not/ commented out.
    Thx! Now I know how .. 🙂

    --
    dukester

    #83787
    Member
    dukester
    Helpful
    Up
    0
    ::

    Didn’t work!
    I logged out first beforehand. No joy! Then I rebooted. No joy!
    Must be controlled somewhere else? Plan B?? TIA ..

    --
    dukester

    #83788
    Moderator
    caprea
    Helpful
    Up
    0
    ::

    Did you also try to set LID_SLEEP=false ?

    If this also does not help you could try to edit /etc/elogind/logind.conf

    Look for the line
    #HandleLidSwitch=suspend

    delete the # and change it to
    HandleLidSwitch=ignore

    save and reboot

    #83789
    Member
    dukester
    Helpful
    Up
    0
    ::

    Did you also try to set LID_SLEEP=false ?

    Nope! But I will .. and thx for the other possible solution!!

    --
    dukester

    #83790
    Member
    blur13
    Helpful
    Up
    0
    ::

    I’ve had the same issue as you and my solution was to install xfce4-power-manager (its in the repos).

    sudo apt install xfce4-power-manager

    Open the program and there are options for what closing the lid does, such as “do nothing”

    #83794
    Member
    dukester
    Helpful
    Up
    0
    ::

    try to edit /etc/elogind/logind.conf
    HandleLidSwitch=ignore

    That did the trick! Muchas Gratias!! 🙂

    --
    dukester

    #83795
    Member
    dukester
    Helpful
    Up
    0
    ::

    sudo apt install xfce4-power-manager

    Got it fixed, but I’ll install your suggestion as a back-up.
    Thanks for the info!

    --
    dukester

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.