latest update pulled in youtube-dl, breaking mpv streaming

Forum Forums Official Releases antiX-19 “Marielle Franco, Hannie Schaft, Manolis Glezos, Grup Yorum, Wobblies” latest update pulled in youtube-dl, breaking mpv streaming

Tagged: 

  • This topic has 9 replies, 4 voices, and was last updated Sep 6-5:24 am by Xunzi_23.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #114401
    Member
    blur13

      Hi!

      latest update, in antiX 19.5:

      The following NEW packages will be installed:
      youtube-dl (2021.04.07-1.0antix1)
      The following packages will be upgraded:
      libjavascriptcoregtk-4.0-18 (2.38.6-0+deb10u1 => 2.38.6-0+deb10u1.0nosystemd1)
      libwebkit2gtk-4.0-37 (2.38.6-0+deb10u1 => 2.38.6-0+deb10u1.0nosystemd1)
      openssh-client (1:7.9p1-10+deb10u2.0nosystemd1 => 1:7.9p1-10+deb10u3)
      openssh-server (1:7.9p1-10+deb10u2.0nosystemd1 => 1:7.9p1-10+deb10u3)
      openssh-sftp-server (1:7.9p1-10+deb10u2.0nosystemd1 => 1:7.9p1-10+deb10u3)
      unrar (1:5.6.6-1+deb10u1 => 1:5.6.6-1+deb10u3)
      yt-dlp (2023.03.04-1mx19+1 => 2023.07.06-1~mx19+1)

      I dont understand why youtube-dl was installed, I suspect it must have been because of the yt-dlp update? Anyways, when streaming youtube videos using mpv, yt-dlp should be used instead of youtube-dl. This is accomplished using a symlink

      $ ls -l /usr/bin/youtube-dl
      lrwxrwxrwx 1 root root 15 Aug 17 23:25 /usr/bin/youtube-dl -> /usr/bin/yt-dlp

      The package youtube-dl (2021.04.07-1.0antix1) replaces the symlink with the actual binary youtube-dl (which is deprecated, doesnt work at all).

      In case anyone else got a similar update then I recommend uninstalling youtube-dl and recreating the symlink

      sudo ln -s /usr/bin/yt-dlp /usr/bin/youtube-dl

      #114402
      Member
      blur13

        I cant figure out why youtube-dl is pulled in. Its not a dependency of yt-dlp. The same thing happend on another antiX 19.5 system that I dist-upgraded.

        $ apt-cache depends yt-dlp
        yt-dlp
        Depends: python3-pkg-resources
        Depends: python3-brotli
        Depends: python3-certifi
        Depends: python3-mutagen
        Depends: python3-pycryptodome
        Depends: python3-websockets
        Depends: <python3:any>
        python3:i386
        python3
        |Recommends: aria2
        |Recommends: wget
        wget:i386
        Recommends: curl
        curl:i386
        Recommends: ca-certificates
        Recommends: ffmpeg
        ffmpeg:i386
        Recommends: python3-pyxattr
        python3-xattr
        Recommends: rtmpdump
        |Suggests: libfribidi-bin
        Suggests: bidiv
        bidiv:i386
        |Suggests: mpv
        mpv:i386
        Suggests: mplayer
        mplayer:i386
        Suggests: phantomjs

        #114403
        Member
        blur13

          Youtube-dl is a recommended package of mpv, and I have set up apt to install recommended packages. But mpv wasnt updated. And I assume the recommended packages of mpv hasnt changed. Even so, would a change in recommended packages of an installed package trigger the installation of the newly recommeded packages? This is a mystery (to me).

          #114408
          Member
          Xunzi_23

            Hi blur 13,
            Thank you for useful post.
            Some time ago I had same problem. In the end I apt pinned ytdl to keep it away.
            First part of my mpv config as below. In case it can be of assistance.
            Rest is from subluminal. http://github.com/subluminal-byte/mpv-config-video-image-viewer
            Changing config makes a huge difference if the hardware can handle the load :-).

            ## Global Settings ##
            ######################
            script-opts=ytdl_hook-ytdl_path=/usr/bin/yt-dlp
            vo=gpu
            hwdec=auto-safe # hwdec=no is default and overall best option if you plan to use a lot of filters. Some filters simply won't work without hwdec=no
            fullscreen=no
            ytdlp-format=bv*[height<=?1440]+ba/best
            ytdlp-raw-options=no-playlist=
            script-opts-append=ytdl_hook-ytdl_path=/usr/bin/yt-dlp # change the path as needed
            idle=yes
            video-sync=display-resample
            msg-level=all=v
            hr-seek-framedrop=no                # Fixes audio desync
            resume-playback=no                  # Not compatible with SVP
            #x11-bypass-compositor=yes
            #fbo-format=rgba16f # For FSRCNN
            # ===== Audio set to always use alsa=====
            ao=alsa
            audio-device= Audigy2
            #114409
            Member
            blur13

              Thanks Xunzi_23!

              For some reason the script-opts=ytdl_hook-ytdl_path=/usr/bin/yt-dlp and script-opts-append=ytdl_hook-ytdl_path=/usr/bin/yt-dlp doesnt work on the version of mpv in antix 19 (mpv v. 32), thats why I use the symlink solution. I think all that has been sorted in more recent versions. I dont recall needing a symlink on MX 23, for instance.

              I use
              ytdl-format=bestvideo[height<=?1080][fps<=?30][vcodec!*=?vp]+bestaudio/best

              the important part is vcodec!*=?vp, when streaming from youtube you will always get the h264 codec. Works better on old hardware (and is just plain better on all hardware, in my opinion)

              #114422
              Member
              calciumsodium

                [fps<=?30]

                Hello,

                I have used fps <= 30 for a long time, but have taken this part out on my newer computers. The quality of the video is so much better. Yes, the CPU will work harder. But I have found out that if your CPU is an i3 clocking at about 2.400 GHz or better, it is not much of a difference. On an i5 CPU, the difference is neglible. I am suggesting on newer computers, this fps <= 30 requirement is not necessary. The video experience will be very good, especially on antiX23, which has the newer xorg video renderer. Also, many newer streams only have 60 fps.

                On old computers, this fps <= 30 is a must. Otherwise, the CPU is working very hard.

                I have been using vp9. I tried the vp. There does not seem to be much of a difference between vp9 and vp.

                • This reply was modified 10 months, 1 week ago by calciumsodium.
                #114427
                Member
                blur13

                  @calciumsodium

                  Thank you, I’ll try removing the 30 fps limit on my newer computers. I always thought anything over 30 fps was overkill, I mean feature films are usually 24 fps. But I’ve recently started recording video in 60 fps on my phone and the result is much better than 30 fps, especially when there is a lot of action.

                  Regarding the vp9 codec, I used to have vcodec!*=?vp9 but that doesnt work anymore on youtube since the codec is identified as vp09. Using vp* catches that.

                  #114428
                  Member
                  Xunzi_23

                    Thanks calciumsodium, I guess different settings perform differently according to hardware.

                    a friend has a device with a reasonably fast core duo, that performs well enough at 60fps to full HD monitor.
                    Caveat: As long as players are involved. Watching video in a browser is not satisfying.
                    OS is antiX 22 6 series kernel running and caching from is from a fast San Disk SSD.

                    What I find very important is cooling, CPU and memory, that ca 12 year old device works way better since I cleaned it
                    carefully then replaced CPU cooling paste plus re lubricated fans. Memory is from a gamers hoard, has heat spreader
                    cooling and runs as fast as BIOS and bus allow, fitting it did make a noticeable difference. Before we saw video glitches.

                    • This reply was modified 10 months, 1 week ago by Xunzi_23.
                    #116089
                    Member
                    Stéphane Ascoët

                      I cant figure out why youtube-dl is pulled in. Its not a dependency of yt-dlp. The same thing happend on another antiX 19.5 system that I dist-upgraded.

                      I’ve noticed the same behavior and it seems that it’s related with a ytfzf dependency

                      #116090
                      Member
                      Xunzi_23

                        ytfzf depends: according to http://github.com/pystardust/ytfzf#Dependencies
                        ytdlp is an optional not ytdl. I had same problem months ago, can not remember
                        how I fixed it, think it was in a config.

                        Required dependencies are jq and curl

                        Recommended dependencies

                        mpv (the default video and audio player)
                        fzf (the default menu selection screen)

                        Optional dependencies

                        yt-dlp (for downloading)
                        dmenu (only if using the -D option)
                        ueberzugpp
                        needed for the following thumbnail viewers:
                        kitty, iterm2, sixel, and ueberzug ueberzug seems to be deprecated as it will not work with wayland
                        ueberzugpp is intended as a dropin replacement

                        Do you have any extra rhel/gnome apps, many of those pull in a host of crappy depends. ytdl seems to be in undead, the zombie
                        is still pushed as integrated in gnome shell setup. And recommended for some Buntu flavours and puke: IBM/Rhel.

                        • This reply was modified 9 months, 3 weeks ago by Xunzi_23.
                      Viewing 10 posts - 1 through 10 (of 10 total)
                      • You must be logged in to reply to this topic.