lenovo b50-80 sound

Forum Forums Official Releases antiX-17 “Heather Heyer” lenovo b50-80 sound

  • This topic has 3 replies, 4 voices, and was last updated Jul 8-2:19 pm by Xecure.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #25332
    Member
    Avatarzpimp

    so i have this laptop, with 2 sound cards (i assume one is hdmi out)
    select sound card only lists one – intel pch wich is the correct ( real one)
    but it doesent output sound, until i install pulseaudio
    is there another way without pulse? i dont like pulseaudio on my linux 🙂

    demo@antix1:~
    $ inxi -F
    System:
      Host: antix1 Kernel: 4.9.160-antix.2-486-smp i686 bits: 32 Desktop: IceWM 1.4.2 
      Distro: antiX-17.4.1_386-full Helen Keller 28 March 2019 
    Machine:
      Type: Laptop System: LENOVO product: 80EW v: Lenovo B50-80 serial: <root required> 
      Mobo: LENOVO model: Lenovo B50-80 v: No DPK serial: <root required> 
      UEFI [Legacy]: LENOVO v: A8CN54WW(V3.07) date: 09/02/2016 
    Battery:
      ID-1: BAT1 charge: 25.2 Wh condition: 25.3/28.5 Wh (89%) 
    CPU:
      Topology: Dual Core model: Intel Core i3-5010U bits: 64 type: MT MCP 
      L2 cache: 3072 KiB 
      Speed: 2000 MHz min/max: 500/2000 MHz Core speeds (MHz): 1: 2000 2: 2000 3: 2000 
      4: 2000 
    Graphics:
      Device-1: Intel HD Graphics 5500 driver: N/A 
      Display: server: X.Org 1.19.2 driver: vesa unloaded: fbdev,modesetting 
      resolution: 1368x768~N/A 
      OpenGL: renderer: Gallium 0.4 on llvmpipe (LLVM 3.9 256 bits) v: 3.3 Mesa 13.0.6 
    Audio:
      Device-1: Intel Broadwell-U Audio driver: snd_hda_intel 
      Device-2: Intel Wildcat Point-LP High Definition Audio driver: snd_hda_intel 
      Sound Server: ALSA v: k4.9.160-antix.2-486-smp 
    Network:
      Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
      IF: eth0 state: down mac: f0:76:1c:69:8c:a7 
      Device-2: Intel Wireless 3160 driver: iwlwifi 
      IF: wlan0 state: up mac: 34:de:1a:de:76:05 
    Drives:
      Local Storage: total: 14.71 GiB used: 245.5 MiB (1.6%) 
      ID-1: /dev/sda type: USB vendor: Transcend model: JetFlash Transcend 16GB 
      size: 14.71 GiB 
    Partition:
      ID-1: / size: 1.90 GiB used: 245.5 MiB (12.6%) fs: overlay source: ERR-102 
    Sensors:
      System Temperatures: cpu: 43.0 C mobo: 43.0 C 
      Fan Speeds (RPM): N/A 
    Info:
      Processes: 146 Uptime: 9m Memory: 2.40 GiB used: 445.2 MiB (18.1%) Shell: bash 
      inxi: 3.0.29 
    #38643
    Member
    AvatarMartin

    Hi,

    i had the same problem with my T440. No sound over the intern card.

    $ aplay -l
    **** Liste der Hardware-Geräte (PLAYBACK) ****
    Karte 0: PCH [HDA Intel PCH], Gerät 0: ALC3202 Analog [ALC3202 Analog]
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0
    Karte 0: PCH [HDA Intel PCH], Gerät 3: HDMI 0 [HDMI 0]
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0
    Karte 0: PCH [HDA Intel PCH], Gerät 7: HDMI 1 [HDMI 1]
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0
    Karte 0: PCH [HDA Intel PCH], Gerät 8: HDMI 2 [HDMI 2]
      Sub-Geräte: 0/1
      Sub-Gerät #0: subdevice #0
    martin@antix:~
    

    I found a solution here: https://wiki.debianforum.de/Audiokonfiguration

    I have created a “.asoundrc” in the root of my home.

    defaults.pcm.!card 0
    defaults.pcm.!device 8

    After reboot i can use alsamixer with the output “pre-Amp”. On “Open-Mixer” you can change the Channel to “PRE-AMP”.

    #38645
    Member
    Avatarkksmith

    i would try running alsamixer in terminal:

    first check to see if any outputs are muted;
    then press F6 to pick the right sound card;
    then esc out of alsamixer.
    save setting by sudo alsactl store. might have to reboot.

    #38651
    Member
    XecureXecure

    Martin’s answer is correct. Sometimes alsamixer and sound card selector do not pick the correct device, and one needs to create a file .asoundrc in home or editing the one in /etc.
    But kksmith is also right (to first test if the channel is muted).

    There are a few problems in the forum that could only be solved using Martin’s advice.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.