Liquorix 6.8 kernel – not showing in grublist on booting

Forum Forums New users New Users and General Questions Liquorix 6.8 kernel – not showing in grublist on booting

  • This topic has 4 replies, 3 voices, and was last updated Jun 4-11:16 am by Brian Masinick.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #144070
    Member
    mikey777

      I thought I’d try the Liquorix kernel on my 16-year-old laptop (Asus X71Q), so installed the 6.8 version onto antiX-21 as described in https://www.linuxcapable.com/how-to-install-liquorix-kernel-on-debian-linux/

      Its install appeared to go smoothly. However, it doesn’t appear in the grublist at boot-up, so I’m unable to select it on the grubscreen during booting, despite the grub-file being updated. There seems to be some information relating to this at the end of the following terminal output, but don’t know how I can fix this:

      asus@asus:~
      $ sudo apt list --installed | grep linux-image
      [sudo] password for asus: 
      WARNING: apt does not have a stable CLI interface. Use with caution in scripts.
      linux-image-5.10.194-gnu1/now 5.10.194-gnu1-1.0 amd64 [installed,local]
      linux-image-6.8.12-1-liquorix-amd64/stable,now 6.8-18.1~bookworm amd64 [installed,automatic]
      linux-image-liquorix-amd64/stable,now 6.8-18.1~bookworm amd64 [installed]
      asus@asus:~
      $ sudo update-grub
      Generating grub configuration file ...
      Found background: /usr/share/wallpaper/grub/back.png
      Found background image: /usr/share/wallpaper/grub/back.png
      Found linux image: /boot/vmlinuz-6.8.12-1-liquorix-amd64
      Found linux image: /boot/vmlinuz-5.10.194-gnu1
      Found initrd image: /boot/initrd.img-5.10.194-gnu1
      Warning: os-prober will not be executed to detect other bootable partitions.
      Systems on them will not be added to the GRUB boot configuration.
      Check GRUB_DISABLE_OS_PROBER documentation entry.
      done

      Any help on this is much appreciated.

      • This topic was modified 1 month, 3 weeks ago by mikey777.
      • This topic was modified 1 month, 3 weeks ago by mikey777.
      • This topic was modified 1 month, 3 weeks ago by mikey777.

      ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
      - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
      ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
      - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
      - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

      #144078
      Member
      abc-nix

        It looks like the initrd image was not created for the liquorix kernel.

        What do you see when you run
        sudo update-initramfs -u -k all
        ? Does it generate an initrd image for the liquorix 6.8.12 kernel? If it does, then update grub again to see if it detects it.

        #144086
        Moderator
        Brian Masinick

          “Warning: os-prober will not be executed to detect other bootable partitions.
          Systems on them will not be added to the GRUB boot configuration.
          Check GRUB_DISABLE_OS_PROBER documentation entry.”

          This means what it says.

          Check the file /etc/default/grub.

          I have this:
          # If your computer has multiple operating systems installed, then you
          # probably want to run os-prober. However, if your computer is a host
          # for guest OSes installed via LVM or raw disk devices, running
          # os-prober can cause damage to those guest OSes as it mounts
          # filesystems to look for things.
          GRUB_DISABLE_OS_PROBER=false

          Set GRUB_DISABLE_OS_PROBER=false
          Then run update-grub and you should see your kernels and full set of alternatives;
          it has NOTHING to do with other matters, unless the kernel itself is tainted.

          --
          Brian Masinick

          #144087
          Moderator
          Brian Masinick

            If it STILL fails, run sudo apt update; sudo apt install –reinstall linux-image-liquorix-amd64
            then make sure you have the settings I indicated above; reinstalling the kernel should ensure
            that you get the correct initrd configuration, with or without header files; I prefer to run
            my configuration WITHOUT header files because I do not need the capabilities they offer in
            addition to JUST the kernel; a kernel and initrd are sufficient for simple browsing and editing;
            since that’s all I do, that’s enough for me, particularly in extra lean configurations.

            --
            Brian Masinick

            #144270
            Moderator
            Brian Masinick

              For what it’s worth, IF you use a Liquorix kernel, the 6.8.12-1-liquorix-amd64 is now several days old; my current Liquorix kernel is (and has been for at least two days): version 6.9.3-1-liquorix-amd64.

              --
              Brian Masinick

            Viewing 5 posts - 1 through 5 (of 5 total)
            • You must be logged in to reply to this topic.