Live-USB creator issues.

  • This topic has 6 replies, 5 voices, and was last updated Jan 11-11:47 pm by olsztyn.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #49592
    Member
    catfood

    I currently have 1 installed MX 19.2, one install sid core in progress, and a 19.2 of antiX and 19.2 MX live on USBs. The issue started a few months ago on whichever live-usb I did last, it took a lot of tries.

    Currently trying to make another antiX liveusb, but cannot for the life of me. I have tried live-usb maker from all the (up & running)above using a known good 19.2 antiX iso. Failed from all. Currently, “clone running antiX” is also failing(I think that was the only way last one did pass). Today, I got new gpg/sha verified antiX 19.3 full, but similar if not same failures.

    Regardless clone or iso(or new iso), always seems to fail creation between 1.5-3 seconds. As I remember, always fails around same step too:
    (copied txt from live-usb maker tonight:)

    “Ready to make encrypted live-usb on device sdg
    … by copying file /home/demo/Live-usb-storage/antiX-19full/antiX-19.3_x64-full.iso
    live-usb-maker 2.41.18: partition-clear >> partition-clear
    live-usb-maker 2.41.18: partition-make >> partition-make
    Using msdos partitioning
    live-usb-maker 2.41.18: makefs-data >> makefs-data
    live-usb-maker 2.41.18: makefs-data >> makefs-data
    Make ext4 filesystem
    live-usb-maker 2.41.18: set-ownership >> set-ownership
    Setting data partition ownership to demo:users
    live-usb-maker 2.41.18: makefs-bios >> makefs-bios
    live-usb-maker 2.41.18: makefs-uefi >> makefs-uefi
    live-usb-maker 2.41.18: encrypt-main >> encrypt-main

    live-usb-maker took 2 minutes and 8 seconds.” :

    – [GUI popup failure] –

    Most if not all fails seem to occur around that encryption step.
    Between live-usb maker attempts, I have gparted new table, and or new table with a blank fat32/exfat single partition, like most dd to usb’s ask for.
    I have also tried dd /dev/zero and /dev/urandom to make sure USB was fully clear between. I checked new usb with I believe fdisk and per a thread elsewhere, a terminal badblocks check. No badblocks or other hardware failures seem present on USB, so not sure what else I could try?

    Failed with either exfat or ext4 for storage partition.
    Currently trying to do encrypted, use full usb, use 50% for ext4 storage, default the rest. (though I have disabled automount on all my working antiX, always sudo umount the usb b4 proceeding to make sure(cautious paranoia), and have tried on and off clicking [x] disable automount option in usb-maker as well, but no noticeable difference.

    No rush as always, just exhausted my troubleshooting logic, so above my “pay-grade” at this point…
    Thanks.

    • This topic was modified 5 months, 1 week ago by catfood. Reason: I forget details
    • This topic was modified 5 months, 1 week ago by catfood.
    • This topic was modified 5 months, 1 week ago by catfood.

    Howdy Jessie.

    #49598
    Member
    Robin
    Helpful
    Up
    0
    :D

    hello catfood

    Just created an 19.3 USB stick some hours ago, without any errors.

    Only difference seems to be: I dont use encrypted file system. So, did you give it a try without encryption?

    Here is the complete output, maybe it can be of any help to you:

    ===============================================================================
    Starte live-usb-maker
    ===============================================================================
    live-usb-maker Found live media device /dev/sdb
    Gerät /dev/sdc (58,6G Generic Flash Disk) wird als Ziel verwendet
    Datei /media/_daten4/antiX 19/antiX-19.3_386-full.iso wird als Quelle verwendet
    Distro: antiX-19.3_386-full Manolis Glezos 15 October 2020

    gesamt benutzt unbelegt
    Gesamtes Laufwerk 60,000 59,999 1 MiB
    Hauptpartition 59,949 1,239 58,710 MiB
    UEFI Partition 50 18 32 MiB
    Bereit live-usb auf Gerät sdc
    … mit Kopiere Datei /media/_daten4/antiX 19/antiX-19.3_386-full.iso zu erstellen
    live-usb-maker: partition-clear >> partition-clear
    live-usb-maker: partition-make >> partition-make
    gpt Partitionierung wird verwendet
    live-usb-maker: makefs-bios >> makefs-bios
    mke2fs 1.43.4 (31-Jan-2017)
    64-bit filesystem support is not enabled. The larger fields afforded by this feature enable full-strength checksumming. Pass -O 64bit to rectify.
    Ein Dateisystems mit 15346688 (4k) Blöcken und 630336 Inodes wird erzeugt.
    UUID des Dateisystems: 326eac56-4981-40d1-9a28-14376a8aa6a7
    Superblock-Sicherungskopien gespeichert in den Blöcken:
    32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
    4096000, 7962624, 11239424

    beim Anfordern von Speicher für die Gruppentabellen: 0/469 erledigt
    Inode-Tabellen werden geschrieben: 0/469 erledigt
    Das Journal (8192 Blöcke) wird angelegt: erledigt
    Die Superblöcke und die Informationen über die Dateisystemnutzung werden
    geschrieben: 0/469 erledigt

    tune2fs 1.43.4 (31-Jan-2017)
    live-usb-maker: makefs-uefi >> makefs-uefi
    mkfs.fat: warning – lowercase labels might not work properly with DOS or Windows
    mkfs.fat 4.1 (2017-01-24)

    Dateisystem Typ Größe Benutzt Verf. Verw% Eingehängt auf
    /dev/sdc1 ext4 59G 52M 59G 1% main
    /dev/sdc2 vfat 50M 0 50M 0% uefi

    live-usb-maker: copy-uefi >> copy-uefi
    Kopiere von iso auf Partition uefi
    Dateien: [Ee][Ff][Ii] boot/{grub,uefi-mt} version
    Dell uefi memtest Bug beheben
    live-usb-maker: copy-main >> copy-main
    Kopiere von iso auf Partition main
    copy /antiX/vmlinuz
    ext4 defragmentation for ./antiX/vmlinuz
    [1/1][79;0H[K[1/1]./antiX/vmlinuz: 0%[79;0H[K[1/1]./antiX/vmlinuz: 100% extents: 2 -> 1 [ OK ]
    Success: [1/1]
    copy /antiX/initrd.gz
    ext4 defragmentation for ./antiX/initrd.gz
    [1/1][79;0H[K[1/1]./antiX/initrd.gz: 0%[79;0H[K[1/1]./antiX/initrd.gz: 100% extents: 2 -> 1 [ OK ]
    Success: [1/1]
    copy remaining files …

    live-usb-maker: check-usb-md5 >> check-usb-md5
    check md5 for initrd.gz
    initrd.gz: OK
    check md5 for linuxfs
    linuxfs: OK
    check md5 for vmlinuz
    vmlinuz: OK
    live-usb-maker: uuids >> uuids
    live-usb-maker: install >> Installieren
    extlinux version 6.03
    /run/live-usb-maker/main/boot/syslinux is device /dev/sdc1

    Dateisystem Typ Größe Benutzt Verf. Verw% Eingehängt auf
    /dev/sdc1 ext4 59G 1,3G 58G 3% main
    /dev/sdc2 vfat 50M 20M 31M 39% uefi

    >> Abgeschlossen

    live-usb-maker took 5 minutes and 42 seconds.

    Robin.

    P.S.: since there is mentioned an error concerning a popup in UI, you may give it a try using another desktop manager.

    • This reply was modified 5 months, 1 week ago by Robin.
    #49614
    Member
    Xecure
    Helpful
    Up
    0
    :D

    . I clearly don’t know what I am talking about

    • This reply was modified 5 months, 1 week ago by Xecure. Reason: Removed comment
    #49616
    Member
    skidoo
    Helpful
    Up
    0
    :D

    /var/log/live-usb-maker-gui-antix.log
    Are any further details provided in the logfile?

    #49620
    Member
    olsztyn
    Helpful
    Up
    0
    :D

    Encryption has been a problem for live USB for some time. That is probably the issue you are experiencing. Make sure the live-usb-maker is up to date, just in case some bug fixes have solved the specific problem you are experiencing.

    Just to mention, I am mostly using encrypted antiX Live USB and it works with no problem for me. My antiX Live is 19.2 Hannie Schaft fully updated, which is in my understanding the same composition as 19.3. Please correct me if there is any difference, though…
    Just from my experience with Live antiX Live USB Maker:
    – Cloning from unencrypted Live USB antiX works fine to create another unencrypted Live USB
    – Cloning from encrypted Live antiX works fine to unencrypted Live antiX
    – Cloning from encrypted Live antiX to encrypted Live antiX has proved not to work since version 2.15, if I got the version terminology right…
    Live USB Maker and cloning Live antiX is important to me as Live antiX is what I run on all my many different Thinkpads.
    I should add that one peculiar condition I came to realize was that when cloning or remastering one should take thee laptop out of docking station, even if usb sticks are directly in the laptop not in docking station. I experience cloning and remastering errors if laptop is in docking station. I do not understand why this would matter but apparently there is something that throws these programs out of the water if plugged in…

    • This reply was modified 5 months, 1 week ago by olsztyn.
    #49624
    Member
    Xecure
    Helpful
    Up
    0
    :D

    Just to mention, I am mostly using encrypted antiX Live USB and it works with no problem for me.

    Sorry for making assumptions based on past threads. I don’t know what I am talking about. Please help the user as best you can, olsztyn, as you have more experience than me with encrypting USB devices.

    #49627
    Member
    olsztyn
    Helpful
    Up
    0
    :D

    Sorry for making assumptions based on past threads.

    Xecure – nothing to be sorry about, Live USB Maker is one of the most valuable and important tools of antiX, but there was some complexity that affected expectation that it would work reliably after updates…
    I remember BitJam came up with a plan to re-code certain part of it about one and half year ago. This was prompted by the fact that certain redundancy of vmlinuz and initrdr had to be in place, in case you switch kernel… Long story, so not going into details now. I do not know what happened to that project, fact is that each time I do an upgrade I test extensively whether Live USB Maker still works correctly… If still works fine, then I upgrade the entire caboodle.
    Thanks and Regards…

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.