Live USB doesn’t honour boot settings

Forum Forums Official Releases antiX-23 “Arditi del Popolo Live USB doesn’t honour boot settings

Tagged: 

  • This topic has 5 replies, 3 voices, and was last updated Apr 20-10:36 pm by spammy.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #139983
    Member
    spammy

      antiX 23.1

      I have created a “fully featured” live USB by first dd’ing the base iso to a temporary USB, and then booting that to access live-usb-creator to create the actual real Live USB I wish to work with (using the base ISO to clone off).

      In both the “naive” live usb and “fully featured” live usb, no options set in the UEFI menu at boot are respected. No locale setting, no desktop setting, and significantly for the latter stick, no persistence setting.

      The only error I see is “Warning: MD5 CHECK FAILED FOR vmlinuz1” while creating the second USB (which does boot so…). I have tried multiple ISOs.

      I didn’t think anything of the naive stick not honouring the boot settings (thought it was expected), but the fact that neither do indicates some kind of systemic issue. Am I missing something obvious?

      • This topic was modified 1 month ago by spammy.
      #139985
      Forum Admin
      anticapitalista

        Have you set up a persistence file?
        Did you use the Save option in the live menu?

        Philosophers have interpreted the world in many ways; the point is to change it.

        antiX with runit - leaner and meaner.

        #139990
        Member
        spammy

          Persistence file: Not explicitly – I was under the impression that I only had to select “fully featured” in the Live USB Maker menu.

          Save option: I couldn’t see one strikingly obvious. I’ll have another closer look.

          #139991
          Forum Admin
          anticapitalista

            A bit old, but should help
            https://www.google.com/search?client=firefox-b-e&q=antiX+eufi+live+options#fpstate=ive&vld=cid:69236b38,vid:2BKAWeXZ4uU,st:0

            Philosophers have interpreted the world in many ways; the point is to change it.

            antiX with runit - leaner and meaner.

            #140002
            Member
            abc-nix

              In << Advanced Options >>, Save options, grubsave

              Should save UEFI boot options. Should work for base and full, but not sure if it works for core and net.

              Once you boot into the live system, run this command to check if it has added the correct boot parameters.
              cat /proc/cmdline

              for language selection, it should be lang=<lang_code>, for keyboard layout kbd=<keyboard-code>, etc.

              #140026
              Member
              spammy

                A bit old, but should help
                https://www.google.com/search?client=firefox-b-e&q=antiX+eufi+live+options#fpstate=ive&vld=cid:69236b38,vid:2BKAWeXZ4uU,st:0

                I read “The Most Extensive Live-usb on the Planet!” which got me this far and noted the difference between legacy and UEFI boot. None of the F keys seemed to do anything. Interestingly however the search did lead me to this: https://www.antixforum.com/forums/topic/uefi-live-menu-changes-not-saved/ so it seems I’m not going crazy.

                In << Advanced Options >>, Save options, grubsave

                I did select this to no avail previously.

                BUT!

                It seems to be working now suddenly. I get a desktop and even a question on exit of the boot menu asking if I wish to create persistence. All very strange.

                I did disable “Legacy USB Support” in BIOS before it started working, but enabling this again doesn’t stop it from working. One significant difference is that on exiting the boot menu I now see a pretty screen with “alt f1” and “alt f10” options and a status bar of dots. Previously I would see a quick reboot to the motherboard logo, then stream of boot messages starting with a disk scan looking for something to boot and ending at a terminal login.

                I’m also now missing a menu item “>>>Advanced Options for antiX-23.1 x64-base<<< that I think I had before.

                Anyway, I suppose this is fixed for me. Happy to experiment further if you feel it’s needed.

              Viewing 6 posts - 1 through 6 (of 6 total)
              • You must be logged in to reply to this topic.