Lost audio output… Help!

Forum Forums Official Releases antiX-16 “Berta Cáceres” Lost audio output… Help!

  • This topic has 6 replies, 6 voices, and was last updated Nov 27-3:56 am by SamK.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2268
    Member
    AvatarPPC

    Hi. I have a recent (a couple of weeks old) 64 bits 16.2 install on my old intel netbook. Out of nowhere, I lost all audio output that had been working great the day before. Booting from a 17 live usb, the audio works great…
    My inxi -A output is:
    Audio: Card Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel
    Sound: Advanced Linux Sound Architecture v: k4.4.10-antix.1-amd64-smp

    I tried rebooting, Using CC to test audio output (no audio), I used alsa mixer, the default Card and chip say just “pulseaudio”, so I try selecting “HDA intel” sound card (the info changes to Card: HDA Intel Chip: Realtek ALC269″, turned all audio output to the max, Disabled automute… and still no sound…
    As I said, the hardware is working (my root persistant live usb 17 antix has audio, strangely, the volume was down to 0, I had to turn it up, to test the audio… And no, I don’t want to upgrade to 17, is not that smooth on my hardware…).
    One note: when I log on, I have the volume icon crossed out, like it was on mute. I turn the volume up, and nothing happens. I tried to connect phones, also, the “mute” icon on the bar, also turn volume to the max, and still no sound…
    Any help is appreciated.

    • This topic was modified 2 years ago by PPC.
    #2278
    Member
    anarcomanarcom

    could:
    amixer set Master unmute
    be of help?

    #2313
    Forum Admin
    DaveDave

    Did this happen with a recent update / program install?
    My guess it that you now have pulse audio installed and need to change the settings for pulse (using pavctrl IIRC) rather than for alsa like you have been trying. Or perhaps another way might be to remove pulse audio? I am not to familiar with the pulse audio/alsa interaction. Perhaps someone else can help out better as I am pretty sure MX uses pulse.

    Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

    #2488
    Member
    AvatarPPC

    Thanks, Anarcom! That did it!
    @ Dave: thanks for your input. If this happened after installing anything, I’m not really sure. But I recently did a apt-get update on my system, I’m not sure if that was before or after losing sound output.
    I’ll keep this thread open for a while, to try to figure out what happened and to check if this was a permanent fix…

    Many thanks!

    #2772
    Member
    jdmeaux1952jdmeaux1952

    Now since I move back and forth between machines (which shouldn’t effect any of this), AND I use headphones or speakers depending who is home (my wife doesn’t like to listen to my music at concert levels like I do), I too have had the problem occasionally on both machines. I found that if I go into the Audio Mixer for alsa, my speaker either gets muted or it locks the Line Out/Headphones to whichever I was using last before a shutdown. If I was using the headphones and shutdown the machine, if I restart it with the headphones disconnected, it will stay as if it had the headphones plugged in when they are NOT. But a simple mouse click solves that problem.

    At first I thought it was a PLUG problem, but if I unplug the headphones before shutting down to get speakers, it doesn’t do it on a restart. I have cleaned the headphone plugs on both machines, and I even went so far as replacing the phone jack on the laptop. I have no idea if it is a hardware problem or a bug in the system files. So I just use a few mouse clicks to fix it.

    JD

    • This reply was modified 1 year, 12 months ago by jdmeaux1952.

    The Kernel has my back covered.
    AMD desktop FX-8320 ASUS M5A97 LE R2.0 nVidia GeForce 730 GT 8 Gb memory
    MSI laptop S6000 i5-460M 4 Gb ram

    A great mind is something to get terribly wasted.
    LRU# 563815

    #2788
    Member
    Avatarskidoo

    At first I thought it was a PLUG problem, but if I unplug the headphones before shutting down to get speakers, it doesn’t do it on a restart. I have cleaned the headphone plugs on both machines, and I even went so far as replacing the phone jack on the laptop. I have no idea if it is a hardware problem or a bug in the system files. So I just use a few mouse clicks to fix it.

    JD

    ^——— Tip of the week ! ! !

    Thanks!

    #3171
    Forum Admin
    AvatarSamK

    …my speaker either gets muted or it locks the Line Out/Headphones to whichever I was using last before a shutdown. If I was using the headphones and shutdown the machine, if I restart it with the headphones disconnected, it will stay as if it had the headphones plugged in when they are NOT.
    …if I unplug the headphones before shutting down to get speakers, it doesn’t do it on a restart.

    ALSA uses a file to enable its settings to survive between each boot up.
    For antiX it is /var/lib/alsa/asound.state.

    • At system startup it automatically reads the previous values from the file.
    • At system shutdown it automatically saves the current values to the file.

    Perhaps the reported behaviour might be a result of the usual way ALSA works in antiX.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.