[Solved] Lost sound on Antix-19.2.1-x64-Base

Forum Forums New users New Users and General Questions [Solved] Lost sound on Antix-19.2.1-x64-Base

  • This topic has 7 replies, 3 voices, and was last updated Aug 2-4:32 am by anilkagi.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #39655
    Member
    Avataranilkagi

    Hello,
    Probably I lost sound after doing any or all of the following, which I exactly don’t remember.

    sudo apt-get autoclean
    sudo apt-get clean
    sudo apt-get autoremove
    deborphan | xargs apt-get -y remove
    COLUMNS=200 dpkg -l |grep ^rc |awk '{print $2} ' | xargs dpkg -P

    Now when I start any audio or video file, in vlc I get;

    
    Audio output failed:
    The audio device "default" could not be used:
    No such device or address.

    XMMS gives the error asking me to check if;

    Soundcard is properly configured
    Correct output plugin is selected
    No program is blocking the soundcard

    I checked Alsamixer. There seems to be no issue there. I selected the soundcards being displayed on pressing F6: Defaults & Intel HDA. Both selections didn’t work.

    I even reinstalled some packages related to Alsa/Sound/Audio through Synaptic and rebooted. The problem persists.

    How do I resolve the issue?

    Thanks & Regards

    • This topic was modified 2 weeks ago by anilkagi.
    • This topic was modified 2 weeks ago by anilkagi.
    • This topic was modified 1 week, 6 days ago by anilkagi.
    #39662
    Member
    XecureXecure

    We need more info, for general info:
    inxi -Fxz
    See what you recently upgraded/installed:
    cat /var/log/apt/history.log | tail -30

    Se what you recently uninstalled with that command
    cat /var/log/dpkg.log | tail -500

    If possible, instead of pasting it here, upload a txt file containing the commands.

    If you don’t want to publish it here for privacy, then read those command outputs and search for possible sound and alsa packages and libraries that were updated/uninstalled.

    #39663
    Member
    capreacaprea

    Might also be helpful the output of
    aplay /usr/share/sounds/alsa/Front_Center.wav

    #39664
    Member
    Avataranilkagi

    Thanks Xecure & Caprea for coming,

    Though I will try to read them myself, but I don’t think I can discern much, so I am posting the outputs here below.

    The returns of the commands,

    inxi -Fxz
    
    cat /var/log/apt/history.log | tail -30
    
    cat /var/log/dpkg.log | tail -500  
    
    aplay /usr/share/sounds/alsa/Front_Center.wav 

    are as in the attachments given below;

    Thank you

    • This reply was modified 1 week, 6 days ago by anilkagi.
    • This reply was modified 1 week, 6 days ago by anilkagi.
    • This reply was modified 1 week, 6 days ago by anilkagi.
    #39672
    Member
    XecureXecure

    Unfortunetly, the 500 latest lines of output for dpkg.log only contains data for today, and nothing for the deleted packages from deborphan and dpkg -P.
    The correct kernel module is being used, no problems there.
    Good thing caprea recommended the aplay test:
    ALSA lib dlmisc.c:287:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_equal.so
    reinstall libasound2-plugin-equal and, just in case, alsamixer-equalizer-antix
    sudo apt install --reinstall libasound2-plugin-equal alsamixer-equalizer-antix

    Try to se if that helps.

    #39687
    Member
    Avataranilkagi

    Yes, that did the trick, Xecure & Caprea,

    I gave that command and next I updated and upgraded. Interestingly there were quite a few updates and lots of upgraded packages. I am sorry I did not copy all that action. I forgot. I should have pasted it here, so that this issue could have been further scrutinized and would help better diagnosing any issues for others who face such. Can I extract that from the logs? How do I do that?

    I rebooted and VLC & XMMs are working fine!

    I am marking this thread as solved.

    Thanks a lot Xecure & Caprea.

    #39700
    Member
    XecureXecure

    Now that it is fixed there is no reason to publish the file here.

    If you are interested in knowing what happened, you can read the /var/log/dpkg.log file and see if you can spot when it uninstalled.

    The risk of using commands like

    deborphan | xargs apt-get -y remove
    COLUMNS=200 dpkg -l |grep ^rc |awk '{print $2} ' | xargs dpkg -P

    is that they are uninstalling stuff without you knowing what they will remove, they don’t give you the chance to say NO. If you want to have more control over what is going to be removed, change the commands to:

    deborphan
    COLUMNS=200 dpkg -l |grep ^rc |awk '{print $2} '

    This will display what they want to remove without the risk of accidental removal of important packages. You can then manually remove what you don’t want or you can execute the original commands if you are in agreement of removing all listed packages (just in case, save the output to a file so you can later find and reinstall the packages when an error occurs).

    #39715
    Member
    Avataranilkagi

    I checked the /var/log/dpkg.log file. I found that I had removed;

    libasound2-plugin-equal

    However though;

    alsamixer-equalizer-antix

    was there, it got upgraded.

    Further I found that the following packages were also upgraded.

    alsamixer-equalizer-antix:all 0.1.8 0.1.8
    base-files:amd64 10.3+deb10u4 10.3+deb10u5
    libperl5.28:amd64 5.28.1-6 5.28.1-6+deb10u1
    perl:amd64 5.28.1-6 5.28.1-6+deb10u1
    perl-base:amd64 5.28.1-6 5.28.1-6+deb10u1
    perl-modules-5.28:all 5.28.1-6 5.28.1-6+deb10u1
    libpython3.7:amd64 3.7.3-2+deb10u1 3.7.3-2+deb10u2
    python3.7:amd64 3.7.3-2+deb10u1 3.7.3-2+deb10u2
    libpython3.7-stdlib:amd64 3.7.3-2+deb10u1 3.7.3-2+deb10u2
    python3.7-minimal:amd64 3.7.3-2+deb10u1 3.7.3-2+deb10u2
    libpython3.7-minimal:amd64 3.7.3-2+deb10u1 3.7.3-2+deb10u2
    libgnutls30:amd64 3.6.7-4+deb10u4 3.6.7-4+deb10u5
    dbus-x11:amd64 1.12.16-1 1.12.20-0+deb10u1
    dbus:amd64 1.12.16-1 1.12.20-0+deb10u1
    libdbus-1-3:amd64 1.12.16-1 1.12.20-0+deb10u1
    b43-fwcutter:amd64 1:019-4 1:019-4+deb10u1
    file-roller:amd64 3.30.1-2 3.30.1-2+deb10u1
    firmware-b43-installer:all 1:019-4 1:019-4+deb10u1
    firmware-b43legacy-installer:all 1:019-4 1:019-4+deb10u1
    glib-networking-common:all 2.58.0-2 2.58.0-2+deb10u2
    glib-networking-services:amd64 2.58.0-2 2.58.0-2+deb10u2
    glib-networking:amd64 2.58.0-2 2.58.0-2+deb10u2
    intel-microcode:amd64 3.20200609.2~deb10u1 3.20200616.1~deb10u1
    libexif12:amd64 0.6.21-5.1+deb10u1 0.6.21-5.1+deb10u4
    libexiv2-14:amd64 0.25-4 0.25-4+deb10u1
    libinput-bin:amd64 1.12.6-2 1.12.6-2+deb10u1
    libinput10:amd64 1.12.6-2 1.12.6-2+deb10u1
    liblirc-client0:amd64 0.10.1-5.2 0.10.1-6.2~deb10u1
    libunwind8:amd64 1.2.1-9 1.2.1-10~deb10u1
    nfs-common:amd64 1:1.3.4-2.5 1:1.3.4-2.5+deb10u1

    I wanted to know if these upgrades were also part of the resolution of the issue, or were just regular upgrades.

    Note: I had posted this post twice, but could not see it. So I posted a third time.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.