Macbook Pro Connection to an External Monitor (Help)

Forum Forums General Hardware Macbook Pro Connection to an External Monitor (Help)

  • This topic has 7 replies, 5 voices, and was last updated Jul 6-5:43 pm by dreluis.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #147556
    Member
    dreluis

      Hello,

      I have Antix-21 installed on my computer. It’s a Macbook Pro (2009). The problem I’m facing is the impossibility of connecting the laptop to an external monitor, either with VGA or HDMI connection. At the screen layout editor, there is no VGA or HDMI option. Before installing Antix, there was no problem. I just used a mini display port adapter and it was all fine. Any suggestion?

      A summary of my machine:

      System:
        Kernel: 5.10.57-antix.1-amd64-smp arch: x86_64 bits: 64 compiler: gcc v: 10.2.1 clocksource: hpet
          available: acpi_pm parameters: BOOT_IMAGE=/boot/vmlinuz-5.10.57-antix.1-amd64-smp
          root=UUID=9f5adf12-1ec2-4535-8e0c-fd0efe26edd4 ro quiet
        Desktop: IceWM v: 3.4.5 vt: 7 dm: slimski v: 1.5.0 Distro: antiX-21_x64-full Grup Yorum 31
          October 2021 base: Debian GNU/Linux 11 (bullseye)
      Machine:
        Type: Laptop System: Apple product: MacBookPro5,5 v: 1.0 serial: <superuser required> Chassis:
          type: 10 v: Mac-F2268AC8 serial: <superuser required>
        Mobo: Apple model: Mac-F2268AC8 serial: <superuser required> UEFI: Apple
          v: MBP55.88Z.00AC.B03.0906151708 date: 06/15/09
      Memory:
        System RAM: total: 2 GiB note: est. available: 1.69 GiB used: 1 GiB (59.5%)
        RAM Report: permissions: Unable to run dmidecode. Root privileges required.
      PCI Slots:
        Permissions: Unable to run dmidecode. Root privileges required.
      CPU:
        Info: model: Intel Core2 Duo P7550 bits: 64 type: MCP arch: Penryn level: v1 built: 2008
          process: Intel 45nm family: 6 model-id: 0x17 (23) stepping: 0xA (10) microcode: 0xA0B
        Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB
          L2: 3 MiB desc: 1x3 MiB
        Speed (MHz): avg: 1592 min/max: 798/2261 scaling: driver: acpi-cpufreq governor: performance
          cores: 1: 1592 2: 1592 bogomips: 9020
        Flags: acpi aperfmperf apic arch_perfmon bts clflush cmov constant_tsc cpuid cx16 cx8 de
          ds_cpl dtes64 dtherm dts est flexpriority fpu fxsr ht lahf_lm lm mca mce mmx monitor msr mtrr
          nopl nx pae pat pbe pdcm pebs pge pni pse pse36 pti rep_good sep sse sse2 sse4_1 ssse3 syscall
          tm tm2 tpr_shadow tsc vme vmx vnmi vpid xsave xtpr
        Vulnerabilities:
        Type: itlb_multihit status: KVM: VMX disabled
        Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled
        Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
        Type: meltdown mitigation: PTI
        Type: spec_store_bypass status: Vulnerable
        Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
        Type: spectre_v2 mitigation: Full generic retpoline, STIBP: disabled, RSB filling
        Type: srbds status: Not affected
        Type: tsx_async_abort status: Not affected
      Graphics:
        Device-1: NVIDIA C79 [GeForce 9400M] vendor: Apple driver: nouveau v: kernel alternate: nvidiafb
          non-free: series: 340.xx status: legacy (EOL~2019-12-xx) last: release: 340.108 kernel: 5.4
          xorg: 1.20 arch: Tesla process: 40-80nm built: 2006-2013 ports: active: LVDS-1 empty: DP-1
          bus-ID: 02:00.0 chip-ID: 10de:0863 class-ID: 0300 temp: 64.0 C
        Device-2: Apple Built-in iSight driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
          mode: 2.0 bus-ID: 1-4:2 chip-ID: 05ac:8507 class-ID: 0e02 serial: <filter>
        Display: x11 server: X.Org v: 1.20.11 driver: X: loaded: modesetting unloaded: fbdev,vesa
          dri: nouveau gpu: nouveau display-ID: :0.0 screens: 1
        Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.31x8.31") s-diag: 398mm (15.69")
        Monitor-1: LVDS-1 model: Apple Color LCD built: 2009 res: 1280x800 hz: 60 dpi: 114 gamma: 1.2
          chroma: red: x: 0.639 y: 0.329 green: x: 0.310 y: 0.612 blue: x: 0.149 y: 0.055 white: x: 0.314
          y: 0.329 size: 286x179mm (11.26x7.05") diag: 337mm (13.3") ratio: 16:10 modes: 1280x800,
          1024x768, 800x600, 640x480, 720x400, 640x400, 640x350
        EDID-Warnings: 1: parse_edid: unknown flag 1
        API: OpenGL v: 3.3 vendor: nouveau mesa v: 20.3.5 glx-v: 1.4 es-v: 3.0 direct-render: yes
          renderer: NVAC device-ID: 10de:0863 memory: 241.2 MiB unified: no
      Audio:
        Device-1: NVIDIA MCP79 High Definition Audio driver: snd_hda_intel v: kernel bus-ID: 00:08.0
          chip-ID: 10de:0ac0 class-ID: 0403
        API: ALSA v: k5.10.57-antix.1-amd64-smp status: kernel-api with: apulse type: pulse-emulator
          tools: alsactl,alsamixer,amixer
      Network:
        Device-1: NVIDIA MCP79 Ethernet driver: forcedeth v: kernel port: 21e0 bus-ID: 00:0a.0
          chip-ID: 10de:0ab0 class-ID: 0200
        IF: eth0 state: down mac: <filter>
        Device-2: Broadcom BCM4322 802.11a/b/g/n Wireless LAN vendor: Apple AirPort Extreme driver: wl
          v: kernel modules: ssb pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 14e4:432b
          class-ID: 0280
        IF: wlan0 state: up mac: <filter>
        IP v4: <filter> scope: global broadcast: <filter>
        IP v6: <filter> type: dynamic mngtmpaddr scope: global
        IP v6: <filter> scope: link
        WAN IP: <filter>
      Bluetooth:
        Device-1: Apple Bluetooth Host Controller driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s
          lanes: 1 mode: 1.1 bus-ID: 4-1.1:3 chip-ID: 05ac:8213 class-ID: fe01 serial: <filter>
        Report: hciconfig ID: hci0 rfk-id: 1 state: down bt-service: running rfk-block: hardware: no
          software: yes address: <filter>
        Info: acl-mtu: 1021:5 sco-mtu: 64:1 link-policy: rswitch hold sniff park
          link-mode: slave accept
      • This topic was modified 2 weeks, 6 days ago by rokytnji.
      #147562
      Forum Admin
      rokytnji

        Look in Menu >Control Center > Session > Set screen Resolution arandr,

        Your other screen should show up there. Dial in resolution.

        When asked to save. Save to default.

        Sometimes I drive a crooked road to get my mind straight.
        I don't suffer from insanity. I enjoy every minute of it.
        Motorcycle racing is rocket science.

        Linux Registered User # 475019
        How to Search for AntiX solutions to your problems

        #147565
        Member
        dreluis

          The other screen does not appear there. The outputs shown in arandr are LVDS-1 (my monitor) and DP-1. I can’t activate this last output (DP-1).

          • This reply was modified 2 weeks, 6 days ago by dreluis.
          #147575
          Forum Admin
          rokytnji
            active: LVDS-1 empty: DP-1
                bus-ID: 02:00.0 chip-ID: 10de:0863 class-ID: 0300 temp: 64.0 C

            Don’t know myself why LVDS-1 shows active but DP-1 shows empty myself. Hopefully some Mac user here will see this thread and comment.

            I was hoping for plug and play.

            Sometimes I drive a crooked road to get my mind straight.
            I don't suffer from insanity. I enjoy every minute of it.
            Motorcycle racing is rocket science.

            Linux Registered User # 475019
            How to Search for AntiX solutions to your problems

            #147576
            Member
            ckrev

              I recently have a problem where mini display port does not work on a 2015 macbook pro (however my HDMI connection still works). antiX recognizes the port, but not any connections. If I can find a solution I will post it here.

              #147581
              Member
              abc-nix

                Are the external monitors connected before the machine boots or do you connect to them after booting?

                I would consider installing a newer kernel just in case this is kernel related. This topic on the Linux Mint forums (though with a different macbook) has a similar issue, and had it working using an OS with a newer Linux kernel version.

                #147594
                Member
                Robin

                  This is possibly a nouveau issue. I have not seen hotplugging of vga or tv-out working properly when not running the proprietary nvidia drivers. I remember there was a way to set it up manually on later nouveau versions, using xrandr on console, but have lost my old notes on this topic unfortunately. Additionally I remember some notebooks may need a Fn control key combination to switch between monitors plugged. Possibly the macbook also has some additional hardware switch of this kind? And finally, if your external monitor provides a wrong EEID, it also fails. All this is pretty difficult stuff to handle. Easiest solution for me was always to install the proprietary nvidia drivers to make twinview with multiple monitors or tv-out work (unfortunately the proprietary nvidia drivers for my device are no longer acceptable, since heavily outdated and dishevelled by nvidia, and no longer installable without downgrading X to a prehistoric state. But with the proprietary drivers all this has worked for me out of the box.

                  With nouveau driver it might help, as abc-nix already pointed out, to plug and power up the external monitors already before booting.

                  —————
                  P.S.:

                  5.10.57-antix.1-amd64-smp

                  consider installing a newer kernel

                  You are still running a pretty old 5.10 kernel. nouveau has been heavily improved after 5.15 kernel version. So try running a current 6.x antiX or debian kernels or the latest 5.10.216-antix (I guess the nouveau fixes have been backported to the more recent 5.10 kernel versions) as a first approach.

                  Windows is like a submarine. Open a window and serious problems will start.

                  #148219
                  Member
                  dreluis

                    Thanks for all the replies. I tried a current 6.x kernel as well older ones, but the problem remains. Well, in general the laptop has had a fantastic behavior with Antix, so I think I can live with this minor problem.

                  Viewing 8 posts - 1 through 8 (of 8 total)
                  • You must be logged in to reply to this topic.