Migrate from Connman to Network Manager – Solved

Forum Forums New users New Users and General Questions Migrate from Connman to Network Manager – Solved

  • This topic has 6 replies, 2 voices, and was last updated May 5-11:24 am by kaapi.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #141372
    Member
    kaapi

      Hello All,

      I have to transition from Connman to Network Manager since Connman doesn’t connection isn’t connecting with the univeristy Eduroam. I’ve installed network-manager, network-manager-gnome and nm-tray. I wanna get the service started but I can’t find the service at all on /etc/init.d/. The nm-tray app simply says “NetworkManager is not running”. Could someone please help me start the network manager service? I am aware that before starting the service, I have to remove connman and cmst. Before I lose the internet connection, however, I wanna know exactly how to start the network manager service on the system.

      Here are the details of the system

      System:
        Kernel: 6.1.60-antix.1-amd64-smp arch: x86_64 bits: 64 compiler: gcc
          v: 12.2.0 Desktop: IceWM v: 3.4.7 Distro: antiX-23.1_x64-full Arditi del
          Popolo 21 February 2024 base: Debian GNU/Linux 12 (bookworm)
      Machine:
        Type: Laptop System: Jooyon Tech Co product: J3GP Pro v: N/A
          serial: <superuser required>
        Mobo: JOOYON_IP3 model: GN15A serial: <superuser required>
          UEFI: American Megatrends v: GN15AV401 date: 11/24/2021
      Battery:
        ID-1: BAT0 charge: 31.9 Wh (83.9%) condition: 38.0/38.0 Wh (100.0%)
          volts: 8.2 min: 7.6 model: Intel SR 1 SR Real Battery status: discharging
      CPU:
        Info: quad core model: Intel Pentium Silver N5030 bits: 64 type: MCP
          arch: Goldmont Plus rev: 8 cache: L1: 224 KiB L2: 4 MiB
        Speed (MHz): avg: 879 high: 1122 min/max: 800/3100 cores: 1: 800 2: 796
          3: 800 4: 1122 bogomips: 8755
        Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
      Graphics:
        Device-1: Intel GeminiLake [UHD Graphics 605] vendor: IP3 Tech driver: i915
          v: kernel arch: Gen-9.5 bus-ID: 00:02.0
        Device-2: HRY USB Camera driver: uvcvideo type: USB bus-ID: 1-7:2
        Display: x11 server: X.Org v: 1.21.1.7 driver: X: loaded: modesetting
          unloaded: fbdev,vesa dri: iris gpu: i915 resolution: 1920x1080~60Hz
        API: EGL v: 1.5 drivers: iris,swrast platforms:
          active: gbm,x11,surfaceless,device inactive: wayland
        API: OpenGL v: 4.6 vendor: intel mesa v: 22.3.6 glx-v: 1.4
          direct-render: yes renderer: Mesa Intel UHD Graphics 605 (GLK 3)
      Audio:
        Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
          driver: sof-audio-pci-intel-apl bus-ID: 00:0e.0
        API: ALSA v: k6.1.60-antix.1-amd64-smp status: kernel-api
        Server-1: PipeWire v: 1.0.3 status: active
      Network:
        Device-1: Intel Gemini Lake PCH CNVi WiFi driver: iwlwifi v: kernel
          bus-ID: 00:0c.0
        IF: wlan0 state: up mac: <filter>
      Bluetooth:
        Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
          v: 0.8 type: USB bus-ID: 1-9:3
        Report: hciconfig ID: hci0 rfk-id: 1 state: down bt-service: running
          rfk-block: hardware: no software: yes address: <filter>
      Drives:
        Local Storage: total: 116.48 GiB used: 11.66 GiB (10.0%)
        ID-1: /dev/mmcblk0 model: MMC128 size: 116.48 GiB
      Partition:
        ID-1: / size: 41.04 GiB used: 11.42 GiB (27.8%) fs: ext4 dev: /dev/mmcblk0p3
        ID-2: /boot size: 973.4 MiB used: 107.5 MiB (11.0%) fs: ext4
          dev: /dev/mmcblk0p2
        ID-3: /boot/efi size: 511 MiB used: 288 KiB (0.1%) fs: vfat
          dev: /dev/mmcblk0p1
        ID-4: /home size: 71.28 GiB used: 137.3 MiB (0.2%) fs: ext4
          dev: /dev/mmcblk0p4
      Swap:
        ID-1: swap-1 type: file size: 2.1 GiB used: 0 KiB (0.0%) file: /swap/swap
      Sensors:
        System Temperatures: cpu: 53.0 C mobo: N/A
        Fan Speeds (rpm): N/A
      Info:
        Processes: 185 Uptime: 1h 1m Memory: total: 4 GiB available: 3.65 GiB
        used: 1.45 GiB (39.7%) Init: SysVinit runlevel: 2 Compilers: gcc: 12.2.0
        Packages: 1914 Shell: Bash v: 5.2.15 inxi: 3.3.31
      
      • This topic was modified 2 months, 2 weeks ago by kaapi.

      Dubito, ergo Cogito

      #141373
      Member
      RJP
        #141374
        Member
        kaapi

          I saw this but I didn’t know the steps were the same for sysvinit as well. Thank you so much!!

          Dubito, ergo Cogito

          #141375
          Member
          RJP

            With sysvinit you need only add NetworkManager start to the /etc/rc.local file. You also need to edit connections via root nm-applet (gksu nm-applet).

            #141379
            Member
            kaapi

              Thanks again for the input. I’ve got an issue that others have, namely, it connects to the AP but there is no name resolution. I’ve tried the symlink suggested in this post, namely

              1. Remove connman

              […]

              2. Delete the resolv.conf sym link in /etc/
              3. Create a new symlink in etc like this (in a terminal)

              sudo ln -s /etc/resolvconf/run/resolv.conf /etc/resolv.conf

              4. Try ceni again

              But that symlink hasn’t worked. I also tried the following symlink sudo ln -s /etc/resolvconf/resolv.conf /etc/resolv.conf

              I tried this since /etc/resolv/resolv.conf actally exists but this leads to a “Device not managed” dialog when nm-tray is selected.

              Do you have any suggestions?

              • This reply was modified 2 months, 2 weeks ago by kaapi.
              • This reply was modified 2 months, 2 weeks ago by kaapi.

              Dubito, ergo Cogito

              #141382
              Member
              RJP

                In my antix 23 runit

                sudo find / -iname "resolv.conf"
                [sudo] xxxxxxx-käyttäjän salasana: 
                /etc/resolv.conf
                /run/NetworkManager/resolv.conf
                /run/resolvconf/resolv.conf

                You have a wrong path. ;)

                PS. I have not removed Connman, just commented out antiX network check in $HOME/.desktop-session/startup file.

                PS2. Remove connection from Connman before making a new connection via nm-applet.

                #141383
                Member
                kaapi

                  Ah yes, there are three files. I have two questions.

                  1) Which file should I symlink with /etc/resolv.conf? My guess is `sudo ln -s /run/NetworkManager/resolv.conf /etc/resolv.conf’.

                  2) When you say remove connection from connman, is it enough if I delete the wifi_*** file(s) that connman has for different ssid(s) ?

                  I had to symlink with /run/resolvconf/resolv.conf. Thank you so much!!

                  • This reply was modified 2 months, 2 weeks ago by kaapi.
                  • This reply was modified 2 months, 2 weeks ago by kaapi.

                  Dubito, ergo Cogito

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.